Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

09/08/2011 #1


4n25 mas transitor npn. Tiene la logica cambiada!!
Estoy intentando utilizar un 4n25 para alimentar la base de un transistor NPN para controlar una carga. Lo he montado pero la logica me sale a la inversa. Quiero decir qeu cuando le doy corriente al 4n25 digamos se me apaga la carga (un led por ejemplo) y cuando pongo el 4n25 a 0 se me enciende el led.
Lo primero es que no entiendo por que, asi que si alguien es tan amable....
Lo segundo es que esta configuracion no me interesa porque va a hacer que gaste la pila mientras la carga no esta funcionando.
Añadir que estoy mandando la señal con un arduino pero creo que eso no es importante
09/08/2011 #2


Men reviza la polaridad del 4n25...
a lo mejor cuando lo polarizas se pone en corto y estoy casi seguro que lo estas polarizando de forma invertida
Suerte...
09/08/2011 #3
Moderador general

Avatar de DOSMETROS

¡¿ Ni un mísero dibujo !?

Poné un planito por favor
09/08/2011 #4


aqui dejo el esquema

con el interuptor abierto esta encendido el led y cerrado se apaga ?¿?¿?¿?¿
Imágenes Adjuntas
Tipo de Archivo: png 4n25.PNG (16,1 KB (Kilobytes), 97 visitas)
09/08/2011 #5
Moderador general

Avatar de DOSMETROS

Probá intercambiar la resistencia de 1k con las patas 4 y 5 del opto
09/08/2011 #6


gracias amigo por contestar.
supongo que te refieres a la resintencia de 10 k de la pata 5.
Esa resistencia no puedo quitarla porque va a la base del transistor, tengo que limitar la corriente o me lo cargo.

te refieres a que quite esa resistencia de la pata 5 y la ponga en la 4?
09/08/2011 #7

Avatar de Daniel Meza

Te resulta esa logica debido al transistor que colcaste externamente, este maneja la corriente del led pero "invierte" el estado de la salida del opto... según su hoja de caracteristicas puede manejar 10mA directamente sin problemas, rango promedio del consumo para el LED. Entonces estableciendo una R para el LED que mantenga la corriente en este intervalo tu circuito funcionará con la lógica que requieres.
Saludos
09/08/2011 #8


gracias Daniel
En realidad tengo previsto encender un motor dc pequeñito con este dispositivo. Por eso tengo ahi puesto el transistor.
A mi, esto de que se me invierta la logica me trae loco porque significaria que tengo que estar alimentando constantemente el opto. Y esto es un consumo innecesario, y supongo que tambien acortaria la vida del opto (exagerando un poco)

Pregunta ¿Con otros tipos de optos me pasaria igual? y otra cosa, a mi en la hoja de datos no consigo ver nada que me diga que me va a pasar esto.

Bueno en realidad me gustaria entender por que pasa esto.
09/08/2011 #9
Excluido


pero che....fijate lo que hiciste:

con el int abierto el opto no conduce .........y asi como lo pusis te , si el opto no conduce el T si !!!!!!!!

no ves que el T. conduce por como pusiste la R.
entretenete pensando un poquito.........
pensa......

vos queres que sin el opto .SIN el opto el T. no NO conduzca.

y cuando el opto activa si conduzca........

es lindo ejercicio para queien empieza , se entretenga un rato con un led, no hay ningun peligro.
Imágenes Adjuntas
Tipo de Archivo: jpg zza12.JPG (10,4 KB (Kilobytes), 63 visitas)
09/08/2011 #10


JA JA JA, amigo gracias, segun tu respuesta intuyo que estoy haciendo algo mal, almenos es algo.
Es un fallo de concepto yo soy un aficionado y no tengo mucha idea. Mantengo mi posicion, creo quecon el interruptor abierto no puede pasar corriente a la base del transistor.
Supongo que ahi esta el error.
ahora no estoy muy lucido, asi que lo dejare para mañana.

gracias a todos

(perdon no vi el dibujo cuando escribi lo de arriba)
Vale podria ser con esta configuracion no queda a 0 (tierra) la base del transistor?
como dije antes mañana lo averiguare
09/08/2011 #11
Excluido


es correcto lo de dejarlo para mañana, las cosas se mastican tranquilo y se prueban.
hasta mañana .
10/08/2011 #12
Moderador general

Avatar de DOSMETROS

. . . No es el diagrama final , es solo para que veas otra posibilidad . . .


Imágenes Adjuntas
Tipo de Archivo: png 4n25_.PNG (15,2 KB (Kilobytes), 120 visitas)
10/08/2011 #13

Avatar de Black Tiger1954

Te dejo una forma de hacerlo. Es lo mismo que te subió 2M con el agregado de una resistencia más limitadora de corriente para la base.
Imágenes Adjuntas
Tipo de Archivo: jpg Opto elemental.jpg (32,4 KB (Kilobytes), 63 visitas)
10/08/2011 #14

Avatar de Gudino Roberto duberlin

zacarino dijo: Ver Mensaje
aqui dejo el esquema

con el interuptor abierto esta encendido el led y cerrado se apaga ?¿?¿?¿?¿
Amigo, debes conectar la salida del opto con la entrada al transistor en modo darlington, obviamente debe llevar una R limitadora.-

DOSMETROS dijo: Ver Mensaje
. . . No es el diagrama final , es solo para que veas otra posibilidad . . .


Amigo con esa configuracion estas destruyendo al pobre transistor, piensa que al conducir la salida del opto, estas cortocircuitando la tension de la fuente en .7V.!!!!!!!!!!!!!!
10/08/2011 #15
Excluido


ansiedad..............................

ya sabemos que todos lo saben, la cosa es que el pibe piense un poco .
10/08/2011 #16


Cuanta crueldad hay por aqui (va por ti fernandob)
No hombre! es broma, os tengo que dar muchas gracias de nuevo, ahora que se como se hace voy a intentar razonarlo un poco, de momento me surgen algunas dudas, pero si me dais un poco mas de tiempo para que lo mastique dare con la tecla. Ademas ahora tengo hasta una banda sonora para inspirarme.
Si, me he dado cuenta de que lo que hice es una burrada pero fue un fallo tecnico. De todos modos tengo algunas dudas. ¨Ya os la consultaare.

Ahora voy a calentarme un poco el coco y ya os contare

Gracias a todos
10/08/2011 #17
Moderador general

Avatar de DOSMETROS

zacarino dijo: Ver Mensaje
Cuanta crueldad hay por aqui (va por ti fernandob)
No hombre! es broma, os tengo que dar muchas gracias de nuevo, ahora que se como se hace voy a intentar razonarlo un poco, de momento me surgen algunas dudas, pero si me dais un poco mas de tiempo para que lo mastique dare con la tecla. Ademas ahora tengo hasta una banda sonora para inspirarme.
Si, me he dado cuenta de que lo que hice es una burrada pero fue un fallo tecnico. De todos modos tengo algunas dudas. ¨Ya os la consultaare.

Ahora voy a calentarme un poco el coco y ya os contare

Gracias a todos
No es una burrada si tu proyecto hubiera sido :

"con el interuptor abierto esta encendido el led y cerrado se apaga "

Saludos !
10/08/2011 #18
Excluido


y digou you ...........y si ponia a el interruptor a que prenda a el led o lo que sea??
no se usa pa eso el interruptor ???

pa que silicio, germanio carbon o estaño ??? ???
no hay retardo, no hay ninguna misera funcion .....nada.
11/08/2011 #19


Pues ya lo he entendido, decirte fernado que en realidad quiero encender un motor, puse el led para que fuera todo mas sencillo.

Lo he entedio y ahora me funciona como quiero es decir cuando cierro el interruptor se enciende el led. Vale pero lo que no entiendo es por que lo hacia a la inversa, asi que para simplificar os pongo un nuevo circuito. este solo tiene un transitor y un interuptor.
transistor.PNG

este circuito si el interruptor esta cerrado la luz no se enciende y si esta abierto si.?¿?¿??¿?

venga esta es mi ultima pregunta!!!!!!!
11/08/2011 #20
Excluido


la ultima ????????
que si te gusta entonces no deberias decir eso .

me agarraste justo dibujante

PD: una llave tambien prende y apaga un motor .
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.