Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/04/2011 #1


Activar rele 5v con optoacoplador
Hola Y GRACIAS DE ANTEMANO POR LEER ESTE NUEVO TEMA/PROBLEMA,

Dispongo del siguiente circuito detector de presencia por infrarrojos

http://www.pablin.com.ar/electron/ci...rios/proximid/

que me funciona perfectamente con 5V.

COmo indica, si quiero commandar un circuito externo, he sustituido el LED por un optoacoplador, el 4N35 con una RL de 20 ohmios, y no me funciona, no activa el relé de 5V ( que alimento con la misma tension de 5V) con el que quiero comandar un circuito de alterna para activar una electroválvula.

¿ Que he hecho mal? debo utilizar otro optoacoplador, uno con darlington para mayor I ? Muchisimas gracias
27/04/2011 #2

Avatar de pandacba

poses subir un circuito para ver como hiciste el coneccionado y aconsjarte que hacer?
27/04/2011 #3



Mira si funciona el siguiente enlace donde esta la foto. Muchas gracias

27/04/2011 #4


Hay que ver si esta bien conectado el optoacoplador.
Como se ve el led alli, tiene que estar conectado el fotodiodo del optoacoplador.
--
Conecta un led con una resistencia de 1kohm en el lugar del Rele para ver si funciona.

PD:Tenes la hoja de datos del optoacoplador, q nombre tiene?
27/04/2011 #5

Avatar de Rigeliano

Creo que pandacba se referia a el circuito que tu hiciste para activar el rele con el optoacoplador, y si estendi bien creo que intentaste activar el rele solo con el optoacoplador y nada mas, si es asi no va a activar el rele por que no te da la corriente necesaria.
27/04/2011 #6

Avatar de pandacba

Si, me referia al esquema modificado, no al original para ver como conectaste el opto

Si utiizas un TIP125 en lugar del BC558 puedes manejar directament el relay si olvidar poner el diodo de protección en paralelo con el relay catodo al los 5V
27/04/2011 #7

Avatar de Rigeliano

Pero lo que quiere es separar electricamente el rele o no?
27/04/2011 #8

Avatar de pandacba

no, eso pense al principio de echo el relay tambien separa.... pero dice que se alimenta de los mismos 5V entonces no tiene sentido el opto
27/04/2011 #9

Avatar de Rigeliano

Entonces a hacerle caso a pandacba con el TIP125
28/04/2011 #10


Muchas gracias, probare pues con un led como me indicas y la R de 1K y buscare el TIP125 . El opto que tengo es el 4N35, tenia la duda de si utilizar el 4N30 que viene con darlington por el problema de la corriente. Qué diodo pongo en paralelo para la protección? el 1N47 ?
28/04/2011 #11


Me queda la duda del problema con la corriente, yo utilice para algo parecido un opto de 4 patas, pero si los expertos lo dicen...

El diodo puede ser cualquiera, es solo para las corrientes inversas. Con un zener comun como 1n4148 deberia andar.

Saludos
28/04/2011 #12

Avatar de Scooter

No tiene mucho sentido poner un optoacoplador y luego un relé porque el relé ya tiene aislamiento galvánico, no necesitas dos aislamientos.
De todos modos es probable que el opto no de bastante corriente; la mayoría tienen una función de transferencia en corriente de uno mas o menos, si el led consume 15mA el transistor conduce una cosa por el estilo.
Soluciones:
- Usa un optodarlington como el 4N32
- Pon un transistor externo
- Aumenta la corriente por el led aunque eso no se si será bastante
28/04/2011 #13


Lo de poner el relé es porque quiero activar una electroválvula que funciona con alterna. El circuito funciona bien tal cual el esquema.
Según la web donde el esquema
http://www.pablin.com.ar/electron/ci...rios/proximid/
indica que para controlar / activar un circuito externo basta SUSTITUIR EL LED por un optoacoplador, supongo para tener más corriente.

Yo he probado con el 4N30 y no funciona según este esquema donde R la he puesto de 20ohmios y alimentando el relé a la salida del opto con 5V, deberia alimentarlo con más tensión? entiendo que funciona con valores de 3 a 5 V.



PAra conseguir más corriente y poder activar el relé según me dices puedo probar el optodarlington 4N32 en vez del 30, lo del transistor externo, a que te refieres, donde lo conecto? te refieres al apunte de pandacba de sustituir el 558 por el TIP125?

Muchisimas gracias a todos por vuestra ayuda y aportes, estoy bastante perdido en este ultimo paso del circuito

http://perso.wanadoo.es/pictob/image...oacoplador.gif
28/04/2011 #14

Avatar de pandacba

un diodo 1N4007 te servira, reemplaza la R y el dido en el esquema original por la bobina y el diodo en paralelo recordando que el cátodo debe estar hacia el postivo
28/04/2011 #15


Ok, muchas gracias pandacba, mañana por la mañana a primera hora lo pruebo, tengo diodos 1N4004. y te digo como ha ido
29/04/2011 #16


Funciona !!! Muchisimas gracias por tu aporte, efectivamente si lo dejo todo en paralelo , R y diodoLED no funciona, pero al poner directamente el relé con el diodo funciona, así que seguidamente he conectado la electroválvula que comanda el relé. Ahora ya sale agua cuando ponemos las manos bajo el grifo...... Gracias de nuevo. Saludos.
PD: Curiosamente solo me funciona con fuente de 5V ( utilizo un cargador de telefono movil, 5,2V-350mA ), con alimentación de 7V -350mA, no funciona ( el rele se volvia loco) pese a indicaciones de que el circuito funciona desde los 5 a los 9V, sabes por qué? es por el cargador del movil, la I?

Otra cosa, ahora he perdido la opcion de saber cuando funciona el sensor de presencia, es decir, ya no avisa el led apagándose, si no el rele que se desactiva y aprovecho para abrir la electroválvula. No se si es la mejor opcion pese a que funciona, ya que sin presencia de nada el relé esta activado (consumiendo), la presencia de algo es lo que desactiva el relé. Debería estar esta parte del relé en la pata del emisor con tierra para obtener el efecto contrario? Gracias de nuevo por tu experiencia
29/04/2011 #17

Avatar de Scooter

Pues depende. ¿Si se va la corriente, como quieres que se quede?
30/04/2011 #18


Al activar la corriente el relé se activa, claro, si se va, activara la electrovalvula, pero si se va tambien la alterna el agua no saldra, el problema vendria si se va la continua, el relé queda en posicion de activar la alterna; se abriria la electrovalvula,

Ese fue el motivo de utilizar el optoacoplador, que , segun el esquema arriba enviado, solo activa el relé en el caso de no recibir señal del LED.

Si acaso probare el optodarlington a ver si funciona para que al encender todo, no active el rele hasta la deteccion de presencia, si no , no se me ocurre alternativa. Pensaba en poner el LED y su resistencia en el lado del emisor ( recordando el famoso circuito LDR deteccion de luz o oscuridad ) pero como mis conocimientos de electonica son limitados, no se si funcionara, menos mal que los componentes son baratos ( escepto el fotoreceptor ) y si fundimos algun transistor, tenemos repuesto......

Si pongo el relé //1N4007 en la pata del emisor conseguiré lo comentado? Gracias
30/04/2011 #19

Avatar de Scooter

Depende, igual se rompe solo la fuente de tu circuito. Tienes que pensar la condición mas segura para dejar de funcionar.
Si quieres un led ponlo sencillamente en serie con el del optoacoplador, reduces la resistencia limitadora y ya está.
Sigo sin entender para que quieres un optoacoplador y un relé, el optoacoplador sobra claramente.
30/04/2011 #20


Lo del opto

era solo para activar la salida ( al rele ) solo en el caso de no detectar presencia ( es decir, led apagado ).

del fichero encontrado "La tensión de la fuente de la izquierda y la resistencia en serie establecen una corriente en el LED emisor cuando se cierra el interruptor S1. Si dicha corriente proporciona un nivel de luz adecuado, al incidir sobre el fototransistor lo saturará, generando una corriente en R2. De este modo la tensión de salida será igual a cero con S1 cerrado y a V2 con S1 abierto."
La solucion que funciona, poner directamente el rele, implica que el rele siempre esta activado (consumo ) hasta que el led apagado (presencia ), lo desactiva.

Queria tan solo implementar la opcion de que todo este apagado ( rele ) en situacion de reposo ( no presencia )
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.