Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/10/2013 #1

Avatar de Xapas

Calentamiento LM3914
Hola, muy buenas. Escribo este tema porque no encontré ningun tema similar o que me ayudara en mi problema. Estoy construyendo un medidor de voltaje con el circuito LM3914. Me baje el datasheet, y encontré unas ecuaciones que determinaban el valor de resistencias para fijar la escala y la intensidad de los leds.
Il=12.5/R1
Ref=1'25*(1+R2/R1)

EL medidor que estoy montando posee una escala de 5V. Primero probé a insertar una R1=680 ohmios, que si hacemos cuentas, salen unos 18mA, lo cual esta bien para los leds, que por cierto, son leds rojos de alto brillo. Sin embargo, probé el circuito y el integrado comenzo a calentarse de manera alarmante, asi que cuando quema le apago la alimentacion. Para la escala de 5V, R2=2k2, mas o menos. Pense que seria problema de la intensidad que tiraban los leds, asi que cambie R1=1k2, lo que proporciona unos 10mA. R2 debe ser de 3k3, aproximadamente. Sin embargo, sigue calentando mucho. Cambie el integrado, por si estuviera mal, y sigue fallando. La entrada la inserto mediante una resistencia variable, y siempre que me acerco al maximo de escala, empieza a calentarse.
Alguien me podría echar una mano?
07/10/2013 #2

Avatar de Eduardo

Xapas dijo: Ver Mensaje
...EL medidor que estoy montando posee una escala de 5V. Primero probé a insertar una R1=680 ohmios, que si hacemos cuentas, salen unos 18mA, lo cual esta bien para los leds, que por cierto, son leds rojos de alto brillo. Sin embargo, probé el circuito y el integrado comenzo a calentarse de manera alarmante, asi que cuando quema le apago la alimentacion. Para la escala de 5V, R2=2k2, mas o menos. Pense que seria problema de la intensidad que tiraban los leds, asi que cambie R1=1k2, lo que proporciona unos 10mA. R2 debe ser de 3k3, aproximadamente. Sin embargo, sigue calentando mucho. Cambie el integrado, por si estuviera mal, y sigue fallando. La entrada la inserto mediante una resistencia variable, y siempre que me acerco al maximo de escala, empieza a calentarse.
Se calienta porque felizmente se siguen cumpliendo las leyes de la física.

Al alimentar todo desde 12V, el pobre 3914 debe disipar (12-Vled)*0.018 ~ 0.2W por cada led encendido.
Así que con 5 leds encendidos disiparía ~1W y con la barra completa ~2W ==> mas que suficiente para que hierva.

¿Que se hace?

- Lo mejor es que la barra de led tenga su propia alimentación (de 2..3...4V según el tipo de leds) de manera que las salidas del 3914 queden casi saturadas.
Si la única alimentación sigue siendo 12V, se hace un regulador serie pedorro (zener+transistor+resistencia) con un disipadorsito para digamos 2W, porque ahora el que va a calentar es el transistor.

- Se puede poner una resistencia en serie con cada led.

- Se puede cambiar el modo a led individual (pin9 libre)
07/10/2013 #3

Avatar de Xapas

Pero se supone que deberia funcionar bien con esa configuracion, ya que luego cambie la resistencia a 1k2, pero sigue calentando. Además, esa configuración viene en el datasheet. He visto numerosos circuitos parecidos al mio en los que en algunos, el pin 8 se establece a masa, mientras que en otros va con una resistencia, como tengo yo. Que diferencia hay?

Si le cambio la resistencia a 1k2, la intensidad sería de unos 10mA.
Vled aprox. 3V
P=(12-3)*0'01=0'09
Pt=0'09*10=0'9W, y el datasheet dice que la máxima potencia son 1365mW. Debería funcionar.
07/10/2013 #4

Avatar de Eduardo

Xapas dijo: Ver Mensaje
Pero se supone que deberia funcionar bien con esa configuracion, ya que luego cambie la resistencia a 1k2, pero sigue calentando. Además, esa configuración viene en el datasheet.
La configuración está bien, lo que está mal es usarlo en modo barra con 12V.

He visto numerosos circuitos parecidos al mio en los que en algunos, el pin 8 se establece a masa, mientras que en otros va con una resistencia, como tengo yo. Que diferencia hay?
El pin8 maneja la tensión de referencia, se ajusta según el rango de la señal de entrada.

Si le cambio la resistencia a 1k2, la intensidad sería de unos 10mA.
Vled aprox. 3V
P=(12-3)*0'01=0'09
Pt=0'09*10=0'9W, y el datasheet dice que la máxima potencia son 1365mW. Debería funcionar.
Funcionar no significa integrado frío.

Ese encapsulado disipando 1W va a estar caliente, supongas lo que supongas.
07/10/2013 #5

Avatar de Xapas

Eduardo dijo: Ver Mensaje
La configuración está bien, lo que está mal es usarlo en modo barra con 12V.
No es el primer medidor que veo alimentado por 12V y en modo barra.
07/10/2013 #6
Moderador general

Avatar de Fogonazo

¿ Que valor tiene R1 ?
07/10/2013 #7

Avatar de Xapas

La resistencia R1 tiene un valor de 1k2 actualmente.

Esta pagina es un buen ejemplo.
http://www.dj-sures.com/GraphicFiles...%20Monitor.htm
07/10/2013 #8
Moderador general

Avatar de Fogonazo

Has una prueba reemplazando R1 por otra de 2200Ω
07/10/2013 #9

Avatar de lm555cn

Según la hoja de datos, la corriente máxima por LED permitida es de 13mA a 5V. Al estar operando a 10mA por LED con la resistencia de 1.2K, verás que estás trabajando casi al límite de las especificaciones, los 1365mW que mencionas. Haciendo un cálculo rápido a 10 mA por LED, la potencia total disipada del IC es de 1315mW, con 12V, por lo que va a calentar y mucho!. Si la fuente de poder fuera de 5V la potencia total disipada en teoría sería de 548mW, por lo que no calentaría del todo o lo haría muy poco. Esto con todos los LEDS encendidos y en modo barra, en modo punto sería manejable con los dos voltajes. Es lo que se me ocurre de momento. Tal vez puedas probarlo de esa manera, utiliza 5V en la fuente de poder y prueba a ver si el integrado calienta. De todas formas, trabajando a 12V no ganas mucho, pues el rango de medición de voltaje calculado es hasta los 5V. Si aún así quieres tener el potenciómetro a 12V, R1 debería ser de 2400 Ohmios y así no debería calentar el integrado.
15/11/2013 #10

Avatar de Xapas

Hola, que tal? Siento haber tardado tanto en contestar (y por cierto, gracias a todos por contestar), ya que estuve liado. Ahora que tengo tiempo libre, he vuelto a hacer pruebas con el LM3914

Eduardo dijo: Ver Mensaje
- Se puede poner una resistencia en serie con cada led.
Como dijo el amigo Eduardo, he puesto una resistencia de 1k en serie con cada led, ya que antes estaban todos los leds alimentados a 12V. Ahora bien, cuando someto la entrada del LM3914 a 12V en continua (cambie la escala del LM3914 a 12V, R1=680 ohm, R2=5600 ohm), ya no calienta nada, y funciona perfectamente. Sin embargo, se me olvido comentar algo. Este circuito, en realidad, sera un efecto de luces (no vumetro), que poseera dos modos, es decir, un modo con leds fijos (entrada a 12V en continua) y un modo con leds que se enciendan con una entrada de sonido (Sé que el LM3914 no es apto para esto, pero en mi zona no se vende el LM3916, y para hacer un efecto de luces no creo que importe). Antes, cuando el integrado se calentaba, en el "modo" de sonido no lo hacía, pero ahora, funciona con los 12V en continua pero no reconoce la onda de sonido, no prende ningun led. Debo decir que la onda de sonido proviene de un preamplificador, no del amplificador. Que solucion tiene para poder prender los leds con el sonido? he probado a ponerle un diodo en serie, pero nada. También probé con un detector de picos, pensando que el condensador descargaría, pero tampoco. Alguna sugerencia?
15/11/2013 #11
Moderador general

Avatar de DOSMETROS

El datasheet te explica y tiene las formulitas , como se configura la entrada para diferentes niveles de tensión.

Saludos !
16/11/2013 #12

Avatar de Xapas

He seguido el datasheet, y la intensidad y la escala las saqué con esas fórmulas, lo que no entiendo, es, si la escala es de 12V, porque funciona bien con una señal continua y mal con una señal de audio, si ambas poseen distintos niveles de tensión? Lo raro es que cuando la entrada es la de audio, no prende ningún led, lo que significaría que la señal es cero, cuando no lo es.

---------------------------------------
Creo haber encontrado una solución, simplemente habría que probar el circuito con la entrada de audio, y medir el Vpp de dicho audio, más o menos, de forma que la escala la fijemos al máximo de la Vpp del preamplificador. Luego, para la entrada a 12V en continua, se podría hacer un divisor de tensión fijo a la máxima escala, es decir, un valor similar al máximo Vpp del preamplificador.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.