Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

30/12/2012 #1

Avatar de Juanjogc

Se calienta la fuente de alimentación con un 16f876
Hola amigos, tengo tres problemas con un proyecto y no sé cómo seguir, a ver si alguien me puede ayudar.
He montado un programador de riego con un 16F876 a 4Mhz, que programo mediante teclado de pulsadores y pantalla LCD. A su vez he puesto indicadores mediante led´s y un sistema de mando a distancia por RF.
El sistema tiene tres salidas desde el micro a tres optoacopladores que comandan tres triacs para dar corriente a las válvulas de riego que trabajan a 24V AC.

Primer problema: El regulador de tensión de la fuente de alimentación 7812 se calienta hasta alcanzar los 80 grados centígrados (53 grados si pongo disipador) con un consumo de 80mA del sistema en reposo. No me parece normal ese calentamiento.

Segundo problema: Cuando alimento el sistema con 24V AC (la fuente lo regula a 5V DC) el micro funciona mucho más lento que si lo alimento con una pila de 9V. No veo la lógica

Tercer problema: El mando a distancia por RF no funciona cuando alimento a 24V AC y sí a 9V DC

Pongo el esquema de la fuente de alimentación, cuyo funcionamiento sería:
A la fuente de alimentación le llegan 24V AC (a la vez que a los triacs para el servicio de las válvulas) ésta tensión es rectificada por el puente BR1 y enviada a U8 que la transforma en 12V DC. Desde aquí, a través de D6 llega a U9 que entrega 5V DC al circuito.
En caso de fallo de tensión, entra en funcionamiento la batería de 9V DC ya que al no llegar a la base del transistor Q1 corriente positiva desde el 7812, dicha base queda polarizada a masa a través de la resistencia R25 y como el transistor en PNP deja pasar la corriente desde el emisor al colector y a través de D7 alimenta el 7805 que da tensión al circuito manteniendo los datos programados en el 16f876

En principio pensé que U8 se calentaba por la resistencia R25 a masa, la desconecté y se calienta igual.

No sé cómo continuar, os agradezco cualquier ayuda.
Muchas gracias de antemano

Este es el esquema de la FA:
30/12/2012 #2


Hola Juanjogc, yo creo que el paso de los 24 voltios de alterna al regulador 7812 es demasiado salto, está rectificado pero su rizado es enorme ya que no tiene un condensador gordote entre la salida del puente rectificador y la entrada al regulador, además de tener una tensión bastante grande, 24*1,41 -1,4 = 32,5V si no me equivoco, teniendo en cuenta la tensión de 24v por raiz de 2 y restando la caida de los diodos.

Yo cogería esa entrada de 24v con el puente rectificador, un condensador un poco gordo y luego le metería un LM317 con el que puedes regular la salida directamente a 5v, en el datasheet aparece como regular la salida a tu antojo mediante una formula. Entiendo que los 12v no los quieres para nada, es simplemente un paso intermedio antes de llegar al regulador 7805....

Un saludo.
30/12/2012 #3

Avatar de Juanjogc

Gracias Jurty, la tensión de 12v es un paso intermedio, pero necesito que exista una tensión superior a 9V en la base del transistor para que no haya consumo de la batería cuando hay tensión de la red. En teoría el 7812 debería aguantar hasta unos 35V sin problema.
Efectivamente, como comentas, el rizado debe ser importante a la entrada del 7812 pero dudo que el calentamiento de éste se reduzca con un condensador, no obstante lo voy a probar, por supuesto.
30/12/2012 #4

Avatar de Daniel Meza

Puedes quitar el transistor y poner un circuito más sencillo como este para hacer la conmutación de las fuentes de alimentación.

Circuito.png


Con la alimentación normal (12V) D2 queda abierto impidiendo el paso de corriente desde la batería. Si la fuente llegase a fallar, la pila entra en acción por medio de D2 y D1 se abre impidiendo que la pila se cargue con la fuente de 12V. C1 es representativo, coloca un capo de unos 470uF para eliminar mejor el rizado
30/12/2012 #5

Avatar de Juanjogc

Por las pruebas que he realizado, el esquema que me propones, Daniel, hace que el 7805 consuma corriente a partes iguales desde ambas alimentaciones. El esquema que propuse al abrir éste hilo, funciona a la perfección, comprobado sobre protoboard, con un consumo de la batería auxiliar de 9V de 0mA cuando la alimentación principal está activa, lo que hace que dicha pila me pueda durar incluso más de un año, que es lo que busco. Mi problema es el calentamiento creo yo excesivo del regulador 7812.
Estoy intentando la solución propuesta por Jurty, cuando tenga resultados os comento.
Gracias
30/12/2012 #6

Avatar de Daniel Meza

Yo lo decía por la necesidad de un voltaje de esa magnitud para lograr la polarización del transistor. Con ese circuito se eliminaba esa necesidad aunque no solucionaba el problema del calentamiento. Este es por la excesiva potencia que debe de disipar el 7812, es decir se tiene que "comer" aprox 23 volts para regular su salida a 12V. A calculos burdos tenemos que:

P=VI=(23V)(80mA)=1.84 W

lo cual ya es algo considerable.

Bueno veamos, ¿el transformador tiene derivación central?, para que de alguna forma se disminuya el voltaje a la entrada del 7812, si no otro método sería reducir el voltaje de entrada por medio de una combinación zener+transistor.

PD: Sobre el problema de el funcionamiento errático con AC, es posible que el transformador o las válvulas estén metiendo mucho ruido al sistema. Pregunto, ¿Los TRIACS tienen su respectiva red "Snubber"?
31/12/2012 #7

Avatar de Juanjogc

Buenos días:
Éstas son las pruebas que he hecho hasta ahora:
He puesto un condensador de 470µF a la entrada del 7812 y parece hacer el sistema más estable, ésto es, el reloj que tengo programado para que aparezca en el LCD va a una velocidad similar tanto con la alimentación a 24v AC como con la batería auxiliar, aunque todavía no es uniforme.
También de ésta manera el receptor de RF recibe la señal del mando a distancia, lo que me hace pensar que se estaba colando alguna componente de alterna que interfería con la señal de radio, pero, el 7812 se sigue calentando, incluso más que antes, con temperaturas de hasta 75 grados con disipador colocado.
Algo hemos avanzado aunque no lo suficiente.
En respuesta a tu pregunta, Daniel, el transformador no tiene toma central. Efectivamente la potencia a disipar es de 1,84w y por ahí podria ir el tema del calentamiento, pero cuando probé ésta fuente en protoboard, sólo tenía conectados un par de led´s y se calentaba igualmente.

En cuanto a la configuración de los triacs, es la que aparece en la imagen, y que ya he montado en otros proyectos con buenos resultados.

Os estoy muy agradecido por la ayuda que me estáis prestando.
Saludos
Imágenes Adjuntas
Tipo de Archivo: jpg TRIACS.jpg (140,3 KB (Kilobytes), 13 visitas)
31/12/2012 #8


te recomendario primero que hagas un analisis de cuanto consume cada dispositivo que tienes en tu circuito (uC , valvulas,lcd,otros) no creo que sea mucho pero de todas maneras calculalo.
Talves uno de los dispositivos esta fallando (internamente un corto o algo asi) . Pero eso de que el pic baje su velocidad no me cabe(acaso se calienta el uC??) . bueno ojala lo soluciones!
31/12/2012 #9

Avatar de Daniel Meza

Juanjogc dijo: Ver Mensaje
Buenos días:
Éstas son las pruebas que he hecho hasta ahora:
He puesto un condensador de 470µF a la entrada del 7812 y parece hacer el sistema más estable, ésto es, el reloj que tengo programado para que aparezca en el LCD va a una velocidad similar tanto con la alimentación a 24v AC como con la batería auxiliar, aunque todavía no es uniforme.
También de ésta manera el receptor de RF recibe la señal del mando a distancia, lo que me hace pensar que se estaba colando alguna componente de alterna que interfería con la señal de radio, pero, el 7812 se sigue calentando, incluso más que antes, con temperaturas de hasta 75 grados con disipador colocado.
Algo hemos avanzado aunque no lo suficiente.
En respuesta a tu pregunta, Daniel, el transformador no tiene toma central. Efectivamente la potencia a disipar es de 1,84w y por ahí podria ir el tema del calentamiento, pero cuando probé ésta fuente en protoboard, sólo tenía conectados un par de led´s y se calentaba igualmente.

En cuanto a la configuración de los triacs, es la que aparece en la imagen, y que ya he montado en otros proyectos con buenos resultados.

Os estoy muy agradecido por la ayuda que me estáis prestando.
Saludos

Bien bien, se va aislando el problema, ahora ¿has probado dejar el 7812 sin carga?, ¿sin ningún led incluso? esto para descartar una posible falla interna en el regulador.
Una posible solución (y que seguramente solucionará el problema del ruido) es colocar una fuente separada para la lógica de control y otra para las válvulas.
Puedes aprovechar algún cargador de celular en desuso y solamente adaptarle el conmutador de falla de fuente.

Con respecto a los TRIAC's no está por demás colocarle su respectiva red snubber a cada válvula. Hay formas para calcular los valores pero la verdad las desconozco. Yo suelo poner los valores a prueba y error. Para comenzar R=100Ω y un C=0.1µF con lo que en la mayoría de casos obtengo buenos resultados



Saludos
01/01/2013 #10

Avatar de dmc

Juanjogc, cuando utilice circuitos similares a que estas ocupando, también tuve problemas de temperatura por 3 causas:
1° Tensión de alimentación alta (más de 8 o 10 volts del valor del 78xx)
2° Consumo mayor a los 700 mA.
3° Resistencias del Led del LCD sobre positivo.

A pesar de que el 7812 soporta hasta 36Vcc Máx., una diferencia mayor a los 8 volts (es decir a partir de los 20V) noto que este elemento tiende a calentarse (aun sin consumo).
Si bien el 7812 es de 1 Amp, esto es el consumo máximo que soporta, por lo cual no lo utilizo a mas de la mitad de su capacidad, utilizando como limitador una resistencia de 3W de metalfilm (100 o 150 Ohms o lo que haga falta) a la entrada de tensión (20 / 24V).
A veces, a pesar de todo lo hecho, si aun continuaban calentandose los reguladores (7812 / 05), cambiaba la resistencia del led del LCD del positivo al ramal negativo, es decir dejaba los 5 volts directos al ánodo y del cátodo con una resistencia a Gnd y los reguladores comenzaban a trabajar más frios (realmente no se por que, si supuestamente es lo mismo). Y ahi terminaban mis problemas. Espero que mi comentario te sirva de algo. Ahh, yo aumentaría los capacitores de 470 y de 330 a 1000 uF, y colocaría uno de 470 o 1000 uF en el pin 3 del 7805. Suerte.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.