Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/06/2009 #1


Contador fotoelectrico 0-9
Hola!

Necesito hacer un contador 0-9 de personas.

Monte el circuito del contador que se encuentra en proyectos practicos (http://www.forosdeelectronica.com/pr...oelectrico.htm) lo hice con un solo display y reemplaze la fotocelda por un fototransistor, el problema es que al conectar todo el display no me da numeros, solo se prenden partes y cuando le mando el pulso no obtengo ninguna respuesta.

Espero me puedan ayudar.
Muchas gracias de antemano.
02/06/2009 #2

Avatar de alexus

pone alguna foto de como lo tenes montado en este momento,

si lo armas en protoboard, etc...

y adjunta los circuitos (esquemas) de lo que estas usando!
03/06/2009 #3


Lo primero que debes verificar es si realmente el fotoresistor está "viendo" algo. Para ello mides tensión en la salida del inversor schmitt-triger o lo que hayas puesto como conformador de onda. Debería cambiar de 0 Volt a 5 Volt cuando "se atraviesa la persona". Si no cambia....... uno de los problemas está ahí. Si cambia, debes chequear el contador, que esté habilitado, que no esté reset......
Que el display te muestra cualquier cosa puede probablemente sea que lo has conectado como el orto. También es fácil de diagnosticar, mides con el tester qué valor binario hay en la entradas A, B, C, D ó I0, I1, I2, I3 ó como se llamen y te fijas si están activadas las salidas correspondientes. Otro posible problema es que tengas display de 7 segmentos ánodo común cuando en su lugar debería ser cátado común.
Cómo te menciona ALEXUS, sin los esquemáticos no es fácil darte una mano.

Saludos,
Hernán
04/06/2009 #4


Aqui pongo el esquema de como lo tengo montado en este momento en la protoboard.

Estuve chequeando el conformador de pulsos y esta funcionando bien, el contador no supe como chequearlo ops:
Imágenes Adjuntas
Tipo de Archivo: jpg esquema_contador_175.jpg (43,7 KB (Kilobytes), 230 visitas)
04/06/2009 #5

Avatar de alexus

que fucnion debe cumplir? describe!

poruqe se puede hacer mas sencillo...
04/06/2009 #6


Debe contar el paso de personas u objetos desde 0 hasta 9 y reiniciar la cuenta
04/06/2009 #7

Avatar de alexus

cuando? cuando le llega luz? cuando el haz es cortado? cuando?

poruqe no entiendo el poruqe del oscilador!
04/06/2009 #8


cuando se interrumpe el haz
04/06/2009 #9

Avatar de alexus

osea, se corta el haz, y aumenta un digito la cuenta?
04/06/2009 #10


exacto
05/06/2009 #11


Lo primero que puedo observarte es que tienes conectado el display al Dígito más significativo (las centenas; pin 15). Conectado así el dígito se incrementa en 1 cada 100 clock. Deberías conectar el transistor al pin 2 del MC14553.
http://www.datasheetcatalog.org/data...a/MC14553B.pdf

Imagino que C1 lo has puesto como dice la hoja de datos, 0.001 microF

El pin 10 del MC14553 debería estar a masa. Un resistencia a masa vendría bien, una vez que funcione se la quitas para ver si hace falta o no. Creo que no hace falta pero...... por si las moscas

IMPORTANTISIMO !!! El tranistor está alrevés. El emisor se conecta a VDD (+9V) y el colector al display. El display debe ser ánodo común.

Podés probar el CD4543 de la siguiente manera:
Desconectas R14 del MC14553 y la conectas directo a +9V. Con ello consigues que el display esté siempre energizado a travez del transistor.
Luego desconectas los cuatro cables del dígito binario (MC14553 pines 9;7;6;5 --- CD4543 pines 5;3;2;4)
Luego, con cuatro cables conectados al CD4543 a los pines 5;3;2;4 le metes combinacioes binarias y chqueas que el display junto con el decodificador BCD-7 Segmentos funcione correctamente.
Si no funciona.... estás en el horno. Está fregado el CD4543.... o el transistor. Para chequear si es el transistor, le haces un puente en colector y emisor, si empieza a funcionar el display es porque el transistor está pa atrás o la R14 es muy grande. Reemplaza.

Si estás seguro que el conformador de onda está funcionando, el resto debería funcionar, luego de corregir lo de transistor y conectar R14 al pin 2.

Si con todo ésto no funciona, avisa y vemos cómo probar el contador. Hay que saarle el capacitor, poner un pulsador y..... si hace falta lo vemos.

Suerte,
Hernán
Imágenes Adjuntas
Tipo de Archivo: jpg esquema_contador_ver2_133.jpg (43,6 KB (Kilobytes), 112 visitas)
05/06/2009 #12


Bueno pues ya corregi lo que me dijiste y probe el 4543 pero parece ser que esta malo, voy a reemplazarlo a ver que pasa y te comento.
Gracias por la ayuda.
05/06/2009 #13

Avatar de alexus

busca la hoja de datos del 4510 y del 4511, es mucho mas sencillo, el clock del contador lo manejas saturando y cortando un transistor con el LDR...

vos ves, me aprece que es mas sencillo con esos integrados!
07/06/2009 #14


Cambie el 4543 pero ahora el display no me prende

Me podrias decir por favor como conectar cada pin de los integrados que mencionas (4510, 4511)?
07/06/2009 #15


Algo como ésto debería funcionar
Verificá con las hojas de datos que esté casi todo bien.

Falta conectar la alimtación al 4510

Suerte,
Hernán
Imágenes Adjuntas
Tipo de Archivo: jpg 4510_4511_322.jpg (14,9 KB (Kilobytes), 222 visitas)
Archivos Adjuntos
Tipo de Archivo: pdf 4511_162.pdf (112,0 KB (Kilobytes), 63 visitas)
Tipo de Archivo: pdf 4510_112.pdf (136,0 KB (Kilobytes), 47 visitas)
07/06/2009 #16

Avatar de alexus

en las hojas de datos esta como hacer contadores y cosas asi..
07/06/2009 #17


Ya lo tengo todo conectado, la fotocelda con el transistor al clock del 4510, el display me muestra el numero cero pero al interumpir la fotocelda no pasa nada, el numero no cambia.
08/06/2009 #18

Avatar de alexus

trata de exitar dos transistores, con el ldr comandas uno, y de el emisor de ese uno comandas otro, no falla, porque no he probado, de ultima proba con los fototransistores de esos genericos...
08/06/2009 #19


Podés verificar que el circuito del contador esté funcionando desconectando el clock del circuito barrera y generando pulso con un pulsador, así te sacás la duda si el conador está funcionando.
Del mismo modo probás el circuito de la barrera, desconectándolo del contador y midiendo con el multímetro tensión a la salida del Schmit-trigger y viendo que cambie cuando le hacés sombra al fototransistor. A partir de ahí vemos dónde está el problema.
09/06/2009 #20


El 4510 no responde a los pulsos, lo raro es que lo cambio por otro 4510 y tampoco responde.

Otra cosa es que, no se si sea normal, desconecte del 4510 los cables que van al 4511(pines 6, 11, 14, 2), al mover esos cables que seguian conectados al 4511 el display hiba cambiando de numero aleatoriamente.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.