Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

14/01/2011 #1


Diseño de filtro paso alto
Muy buenas, y antes de nada, agradeceros vuestra ayuda de antemano. He diseñado un filtro paso alto. Bien, he comprobado mediante Matlab que las ecuaciones son correctas examinando los correspondientes diagramas de Bode. El problema me viene a la hora de montarlo.

Estamos hablando de un filtro de orden 3. He probado con 2 operacionales: el primero (LM324) comienza a funcionar a frecuencias mas altas, no a la calculada; el segundo (UA741) simplemente no funciona, y ademas añade un Offset de 2V. Esto puede ser debido a alguna caracteristica de los operacionales que no haya tenido en cuenta?

Es el primer filtro que ademas de diseñar, construyo. Y estoy un poco perdido... Muchas gracias por vuestro tiempo.
14/01/2011 #2
Moderador general

Avatar de Fogonazo

Y en base a que esquema se podría opinar sobre el problema.

Reglas generales de uso del foro

03) Cuando preguntes, danos la máxima información posible. ¡ No somos adivinos !

12) Cuando consultes sobre algún esquema sobre el que estás trabajando ! Publícalo ¡ NO presupongas que somos adivinos y conocemos sobre que cosa estas hablando.

15) Cuando abras un tema (Post) ponéle un poco de "Onda", agrega alguna descripción, comentario, reflexión, NO tires un esquema o una pregunta sin ningún agregado.
14/01/2011 #3

Avatar de Eduardo

No se ve el adjunto con las especificaciones del filtro, la ecuacion del filtro y la imagen del circuito que implementaron.
14/01/2011 #4
Excluido


Algalordmaster dijo: Ver Mensaje
. . . he comprobado mediante Matlab que las ecuaciones son correctas examinando los correspondientes diagramas de Bode. El problema me viene a la hora de montarlo . . .
Sin mirar el circuito que usted realizo, solo puedo decir que:

El circuito real es muy diferente al circuito virtual, porque los componentes reales no tiene los valores exactos o absolutos, que aparecen en cada referencia. Esa "pequeña tolerancia" afecta el resultado esperado.

A la hora de la practica: si quiere que el circuito funcione exactamente igual a la simulacion, tiene que buscar en un lote de componentes; aquellos que sean exactos a los valores usados en el circuito virtual.

15/01/2011 #5


Muchas gracias por vuestro tiempo, y disculpas por la falta de información: El filtro está diseñado de acuerdo a las siguientes especificaciones:
  • Filtro paso alto
    Amax = 0,5 dB
    Amin = 13,97 dB
    fc= 35Khz
    fs= 20Khz

He calculado los componentes y me sale el esquema adjunto. Bien, lo he montado y no funciona... Cómo la situación me parecía un poco extraña probé a simular con Matlab las funciones de transferencia. Y adjunto dos diagramas frecuenciales de Matlab: uno con los componentes reales a utilizar, y otro con los componentes calculados teóricamente. Los cálculos se han realizado a mano basándome en mis apuntes de instrumentación electrónica, y los he comprobado y recomprobado.

Por cierto, la topología utilizada en el diseño del filtro es la de montaje inversor con realimentación múltiple. Muchas gracias de nuevo por vuestro tiempo.
Archivos Adjuntos
Tipo de Archivo: zip foro_electronica.zip (123,9 KB (Kilobytes), 65 visitas)
15/01/2011 #6

Avatar de Eduardo

Algalordmaster dijo: Ver Mensaje
He calculado los componentes y me sale el esquema adjunto. Bien, lo he montado y no funciona...
Hay dos errores:
1- Estas usando fuente simple. Desde el momento que elimina la componente continua --> Como va a hacer el pobre operacional para tener salida negativa durante los semiciclos negativos? Va a pedir pilas prestadas?

2- En la union de los condensadores de 1n,820p y la R de 1K , da la impresion que no estan unidos (falta el punto).

Cómo la situación me parecía un poco extraña probé a simular con Matlab las funciones de transferencia. Y adjunto dos diagramas frecuenciales de Matlab: uno con los componentes reales a utilizar, y otro con los componentes calculados teóricamente. Los cálculos se han realizado a mano basándome en mis apuntes de instrumentación electrónica, y los he
El circuito esta bien calculado, yo lo simulo con LTSpice y da todo como debe ser ---> Revisa lo que metiste en el simulador.
Imágenes Adjuntas
Tipo de Archivo: jpg Clipboard-1.jpg (72,4 KB (Kilobytes), 45 visitas)
18/01/2011 #7


Muchas gracias por vuestras respuestas. El filtro funciona perfectamente ahora. Y, como tendré que diseñar más filtros, existe un software que los calcule de manera sencilla? Muchas gracias por todo.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.