Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

12/10/2011 #1

Avatar de Alaan

Displays Anodo Comun
hola hice un circuito contador de personas y objetos con un ldr, el circuito funciona perfecto, cuenta hasta 999, cuando prendo el circuito se prenden todos los display y todos los segmentos, pero cuando cuenta por ejemplo 1 sigue prendido el segemtnos f que no es necesario para el numero 1 u otros números, lo mismo hace en los otros 3 displays, como soluciono esto?

Les dejo una imagen del circuito

Esquematico


Ejemplo numero 111

bno espero su ayuda es solo este problemita
12/10/2011 #2

Avatar de cosmefulanito04

No tengo demasiadas ganas de verificar el impreso, pero verifica que en el tuyo, con el circuito desconectado y usando un tester en modo continuidad no haya conducción entre Vcc y el segmento F o continuidad entre Vcc y la salida del 4543 que se encarga de manejar ese segmento.

Si llega haber continuidad, saca el 4543 y volvé a probar, en caso de que siga habiendo continuidad, tenés una pista del segmento "F" que hace contacto con Vcc, sino hay continuidad, entonces puede ser el IC 4543, verificá la continuidad entre Vcc y el driver que maneja el segmento "F".

Otra cosa, en el esquemático los transistores Q1, Q2 y Q3 están mal conectados, el emisor debería ir conectado a Vcc y el colector a los displays.

Editado:

A simple vista, se ve que en el impreso, tanto Q1, Q2 y Q3 están bien conectados y es en el esquemático que se encuentran mal conectados.

Editado2:

Según la hoja de datos del IC 4543, la salida es con estado alto, es decir a la hora de habilitar un segmento, la salida será 9V. Ahora mi sentido común me dice que eso no puede ser, se supone que en la forma en que conectaste el 7segmento, los segmentos debieran habilitarse con salida del IC 4543 en estado bajo y no alto como dice la hoja de datos (la tabla de verdad).

Te pido que verifique eso, es decir la salida del IC 4543 de un segmento cuando el led esta activado.
12/10/2011 #3

Avatar de Alaan

cosmefulanito04 dijo: Ver Mensaje
No tengo demasiadas ganas de verificar el impreso, pero verifica que en el tuyo, con el circuito desconectado y usando un tester en modo continuidad no haya conducción entre Vcc y el segmento F o continuidad entre Vcc y la salida del 4543 que se encarga de manejar ese segmento.

Si llega haber continuidad, saca el 4543 y volvé a probar, en caso de que siga habiendo continuidad, tenés una pista del segmento "F" que hace contacto con Vcc, sino hay continuidad, entonces puede ser el IC 4543, verificá la continuidad entre Vcc y el driver que maneja el segmento "F".

Otra cosa, en el esquemático los transistores Q1, Q2 y Q3 están mal conectados, el emisor debería ir conectado a Vcc y el colector a los displays.

Editado:

A simple vista, se ve que en el impreso, tanto Q1, Q2 y Q3 están bien conectados y es en el esquemático que se encuentran mal conectados.
Ok muchas gracias por tu respuesta ahora me pongo a testear, espero poder solucionarlo, saludos
12/10/2011 #4

Avatar de cosmefulanito04

Alaan dijo: Ver Mensaje
Ok muchas gracias por tu respuesta ahora me pongo a testear, espero poder solucionarlo, saludos
Verificá lo último que puse en el mensaje anterior.
12/10/2011 #5

Avatar de Alaan

osea cuando esta el numero 1 prendido tengo q testear alguna pata del 4543 con la entrada de 9v? perdona las molestiasno entiendo mucho de electronica, solo lo hago de hobbie, bueno en este caso es para un proyecto de la escuela ,)

cosmefulanito04 dijo: Ver Mensaje
Verificá lo último que puse en el mensaje anterior.
osea cuando esta el numero 1 prendido tengo q testear alguna pata del 4543 con la entrada de 9v? perdona las molestiasno entiendo mucho de electronica, solo lo hago de hobbie, bueno en este caso es para un proyecto de la escuela ,)
12/10/2011 #6

Avatar de cosmefulanito04

Olvidate lo que te dije, ya entendí como trabaja el IC 4543:



Cuando la pata 6 del 4543 está en 1 (a Vcc), invierte las salidas, con lo cual el IC 4543 queda funcionando en estado bajo que es lo que vos necesitas.

Ahora de lo 1ero que te dije, hace eso pero en vez de comparar continuidad con Vcc hacelo con masa. Esto deberías hacer:

- Medición 1:

1) Circuito apagado.
2) Medir continuidad entre la pata 15 y la pata 8 del IC 4543 (si hay lee "a)", si no hay lee "b)").

3)

a) Si hubo continuidad, saca el IC 4543 (espero que hayas usado zocalos), y comprobá de nuevo la continuidad sobre el IC. Si hay continuidad el IC 4543 está cagado, de lo contrario, medí continuidad de nuevo en tu circuito en los conectores de dichas patas para verificar que no se toquen las pistas.

b) Si no hubo continuidad, medí continuidad entre pata 8 del IC 4543 y pata "F" de los 7 segmentos, si hay continuidad verificá que no se toquen las pistas.

- Medición 2 (en caso que medición 1 no arroje fallas):

Si en ningún caso encontraste continuidad, entonces probá el circuito funcionando, dejalo en un mismo Nº fijo en los 3 dígitos y el cual "f" no deba estar encendido, medí la tensión en la pata 15 del 4543, si medís 0V, el 4543 no funciona bien.
12/10/2011 #7

Avatar de Alaan

cosmefulanito04 dijo: Ver Mensaje
Olvidate lo que te dije, ya entendí como trabaja el IC 4543:



Cuando la pata 6 del 4543 está en 1 (a Vcc), invierte las salidas, con lo cual el IC 4543 queda funcionando en estado bajo que es lo que vos necesitas.

Ahora de lo 1ero que te dije, hace eso pero en vez de comparar continuidad con Vcc hacelo con masa. Esto deberías hacer:

- Medición 1:

1) Circuito apagado.
2) Medir continuidad entre la pata 15 y la pata 8 del IC 4543 (si hay lee "a)", si no hay lee "b)").

3)

a) Si hubo continuidad, saca el IC 4543 (espero que hayas usado zocalos), y comprobá de nuevo la continuidad sobre el IC. Si hay continuidad el IC 4543 está cagado, de lo contrario, medí continuidad de nuevo en tu circuito en los conectores de dichas patas para verificar que no se toquen las pistas.

b) Si no hubo continuidad, medí continuidad entre pata 8 del IC 4543 y pata "F" de los 7 segmentos, si hay continuidad verificá que no se toquen las pistas.

- Medición 2 (en caso que medición 1 no arroje fallas):

Si en ningún caso encontraste continuidad, entonces probá el circuito funcionando, dejalo en un mismo Nº fijo en los 3 dígitos y el cual "f" no deba estar encendido, medí la tensión en la pata 15 del 4543, si medís 0V, el 4543 no funciona bien.
Gracias por la respuesta espero no quitarte tiempo, probelo q me dijiste en ningun caso habia continuidad así q medí la tension en la pata 15 con masa y me da 0. bueno no creo poder solucionarlo jaja se me agotaron los conocimientos de electrónica jaja. aunquesea funciona bien d no ser por ver mal algunos numeros por ese segemtno q queda prendido todo el tiempo..gracias...
12/10/2011 #8

Avatar de cosmefulanito04

Si nunca obtuviste continuidad, entonces cambia el 4543, tal vez se cagó el driver de ese segmento.

Si estás usando zocalo, con mucho cuidado agarra el 4543 y doblá la pata 15 para que no entre en el zocalo, encende el circuito y si todo va bien no debería encenderse ese segmento en ningún momento.
12/10/2011 #9

Avatar de Alaan

cosmefulanito04 dijo: Ver Mensaje
Si nunca obtuviste continuidad, entonces cambia el 4543, tal vez se cagó el driver de ese segmento.

Si estás usando zocalo, con mucho cuidado agarra el 4543 y doblá la pata 15 para que no entre en el zocalo, encende el circuito y si todo va bien no debería encenderse ese segmento en ningún momento.

ya doble la pata 15 El segemento f se enciende para algunos numeros si y para otros no, ¿no sera q en el impreso habra alguna pista demas q una los tres segemtnos f de los displays o un puente q no va?
12/10/2011 #10

Avatar de cosmefulanito04

Entonces es posible que tengas dos pistas que se toquen.

Verificá que la pata 14 no se toque con la 15 que ahí está medio jugado el espacio.

Si no encontrás nada, hacé esto:

1- Saca el IC 4543.
3- Encendé el circuito.
2- Verificá que ningun led se encienda.
3- Con un cablecito, uní GND con la pata 15 del IC 4543 (osea del mismo zócalo uní pata 8 con pata 15), se debería prender solo el segmento "F", si se prende otro segmento, significa que algún lado las pistas de esos 2 segmentos se tocan.
12/10/2011 #11

Avatar de Alaan

cosmefulanito04 dijo: Ver Mensaje
Entonces es posible que tengas dos pistas que se toquen.

Verificá que la pata 14 no se toque con la 15 que ahí está medio jugado el espacio.

Si no encontrás nada, hacé esto:

1- Saca el IC 4543.
3- Encendé el circuito.
2- Verificá que ningun led se encienda.
3- Con un cablecito, uní GND con la pata 15 del IC 4543 (osea del mismo zócalo uní pata 8 con pata 15), se debería prender solo el segmento "F", si se prende otro segmento, significa que algún lado las pistas de esos 2 segmentos se tocan.
hice puente entre la pata 8 y 15 y se encendieron todos los segmentos f de los 3 displays pero tambien los 3 segmentos b de los 3 displays, quiere decir q hay pistas unidad no?
12/10/2011 #12

Avatar de cosmefulanito04

Exacto, las pistas del segmento "F" se tocan con las del "B", verificá si hay continuidad entre las patas 15 y 10, si no hay continuidad, verificá continuidad entre el segmento "F" y "B" de alguno de los 7 segmentos.
12/10/2011 #13

Avatar de Alaan

Si hay continuidad entre el segmento "F" y "B" de los 3 displays, hay q cortar alguna pista ahora no?

cosmefulanito04 dijo: Ver Mensaje
Exacto, las pistas del segmento "F" se tocan con las del "B", verificá si hay continuidad entre las patas 15 y 10, si no hay continuidad, verificá continuidad entre el segmento "F" y "B" de alguno de los 7 segmentos.
Si hay continuidad entre el segmento "F" y "B" de los 3 displays, hay q cortar alguna pista ahora no?

estaran bien esos puentes q estan debajo de los displays? al parecer esos son los causantes del problema creo yo
12/10/2011 #14

Avatar de cosmefulanito04

Verificá que no se toquen acá las pistas:



Ahí usaste 2 puentes para el segmento "F", tal vez esas islas están tocando la pista del segmento "B".

Los puentes en si están bien.
12/10/2011 #15

Avatar de Alaan

cosmefulanito04 dijo: Ver Mensaje
Verificá que no se toquen acá las pistas:



Ahí usaste 2 puentes para el segmento "F", tal vez esas islas están tocando la pista del segmento "B".

Los puentes en si están bien.
Era una pista que se estaba tocando con otra, raro q se me halla escapado bueno ya esta solucionado y anda de 10, amigo mas q muchas gracias, nose como agradecerte, espero no haberte quitado tiempo seguro trabajas u otras cosas, bueno saludos
02/06/2013 #16


Multiplexado Displays Anodo Comun
Buen dia a todos, este es mi primer tema y tengo una consulta sobre un proyecto. Estoy realizando una plaqueta que consiste de un CD4511 para el codigo BCD y de ahi directamente se iban a conectar 4 displays catodo comun (en paralelo), pero no los pude conseguir, ahora mi pregunta es si poniendo un 2803 a la salida del 4511 podria conectar los displays de anodo comun, y que tendria que hacer con los transistores, ademas si el 4555 que uso como decodificador lo podria seguir usando gracias
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.