Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

03/10/2010 #21
Moderador general

Avatar de Fogonazo

Respuesta: Duda con optoacoplador
VladimiroTotal dijo: Ver Mensaje
....Las resistencias que me comentas son de 10K y de 4K7....
Con 10KOhms entre base y emisor debería poner al corte el transistor del opto

¿ El opto está sano ?

Intenta esta configuración:
03/10/2010 #22


Respuesta: Duda con optoacoplador
Fogonazo dijo: Ver Mensaje
Con 10KOhms entre base y emisor debería poner al corte el transistor del opto

¿ El opto está sano ?

Intenta esta configuración:

Hola.

Gracias por contestar.

Mirando ese esquema, veo que es lo mismo que tengo, solo que en lugar de poner el led y la resistencia por la patilla 5, tu la has puesto en la 4, eso cambia algo ????????
Lo pregunto desde la total ignorancia...

Y lo de que esté sano el optoacoplador, tengo un circuito de prueba, y 5 optoacopladores, y a todos les pasa igual, tienen puenteadas las patillas 4 y 5, con lo cual, deduzco que este modelo de optoacoplador, o es una basura, o me no vale para lo que lo necesito.

No me importa el tener que comprar otro modelo, pero quiero tener la seguridad de que las salidas no van a estar puenteadas de forma constante.

En fín, vosotros sabreis más, espero algún consejo, ando resignado, no me puedo creer que a nadie le haya pasado...

Gracias y saludos...
03/10/2010 #23
Moderador general

Avatar de Fogonazo

Respuesta: Duda con optoacoplador
VladimiroTotal dijo: Ver Mensaje
....Mirando ese esquema, veo que es lo mismo que tengo, solo que en lugar de poner el led y la resistencia por la patilla 5, tu la has puesto en la 4, eso cambia algo ????????.....
En tu esquema la base del Foto-Transistor se polariza a la misma tensión que el emisor.
En el otro caso, la base del Foto-Transistor se polariza a una tensión negativa respecto del emisor.
03/10/2010 #24

Avatar de kal00

Respuesta: Duda con optoacoplador
Bueno, en base a todos los esquemáticos y configuraciones que he visto y usado de optoacopladores, éste se debe de usar de la siguiente manera:

03/10/2010 #25


Respuesta: Duda con optoacoplador
Fogonazo dijo: Ver Mensaje
En tu esquema la base del Foto-Transistor se polariza a la misma tensión que el emisor.
En el otro caso, la base del Foto-Transistor se polariza a una tensión negativa respecto del emisor.

Ah vaya, entonces me equivoqué de patilla al colocar la resitencia y el diodo, y eso podría ser el motivo de que la patilla 4 y 5 estén siempre conectadas...

Chico, no sé, ojalá supiera electrónica como vosotros, lo voy a probar, voy a cambiar los elementos y a probar, rezaré para que al cambiar los elementos de patilla, la patilla 4 y 5 no hagan continuidad...

Ya os digo algo...

Gracias y saludos...
04/10/2010 #26


Respuesta: Duda con optoacoplador
kal00 dijo: Ver Mensaje
Bueno, en base a todos los esquemáticos y configuraciones que he visto y usado de optoacopladores, éste se debe de usar de la siguiente manera:

Hola compañero.

Extraño esquema, pues creo que es el mismo que he puesto yo mas arriba en el inicio.

Y por otra parte, después de todo lo escrito, estás contradiciendo a Fogonazo en usar la patilla 5 en lugar de la 4.

De todas formas, gracias y Saludos...
04/10/2010 #27

Avatar de kal00

Respuesta: Duda con optoacoplador
No es el mismo que has puesto porque en el primero estás alimentando la Base del transistor, por eso el transistor entra en un pequeño estado de saturación y te deja pasar corriente entre el Colector y Emisor. Puede que la configuración de Fogonazo funcione, nada pierdes con intentar las 2. En un transistor el Colector siempre es el que te va a proporcionar la salida.
04/10/2010 #28


Respuesta: Duda con optoacoplador
Síiiiiiiiiiiiiiiiiii...

Conseguido, ha funcionado....

He colocado los componentes en la patilla 4 y ya no pasa la corriente.

Muchas gracias.

Eso sí, se me ha fundido el Optoacoplador, pero tengo otros 4 para seguir probando.
Antes de fundir otro optoacoplador, creo que hay que colocar una resistencia a la entrada del optoacoplador, yo la he denominado R3, pero, me podrían decír que valor debe tener R3 ?????



Creo que una vez sepamos lo que vale R3 lo habremos conseguido.
Eso sí, tengan en cuenta que la entrada al optoacoplador varía de 0 a 16 voltíos, no siempre es constante, pero es siempre corriente contínua.
En la salida del optoacoplador, el led luminoso recibe unos 9 voltios de corriente contínua, que puede varias 1-2 voltios nada más.

Pues nada más, a la espera de saber lo que vale R3 y poder terminar esta intriga de circuito.

Gracias compañeros, llevo un mes con el maldito circuito, y creo que estamos a punto de lograrlo, por favor, creo que solamente falta saber el valor de R3 y estará conseguido gracias a ustedes.

Muchas gracias y saludos
04/10/2010 #29

Avatar de kal00

Respuesta: Duda con optoacoplador
Recuerda que dentro del encapsulado está un LED, a un LED normal no le puedes meter de golpe 16v o sí? Necesita una resistencia ad hoc con el valor de voltaje que le estás metiendo, el problema es que tu señal varía demasiado. La resistencia correcta para 16v de un LED de 2v a 15mA es de 1 KiloOhm, pero si le llegan 5v al LED, sería de 330 Ohms. Si tu aplicación no estará encendida mucho tiempo, con una de 800 Ohms aproximadamente estará bien, el problema será cuando le lleguen 3 o 4 volts, posiblemente no te pase la corriente necesaria para activar el optoacoplador. Estaría bien que pusieras un LM7805 para regular la salida, pero si le llegan menos de 5v no pasará señal.

Te dejo una página para calcular la resistencia de los LEDs.

http://ledcalc.com/
04/10/2010 #30


Respuesta: Duda con optoacoplador
kal00 dijo: Ver Mensaje
Recuerda que dentro del encapsulado está un LED, a un LED normal no le puedes meter de golpe 16v o sí? Necesita una resistencia ad hoc con el valor de voltaje que le estás metiendo, el problema es que tu señal varía demasiado. La resistencia correcta para 16v de un LED de 2v a 15mA es de 1 KiloOhm, pero si le llegan 5v al LED, sería de 330 Ohms. Si tu aplicación no estará encendida mucho tiempo, con una de 800 Ohms aproximadamente estará bien, el problema será cuando le lleguen 3 o 4 volts, posiblemente no te pase la corriente necesaria para activar el optoacoplador. Estaría bien que pusieras un LM7805 para regular la salida, pero si le llegan menos de 5v no pasará señal.

Te dejo una página para calcular la resistencia de los LEDs.

http://ledcalc.com/
Gracias por responder tan rápido.

Por lo que se ha visto no, no aguanta los 16 voltios.

Vaya, ahora el problema es la variación de tensión.
Es que no siempre será constante, es como, si jugásemos al scalextric, cada vez que el cochecito del scalextric pase por un tramo, el sistema debe activarse, pero el cochecito puede tener un voltaje de 2-3 voltios hasta los 16 voltios en contínua, y el tiempo de pasada puden ser 5-10 segundos por ese tramo.

Un transformador de scalextric puede dar 4-5 amperios a 16 voltios.

Vaya, ahora ya me dejas con la duda.

Pongamos que le ponemos una de 700 u 800, que le podría pasar ?????

Ando angustiado.

Gracias y Saludos.
04/10/2010 #31

Avatar de kal00

Respuesta: Duda con optoacoplador
Si le pones una de 800, te aguantará sin problemas los 5-10 segundos de los 16v, simplemente se acortará la vida del optoacoplador. El problema será cuando le lleguen 3 o 4 volts, no te pasará corriente al LED, y si es que llega a pasar verás el LED con casi nada de brillo, y ni se diga si le llegan 2 volts, no verás nada.

Hay reguladores de voltaje que pueden regularte hasta 3v, independientemente de la señal de entrada, si le metes 16v, el regulador te entregará 3v, pero si le llegan 3v o menos no te va a dar señal.

Nunca me había preguntado cuanto voltaje usaban esas pistas de coches, creo que tengo una guardada en mis escombros, estaría bueno probarlas, pero podrías explicarme porque varía tanto la señal de voltaje?
04/10/2010 #32


Respuesta: Duda con optoacoplador
kal00 dijo: Ver Mensaje
Si le pones una de 800, te aguantará sin problemas los 5-10 segundos de los 16v, simplemente se acortará la vida del optoacoplador. El problema será cuando le lleguen 3 o 4 volts, no te pasará corriente al LED, y si es que llega a pasar verás el LED con casi nada de brillo, y ni se diga si le llegan 2 volts, no verás nada.

Hay reguladores de voltaje que pueden regularte hasta 3v, independientemente de la señal de entrada, si le metes 16v, el regulador te entregará 3v, pero si le llegan 3v o menos no te va a dar señal.

Nunca me había preguntado cuanto voltaje usaban esas pistas de coches, creo que tengo una guardada en mis escombros, estaría bueno probarlas, pero podrías explicarme porque varía tanto la señal de voltaje?
Hola.

Pues me dejas con la duda, osea que no hay resistencia que me pueda valer para esa variación de voltaje... Madre mía, que suicidio...

La variación de voltaje se debe a la velocidad del cochecito y se resume así:
0 voltios no se mueve,
3-5 voltios anda despacito,
7-9 vas mas rápido,
10-14 va muy rápido,
16 voltios va a toda la velocidad que su motorcito pueda alcanzar por la pista.

Me dejas con mal cuerpo.

De todas formas, voy a comprobar un detalle y os cuento.
Aunque quizás ya no pueda escribir hasta mañana.

Saludos y muchas gracias, creo que estamos a punto de lograrlo, nos falta el detalle...

Saludos compañeros...
04/10/2010 #33

Avatar de kal00

Respuesta: Duda con optoacoplador
Mucha suerte, esperemos que a Fogonazo se le ocurra otra forma de la que yo no tenga conocimiento.

Saludos.
05/10/2010 #34


Respuesta: Duda con optoacoplador
Hola buenas.


Un amigo me ha dicho que pruebe este circuito para que no se me queme el Optoacoplador, pero creo que los valores de la resistencia R2 no puede ser tan bajo, aunque claro, desconozco la función que realiza R1:



Alguien me puede orientar de si eso puede valer ?????

La corriente que viene del Transformador de Tracción sigue siendo la misma, corriente contínua variable entre 0 y 16 voltios.

Gracias y saludos.
05/10/2010 #35
Moderador general

Avatar de DOSMETROS

Respuesta: Duda con optoacoplador
Con dos díodos tenés 1,2 o 1,4 volts de caida , quizás tengas que poner 3 y 3 para obtener 1,8 o 2,1 volts , los para un lado son de la tensión de marcha y los para el otro son para la contramarcha.

Quizás R2 la modifiques entonces a 47 ohms , probá con un led primero

Saludos !

EDITO : Ese sistema resta tensión a las vias , o sea que ya no tendrás 16 Vdc , sino 14 Vdc
05/10/2010 #36


Respuesta: Duda con optoacoplador
DOSMETROS dijo: Ver Mensaje
Con dos díodos tenés 1,2 o 1,4 volts de caida , quizás tengas que poner 3 y 3 para obtener 1,8 o 2,1 volts , los para un lado son de la tensión de marcha y los para el otro son para la contramarcha.

Quizás R2 la modifiques entonces a 47 ohms , probá con un led primero

Saludos !

Hola DOSMETROS, bienvenido al hilo y gracias por aportar.

Entonces 22 ohms es poco verdad ????

De todas formas, no entiendo muy bien lo de poner un led, donde se pondría, en lugar de R2 ????

Y alguien sabe para que vale R1 ?????

Saludos...
05/10/2010 #37
Moderador general

Avatar de DOSMETROS

Respuesta: Duda con optoacoplador
No no , en lugar de A - K o sea en lugar de las patas 1 y 2 del opto 4n25 , así ves si se enciende bien. Ya que el opto es cerrado y no lo ves , es solo para probarlo sin romper optos.

Yo le ponía con el sistema de díodos las luces largas (2 lamparitas de 1,5 V con lupita) , las de posición traseras (2 leds naranjas) y las de freno (2 leds rojos) a los autos de Scalectrix para unas carreras nocturnas. Por eso te digo que le baja un poco de velocidad. En esas carreras no había problemas ya que todos corríamos en igualdad de condiciones.

Saludos !
05/10/2010 #38


Respuesta: Duda con optoacoplador
DOSMETROS dijo: Ver Mensaje
No no , en lugar de A - K o sea en lugar de las patas 1 y 2 del opto 4n25 , así ves si se enciende bien. Ya que el opto es cerrado y no lo ves , es solo para probarlo sin romper optos.

Yo le ponía con el sistema de díodos las luces largas (2 lamparitas de 1,5 V con lupita) , las de posición traseras (2 leds naranjas) y las de freno (2 leds rojos) a los autos de Scalectrix para unas carreras nocturnas. Por eso te digo que le baja un poco de velocidad. En esas carreras no había problemas ya que todos corríamos en igualdad de condiciones.

Saludos !

Jejeje, no hace falta, los coches de ahora del scalextric ya traen luces blancas y rojas, son muy modernos.

Lo de poner el diodo led en lugar del optoacoplador, en lugar de las patillas 1 y 2, ya lo he probado y va bien, incluso sin poner la resistencia R2, funciona perfectamente a 16 voltios y no se funde, pero no sé el motivo, ya he fundido dos optoacopladores, y por eso pregunto si tengo que poner la resistencia R2 y que valor debe tener.

También sigo sin entender que hace la resistencia R1 en ese circuito.

Gracias y saludos.
05/10/2010 #39
Moderador general

Avatar de DOSMETROS

Respuesta: Duda con optoacoplador
Evidentemente los optoacopladores son más sensibles que un led , la resistencia R2 con 3 díodos probale 47 ohms.

Tampoco se para que está R1. No le veo sentido.

Saludos !
06/10/2010 #40


Respuesta: Duda con optoacoplador
DOSMETROS dijo: Ver Mensaje
Evidentemente los optoacopladores son más sensibles que un led , la resistencia R2 con 3 díodos probale 47 ohms.

Tampoco se para que está R1. No le veo sentido.

Saludos !

No, el circuito debe llevar 4 diodos 1N4007, con lo cual debo saber que valor tiene que tomar R2.

Efectivamente, no sé para que puede servir R1, quizás para evitar algún corto.

Pues eso, con 4 diodos tengo que saber cuanto vale R2.

Gracias y saludos.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.