Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/08/2014 #1


Duda: Resistencia adecuada en gate de IRF4905
Bueno, pues explico lo que tengo:

Quiero construir un simulador de Fórmula 1 moviendo una butaca de coche con unos motores de limpiaparabrisas de 24v.

Ya tengo construidas las placas de control y puente H correspondientes y funcionan. Pero tengo un problema.

El puente H es controlado por un 74HC08 y este a su vez recibe las órdenes desde la placa de control. Los motores llevan acoplados en su eje de movimiento unos potenciómetros (feedback) que le hacen saber a la placa de control en qué posición están los motores.

Pues bién, según el diseñador de las placas, para probar el puente H se alimenta la placa de control y la entrada del puente H que puede ser desde 5 a 50v, y al mover los potenciómetros se deben de mover los motores. Y efectívamente funcionan, pero al cabo de estar unos segundos moviendo los potenciómetros a izquierda y derecha, y por ende moviéndose los motores en dichas direcciones, noto que se calientan en exceso sobretodo los IRF4905.

He leido varios post del foro sobre puentes H y he llegado a la conclusión de que el problema puede ser que los mosfet no saturen bien y por eso el sobrecalentamiento. Cada fila de 4 mosfet los tengo puestos en una placa de aluminio como disipador (creo que lo suficientemente grande) y además refrigerados por un ventilador. También probé a ver si estaban comunicados a través del disipador, pero los he medido y están correctos.

Observo que los mosfet IRF4905 y IRLZ44N llevan la resistencia del gate de 2k2 y 3k6 respectivamente, lo que me hace pensar que pueden ser demasiado altas de valor.

El diseñador de las placas comenta que el puente H está optimizado para funcionar con motores de 12v. Yo alimento obviamente con 24v, pero aún así me parece que esas resistencias no son correctas.

Creeis que debería de cambiar esos valores? Y de ser así, ¿qué valores recomendais que ponga?

Muchas gracias de antemano y perdón por el ladrillo.


Adjunto diseño de la placa del puente H para que podais ver cómo está construido.





07/08/2014 #2

Avatar de papirrin

Esta raro que le ponga una resistencia de ese valor el Datasheet dice que la Rg=25 Ohms

no tienes el diagrama? (no el PCB)
07/08/2014 #3

Avatar de juanma2468

Por lo general los valores de resistencia que llevan son bajos, no mayores a 100 ohms, puedes poner 10, 22, 33 y hasta incluso 47 ohms y deberia andar bien.
07/08/2014 #4

Avatar de papirrin

a ver si sirve como referencia, he leido mas no comprobado, que esa resistencia depende de la capacitancia del gate, entre mayor sea la resistencia tarda mas en suichear y entre mas pequeña mete mas ruido, asi que podria suponer que no es ese el problema.
07/08/2014 #5
Moderador general

Avatar de Fogonazo

En la página donde conseguiste el esquema figura el mismo pero con un cooler, ¿ Le colocaste disipadores a los MOSFET ?
Imágenes Adjuntas
Tipo de Archivo: jpg 6181-bd4f3080ee70698ba142f3bd7f728225.jpg (10,4 KB (Kilobytes), 19 visitas)
07/08/2014 #6


Sin tener el circuito, relevando el PCB que pasaste le veo dos problemas:

Primero, el 74HC08 tiene capacidad de entregar corrientes de hasta 20mA. Los MOSFETS tienen capacidades en su compuerta del órden de 1,7nF y 3,4nF respectivamente. Eso hace que al intentar excitar con esas corrientes bajas el tiempo de conmutación sea del órden de 1 uSegundos para el MOSFET-N. Este tiempo no parece ser alto, pero puede que produzca calentamiento.

Segundo, los MOSFETs P se encienden invirtiendo la misma señal que activa el MOSFET-N. Y acá tiene una resistencia de 2K2 lo que te da un tiempo de conmutación de unos 7uSeg. Esto hace que haya un tiempo dentro de los 7uSeg donde se activan en forma simultanea el MOSFET-N y el MOSFET-P (o eso parece porque no tengo el circuito completo para analizarlo mejor). Esto te hace que haya un cortocircuito de por lo menos 6uSeg entre el MOSFET-N y el MOSFET-P. Esto puede producirte un sobre calentamiento, y te puede llegar a quemar los transistores.
11/08/2014 #7


Si, tengo disipadores puestos a los mosfet e incluso ventilados.

Y entonces a vuestro entender, cual sería la mejor solución?:

- Bajo valores de resistencia y pruebo?

Por desgracia no tengo el diagrama, en la página lo dan ya la placa preparada.

Muchas gracias por vuestro interés.

Edito: Acabo de conseguir el esquema. Os lo adjunto.
Archivos Adjuntos
Tipo de Archivo: pdf dual_simple_hbridge_schematic.pdf (28,2 KB (Kilobytes), 19 visitas)
11/08/2014 #8

Avatar de juanma2468

Pues viendo el esquema, y por lo que vos comentas, me parece que el tema es que en los IRF4905 cuando los transistores BC546 saturan, no mandan a un cero total el gate de los MOSFET, por lo que puede que quedan en una zona de trabajo lineal, en la que disipan mucha potencia. Para mi la solucion seria probar puenteando las resistencia de 160 ohms con un corto, o sea que los emisores de los transistores BC546 queden conectados directamente a masa.
12/08/2014 #9


Muchas gracias Juanma por tu respuesta.

Probaré también lo que me dices. A ver si dá resultado.

Lo que también me he dado cuenta es que, en este esquema, el autor todavía no ha implementado los diodos zener y demás, aunque en la placa final ya los puso.

Se aceptan por supuesto más ideas (faltaría más). Prometo que después de las pruebas postearé cual fué la que solucionó el problema, y de no solucionarlo, cual fué la que más disminuyó el sobrecalentamiento.

Muchas gracias a todos.
15/10/2014 #10


Bueno.

Después de un tiempo hasta que pude probar, ya tengo un resultado de la prueba que hice al hacer lo que comentó Juanma, o sea, puenteé las resistencias de 160 ohmios y así dejé el emisor del transistor a masa.
Resultado:
Funciona el motor durante unos 10 segundos y se casca el transistor bc546 que comanda en ese momento la dirección de movimiento del motor.

Todavía no he probado a cambiar el valor de las resistencias 2k2 que llevan los irf4905, pero ya me dá hasta miedo.

Saludos.
17/10/2014 #11

Avatar de juanma2468

Pues proba bajando el valor de la resistencia de 2k2 a 1k5 y el valor de la resistencia de 160 a un valor de 120 ohms y volve a probar. Lamento se que te haya quemado el transistor, estas cosas de prueba y error son asi en la electronica.
17/10/2014 #12


Hola a todos ,devemos saper y recordar que los transistores MosFet para funcionar como chave tienem que tener en su VGS un valor optimo de tensión , esa tensión es aclarada en la hoja de datos de lo fabricante.
Un VGS bajo , por ejenplo 5voltios puede no ser suficiente para cerriar totalmente lo canal Dreno Y Sourse (RDSon) asi lo transistor no funciona como chave y si como un resistor (trabajando en la región lineal )calientando se en demasia , pero tanbien hay lo caso contrario: un VGS en mucho elevado puede dañar lo transistor definitivamente ( muchos fabricantes aclaran 20 Voltios como un VGS maximo). en DC no hay circulación de curriente en lo gate porque ese si conporta exactamente como un capacitor de alguns nFaradios , haora en regimes pulsados , si hay circulação de curriente en lo Gate durante la carga y descarga dese "capacitor" .
La tensión ideal para cerriar conpletamente lo canal Dreno y Sourse (RDSon)de un MosFet es algo en torno de 10 Voltios y menos de 18Voltios por questiones de seguridad (no estropiar lo MosFet por exceder su VGS maximo).
Desejo tener sido claro en mis aclaraciones , dudas adiciones pregunten es un plaser platicarmos.
Att.

Daniel Lopes.
20/10/2014 #13


Ok chicos.

Muchas gracias por las respuestas. En cuanto tenga tiempo haré las pruebas y posteo resultados.

Saludos.
28/10/2014 #14


Muy buenas.

Traigo nuevas pruebas:

He medido con el multímetro el voltaje que tiene el gate del IRF4905 cuando se satura a tope y me ha dado -10,5v.
He cambiado la resistencia de 160 Ohm que lleva el bc546 en su emisor por una de 100 Ohm para probar, y el resultado ha sido de -14,8v. en el gate.

No sé si será conveniente subir tanto la Vgs para que se sature mejor ó lo bajo a unos -12v ?

Si lo dejo en -14,8v, es conveniente cambiar los zener que lleva de 15v. entre gate y source por otros de 16v ?

Y por último, creen que corro algún riesgo en bajar el valor de la resistencia de 2,2K a por ejemplo 1K ? O sólamente influirá en el tiempo de suicheo?

Muchas gracias a todos.
28/10/2014 #15

Avatar de juanma2468

Pues la Vgs maxima de los MOSFET es de 20V, por lo que no corres ningun riesgo, igual por lo que mencionas del diodo zener aun menos riesgo corres, ya que el zener establece en el GATE un valor maximo igual a la tension de zener, por lo que nunca superara el valor de 16V en el GATE por mas que le metas un valor mayor a este. Proba con bajar el valor de la resistencia de 2K2 por una de 1K8 y proba, anda bajandolo de a poco y nos comentas. Ya lo probaste asi con la resistencia de 100 ohms y la de 2K2?
28/10/2014 #16


Hoal caro davidmval , !14.8Voltios en VGS es optimo valor ! , basta chequear lo VDS , ese seguramente estas en mui bajo valor (Fet cerriado) y quanto a lo diodo zener de 15 Voltios estas bien no hay que canbiar.Quanto a lo resistor de Gate sener 2,2kohms estas bien , bajar mas aun no miro grans vantagens, haora con auxilio de un osciloscopio (preferencialmente un digital en modo de barrido "single") es possible saper lo quanto es esa mejora en lo tienpo de corte del FET canbiando su valor .
!Fuerte abrazo!
Att.
Daniel Lopes.
29/10/2014 #17


Hola a todos.

Muchas gracias por las respuestas.

No, todavía no he probado a cambiar el valor de las resistencias de 2,2K.

El tema sería probar a bajar esa resistencia, ya que, según comentaba en este mismo hilo más arriba el amigo Papirrin y Penrico (y creo haberlo leido en alguna web sobre mosfet), al variar este valor (en este caso bajarlo) se reduce el tiempo de suicheo del mosfet y por eso puede que lleguen a estar en algún momento (nanosegundos) activados a la vez dos de los mosfet.
Lo curioso es que sólamente se calientan los IRF4905, los IRLZ44N ni siquieran llegan a templarse con una carga de 3A, cosa que veo normal.

Un saludo y muchas gracias.
29/10/2014 #18


davidmval dijo: Ver Mensaje
Hola a todos.

Muchas gracias por las respuestas.

No, todavía no he probado a cambiar el valor de las resistencias de 2,2K.

El tema sería probar a bajar esa resistencia, ya que, según comentaba en este mismo hilo más arriba el amigo Papirrin y Penrico (y creo haberlo leido en alguna web sobre mosfet), al variar este valor (en este caso bajarlo) se reduce el tiempo de suicheo del mosfet y por eso puede que lleguen a estar en algún momento (nanosegundos) activados a la vez dos de los mosfet.
Lo curioso es que sólamente se calientan los IRF4905, los IRLZ44N ni siquieran llegan a templarse con una carga de 3A, cosa que veo normal.

Un saludo y muchas gracias.
Hola a todos , los MosFet que si calientan seguramente NO estan con su canal Dreno y Sourse conpletamente cerriados( decenas de miliohmios) y eso puede sener averiguado medindo lo VDS con auxilio de un osciloscopio , recomendo tanbien averiguar lo VGS en esa condición.
!Fuerte abrazo!
Att.
Daniel Lopes.
30/10/2014 #19


Hola Daniel.

Pido perdón porque a lo mejor no me he explicado bien del todo.

Si yo pongo a funcionar en una dirección el motor de manera contínua, NO hay sobrecalentamiento.

El sobrecalentamiento viene cuando yo muevo (relativamente rápido) el potenciómetro (feedback) para hacer girar a un lado y al otro al motor. Estos potenciómetros están conectados en la placa que controla por pwm el puente H. O sea, que si lo entendí bien, realmente la que controla el puente H es esta placa por pwm y los potenciómetros los llevan acoplados los motores en sus ejes para que la placa sepa en qué posición se encuentran éstos. Creo recordar que hicieron pruebas y este puente H funcionaba bien incluso a una frecuencia de 20Khz. (Que sinceramente, no se muy bien que significa).

Por esto, pienso que el problema puede venir por la velocidad con la que los IRF4905 hacen el switch.

Que opinais?

Muchas gracias a todos.
31/10/2014 #20
Moderador general

Avatar de DOSMETROS

davidmval dijo: Ver Mensaje
El sobrecalentamiento viene cuando yo muevo (relativamente rápido) el potenciómetro (feedback) para hacer girar a un lado y al otro al motor.
O sea que arrancás el motor y rodando ¿ le invertís la polaridad ? My Good

Los valores de corriente posiblemente estén haciendo picos de unas 20 veces o más el consumo nominal del motor ! , supongo que eso te explique lo que ocurre.

Saludos !
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.