Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

10/05/2011 #1


duda con winpic
hola
Bueno mi duda es que he montado el programador pipo2
Y con winpic al hacer la prueba de harware me dice ok.
Pero La barra de progreso se queda a 0.

Es valido puedo suponer que el programador funciona?


Gracias.
10/05/2011 #2


Es valido puedo suponer que el programador funciona?
Dale con confianza... intenta grabar un 16f628a o cualquiera que sea economico....

de cualquier manera el winpic no es capaz de verificar si lo armaste correctamente...
10/05/2011 #3


programador pipo2
Gracias por responder

Vale tengo un pic 16f876
estoy mirando a ver si encuentro un ejemplo de codigo para encender un simple led
y grabarlo al pic y probarlo en la protoboard.
pero no domino mucho, no encuentro el codigo para probar.

Si pudieras pasarme un link o el codigo para quemarlo y salir de dudas.
luego ya me espavilare para programar cosas mas complicadas.
10/05/2011 #4


escoje alguno...
Solo Ejemplos PICBASICPRO-PROTEUS

desempacas y cargar el archivo Hex en el winpic...


este si tiene el hex ya lo verifique...
Solo Ejemplos PICBASICPRO-PROTEUS

Ouch perdon... dices que un programa para encnder un led.... que pic tienes el 16f876 o el 16f876A???
10/05/2011 #5


el que yo tengo Pone pic 16f876
e visto por hay que tambien hay el 16f876a no se que diferencia hay?


Gracias

Un saludo.
10/05/2011 #6


e visto por hay que tambien hay el 16f876a no se que diferencia hay?
En realidad no se exactamente se tendrian que comparar las caracteristicas de cada uno, puede ser cualquier cosa como memoria, un modulo extra (como comparadores, interrupciones, Conversores, USART, I2C, SPI Etc Etc..) o la distibucion de pines o que se yo... no te preocupes por ver la diferencia entre cada uno hasta que vayas conociendo sus funciones y tus necesidades...

mira... armalo asi...

|
v



y carga este codigo...

|
v
Imágenes Adjuntas
Tipo de Archivo: jpg Dibujo.JPG (68,0 KB (Kilobytes), 26 visitas)
Archivos Adjuntos
Tipo de Archivo: rar led.rar (272 Bytes, 2 visitas)
11/05/2011 #7


ok gracias por la explicacion tan clara

pero cuando grabo el pic me tira Error 0000h
Sabes a que es debido ¿ que estara mal el programador.?
¿El codigo que le intento meter es el ultimo que me pasaste del led y cuando solo verifico
me tira el mismo error?
11/05/2011 #8


¿El codigo que le intento meter es el ultimo que me pasaste del led y cuando solo verifico
me tira el mismo error?
lo mas seguro es que si este algo mal...

intenta detectar el dispositivo, es un incono que me parece que tiene un signo de interrogacion amarillo (no tengo en esta pc el winpic) si te pone el codigo del pic es que si esta bien el grabador y lo que puede estar dañado es el pic.... si te pono dispositivo desconocido o algo asi es el grabador...

pero debes seleccionar el grabador que estas utilizando en el menu que dice Hardware...
11/05/2011 #9


Bueno lubeck

Detecto dispositivo y carga al 100%
me pone: Detectado -> desconocido
estoy usando la opcion jdm.

Y en test harware: harware ok.

No se parece que me deja leer borrar pero no insertar el codigo.
De todas maneras probare a montarlo otra vez porque no salgo de este error.

Mil Gracias Por Tus Aclaraciones.

Un Saludo.
11/05/2011 #10


me pone: Detectado -> desconocido
mientras te ponga eso quiere decir que no lee ni borra ni graba el pic...

intenta revisar el grabador.... mide la tension que envia al pin 1 ( vpp) del micro debe ser superior a 12v
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.