Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/03/2013 #1

Avatar de Daniel Meza

Inductor de choque en alimentación de microcontrolador
Saludos... Ando diseñando un controlador de una válvulas para una máquina de inyección y me viene el típico problema de "ruido" en la fuente de alimentación provocando que la lógica de control se altere.
Para evitar esto he visto que se suele colocar un inductor de choque en serie con la alimentación de los microcontroladores y mi duda viene en este punto. ¿Este valor en base a que se calcula?. El micro con sus cargas conectadas consume a lo mucho unos 30 mA con 5V. ¿Que valor de inductor me vendría para este caso y de que otra forma puedo disminuir los problemas de ruido?. Dejo el circuito del que hablo.

Bobina.png
03/03/2013 #2

Avatar de chclau

Yo uso ferrite chip beads de Murata, son los que mejor resultado me dan ya que entre otras cosas garantizan impedancia mínima para un muy amplio rango de frecuencias y no presentan comportamiento capacitivo a altas frecuencias como lo suelen hacer muchas bobinas. La serie BLM18 en tamaño SMD 0603 viene en varios valores con los que podes experimentar para ver si resuelve tu problema. Para señales muy sensibles, tales como los pines de alimentación "analógica" del micro para las secciones de ADC o DACs, yo uso un filtro balanceado, poniendo un BLM en serie con la Vcc y el otro en serie con GND.

El capacitor de 10uF yo lo pondría del "lado de adentro", o sea cercano al micro, junto con uno o más de 100nF, y pondria del lado de afuera otro de 100 nF. La razón para poner el grande adentro es que si el micro pide picos de corriente, y el capacitor grande está afuera, puede ser que la tension sobre el micro baje demasiado y se resetee.
03/03/2013 #3

Avatar de Daniel Meza

Gracias por responder, he visto los inductores que me recomiendas pero por el momento me es difícil conseguirlos, sin embargo he estado experimentando con algunas bobinas que obtuve de PCB's descompuestos; hallé una que tiene el número 101K escrito ¿hablamos de 100uH?. Cambie el circuito de la fuente por este otro:
fuente.png

Al parecer el problema disminuyó notablemente, incluso en el peor de los casos (10 relevadores activados simultáneamente con un consumo de 600mA en total) rara vez el micro se reseteó.

¿Alguna sugerencia más para la fuente?
03/03/2013 #4

Avatar de Scooter

A mi lo que mejor me ha ido siempre son los varistores entre fase, neutro y tierra.
Filtros LC los probé de todos los gustos y sabores sin ningún resultado positivo ni negativo en observaciones subjetivas.
Y no usar un 7805 , el lm323 (si no me equivoco de nombre) funcionaba bastante mejor.
Luego ver el resto de las líneas de los sensores y actuadores a ver como están hechas...
Si usas dos fuentes, dos fuentes enteras de punta a punta transformador incluido.
Si puedes una fuente comercial "decente", la diferencia es abismal (en precio y en prestaciones )
03/03/2013 #5

Avatar de Daniel Meza

Vamos eso si, la diferencia de precios es bastante, trato de mantener un equilibrio en el precio, obvio sin arriesgar la calidad.
Con respecto al regulador, puedo conseguir el LM323K, es decir el de encapsulado en corcholata pero se me hace excesivo, 3Amp!!, (además del costo), según su hoja de datos está la versión en TO-220, trataré de conseguirlo.
Ahora, supongo el varistor iría entre el regulador y ¿el puente no?, antes de la bobina, en ese punto tengo aprox 9V, ¿un varistor de 10V me vendría bien?. Gracias
04/03/2013 #6

Avatar de Scooter

No, los varistores van a la entrada de alterna antes del transformador.
En continua ya tienes zeners, reguladores etc que "se supone" que ya filtran.
04/03/2013 #7

Avatar de chclau

Como alternativa, usando las bobinas, yo probaria poniendo dos bobinas a la salida del regulador que va a la logica, una en serie con la alimentacion y una en serie con la masa.

Fijate Scooter que parte de los ruidos se pueden estar acoplando a traves de la alimentacion de 5V para los reles que esta en el secundario, asi que no se si el varistor en el primario sera la respuesta.
05/03/2013 #8

Avatar de Scooter

Por eso no debe de usar el mismo secundario, ni el mismo primario. Lo primero que propuse es "dos fuentes enteras separadas".
Las bobinas después del regulador no las acabo de ver; las bobinas no suelen ser muy ideales y llevan su resistencia interna, cuando suba el consumo caerá la tensión. Los sistemas digitales cambian muy bruscamente de consumo, si la bobina lo impide no tengo muy claro que es lo que va a pasar. Todos los filtros LC que he visto estaban antes del regulador, incluso antes del transformador.

Aunque todo son recomendaciones generales, sin un esquema ni una idea de como está cableado, dimensionado y distribuido el sistema solo son anécdotas de como lo solucioné yo.
05/03/2013 #9

Avatar de Daniel Meza

Scooter dijo: Ver Mensaje
Por eso no debe de usar el mismo secundario, ni el mismo primario. Lo primero que propuse es "dos fuentes enteras separadas".
Las bobinas después del regulador no las acabo de ver; las bobinas no suelen ser muy ideales y llevan su resistencia interna, cuando suba el consumo caerá la tensión. Los sistemas digitales cambian muy bruscamente de consumo, si la bobina lo impide no tengo muy claro que es lo que va a pasar. Todos los filtros LC que he visto estaban antes del regulador, incluso antes del transformador.

Aunque todo son recomendaciones generales, sin un esquema ni una idea de como está cableado, dimensionado y distribuido el sistema solo son anécdotas de como lo solucioné yo.
Por el momento opté por una sola fuente como el diagrama, pero la etapa de potencia la separé lo más posible de la lógica de control y parece ya no haber más problemas.
El consumo de la lógica es poco por lo que los pequeños picos de tensión que se forman en la bobina son amortiguados por el capacitor C1.

Hasta que monte el sistema en su entorno real me daré cuenta si es necesario o no el filtro LC a la entrada del transformador y les cuento... lo más seguro es que en el transcurso de la semana vaya a montarlo, por el momento solo son ideas de diseño. De antemano gracias
15/06/2013 #10
Excluido


todavia no NO esta el cartelito rojo.,...jeee ...asi que pregunto aca:

una "idea " de cuantas vueltas hacen a un choque de estos mas o menos bueno ??
enrollado sobre una vulgar R . en el caso 1
y en un ferrite en el caso 2 ??

no hace falta exactitud, solo saber si son 10 vueltas...... 100 ... 500 .... solo una idea .

gracias
15/06/2013 #11

Avatar de foso

Para amplificadores operacionales se suele usar un filtro con choques en los dos terminales de alimentación. El inductor que se suele usar está hecho con un simple cilindro de ferrita con un agujero a lo largo de su eje. Por este agujero se pasa un cable y listo!, ese es el inductor. No tiene vueltas ni nada. Hace poco armamos un amplificador en el cual usamos estos inductores y medimos cerca de 1 uH de inductancia. Esto es suficiente.
Lo que se suele usar también es un resistor de 10 ohm en serie con el choque para bajar el Q del filtro y así evitar oscilaciones, dado que después del choque vienen un par de capacitores en paralelo como bien explicó Chclau, ( 10uF // 100nF).
Si el capacitor de 10 uF es de tantalio, mucho mejor. Aunque son caros.
16/06/2013 #12

Avatar de Nuyel

¿como elijo el inductor?
Quiero hacer una placa para experimentar con unos MSP430F5510, ya tengo el chip y estaba diseñando el circuito, como es para experimentar no escatimaré en gastos, necesito la máxima precisión y estabilidad posibles (ya en los circuitos finales se considerará emplearlo o no), pero tengo dudas con lo de la alimentación, adjunto el como es la idea, los capacitores que tengo son X7R que compré en un kit así que no se más detalles, de los de 22µf son de tántalo (AVX TAJA226K006R), por la fuente digital tengo entendido que el chip tiene un regulador interno para el núcleo y el voltaje digital se usa en los periféricos, el regulador de voltaje es un TPS73633 así que espero sea silencioso, lo que no se es como calcular la inductancia ni que parámetros debo revisar al momento de elegir el choke apropiado, mientras se lo pueda pedir a Newark conseguirlo no es problema.
Por lo pronto esperaba dejar como 100mA para los voltajes análogos y alimentar un par de referencias de voltaje y los posibles operacionales que use. ¿que me recomiendan? si se necesitan cambiar valores lo haría y tambien que me aconsejaran en la separación de DVSS y AVSS, tambien tengo mis dudas de si el PowerPad se conecta a DVSS o AVSS
Imágenes Adjuntas
Tipo de Archivo: png Alimentación.png (10,8 KB (Kilobytes), 20 visitas)
18/06/2013 #13

Avatar de Daniel Meza

¿En que ambiente estará trabajando tu prototipo?, puede que sea necesaria o no tanta protección. Saludos
19/06/2013 #14

Avatar de maton00

¿El encendido de los relés te causa esa anomalia?
ó ¿empieza ni bien se enciende todo el sistema?
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.