Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

13/11/2008 #1


¿Ingredientes para hacer un relé para mi problema?
Hola a todos. Antes de nada decir que he leído un post similar sobre un relé estado sólido con Triac que acabó en bronca y que por eso no me ha quedado claro el tema.

Quiero fabricar un relé (u otro elemento que funcione) con elementos fáciles de conseguir en cualquier tienda de electrónica. Las especificaciones que tengo son:

- Trigger mediante tarjeta de adquisición y el ordenador. A 0 voltios ('0') y a 4.72 voltios ('1'). Quiero controlar que se abra o se cierre un circuito de carga (ahora hablaré de él)

- La alimentación del relé preferentemente a base de pilas o, si puede dar problemas, de alguna sugerencia mejor que me podáis dar barata y fiable.

- El circuito de salida es simplemente una fuente de alimentación en alterna (2 voltios) y una resistencia calefactora. Cuando se cierre el circuito quiero que se caliente y cuando se abra que deje de calentar. Llevo mucho tiempo trabajando con un módulo TTL y no paro de tener problemas. Puede que por usar pilas para alimentarlo, porque todo lo demás funciona perfectamente y el módulo aguanta cargas en alterna hasta 2 A.

Ya digo que he visto un post similar pero con discusiones sobre transistores y tal que yo francamente no domino demasiado. ¿Alguien me puede ayudar con la solución más fácil que haya?
13/11/2008 #2

Avatar de pepechip

Si la carga a controlar funciona con 2v en alterna te aconsejo que utilices un rele, ya que cualquier semiconductor tendra una considerable caida de tension y viendo que solo tienes 2 ridiculos voltios no puedes desperdiciar ni una decima.
13/11/2008 #3


¿Y qué relé me recomiendas? estaba usando uno pero no para de darme problemas así que me quiero comprar otro o comprar los componentes por separado y montarlos, pero los circuitos que he visto por aquí tienen una barbaridad de cosas: transistores, varias resistencias, diodos, etc etc. ¿No hay nada más fácil que todo eso?
13/11/2008 #4

Avatar de pepechip

A la hora de pedir un rele hay que facilitarle al vendedor los siguientes parametros:
1º Tension de la bobina y si es alterna o continua.
2º Corriente maxima que soportan los contactos.
3ºNumero de circuitos.
------------------------------------------------------------------
1º posiblemente el mas pequeño que encuentres sea de 5V DC
2º si pasan 2A pidelo de 5A para que no valla forzado
3º de 1 circuito
13/11/2008 #5


Realmente no sé la corriente de la carga. Deberé medirla con el multímetro. Para ello pongo el multímetro en serie con el generador y la resistencia en modo amperímetro ¿no?
13/11/2008 #6

Avatar de pepechip

OK, pero acuerdate de empezar siempre a medir por la escala mas elevada para no deteriorar tu polimetro
13/11/2008 #7


Muchas gracias, mañana investigaré!
13/11/2008 #8

Avatar de zaiz

Re: ¿Ingredientes para hacer un relé para mi problema?
jimmyjames dijo:
Hola a todos. Antes de nada decir que he leído un post similar sobre un relé estado sólido con Triac que acabó en bronca y que por eso no me ha quedado claro el tema.

Quiero fabricar un relé (u otro elemento que funcione) con elementos fáciles de conseguir en cualquier tienda de electrónica. Las especificaciones que tengo son:

- Trigger mediante tarjeta de adquisición y el ordenador. A 0 voltios ('0') y a 4.72 voltios ('1'). Quiero controlar que se abra o se cierre un circuito de carga (ahora hablaré de él)

- La alimentación del relé preferentemente a base de pilas o, si puede dar problemas, de alguna sugerencia mejor que me podáis dar barata y fiable.

- El circuito de salida es simplemente una fuente de alimentación en alterna (2 voltios) y una resistencia calefactora. Cuando se cierre el circuito quiero que se caliente y cuando se abra que deje de calentar. Llevo mucho tiempo trabajando con un módulo TTL y no paro de tener problemas. Puede que por usar pilas para alimentarlo, porque todo lo demás funciona perfectamente y el módulo aguanta cargas en alterna hasta 2 A.

Ya digo que he visto un post similar pero con discusiones sobre transistores y tal que yo francamente no domino demasiado. ¿Alguien me puede ayudar con la solución más fácil que haya?
¿podrías subir aquí un diagrama de lo que quieres hacer?

Esto mismo que dices pero con un dibujo para entender mejor y poder darte una sugerencia.
13/11/2008 #9


Este sería el montaje.

El Relé que he estado usando es un módulo como el que veis dibujado. Alimentación a 12 o a 24 VDC. Triger de 3 a 24 VDC. Carga máxima soportada 2 A. Corriente entrada máxima 3 mA.

Me gustaría mandarlo a tomar por ahí y cambiarlo por algo que no me dé problemas. No está estropeado porque funciona bien hasta pasado un tiempo, que deja misteriosamente de ir. Tengo otro igual y le pasa lo mismo.

Así que si veo que no mejora el asunto lo cambio por otra cosa y ya está
Imágenes Adjuntas
Tipo de Archivo: jpg circuit2_164.jpg (25,8 KB (Kilobytes), 169 visitas)
14/11/2008 #10

Avatar de zaiz

¿No tienes el diagrama interno del módulo?, para ver cómo está conectado y de qué forma maneja el trigger a la bobina del relé.
Puede ser que el problema sea inestabilidad por regeneración del pulso debido a la excitación de la bobina. Y viéndolo se podría dar una opinión.

Tal vez eso se pueda corregir con un diodo (sirve un 1N4001 con el cátodo en el POS+ y el ánodo en el NEG-). O en caso de que no se solucione, agregando un transistor entre la salida TTL y el relé, todo es cuestión de la forma en que esté conectado el módulo por dentro.

(El diodo conectado así sirve para eliminar posibles pulsos falsos y proteger al circuito disparador. Si pruebas con ese diodo, tener cuidado de conectarlo de esa forma, porque si lo pones al revés te acabarías las baterías y no serviría de nada, pues sería prácticamente corto circuito)
Imágenes Adjuntas
Tipo de Archivo: jpg circuit1_139.jpg (26,4 KB (Kilobytes), 126 visitas)
14/11/2008 #11


Siento no ser de más ayuda a la hora de describir el relé por dentro, pero los cachondos de los fabricantes en el data sheet sólo lo explican de contactos para fuera. Lo más que he podido hacer son unas fotos del relé por delante y por detrás.

Muchas gracias a todos los que estáis dando sugerencias. Esta tarde probaré todas las posibles soluciones y si funciona alguna os diré cuál era el problema
Imágenes Adjuntas
Tipo de Archivo: jpg imagen_018_549.jpg (35,2 KB (Kilobytes), 114 visitas)
Tipo de Archivo: jpg imagen_017_141.jpg (42,8 KB (Kilobytes), 118 visitas)
14/11/2008 #12


Más información sobre el problema. El fabricante me ha dicho lo siguiente: " Initiating device should provide at least 3 mA output current when it sends % VDC activating voltage"
14/11/2008 #13


Aunque las fotos permiten imaginar de que va la cosa...¿Cual es el problema?

=Que funcion tiene?

En teoria, vistas las fotos debes alimentar el circuito con una fuente de 12V.

La pieza de 6 patillas es un optoacoplador ¿Que numeracion tiene?, debes aplicarle como minimo una tension de 3V y debe poder dar unos 10mA, por ejemplo 2 pilas normales(no baterias).

No le encuentro la gracia del circuito, parece a si a simple vista una tomadura de pelo, las MASAS estan unidas, para que sirve el opto?

Como no sea para un tema de interferencias... no se..
14/11/2008 #14


Mi problema es el siguiente: http://www.forosdeelectronica.com/about28447.html

Subo de nuevo la parte de atrás para marcar un poco más los contactos que puede que no se vean. pongo también la numeración que hay en algunos de los elementos, por si sirve de algo
Imágenes Adjuntas
Tipo de Archivo: jpg imagen_018_114.jpg (39,7 KB (Kilobytes), 102 visitas)
14/11/2008 #15

Avatar de zaiz

jimmyjames dijo:
Mi problema es el siguiente: http://www.forosdeelectronica.com/about28447.html

Subo de nuevo la parte de atrás para marcar un poco más los contactos que puede que no se vean. pongo también la numeración que hay en algunos de los elementos, por si sirve de algo
Sí sirve. Eso nos dice los componentes que lleva.
Lo que no se ve es en qué punto va conectado el elemento color naranja por la parte superior.

Pero independientemente de eso, sí se ve que tiene un circuito con optoacoplador y un transistor, también está el diodo de protección.

Al parecer debe funcionar bien así.

Si puedes revisar a dónde va conectado el pin de arriba del elemento color naranja.

Me parece que si están bien tus baterías de 9V, debe funcionar bien con éstas.

Puedes hacer una prueba independiente: desconecta el TTL y aplica directamente 5 V a las entradas Trigger y haz lo mismo después de un rato para ver si así funciona bien. Si te presenta el mismo problema, nos platicas.
14/11/2008 #16


La parte de arriba del elemento naranja no está conectada a ningún sitio por lo que puedo ver.

Lo de desconectar el ttl cómo puedo hacerlo estando todos los elementos fusionados en la placa? esta tarde probé a usar una fuente en lugar de las baterías y sigue sin funcionar. Incluso otras veces funcionó en algún momento y esta vez no ha funcionado ninguna vez. Suena el click cuando conmuto el trigger pero mido la impedancia sin carga para verificar si cierra o no y siempre me da una impedancia infinita (circuito abierto). Vamos, que además la resistencia calefactora nunca calienta, por si fuera un problema del multímetro. Mida bien en NA o en NC para un trigger alto o un trigger bajo, siempre siempre tengo el circuito abierto.

Así que doy por perdido el relé. Me gustaría construir o comprar uno nuevo. He ido a una tienda de electrónica pero al no entender mucho del tema no he comprado al final. Lo que sí tengo es un diodo IN4001. Puedo intentar copiar el montaje de la placa, pero no sé los elementos que son y como pedirlos en la tienda
14/11/2008 #17

Avatar de zaiz

jimmyjames dijo:
La parte de arriba del elemento naranja no está conectada a ningún sitio por lo que puedo ver.
Ah, muy bien.

jimmyjames dijo:
Lo de desconectar el ttl cómo puedo hacerlo estando todos los elementos fusionados en la placa?
Desatornillando las entradas que dicen Trig+ y Trig- y retirando los alambres que llegan desde el TTL. Y hacer prueba a ver si funciona poniendo tierra (masa) en Trig- y 5 volts (desde una fuente (o de una batería)) momentáneos en Trig+.
Con esto comprobarías si el problema efectivamente está en el módulo, pues si se activa como debe ser, el módulo estaría bien y el problema sería del ttl, etc.

En cuando a poner un circuito sustituto, también podrías intentarlo, lo que se me hace un tanto raro es que con 2 volts puedas encender un calefactor.
14/11/2008 #18


Necesito hacer balance para comprar mañana los elementos en caso de que tenga que construir un relé propio. Se viene el finde y no quiero que me cierren las tiendas.

-1) ¿Es necesario comprar un optoacoplador para el montaje? ¿Se encuentra fácil?

-2) ¿Deduzco que los elementos marcados como 103, 104 y 302 son resistencias de 1300, 1400 y 3200 ohmios?

-3) ¿El transistor marcado como 1G se pide así tal cual en la tienda?

-4) No sé que son los elementos naranja y negros ops:

-5) ¿El relé se pide con alguna característica especial?

Perdonad mi ignorancia y tantas preguntas, pero soy mas de software que de hardware
14/11/2008 #19


Si es para activar una resistencia calefactora mejor utiliza un rele de estado solido.


Dudo que el rele este estropeado, recuerda que el rele es de 12V, puede que a 9V se active pero esta muy por debajo del limite razonable.


Si quieres contruirte uno de estado solido seria algo como esto
http://www.epanorama.net/circuits/se...s.html#moc3020

El primer circuito ya te sirve, sencillo ¿No?, 2 resistencias, el moc30XX y un triac.


http://www.prato.unifi.it/ingegneria.../MOC3020-M.pdf
Con cualquiera de estos optos,MOC3020, MOC3021, MOC3022 and MOC 3023

Recuerda que el optoacoplador tiene un led normal lo que implica poner una resistencia limitadora, para 5V con una de 330 hay suficiente.
14/11/2008 #20

Avatar de zaiz

jimmyjames dijo:
Necesito hacer balance para comprar mañana los elementos en caso de que tenga que construir un relé propio. Se viene el finde y no quiero que me cierren las tiendas.

-1) ¿Es necesario comprar un optoacoplador para el montaje? ¿Se encuentra fácil?

-2) ¿Deduzco que los elementos marcados como 103, 104 y 302 son resistencias de 1300, 1400 y 3200 ohmios?

-3) ¿El transistor marcado como 1G se pide así tal cual en la tienda?

-4) No sé que son los elementos naranja y negros ops:

-5) ¿El relé se pide con alguna característica especial?

Perdonad mi ignorancia y tantas preguntas, pero soy mas de software que de hardware
Contestando a tu pregunta: no es necesario utilizar el optoacoplador.
Tampoco utilizar el mismo circuito de relé.

Ya que el título de tu tema es buscar los ingredientes para tu relé,
Aquí te dejo una opción. Aclaro que sólo hasta probar podrás saber si funcionará a tu gusto, porque es lo que puedo sugerir sin tener a la mano los elementos. Pero de que funciona, funciona.

El relé hay que pedirlo para 9 volts o para el voltaje que quieras utilizar, como serían tus 2 baterías, o como quieras. Y la corriente no creo que sea un factor muy importante porque según dices, utilizas tan sólo 2 volts! y era para máximo de 2 Amperes, lo que da un consumo mínimo.

Te aseguro que casi cualquier relé cumple y el factor que necesitas es el del voltaje de alimentación que como te digo puede ser de 9, etc, O del que tengan en la tienda y ya tú lo alimentas de acuerdo a su requisito.

(El 2N2222 es un transistor)
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.