Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/08/2013 #1


Necesito orientación para proyecto
En primer lugar, saludos a todos los que pasen y lean este mensaje.

Mi nombre es Leandro y soy estudiante de Ingenieria en Computacion (una mezcla entre Ing. Electronica y Lic. en Sistemas) en la Universidad Nacional de La Plata, Argentina.

Cuento con alguna experiencia (básica) de manejo del microcontrolador MSP430, conocimientos algo asi como básicos de electrónica y conocimientos informáticos avanzados.

Resulta que se me presentó este problema:

Compré unos router inalámbricos marca TP-LINK, modelo WR1043ND y resulta que tienen una falla importante, cada un cierto tiempo se cuelga la interfaz de acceso web y se cae el wifi.

Hacía un tiempo que estaba pensando en construir un relé AC o DC para practicar un poco y ayer se me ocurrió que podía llegar a utilizarlo en este caso.

Quisiera que cuando se cuelga el router, un relé corte la alimentación del dispositivo.

Pensé en dos formas de atacar el problema:

1) Cuando se cuelga el router, el led indicador SYS deja de parpadear, puede quedar encendido o apagado. Podría verificar el estado del LED con un microcontrolador y si no parpadea, cortar la alimentación y volver a conectarla al cabo de 1 segundo. Esto reiniciaría el router y volvería a funcionar correctamente. La fuente especifica: 12V 1.5A.

Como debería desarmar y soldar el router, prefiero no tener que utilizar esta opción. No porque no sepa como ejecutar correctamente las soldaduras sobre LEDs smd, sino porque probablemente algún día venda el router y quiero que esté inmaculado.

2) Como dije antes, cuando se cuelga el router, la interfaz web de administración deja de estar disponible. No devuelve respuesta ante la consulta HTTP a la ip y puerto del dispositivo (WR1043ND). Con algun dispositivo (podría ser un microcontrolador con alguna interfaz o módulo, que sea capaz de comunicarse via ethernet) chequear el estado de la respuesta cada cierto intervalo de tiempo, y en caso de no recibir respuesta, activar el procedimiento de reinicio de la alimentación al router.

Si se les ocurre alguna nueva o mejor manera de implementar esta idea, creo que ahí podríamos mover este tema al subforo correspondiente al método de resolución. Domótica, automatización, no se, después veremos. No supe en qué categoría debería ir esta consulta.

Desde ya, gracias a todos.
07/08/2013 #2

Avatar de capitanp

Medio cavernicola lo tuyo... no probaste en actualizar el firmware del router, o enviarle a TP-Link un mail dando detalles de esta falla... estamos en el siglo XXi y hoy en dia todas las empresas optaron por escuchar a sus clientes...

07/08/2013 #3


Dos cosas:
- La garantía del router ya expiró.
- Estuve leyendo bastante en internet acerca del router y de su firmware y en muchos países aún no han podido solucionar el problema, salieron firmwares basados en DD-WRT y firmwares oficiales estables y beta de TP-LINK y la gente sigue teniendo problemas, asi que sí, prefiero usar una solución cavernícola antes que andar probando cosas que a la mayoría no les funcionó. Prefiero usar mi tiempo en chusmear Amazon Web Services, que me tiene bastante interesado por el momento. O desarrollar soluciones cavernícolas jaja.

PD: Además en los foros TP-LINK tarda una bocha en contestarle a los usuarios, mirá si seran expertos en escuchar al cliente! Mi idea es no comprar más TP LINK de ahora en adelante, para aplicaciones escalables, como las ideas a futuro que tenía planeadas para estos chiches.

PD2: Muy buena la imagen jajaja.
07/08/2013 #4
Moderador general

Avatar de Fogonazo

capitanp dijo: Ver Mensaje
Medio cavernicola lo tuyo... no probaste en actualizar el firmware del router, o enviarle a TP-Link un mail dando detalles de esta falla... estamos en el siglo XXi y hoy en dia todas las empresas optaron por escuchar a sus clientes...
No tiene que ver con la garantía del equipo, es la asistencia al cliente que debería dar el fabricante.
07/08/2013 #5

Avatar de morta

Que se cuelgue el router me suena mas a una mala configuración que al problema de hard, aparte habría que ver si toda la gente que se queja de que se le cuelga el router tiene una mínima noción de como se configura.

Tenes ADSL o Cablemodem?

Verifica que el módem de tu prestador de internet este configurado como "always on" y no en la "opción dial on demand"

deshabilitá el dhcp del modem, que le de una ip fija al router y maneja la red con el dhcp del router.
si usas programas p2p tenes que configurar el NAT para no tener cuelges por exceso de conexiones.

Esconde el id de la red wifi para que no te terminen colgando el router por intentos fallidos de conexiones de algún vecino que este escaneando la red.

controlaste el log del modem para ver que pasa cuando se cuelga?

Hace años que uso y recomiendo esta marca por su buen balance entre precio y prestaciones, pero hay que configurarlo bien para no tener problemas.
07/08/2013 #6

Avatar de Ardogan

leasslp dijo: Ver Mensaje
...
1) Cuando se cuelga el router, el led indicador SYS deja de parpadear, puede quedar encendido o apagado. Podría verificar el estado del LED con un microcontrolador y si no parpadea, cortar la alimentación y volver a conectarla al cabo de 1 segundo. Esto reiniciaría el router y volvería a funcionar correctamente. La fuente especifica: 12V 1.5A.

Como debería desarmar y soldar el router, prefiero no tener que utilizar esta opción. No porque no sepa como ejecutar correctamente las soldaduras sobre LEDs smd, sino porque probablemente algún día venda el router y quiero que esté inmaculado.
...
¿Podrías usar un fotoreceptor puesto por afuera enfrentado al led? (fotodiodo o fototransistor). Va a quedar feo al montarlo pero no haría falta abrirlo
07/08/2013 #7


Fogonazo dijo: Ver Mensaje
No tiene que ver con la garantía del equipo, es la asistencia al cliente que debería dar el fabricante.
Sólo aclaraba lo de la garantía por si alguien me contestaba algo con respecto a eso.

morta dijo: Ver Mensaje
Que se cuelgue el router me suena mas a una mala configuración que al problema de hard, aparte habría que ver si toda la gente que se queja de que se le cuelga el router tiene una mínima noción de como se configura.

Tenes ADSL o Cablemodem?

Verifica que el módem de tu prestador de internet este configurado como "always on" y no en la "opción dial on demand"

deshabilitá el dhcp del modem, que le de una ip fija al router y maneja la red con el dhcp del router.
si usas programas p2p tenes que configurar el NAT para no tener cuelges por exceso de conexiones.

Esconde el id de la red wifi para que no te terminen colgando el router por intentos fallidos de conexiones de algún vecino que este escaneando la red.

controlaste el log del modem para ver que pasa cuando se cuelga?

Hace años que uso y recomiendo esta marca por su buen balance entre precio y prestaciones, pero hay que configurarlo bien para no tener problemas.
El modem es un cablemodem.
Está en always on.
El dhcp si mal no recuerdo está deshabilitado.
No uso programas P2P, en realidad si pero no la mayoría del tiempo, no parece haber un patron por el cual el router falle, pareciera ser que cada tantos días la pila se llena y colapsa el sistema, en algun momento se me ocurrio que podría llegar a tener mucho ripple la fuente de alimentacion, en estos dias voy a llevar la fuente a la facultad donde tienen un osciloscopio. Lo curioso es que sólo se caen el wifi y la interfaz web, puedo seguir conectado via ethernet, lo que no recuerdo haber testeado es si funciona correctamente la redirección de puertos, o si también se cae.
No creo que tenga algún vecino queriendo colgarse, pero voy a probar cambiando el SSID y ocultandolo. Tengo configurado el router con filtrado de mac y clave WPA2. Cuando el router se cuelga pareciera como que le denega la conexion a todos los clientes wifi, como si los filtrara a todos por mac, ese es el comportamiento visible desde los clientes.
Supongo que te referias al log del router, cada vez que tengo que resetear el router pierdo los logs.
Gracias por tus sugerencias, voy a probarlas.

Ardogan dijo: Ver Mensaje
¿Podrías usar un fotoreceptor puesto por afuera enfrentado al led? (fotodiodo o fototransistor). Va a quedar feo al montarlo pero no haría falta abrirlo
La verdad no creo que funcione bien esa alternativa porque tiene varios leds y están muy cerca, tendria que desarmarlo igual para que el fotodiodo no lea la luz de otros leds como power o wlan.
12/08/2013 #8


Actualización 1:

Probé ocultar el SSID, luego cambiarlo, y activar el filtrado de MAC, ayer o antes de ayer se volvió a caer. Cabe aclarar que ocultar y cambiar el SSID requirió un reboot del router, asi que sigue presentando el mismo problema.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.