Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

29/09/2011 #1


Problema con integrado 4017B
Hola, veran, estoy intentando hacer las luces del coche fantastico con 10 LEDs segundo un circuito que utiliza un ne555 y el 4017b, yo lo probe con el dicho 555 y el HEF4017bp pero no funciono, solo se encendia 1 led, y las conexiones estaban tal como en el circuito.
Perdonen por mi ingnorancia pero sera por que en vez de 4017b es Hef4017bp?
aunque mire el datasheet y son iguales
El circuito que utilice fue este http://mvdig.com/f527/4017b-decade-counter-51330/

Muchas gracias
29/09/2011 #2


No pude chequear tu circuito x que pide registrarse para verlo, quizas este sea la solucion a tu problema:
http://www.sonelec-musique.com/image...llard_001b.gif
Hace como 3 años atrás hice este circuito funciona bien. Probalo.
Para estos casos deberías contar con un simulador de circuitos como Proteus, Workbench, Multisim.

http://www.sonelec-musique.com/image...llard_001b.gif

referencia:
http://www.sonelec-musique.com/elect...llard_001.html
29/09/2011 #3

Avatar de zopilote

Lo que tienes mal es ser el IC 555, pusiste un led y su resistencia de mil ohmios en la salida del 555 (3) para testear que esta mandando pulsos. Por que nunca he visto esa configuracion astable.



cambialo como se muestra el la figura.
29/09/2011 #4


Muchisimas gracias, probare los dos metodos y ya os comentare como me fue
29/09/2011 #5


en el circuito original esta mal, donde esta marcado el interruptor de reset. Este debe ir al pin 15 que esta a masa a traves de la resistencia cuando activas el interruptor cambia a +y se resetea. El pin 16 debe estar a la tension positiva que es la alimentacion del integrado
Carlos daniel
02/10/2011 #6


zopilote tu circuito funciono a la perfeccion! carlosdaniel yo el reset q esta mal lo puse directo al + probare lo que dices sobre el pin 15
23/11/2011 #7


Hola, tengo armado un circuito con un 555 como timer, un 4017 a la salida de este y luego un ULN2803 que excita a 4 leds. La idea es que haga el efecto ida y vuelta solo una vez y luego corte. Logré hacerlo funcionar poniendo un relé en una de las salidas del ULN2803, el problema es que la mayoría de las veces que alimento el circuito, el "ida" empieza en el led #2 o el #3 o a veces inlusive arranca enciende solo un led se activa el relé. La mayoría de las veces el efecto empieza desde el led #2 como les decía, pero necesito que siempre arranque desde el #1 y haga la secuencia completa. Alguna idea amigos ??? Gracias.
24/11/2011 #8


yo te recomiendo un circuito que hice yo basandome en otros, es de 12 leds y avanzan hacia el centro y retrocesen, y asi sucesivamente, tambien puedes hacer que los leds se iluminen hasta el final y luego retrocedan quitandole un 4017 y los componestes posteriores a el, pruebalo haber si te gusta http://www.forosdeelectronica.com/al...pictureid=5531 si te interesa avisame y te paso el archivo de livewire, y estoy haciendo el pcb en pcb wizard
24/11/2011 #9


DavidMJ dijo: Ver Mensaje
yo te recomiendo un circuito que hice yo basandome en otros, es de 12 leds y avanzan hacia el centro y retrocesen, y asi sucesivamente, tambien puedes hacer que los leds se iluminen hasta el final y luego retrocedan quitandole un 4017 y los componestes posteriores a el, pruebalo haber si te gusta http://www.forosdeelectronica.com/al...pictureid=5531 si te interesa avisame y te paso el archivo de livewire, y estoy haciendo el pcb en pcb wizard
Te agradezco la ayuda, pero mi circuito ya está armado y funcionando y no quiero desarmarlo todo realmente ... Lo estoy implementando para un tablero de instrumentos de una moto para que haga el efecto una vez que se pone en contacto la misma y luego los leds funcionen indicando para lo que fueron diseñados (temperatura, luces, etc.) por lo que no pueden ser mas de 4 leds.

El circuito del 55 que implementé es el que posteo mas arriba "zopilote" con el unico cambio que una R la reemplazé por un preset para regular la velocidad de salida, el 4017 está configurado igual que tu ejemplo, y el ULN 2803 es un integrado "inocuo" si podría decírse así, que lo que hace es tomar la pobre corriente de salida del 4017 (6,5 mA) y llevarla a un máximo de 500 mA, ya que a la salida estoy poniendo Leds RGB de 10mm que consumen 20mA (es decir, 60 mA por led) por color, lo cual el 4017 no puede manejar.

Mi problema es que el circuito funciona, pero el inicio del barrido de ida de izquierda a derecha inicia aleatoriamente, a veces en el led #2, otras en el #3 , y solo a veces en el #1. Yo necesito que inicie SIEMPRE en el #1 para que el efecto se aprecie bien, ya que al ser solo 4 leds, se nota mucho el problema.

Gracias.
24/11/2011 #10

Avatar de Gudino Roberto duberlin

Hola Amigo, debes generar un one-shot de reset sobre el CI 4017.
24/11/2011 #11


Gudino Roberto duberlin dijo: Ver Mensaje
Hola Amigo, debes generar un one-shot de reset sobre el CI 4017.
Hola, gracias por tu ayuda. No sé como hacer el reset que me sugerís, pero voy a buscar en la hoja de datos del 4017 a ver si entiendo. Lo que no sé me doy cuenta es como lo implementaría, te explico, el circuito que diseñé se alimenta al poner la moto en contacto, es decir, todo el circuito está sin alimentarse y al poner la llave de encendido de la moto en contacto, llegan los 12v al circuito, comienza a oscila (el 555) el 4017 a tomar los pulsos y desparramarlos por las salidas y el ULN a aumentar la corriente de salida e iluminar los leds, todo sin intervención alguna, ya que la idea es que sea algo "estético" y luego queden listos a cumplir la función de monitoreo de la moto. Para que el efecto sea ida y vuelta solo una vez, coloqué un relé doble inversor retroalimentado en una de las salidas (en la 8 puntualmente) para que corte ele efecto. Por lo que no sé en que momento o como implementar un pulso de reset al 4017 en forma automática ... ¿alguna idea ?

Gracias nuevamente.
24/11/2011 #12
Moderador

Avatar de elaficionado

Hola.

Publica tu circuito, para tener una mejor idea de lo que sucede.

Chao.
elaficionado.
24/11/2011 #13


elaficionado dijo: Ver Mensaje
Hola.

Publica tu circuito, para tener una mejor idea de lo que sucede.

Chao.
elaficionado.
Acá dejo los 3 circuitos que acoplados uno a otro dan el resultado final.
Los saqué del sitio www.ledfacil.com.ar, lo aclaro por las dudas por si alguien reclama derecho de autor:

http://dl.dropbox.com/u/2247024/Secuenciador/555.jpg
http://dl.dropbox.com/u/2247024/Secuenciador/4017.jpg
http://dl.dropbox.com/u/2247024/Secuenciador/ULN%202803.bmp

Gracias de antemano por su ayuda.
24/11/2011 #14
Moderador

Avatar de elaficionado

Hola.

Mira este circuito.





Chao.
elaficionado
Nota: El archivo ZIP contiene el circuito en Livewire
Imágenes Adjuntas
Tipo de Archivo: gif 4017-----A.gif (9,7 KB (Kilobytes), 146 visitas)
Tipo de Archivo: gif 4017-----B.gif (3,0 KB (Kilobytes), 138 visitas)
Archivos Adjuntos
Tipo de Archivo: zip 4017B A.zip (3,2 KB (Kilobytes), 28 visitas)
25/11/2011 #15


elaficionado dijo: Ver Mensaje
Hola.

Mira este circuito.





Chao.
elaficionado
Nota: El archivo ZIP contiene el circuito en Livewire
Gracias por su ayuda. Ya está solucionado gracias al aporte de Gudino. Lo que tuve que hacer es quitar la conexión de RESET de masa directa y poner un capacitor de 0.1 uf entre este y +12v. También una resistencia de 1k entre RESET y masa y se solucionó. La explicación es que al momento de alimentar el circuito, el capacitor está poniendo en directo la entrada de RESET a +12v, poniendo un 1 en ella, luego se carga lentamente a través de la resistencia de 1 k y se pasa la entrada a 0, con lo que el 4017 se reinicia y siempre empieza desde la primer salida.

Gracias a todos por su ayuda e interés.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.