Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

12/09/2011 #1


Problema con resistores y leds
Que tal.

Hace unos dias hice un circuito de leds secuenciales; pero necesitaba usar leds azules asi que supuse que necesitaria cambiar la R3:



primero use una de 220Ω y funciono bien, luego por curiosidad le puse una de 330Ω y volvio a funcionar, despues le puse una de 560Ω y funciono, entonces use una de10kΩ y siguio funcionando . Y como funciono con todos ahora no se que resistor usar, que hacen ustedes para saber cual colocar? no se supone que tiene que haber caída de tensión? entonces porque sigue funcionando?, por favor ayúdenme por que no se mucho de electronica.

Gracias
12/09/2011 #2
Moderador

Avatar de elaficionado

Hola.

Usa 680 ohmios

Chao.
elaficionado.
12/09/2011 #3

Avatar de Gudino Roberto duberlin

Blackruz dijo: Ver Mensaje
Que tal.

Hace unos dias hice un circuito de leds secuenciales; pero necesitaba usar leds azules asi que supuse que necesitaria cambiar la R3:



primero use una de 220Ω y funciono bien, luego por curiosidad le puse una de 330Ω y volvio a funcionar, despues le puse una de 560Ω y funciono, entonces use una de10kΩ y siguio funcionando . Y como funciono con todos ahora no se que resistor usar, que hacen ustedes para saber cual colocar? no se supone que tiene que haber caída de tensión? entonces porque sigue funcionando?, por favor ayúdenme por que no se mucho de electronica.

Gracias
Amigo, las salidas de los CI CMOS no estan diseñados para manejar una carga como un LED, pues estos apenas entregan una debil corriente. Debes agregar transistores (en tu caso) para manipular los LEDs.
12/09/2011 #4

Avatar de BKAR

Cierto los CMOS no entregan mucha corriente..ademas los LED azules prenden a mayor voltaje 3vol min creo...y jalan mas corriente..en todo caso fijate en datashett
12/09/2011 #5
Excluido


Blackruz dijo: Ver Mensaje
. . . primero use una de 220Ω y funciono bien, luego por curiosidad le puse una de 330Ω y volvio a funcionar, despues le puse una de 560Ω y funciono, entonces use una de10kΩ y siguio funcionando . . .
Algunos leds comienzan a emitir luz con I<1mA, pero su brillo es debil.
12/09/2011 #6

Avatar de CasiCuentoCasas

E - Vd - Vr = 0
Vr = 9V - 3V = 6V => Ir = 3*Vr/R
Ir = 3* 6V /1.2 kohm = 15mA (esta es la corriente por la resistencia)
Debes fijarte si el IC soporta esa corriente.
Saludos.
12/09/2011 #7

Avatar de Ajna

Mandrake dijo: Ver Mensaje
Algunos leds comienzan a emitir luz con 1mA, pero su brillo es debil.
Es cierto hay led sobre todo los blancos y azules que cuando conecto el anodo al positivo y toco con el dedo el catodo y con la otra mano toco cualquier ventana prende aunque con un brillo bajo pero prenden , cosa del diablo, hummm noooo
12/09/2011 #8
Moderador

Avatar de elaficionado

CasiCuentoCasas dijo: Ver Mensaje
E - Vd - Vr = 0
Vr = 9V - 3V = 6V => Ir = 3*Vr/R
Ir = 3* 6V /1.2 kohm = 15mA (esta es la corriente por la resistencia)
Debes fijarte si el IC soporta esa corriente.
Saludos.
Hola.

Vr= 6V y RLed =1.2k ===> Iled = 5mA
El 4017 enciende un LED a la vez.

Chao.
elaficionado.
13/09/2011 #9


hola ayer no pude revisar mi tema, gracias a todos por sus respuestas.

elaficionado dijo:
Hola.

Usa 680 ohmios
como obtuviste ese dato?

Gudino Roberto duberlin dijo:
Amigo, las salidas de los CI CMOS no estan diseñados para manejar una carga como un LED, pues estos apenas entregan una debil corriente. Debes agregar transistores (en tu caso) para manipular los LEDs.
BKAR dijo:
Cierto los CMOS no entregan mucha corriente..ademas los LED azules prenden a mayor voltaje 3vol min creo...y jalan mas corriente..en todo caso fijate en datashett
pero si los leds encienden perfectamente y con excelente brillo, quieren decir que se dañara el 4017?
13/09/2011 #10
Moderador

Avatar de elaficionado

Hola.

La máxima corriente que da el 4017 es de 6.8mA
Los LED blancos o azules son de 3.4V.

Debí haber puesto de 820 ohm ó 1K.

Chao.
elaficionado.
13/09/2011 #11


Cada led debe consumir 20 ma como máximo. Usá un transistor NPN por cada Led. Este lo pones en el colector con una resistencia de unos 500 ohms en serie. Medís la corriente y bajá el valor de la reistencia hasta unos 18 ma. Probando así te irá bien.
Suerte.
14/09/2011 #12


Gracias, voy a intentar con transistores 2n3904.

14/09/2011 #13
Moderador

Avatar de elaficionado

Hola.

La resistencia limitadora del LED se calcula así:

Rled = (Vcc - n*Vled) / Iled

Rled -----> Resistencia limitadora del LED
Vcc -----> Fuente de alimentación
n -----> Número de LEDs en serie (para un LED n=1)
Vled -----> voltaje del LEDs (depende del color)
Iled -----> corriente típica del LED (20mA, Iled máxima está entre 25 y 30mA, esto depende del color del LED o lo que indique la hoja de datos)
Estos datos te pueden dar una idea sobre el voltaje de los LEDs.

http://www.forosdeelectronica.com/at...5&d=1239911604
http://www.forosdeelectronica.com/at...7&d=1238174569

Chao.
elaficionado.
14/09/2011 #14
Excluido


Blackruz dijo: Ver Mensaje
. . . pero si los leds encienden perfectamente y con excelente brillo, quieren decir que se dañara el 4017?
La aplicacion mas popular del CD4017 es realizar leds en secuencias, entonces si puede usarlo para esa aplicacion.



Tenga en cuenta las siguientes pautas:
  • NO exija mas de 20mA por cada salida.
  • NUNCA olvide colocar la resistencia limitadora de corriente.

Asi puede utilizarlo de forma segura.
15/09/2011 #15

Avatar de CasiCuentoCasas

Mandrake dijo: Ver Mensaje
Tenga en cuenta las siguientes pautas:
  • NO exija mas de 20mA por cada salida.
  • NUNCA olvide colocar la resistencia limitadora de corriente.
Disculpame que te joda por esto, pero de donde sacaste la info que cada salida del 4017 soporta como maximo 20mA. Estuve viendo esta hoja de datos http://www.datasheetcatalog.org/data.../499984_DS.pdf y no lo encontre. Sabrias decirme como debo buscarlo??

Saludos =)
15/09/2011 #16


CasiCuentoCasas dijo: Ver Mensaje
[/LIST]Disculpame que te joda por esto, pero de donde sacaste la info que cada salida del 4017 soporta como maximo 20mA. Estuve viendo esta hoja de datos http://www.datasheetcatalog.org/data.../499984_DS.pdf y no lo encontre. Sabrias decirme como debo buscarlo??

Saludos =)
a mi también me cuesta mucho entender esas hojas y para complicarlo mas, están en ingles .
existe algún curso para entender eso? , por que a a mi nunca me enseñaron sobre eso, o tal vez eso se estudia hasta en la universidad .

Por cierto si excedo esa corriente (del 4017), se va a dañar verdad.

15/09/2011 #17
Moderador

Avatar de elaficionado

Hola.

Mira Ioh y Iol

http://www.datasheetcatalog.org/data.../108737_DS.pdf


Chao.
elaficionado.
15/09/2011 #18
Excluido


CasiCuentoCasas dijo: Ver Mensaje
. . . pero de donde sacaste la info que cada salida del 4017 soporta como maximo 20mA. Estuve viendo esta hoja de datos . . .
La informacion del datasheet, esta condicionada para el funcionamiento digital del integrado:

0 Logico ==> VOL @ IOL
1 Logico ==> VOH @ IOH

Y con esa informacion el fabricante garantiza el correcto funcionamiento del integrado, en aplicaciones digitales.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.