Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

08/03/2012 #1


Problemas con circuito y L293b
Hola estoy haciendo el circuito para controlar un motor de 12v, la idea es que gire hacia un lado hasta que accione un switch, y luego gire hacia el otro lado hasta accionar el otro switch.

Uso el livewire para hacer la simulacion y funciona correctamente. Pero a la hora de hacerlo en forma real, el circuito no funciona y el L293b se calienta.
-El motor ya funcionaba en otro circuito con un l293, accionado por un transistor c945 conectado como interruptor.
-El l293 no está quemado y funciona perfectamente en el otro circuito.

Les dejo el diagrama a ver si me pueden ayudar a saber porque no funciona.


Este es el PCB ya hecho, los transistores son c945.


Espero sus ayuda.
Saludos
08/03/2012 #2

Avatar de phavlo

Fíjate si en el L293 no algún corto entre alguna salida y GND, a mi me paso una vez que se me calentaba mucho y cuando lo revise tenia una mínima pista que cortocircuitaba una de las salidas con GND.
Saludos
08/03/2012 #3


Gracias, el diodo D8 estaba al revez y hacia un corto. Ahora funciona el motor y frena al cortar el switch sw1. Pero el Relé no se acciona con la señal "pic". Medí la salida del transistor Q4 al conectarle 5v en la base y solo entrega 5v siendo que el colector está conectado a 12v.
09/03/2012 #4


Estube revisando, al parecer estoy utilizando en transistor que recive la señal "pic" con el emisor para alimentar el relé y deberia conectar el rele directamente a la alimentacion y el emisor a tierra, pero en mi diseño no se puede.

Intenté con un transistor PNP (emisor a 12v y colector al relé) pero sin que yo mande la señal "pic" activan la base del transistor que va al integrado (Q3 en el diagrama y Q5 en el pcb).
-¿Como puedo hacer para activar el relé y polarizar la base del transistor solo cuando mande la señal del pic?

Espero sus respuestas.
PD:Los transistores tienen las resistencias en las pata de la base por lo que no salen en el pcb.
09/03/2012 #5

Avatar de phavlo

Si usas un trnasistor PNP se va a activar cuando en la base haya un 0 y cuando haya un 1 no va a funcionar, funciona al revez que los NPN, usa un NPN.
Señal del PIC a la base, emisor a GND y el rele entre VCC y colector.
09/03/2012 #6


Ah gracias, voy a ver si duermo algo y lo rediseño.

Saludos
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.