Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

16/02/2016 #1


Problemas con pantalla tactil para PIC
Buenas, tengo un problema con un controlador de pantalla tactil para PIC, no consigo hacer funcionar la pantalla tactil y creo que es fallo del controlador porque nada mas desconectar el controlador del circuito, un transistor me marca que esta en corto entre colector y emisor, otras veces me lo hace otro transistor, y al cabo de un minuto dejan de estar en corto y me dan valores correctos entre base y emisor y base y colector y me estoy volviendo loco porque no consigo averiguar si es fallo de algun transistor o del propio panel tactil.

Pero estoy empezando a sospechar que es la propia pantalla tactil que esta defectuosa aunque no descarto que algun transistor este defectuoso.

No tengo osciloscopio, por lo que la unica manera de probar los transistores es con multimetro pero como digo, me dan valores correctos al cabo de un minuto o 2.
El circuito del controlador de la pantalla tactil es este.
Que me podeis echar una mano para encontrar el problema?
17/02/2016 #2


Creo que un transistor que se pone en corto, no vuelve a su estado normal nunca, algo estás haciendo mal o midiendo mal.

Empecemos del principio, yo uso para medir un tester analógico de los comunes, los digitales no sirven para detectar pequeñas fugas entre E-C o fugas en inversa, y el analógico si los detecta.

La medición que efectuas es con el tr colocado en el circuito o lo sacas??
17/02/2016 #3


Buenas Sergiot, uso el multimetro con los transistores en el circuito, no los he sacado porque es un controlador de pantalla hecho por el fabricante.
Es este:
http://www.mikroe.com/add-on-boards/...troller-proto/
Vamos de una sencillez acojonante, pero no funciona la pantalla tactil y las conexiones estan bien hechas y repasadas y mas que repasadas varias veces una salida al panel tactil y la otra a cada borne, son 6 en total, 4 para el PIC, 2 de ellas al ADC (read X y read Y), 2 para otros 2 puertos(drive A y drive B) y VCC y GND si es que no tiene mas secreto, ah bueno y el conector del panel tactil resistivo que es un molex, asi que imaginate que dificultad puede tener conectarlo.
Pues nada, el panel tactil no funciona, esta mas que repasado todo, el programa, las conexiones, cristal condensadores resistencias, todo esta como debe ser, ademas es un ejemplo basico que ofrece microchip del uso del panel tactil, te dejo el vinculo para que veas que lleva años el ejemplo en la red, por lo que, o esta mal el controlador o esta mal la pantalla tactil, no queda otra.

http://www.mikroe.com/downloads/get/..._pic_01_09.pdf

Bueno, pues todo conectado es imposible que funcione el panel tactil, la pantalla funciona a la perfeccion, pero el panel no hay manera.
Los transistores los pruebo con el tester en la controladora pero sacandola de la proto en modo continuidad, la del sonido y pita entre colector y emisor y al cabo de 2 minutos o asi vuelven a su estado normal, como no sean los capacitores los que me estan haciendo creer que la controladora esta mal, pero es que solo hay 2, son de 100nf y ademas tienen 2 resistencias en paralelo, por lo que dudo que le quedase carga a los condensadores para darme continuidad, si es que ademas esos condensadores ni si quiera ceban la base de ningun transistor para que haya continuidad entre colector y emisor en los transistores.
Al cabo de 2 minutos si mido continuidad en modo diodo, solo al cabo de 2 minutos (con la controladora desconectada de todo) me vuelven a dar valores correctos entre base y emisor y base y colector.
Ya dudo si es el panel tactil que los pines esten mal especificados, pero no se como probarlo o que sea la controladora del panel tactil.
17/02/2016 #4

Avatar de SSTC

mikeekim dijo: Ver Mensaje
Buenas, tengo un problema con un controlador de pantalla tactil para PIC, no consigo hacer funcionar la pantalla tactil y creo que es fallo del controlador porque nada mas desconectar el controlador del circuito, un transistor me marca que esta en corto entre colector y emisor, otras veces me lo hace otro transistor, y al cabo de un minuto dejan de estar en corto y me dan valores correctos entre base y emisor y base y colector y me estoy volviendo loco porque no consigo averiguar si es fallo de algun transistor o del propio panel tactil.

Que me podeis echar una mano para encontrar el problema?

Lo que debes haces es sacar el transistor y medirlo aislador del sistema. Si esta correcto descartados y a seguir midiendo,,,

Saludos
18/02/2016 #5


No, aun no he desmontado los componentes del controlador porque primero quiero saber si es la pantalla tactil, me la han remplezado por otra, pero mucho me temo que la pantalla tactil funcionaba, el problema esta casi seguro en el circuito que es imposible que levante la pantalla tactil para leer los valores del adc del pic porque he encontrado otro circuito parecido pero las conexiones son diferentes.

18/02/2016 #6


En vista que el diseño funciona, o eso suponemos, pero no te funciona a vos, sería bueno que pongas fotos de la placa, de un papel a la realidad hay un abismo.

Te aclaro que no tengo idea de pantallas táctiles ni mucho menos, es solo por cuestiones básicas de las reparaciones y el diseño en general.
18/02/2016 #7


El controlador es comprado a mikrochip, lo compre para evitar problemas y me he encontrado justo lo contrario.
es este:
http://www.mikroe.com/add-on-boards/...troller-proto/
Corresponde al circuito de la imagen superior por las mediciones que he hecho



Y por mas que lo repaso esta todo conectado correctamente, no hay ni la mas minima diferencia conrespecto al esquema este:

La parte del touch screen controller es el de la imagen de arriba, el que compre para evitar problemas.
Hacer funcionar las pantallas LCD y controlar casi cualquier cosa con un pic se me hace relativamente sencillo, pero el touch panel me esta volviendo completamente loco porque no consigo dar con el problema.

18/02/2016 #8


Quiero suponer que la parte que no funciona es la del touch, no? es un panel resistivo?? los pocos que he visto al apretar varia la resistencia en ambas coordenadas, eso lo has controlado?
18/02/2016 #9


Si, es resistivo y lo comprobe nada mas llegar pero no he vuelto a probarlo, ademas cuando esta conectado todo el touch y la controladora, se produce una fuga de corriente de vcc a gnd al poco tiempo, 1 min o 2, que hace que la pantalla vaya perdiendo contraste, hasta que deja de funcionar, el fallo esta en el touch o en la controladora porque sin ellos, la pantalla funciona todo el tiempo que la deje encendida.

Asi que he llegado a la conclusion que algun transistor se va poniendo en corto hasta que crea la fuga, ademas la fuente tiene amperimetro y al conectarlo todo esta en los 90ma pero a medida que va pasando el tiempo, aumenta el amperaje hasta los 170 ma +- que es cuando ya definitivamente deja de funcionar la pantalla por culpa de la fuga que causa o la controladora o el touch panel.

Diria que el touch panel no puede producir la fuga porque a grosso modo es una resistencia variable en todo su conjunto, asi que no queda otra que algun transistor este jodido.

Ademas, cuando saco la controladora de la proto y mido los bornes VCC y GND de la controladora, me marcan continuidad entre ellos y al cabo de unos 2 minutos todo vuelve a su estado normal, no vuelve a haber continuidad en los bornes vcc y gnd de la controladora.
Que es cuando deja de haber la fuga.
18/02/2016 #10


Vayamos por partes, si tu suposición de que un tr se pone en corto, analizando el circuito por ejemplo el primer tr de arriba tiene una r de 1k que quedaría en serie al corto de C-E, de suceder eso es como poner la r de 1k a masa, y a 5V serían como 5 mA, nada.

El otro tr si se pone en corto C-E no esta derivado a masa y no pasa nada, y los otras dos por medio de B-E en corto te ponen 2 resistencias de 1k en serie, menos aún.

Eso sería un análisis medio burdo de la cuestión.
18/02/2016 #11


Eso es lo que creo que hace y no tendra sentido pero explicame porque hay continuidad en ciertos puntos que no estan conectados directamente y pasados un par de minutos dejan de estar en continuidad.
Vamos que aunque suceda eso tu crees que el causante de que no funcione la pantalla tactil es la propia pantalla tactil y no la controladora?
18/02/2016 #12


Lo que no me queda claro es porque con aumento de corriente de 170mA deja de funcionar, no será que tu fuente de alimentación no soporta el consumo del sistema y ese aumento de consumo es algo normal por calentamiento de los tr
18/02/2016 #13


La fuente soporta 2 amperios, le he metido circuitos de casi 2 amp y los ha aguantado sin problemas, la fuente no es, te lo garantizo.
Aqui tienes la prueba, una celula peltier de 12v 3 amp trabajando a 8.8v 1.79 amp.

Si quieres te hago un video para que veas lo que sucede, pero vamos es tal como te lo cuento, va aumentando el amperaje a medida que va disminuyendo el brillo de la pantalla hasta que deja de verse nada en la pantalla y solo lo hace con la controladora puesta, si desconecto el panel tactil de la controladora sigue haciendolo y solo deja de hacerlo cuando esta solo la pantalla conectada.

Por lo que he llegado a la conclusion que, o la controladora esta defectuosa, o el diagrama de la controladora es incorrecto.

Y me niego a creer que un diagrama que lleva publicado varios años en internet oficialmente por mikroelectronika, ningun usuario se haya topado con este problema, por lo que, por coj... la controladora tiene algun defecto.
19/02/2016 #14


Pero entonces, al aumentar el consumo deja de andar el PIC también??

No será que estan muy cargadas las líneas del pic y por eso el aumento del consumo?
19/02/2016 #15


Si fuese asi, porque no lo hace cuando desconecto la controladora del circuito?
Es que estamos hablando de 170ma en el consumo maximo, si esos cables no pueden soportar 170ma, apaga y vamonos.
19/02/2016 #16


No me has entendido, no digo que los cables no soporten ese consumo, digo que por alguna razón ese consumo y el hecho que deje de funcionar el display se deba a que el pic esté muy cargado por la placa controladora y la corriente hace que caliente y que aumente paulatinamente la corriente.

Por lo que yo entiendo según tu explicación, no solo deja de andar el touch, sino también el display el cual recibe la señal del pic, esto es así, no? de ser así lo que deja de andar es el pic.

No recuerdo si has probado de desconectar el touch solamente, dejando la controladora conectada al pic, lo has hecho?
19/02/2016 #17


Cuando aumenta el consumo se resetea, no deja de funcionar nunca, simplemente se reinicia el pic, seguramente por culpa del cruce producido por la controladora o la fuga.

Lo de dejar solo la controladora al pic ya lo habia probado y sigue haciendolo, asi que el touch no es.
19/02/2016 #18


Por lo que veo son 4 líneas que van de la controladora al pic, trata de medir la corriente en cada una de las líneas que van del pic a la controladora.
19/02/2016 #19


Bueno he encontrado el problema del porque se reseteaba el pic e iba perdiendo brillo la pantalla poco a poco, estaba en el regulador de 5v se ve que estaba defectuoso y notaba ese minimo aumento de amperaje poco a poco hasta que sufria una caida de tension y vuelta a empezar, he puesto uno nuevo y le he añadido un zener de 7v5 antes para que sea mas estable el voltaje que le llega porque la idea es que el proyecto vaya alimentado con un arrancador de bateria que varia desde los 13.7v hasta los 10v con todo conectado.

Pero el puñetero panel tactil sigue sin funcionar.
Como se comprueba un panel tactil resistivo si esta defectuoso?
pin Y arriba pin Y abajo y medir y Pin X derecha y pin X izquierda y medir me imagino, pero como se si esta defectuoso?
19/02/2016 #20


Terminó siendo la fuente al final, nunca mencionaste que había un 7805 en la cuestión, pero bueno, ya esta solucionado.

Ojo que entrando con tanta tensión el 7805 se te cocina, yo pondría un 7808 o 7809 antes, no usaría un zener.

Hasta acá llegué, suerte con el touch.
Tema Cerrado
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.