Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

28/08/2011 #1


problemas con sensores infrarojos
amigos de foro electrónica tengo el siguiente problema...tengo un carro seguidor de linea pero este trabaja con la linea negra y en blanco apaga motor....resulta que la primera vez que lo pruebo funciona bien anda en linea negra y apaga en blanco pero cuando vuelve a pasar de blanco a negro queda cargado el circuito osea el led de aviso se le nota un poco de carga me toca levantar lo de la linea y así apaga totalmente....


que puedo hacer,......
28/08/2011 #2

Avatar de Gudino Roberto duberlin

elecmix dijo: Ver Mensaje
amigos de foro electrónica tengo el siguiente problema...tengo un carro seguidor de linea pero este trabaja con la linea negra y en blanco apaga motor....resulta que la primera vez que lo pruebo funciona bien anda en linea negra y apaga en blanco pero cuando vuelve a pasar de blanco a negro queda cargado el circuito osea el led de aviso se le nota un poco de carga me toca levantar lo de la linea y así apaga totalmente....


que puedo hacer,......
Hola amigo sube el esquema para poder ayudarte...
29/08/2011 #3


listo amigo aqui esta---

espero me ayudes
29/08/2011 #4

Avatar de Gudino Roberto duberlin

elecmix dijo: Ver Mensaje
listo amigo aqui esta---

espero me ayudes
Hola Amigo, bien, bueno, 1ro. la R1 tiene un valor muy bajo, dado la alimentacion que tiene, has hecho el calculo segun la Imax. del LED emisor?.
Ademas la R2, prueba cambiar su valor por 22k, 33K, veras los resultados, segun pruebas, ademas las pruebas hazlas con buena iluminacion, ya que estos dispositivos, son facilmente alterados por luz, artificial, solar, etc.
29/08/2011 #5


pues amigo le coloque una resistencia de 200 homios..a r1...que dices...

otra cosa amigo....analiza una cosa... si colocamos el circuito asi sin el foto diodo o con el queda ensendido el led de aviso...me TOCO no colocarle tierra al fotodiodo y colocarlo entre R2 y R3...Y ASI SI FUNCIONA...CORRIGEME.....
29/08/2011 #6

Avatar de Daniel Meza

Quitándole el foto diodo siempre permanecerá encendido el led de aviso. Te recomiendo que utilices en vez del fotodiodo un fototransistor, desempeñan la misma función salvo que este último es más "sensible" a la señal infrarroja... saludos
29/08/2011 #7

Avatar de Gudino Roberto duberlin

elecmix dijo: Ver Mensaje
listo amigo aqui esta---

espero me ayudes
Hola bueno, segun lo que comentas, de esa forma estas cambiando la logica de salida, aumenta aun mas el valor de R2, ademas agrega un diodo tipo 1N4148 en serie con el emisor del transistor y GND.
Pues lo optimo es reemplazar este sistema con un operacional.
31/08/2011 #8


la verdad no quiero cambiar la logica del circuito..pero si lo hago asi como esta me queda directo.. el fotodiodo no hace ninguna funcion.....que hago lo dejo como lo tengo o que?

otro problema analicen este circuito si coloco los diodos rectificando para los motores me crea error....y si no los coloco funciona bien cual es el fin de esos diodos con esos motores... aqui les dejo el esquema
31/08/2011 #9

Avatar de Gudino Roberto duberlin

elecmix dijo: Ver Mensaje
la verdad no quiero cambiar la logica del circuito..pero si lo hago asi como esta me queda directo.. el fotodiodo no hace ninguna funcion.....que hago lo dejo como lo tengo o que?

otro problema analicen este circuito si coloco los diodos rectificando para los motores me crea error....y si no los coloco funciona bien cual es el fin de esos diodos con esos motores... aqui les dejo el esquema
Hola Amigo, los diodos cumplen la funcion muy importante de absorber la f.e.m. generada por los motores cuando estos son conmutados al corte, protegiendo asi la salida del driver.
01/09/2011 #10


pero si los coloco como estan me recalienta el integrado l29...que hago--- o que error tengo
02/09/2011 #11


amigo si modificamos el circuito..
Gudino Roberto duberlin dijo: Ver Mensaje
Hola bueno, segun lo que comentas, de esa forma estas cambiando la logica de salida, aumenta aun mas el valor de R2, ademas agrega un diodo tipo 1N4148 en serie con el emisor del transistor y GND.
Pues lo optimo es reemplazar este sistema con un operacional.

amigo asi como esta el circuito me puedes decir cual seria la logica..... enciende led de aviso con luz o sin luz en el fotodiodo...

Daniel Meza dijo: Ver Mensaje
Quitándole el foto diodo siempre permanecerá encendido el led de aviso. Te recomiendo que utilices en vez del fotodiodo un fototransistor, desempeñan la misma función salvo que este último es más "sensible" a la señal infrarroja... saludos

y colocando el foto diodo según el circuito apagara.....pero al colocarlo como el circuito no me hace nada al detectar luz....porque ayúdame.....
03/09/2011 #12


danril necesito ayuda boy a remplazar el foto diodo yl el led infrarojo por un cny70 como lo conecto al mismo circuito...ayuda
03/09/2011 #13

Avatar de Daniel Meza

Analizando el circuito se puede observar lo que sucede y la causa del problema. haciendo referencia al diagrama y suponiendo que la luz ambiental es máxima (el fotodiodo se encuentra conduciendo), habrá una caída de V apróx ~1 V en el fotodiodo (Valor práctico), esta caída relativamente alta provocará que la base del transistor se encuentre a un potencial mayor de 0.7 Volts y a su vez lo polarice directamente y este se sature haciendo que el led encienda. Apagando la luz (corte del fotodiodo) la corriente de la fuente fluirá por R 10k y R1k hacia la base del transistor provocando el mismo efecto anterior.
Entonces con esto podemos darnos cuenta que lo que se necesita es elevar el potencial de la VBB (Voltaje de la base con respecto a tierra) del transistor; para esto te sugiero que cambies la resistencia limitadora de corriente de 220 del led y la coloques entre emisor y tierra del transistor (y si es posible subirla a 330 ohms). Esto "garantizará" que la base del transistor necesite un voltaje mayor de 0.7 Volts en su base para saturarse y se corte cuando nos e cumpla esta condición (luz encendida y fotodiodo conduciendo).

Espero haberte sido claro. Saludos

Si prefieres usar el CNY70 puedes auxiliarte de este circuito

En este caso, la lógica será la siguiente, cuando haya una señal infrarroja (luz) incidiendo en el sensor hará que el fototransitor interno se satura y la terminal salida marque ~0V. En caso contrario, cuando no incida sobre el fotoransitor alguna señal, este permanecerá en corte y la terminal salida será ~VCC.
03/09/2011 #14


amigo daniel y en que lado puedo colocar el led de aviso....
03/09/2011 #15

Avatar de Daniel Meza

Colocando otro transistor en la salida del sensor (terminal salida) para controlar el led, como en tu diagrama, salvo sin la resistencia de 1k a la base del transistor
03/09/2011 #16

Avatar de Gudino Roberto duberlin

elecmix dijo: Ver Mensaje
pero si los coloco como estan me recalienta el integrado l29...que hago--- o que error tengo
Hola Amigo, pues no deberia suceder eso, en tal caso estan, conectados invertidos.
05/09/2011 #17


Daniel Meza dijo: Ver Mensaje
Analizando el circuito se puede observar lo que sucede y la causa del problema. haciendo referencia al diagrama y suponiendo que la luz ambiental es máxima (el fotodiodo se encuentra conduciendo), habrá una caída de V apróx ~1 V en el fotodiodo (Valor práctico), esta caída relativamente alta provocará que la base del transistor se encuentre a un potencial mayor de 0.7 Volts y a su vez lo polarice directamente y este se sature haciendo que el led encienda. Apagando la luz (corte del fotodiodo) la corriente de la fuente fluirá por R 10k y R1k hacia la base del transistor provocando el mismo efecto anterior.
Entonces con esto podemos darnos cuenta que lo que se necesita es elevar el potencial de la VBB (Voltaje de la base con respecto a tierra) del transistor; para esto te sugiero que cambies la resistencia limitadora de corriente de 220 del led y la coloques entre emisor y tierra del transistor (y si es posible subirla a 330 ohms). Esto "garantizará" que la base del transistor necesite un voltaje mayor de 0.7 Volts en su base para saturarse y se corte cuando nos e cumpla esta condición (luz encendida y fotodiodo conduciendo).

Espero haberte sido claro. Saludos

Si prefieres usar el CNY70 puedes auxiliarte de este circuito

En este caso, la lógica será la siguiente, cuando haya una señal infrarroja (luz) incidiendo en el sensor hará que el fototransitor interno se satura y la terminal salida marque ~0V. En caso contrario, cuando no incida sobre el fotoransitor alguna señal, este permanecerá en corte y la terminal salida será ~VCC.
amigo daniel lo que me quieres decir es que quite la resistencia de 220 y la coloque entre emisor y tierra del transistor....ojala que sea de 330
05/09/2011 #18

Avatar de Daniel Meza

asi es, con una de 330 te servirá
07/09/2011 #19


amigo daniel como corrijo mi sensor ahora necesita mucha carga para detener los motores...osea tiene que star el led de aviso a toda potencia para que haga algo de los dos ciclos...apagar o prender motores...
07/09/2011 #20

Avatar de Daniel Meza

Es decir que la corriente por el transistor aumentará, con un transistor TIP31C te servirá, con buena disipación este transistor soporta hasta 3 Amperes.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.