Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/07/2015 #1

Avatar de ruben90

Proyecto: Enfriador Termoeléctrico (Problema: Calentamiento MOSFET)
Aun no entiendo muy bien esto de los MOSFET, estoy utilizando el Diagrama 1 pero sigue calentándose el transistor. Investigando me encontré con esto:

Código:
Para funcionar como interruptor se utiliza la región de corte 
y la región óhmica. Para el corte basta con hacer VGS < VT, y para 
la región óhmica se debe cumplir:

VGS - VT > VDS === VGS > VDS + VT.
(fuente: Electrónica de potencia: dispositivos by Luis Esquiroz).

entonces, lo estoy haciendo MAL!???

Explicación del circuito (Diagrama 1):

El PWM proveniente del PIC16F819 va a un transistor Q1 el cual invierte y eleva la tensión de 5V a 12V, esta tensión va a la compuerta del MOSFET Q2 y mediante la R3 = 1 Mohm se limita la corriente a unos 10 uA. Q3 y Q4 controlan un Ventilador de 200mA. ...
02/07/2015 #2

Avatar de Sr. Domo

Hola.

Digo, que no es más facil el inversor sin R3 pero usando un arreglo NPN+PNP colector común para que hagan de driver de gate??

Ya que el calentamiento puede ser porque Q2+R2 no sea el mejor driver para manejar el capacitor que se forma entre gate y drain o source (no recuerdo) y pues no carguen o descarguen ese capacitor tan rápido para minimizar el calentamiento.

Te recomiendo usar un TR PNP+NPN en configuración colector común para manejar el gate del MOSFET, ya que este driver provee suficiente corriente para cargar/descargar esta capacitancia que, según lo que he leído, es lo que causa el calentamiento cuando se usa en altas frecuencias como el PWM.

Saludos.
02/07/2015 #3

Avatar de juanma2468

En ves de usar esa configuracion, te conviene usar una configuracion del tipo TOTEM POLE, amen de agregar un diodo en inversa en paralelo con R1 para ayudar a la descarga de los transistores.
https://www.google.com.ar/search?q=t...w=1366&bih=631
Seria algo similar a esto
https://www.google.com.ar/search?q=t...8l3BxNdIVIM%3A
02/07/2015 #4

Avatar de Sr. Domo

juanma2468 dijo: Ver Mensaje
En ves de usar esa configuracion, te conviene usar una configuracion del tipo TOTEM POLE, amen de agregar un diodo en inversa en paralelo con R1 para ayudar a la descarga de los transistores.
https://www.google.com.ar/search?q=t...w=1366&bih=631
Seria algo similar a esto
https://www.google.com.ar/search?q=t...8l3BxNdIVIM%3A
Justamente eso era lo que trataba de decir, solo que a la mera hora se me olvidó su nombre
03/07/2015 #5

Avatar de ruben90

El arreglo de tótem pole lo eh visto en varios libros, pero me llega la duda, lo arme y lo alimente a 12V, y medí el voltaje de salida, y me disparo 5 Voltios, apenas rompe el voltaje de umbral (4V), y pensé en aumentar la señal de 5V a 12V (mediante el inversor), pero eso supera el limite de Vbeo = 6 v, y la verdad simulado si jala, pero solo tengo 2 pares de transistores (NPN y PNP) y me da cosa quemarlos xD (la tienda de electrónica esta re lejos de mi casa) pero bueno probare a ver que pasa.... y comentare si pude solucionarlo. gracias por las respuestas...
03/07/2015 #6

Avatar de eL1ct

Hola,
Yo a esa configuracion lo llamo "push-pull" ... aunque en este articulo tambien lo llama totem-pole: (Imagen 10)

http://www.radio-sensors.se/download/gate-driver2.pdf

Lo que pasa es que tu tienes la señal de 5V y el driver lo tienes que alimentar al rededor de 10V, 12V sirve perfectamente. Asi que lo que necesitas se parece a la imagen 20, pero solo que en tu caso seria N-MOSFET (con sus respectivas diferencias).

Fijate que la resistencia de puerta es importante, mira en el datasheet del MOSFET... Te recomiendo un valor resistivo superior (digamos lijeramente) al que ha usado el fabricante para sus pruebas.

PD: otra opcion es comprar un driver comercial.

---------- Actualizado después de 6 minutos ----------

ruben90 dijo: Ver Mensaje
pero eso supera el limite de Vbeo = 6 v
No entiendo cuando dices esto... supongo que eso corresponde a un PNP ya que el "diodo del emisor" por asi llamarlo no soporta mucha tension de inversa.

Ya que en NPN seria Vebo = 6v

Pero a ti no te supone problema si usas un NPN en emisor comun, no? (ya que no tienes tensiones negativas)

PD: Por cierto, por que poner C2? A y depende del tipo de motor que sea quiza sea mas conveniente otra topologia, u otro control....?

---------- Actualizado después de 5 minutos ----------

Otra cosa, de donde sacaste esto??

VGS - VT > VDS === VGS > VDS + VT.
Yo le veo sentido asi:
Vgs - Vt > Vs === Vgs > Vs + vt

No es lo mismo VDS que VS en tu circuito VS es masa, (supongo 0v) asi que quedaria asi:
Vgs - Vt > 0 === Vgs > vt

Aunque esto a veces no es suficiente para que tabaje en zona ohmica (o que el MOSFET se encienda correctamente digamos), depende... fijate en la grafica <<ID vs VDS con diferentes VGS>>
03/07/2015 #7

Avatar de ruben90

muchas gracias por tu respuesta eL1ct. Bueno el C2 lo coloque ya que sin el, con un ciclo de trabajo del 50%, el PIC se reseteaba, y así se soluciono. Checare el archivo PDF que me anexaste, se ve interesante...
04/07/2015 #8

Avatar de ruben90

Ok, encontre un circuito que me genera el totem pole, el c.i. CD4048 que utiliza tecnologia CMOS, tan solo tendre que colocar una resistencia Rg a la salida, seguida del MOSFET de potencia...

Busque el driver IR2110 que mencionan en el foro, pero no lo manejan por donde vivo, así que me las ingeniare con el inversor...
04/07/2015 #9

Avatar de eL1ct

El CD4048 es un circuito integrado logico y tiene poca capacidad de corriente de salida, por lo tanto no te serviria... mejor que usar eso es construir un driver discreto como los que se muestran en el PDF que adjunte.
Cuando dije driver comercial me referia a algo asi:
http://ww1.microchip.com/downloads/e.../20001420F.pdf

---------- Actualizado después de 2 minutos ----------

Si necesitas condensador ahi puede que sea porque el diodo no es lo suficientemente rapido? y el condensador hace un efecto snnuber? si es asi mejor poner una resistencia de valor ohmico pequeño en serie a este condensador... no se, digo yo
08/07/2015 #10

Avatar de ruben90

Hola nuevamente, muchas gracias por sus respuestas, intente todas y simuladas dan buena pinta, el problema esta en que no encuentro los C.I. aquí en México, ahora, me puse a ver C.I. que poseo y me tope con el L293 y el L298, los cuales son Puentes H, estos entregan una gran cantidad de corriente, aproximadamente 1A. Alguien a usado el L293 como excitador de compuerta?
15/07/2015 #11

Avatar de ruben90

Hola, al fin pude solucionar lo del calentamiento, utilizando el CD4049, y una frecuencia de 10 kHz, y una resistencia de 10 ohms en el GATE del mosfet IRF520, muchas gracias por sus respuestas...
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.