Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

10/12/2007 #1


Radiocontrol con salida digital
Hola, soy nuevo en el foro, y ya tengo un problema . Miren lo q me pasa es lo siguiente: Tengo un radiocontrol de 2 canales hitec, en la salida del receptor tengo 2 salidas de 3 cables para conectarlos a sus respectivos servos,de los 3 cables para conectarlos al servo dos son de alimentacion y otra es de señal. yo necesito controlar un circuito digital, y el nivel de voltaje de salida de ese cable de señal anda por los 30 o 40 mV cuando muevo uno de los trims de la radio, y en los 10 o 20 mV en estado de reposo. Alguien sabria como puedo hacer para convertir esos niveles de voltaje en un 1 o un 0 digital?
11/12/2007 #2


Se me ocurre que puedes utilizar lógica de OPAmps (Amplificadores Operacionales), puedes amplificar las señales de mV para generar convenientemente niveles de voltaje operables por la lógica digital común. Si tienes algún libro de electrónica puedes encontrar suficiente información sobre las configuraciones básicas de amplificador operacionales como para amplificar las señales de la forma que te menciono y hacerlas compatibles con señales digitales. De hecho existen configuraciones especiales para instrumentación, talvés te puedan servir.

Un link... http://www.geocities.com/CapeCanaveral/Lab/2912/

Saludos... espero serte de ayuda.
12/12/2007 #3


ok gracias Mockba. Yo tambien habia en pensado en usar un amlificador operacional, pero en modo comparador, yo lo q pensaba hacer era fijar un voltaje de comparacion q este entre el estado alto de la salida del receptor y el estado bajo, asi asi compara los voltajes producidos por el movimientro del trim de la radio. Q dicen será posible hacer eso?
12/12/2007 #4


Si, es así como se hace, no debe haber problemas, sólo que tendrías que amlpificar primero las señal de mV para evitar manejar señales que sean difíciles de comparar. Si tratas de comparar mV, te va a dar dolor de cabeza.

Saludos...
14/12/2007 #5


sabes, estuve leyendo algo sobre amplificador operacionales, eso q me dijiste sobre amplificar la señal, y la verdad no entendii nada!. si me supieras decir especificamente q circuito necesito, te lo estaria agradeciendo muchisiimooo!
graciass
15/12/2007 #6


En el link que te dejo abajo, se encuentra la sección de los modos de operación, si observas el modo no inversor te darás cuenta de que sólo son dos resistencias las que se acoparán al OpAmp, R y Rf.

http://www.geocities.com/CapeCanaveral/Lab/2912/

Para acabar pronto, si pones R = 1k y Rf = 100K en el primer OpAmp, la señal que metas por la entrada no inversora será multiplicada por 100. A la salida de ese amplificador tendrás 4V si metes 40mV o 2V si metes 20mV. Después viene una etapa de comparación, que tiene un par de resistencias en divisor de voltaje para crear una referencia de 2.5V en la entrada restadora, lo cual ocasiona que al entrar un voltaje menor a 2.5V por la entrada no restadora, en la salida tendras un "0" lógico y al presentarse un voltaje mayor a 2.5V tendras un "1" lógico.

Saludos...
Imágenes Adjuntas
Tipo de Archivo: png salida_ttl_178.png (8,0 KB (Kilobytes), 24 visitas)
16/12/2007 #7


ahh buenisimooo... gracias mockba por tu tiempo, seguro me va a ser de gran ayuda...
saludos...
17/12/2007 #8


Espero que te sirva, sólo te pediré un gran favor, cuando lo termines de probar avísame si te funcionó... Saludos y suerte.
06/01/2008 #9


hola de nuevo, no respondi, porque estuve de viaje, y lejos de una computadora, pero a mi retorno, probe el circuito en un simulador y nada. En teoria deberia de funcionar , y eso lo se, solo me resta probarlo en la realidad. En cuanto lo haga te comento los resultados

saludos julian
06/01/2008 #10


hice una prueba del circuito, pero como me faltaba un 741 (donde lo consiguo un domingo a las 6 de la tarde) lo reemplaze uno por un lm358, parecio funcionar bien, pero al rato no pasaba nada. no amplificaba ni comparaba. sera porque tienen q ser ambos amplificador iguales? existe algun reemplazo por los dos? gracias
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.