Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

08/03/2011 #1


Regulador velocidad CC con 555: problemas de rizado
Hola,

He realizado el típico circuito para regular la velocidad de un pequeño motor de CC. Funciona bien pero por la aplicación donde lo tengo, puedo controlar la velocidad de giro y me doy cuenta de que existe un pequeño rizado. Creo que es porque me falta un condensador. He estado consultando el foro y he visto circuitos similares con condensadores de 470 micros. Sin embargo mi circuito no es exactamente igual y como no soy experto solicito ayuda sobre como y donde situar este condensador (en caso de que sea este el problema). Adjunto un esquema del circuito. No se si se debería poner en paralelo con el conjunto transistor-motor, es decir entre Vcc y GND. Ya sé que se trata de una pregunta muy elemental pero agradeceré vuestra ayuda.

Muchas gracias.
Gikubik
08/03/2011 #2
Moderador general

Avatar de Fogonazo

¿ A que cosa le dices "Rizado" ?
08/03/2011 #3


lo contrario de liso ;-)
Hola!

Gracias por responder. A ver que no me explico muy bien. Por la aplicación a la que tengo conectada el motor puedo ver una gráfica de la velocidad angular en función del tiempo. Con el regulador fijo a una velocidad, no obtengo una recta, sino que puedo ver una gráfica que podriamos definir como senoidal de amplitud casi-cero, es decir que hace como pequeñas montañitas la velocidad (oscila entre un máximo y un mínimo alrededor de una velocidad media). Eso sin tocar el potenciometro del regulador. Entonces me pregunto si eso lo puedo mitigar con un condensador a la salida (que como ves en el circuito no tengo) para conseguir que la velocidad angular sea totalmente una recta (constante con más exactitud) a lo largo del tiempo. Mi pregunta seria: con un condensador lo arreglo? Donde lo pongo? De qué capacidad? Y si no és con un condensador como puedo remediar esta situación?

A velocidades bajas, a simple vista se puede ver como el motor va dando "saltitos" de más y menos rotación. A medida que augmentas la velocidad, este efecto queda mitigado, pero no del todo, como puede observarse.

Un saludo y gracias!
Gikubik
08/03/2011 #4
Moderador general

Avatar de Fogonazo

¿ Tu tensión de alimentación es estable ?

Agrega un electrolítico de 470uF entre Vcc y GND

Reemplaza el capacitor de 330nF por otro de 10nF y prueba si continúa oscilando la velocidad angular.
08/03/2011 #5


Si, es estable
Hola de nuevo,

Sí, la tensión de alimentación es estable, porque dispongo de una fuente de tensión comercial, bastante buena, de hasta 30V y tambien de un osciloscopio y para poder confirmartelo, acabo de ver la señal de tensión continua en él y realmente es muy plana, está bien rectificada y filtrada. Yo creo que es consecuencia de algun componente como tú señalas. Probaré lo que me comentas.

Muchas gracias!!!
Un saludo.
Gikubik.
08/03/2011 #6

Avatar de Scooter

Estás trabajando en lazo abierto con un regulador, que por decirlo muy muy amablemente es "simple", con un motor con un numero de polos desconocido, con carga desconocida, rodamientos, etc etc.

Lo que sería realmente muy muy sorprendente es que la velocidad fuese constante.
09/03/2011 #7


ni idea.
Hola Scooter,

Si conecto el motor directamente a la fuente de tensión comercial que tengo eso no pasa. Supongo que como dices el regulador es simple. Todavía no he probado las correcciones que en el post se señalan. De todas formas, puedes apuntarme a algun otro circuito regulador de velocidad para motores de CC hasta 12-15 voltios, algo más "sofisticado".

Muchas gracias.
Gikubik
10/03/2011 #8

Avatar de Scooter

Hay muchos factores a considerar si descartamos la fuente:
- Velocidad angular, número de polos del motor y frecuencia del pwm que pueden entrar en resonancia.
Como primera prueba sube la frecuencia del pwm.

Realimentar con un 555 es perder el tiempo, habría que estudiar el caso y ver si conviene un PID u otra estrategia de control. Ver la linealidad de loa sensores, actuadores etc etc etc.
10/03/2011 #9


más datos
Hola de nuevo,

Tengo nuevos datos. Como tú apuntas es una cuestión de frecuencia. Se trata de hacer trabajar el motor con el potenciometro al máximo de manera que la frecuencia sea la máxima. Es decir, consigo el máximo de estabilidad en la velocidad si alimento con 6V y tengo el potenciometro al máximo, que si alimento con 12V y tengo el ponteciometro a la mitad. No sé si consigo explicarme. Eso me permite por lo menos evitar el problema, aunque lógicamente no sería lo deseable.

El resto de cuestiones que planteas del PID y demás a mi se me escapa y no puedo realizarlo por falta de conocimientos. Tampoco tengo información detallada sobre el motor. Por lo tanto te agradezco la ayuda. No sé si existe algun circuito genérico de PWM más trabajado que el del 555, que, sin ser perfecto, tenga mayores prestaciones.

Igualmente intentaré de añadir el condensador de 470 micros a ver si mejora un poco todo.

En cualquier caso gracias de nuevo por vuestra ayuda!
Un saludo.
Gikubik.
10/03/2011 #10
Excluido


solo para probar:

pone un buen capacitor pero en // con el motor.
10/03/2011 #11


Esta era mi pregunta inicial
Hola Fernando,

Mi pregunta inicial iba precisamente por ahí: donde pongo el condensador? En paralelo con el motor o bien entre Vcc y GND? Mi pregunta inicial era por esa duda. Fogonazo me comenta que lo ponga entre alimentación y masa, tu opinas que lo haga con el motor... Yo pensaría también de ponerlo en paralelo con el motor, por la configuración del circuito que he usado, al ser PNP el transistor, y estar en el colector, pero ya estoy dudando otra vez.

En fin, supongo que no tengo más remedio que hacer pruebas!

Gracias a todos!
Gikubik.
10/03/2011 #12
Excluido


gikubik dijo: Ver Mensaje

En fin, supongo que no tengo más remedio que hacer pruebas!
plop !!!!!!!

para mi SIEMPRE fue la cosa hacer pruebas.
no como ultimo remedio

la cosa es simple:
segun lo que entendi de lo que pusiste el motor " zapatea" cuando le mandas PULSOS ,.
pues bien , si tienes una fuente de CC variable pruebalo un poquito ,a ver como se comporta con CC variable, no con PULSOS .

yo supuse que seria eso , por ese motivo te mande a poner ahi el C.

PD: de veras esperas que alguien a mil Km de distancia te de "la justa" y no solo ideas que en definitiva tienes que tu probar ????
10/03/2011 #13


pues si
Pues la verdad si que esperaba que alguien me aclarara donde colocar el condensador. Siempre fuí un poco iluso

Un saludo.
Gikubik.
10/03/2011 #14

Avatar de Scooter

Si has hecho bien el PWM el potenciometro no debería de cambiar la frecuencia, solo el reparto.
Me refiero a cambiar la frecuencia de trabajo del pwm, no el reparto. (Acabo de fijarme en el esquema y si que cambia la frecuencia luego no es un pwm ni medio bueno). Buscaré a ver si encuentro otro mejor.
Si añades un condensador a la temporización del 555 bajas la frecuencia, no la subes. Tendrás que hacerlo mas pequeño. (el de 330nF)
El condensador que propone fernandob va en paralelo con el motor como ya te dijo, es intrascendente que transistor uses.

No lo he encontrado así que lo he reconstruido de cabeza, tampoco lo he podido simular, así que no te garantizo nada:


El condensador de 1uF es el típico, (1uF es el valor por defecto y no lo he editado).
Al pin 3 le pones tu transistor.
10/03/2011 #15
Excluido


reset junto a theresould??
y trigger a + vcc

es algo poco comun o te has equivocado. ?
10/03/2011 #16

Avatar de Scooter

Es vedad, me he liado. 2 y 6 juntas al condensador
Reset no activo, a positivo, si lo activamos no sirve de nada.


Es un astable "normal" con algún detalle: El cursor del potenciometro va al condensador y por un lado carga y por el otro descarga de modo que lo que se le pone a un lado se le quita al otro y viceversa para que el periodo sea constante, además hay una resistencia en descarga para que sea simétrico con la carga.
Ahora edito el esquema.

ja ja ja , estaba bien pero dos líneas estaban superpuestas y hacían el efecto que se ve; parecer mal.
Lo he actualizado en dropbox, supongo que actualizando la página se verá bien.
Gracias por advertirme boximil1 :-D


Edito:
Fernandob me ha hecho ver que ese circuito no funciona, ahora no lo recuerdo era algo parecido pero me he precipitado al contestar. Lo monté y funcionó, pero ahora no lo encuentro.

Re edito:
Ahora si que funciona con esos dos diodos, recordaba la idea pero se me escapaban los detalles, gracias a los que os habéis dado cuenta.
Es un astable un poco cambiado: Carga por la R de 1k por un diodo y por un trozo de potenciometro y descarga por el otro trozo de potenciometro, otro diodo y otra r de 1k. De este modo el periodo se mantiene constante (excepto por tolerancias de componentes etc)
Para los que usen el EWB versión del año del ni se sabe: Descargad el archivo
10/03/2011 #17
Excluido


ok , acostumbrate (como consejo mio ) a usar el simbolo correcto y no como hacen todos que dibujan al 555 como viene la pastilla .
veras que es mas facil para analizar.
cuando juntas trigg.+ theresould el 555 es una compuerta inversora trigger .

mira al diferencia en claridad de el esquema a la hora de analizarlo .
Imágenes Adjuntas
Tipo de Archivo: jpg 555x.JPG (34,0 KB (Kilobytes), 22 visitas)
10/03/2011 #18

Avatar de Scooter

Ya, pero es que no tengo nada a mano, tenía hecho el esquema interno en el EWB y funcionaba bien pero lo perdía años ha. (igual algún día lo encuentro por debajo de algún terabyte)
11/03/2011 #19


Gracias
Vale pues muy agradecido a todos. Monto de nuevo el circuito y me olvido del que tengo. Y además probaré las distintas cuestiones propuestas.

Gracias de nuevo.
Gikubik.
11/03/2011 #20
Moderador general

Avatar de DOSMETROS

Probá éstos :









Saludos !
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.