Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

11/02/2009 #1


¿Relé o transistor para hacer de interruptor?
Buenas tardes a todos. tengo una duda en un proyecto casero.

Tengo una señal que me sale de un optoacoplador, esa señal la quiero usar para abrir o cerrar un interruptor.

De mi optoacoplador tengo:

0.41 V y quiero que mi rele este abierto
9 V y quiero que mi interruptor este cerrado

¿Qué interruptor uso? es un relé o un transistor? no tengo muy clara la diferencia entre ellos.

Me hechais una mano, Gracias a todos

Daoiz
11/02/2009 #2

Avatar de Dr. Zoidberg

Re: ¿Relé o transistor para hacer de interruptor?
Daoíz dijo:
Buenas tardes a todos. tengo una duda en un proyecto casero.

Tengo una señal que me sale de un optoacoplador, esa señal la quiero usar para abrir o cerrar un interruptor.

De mi optoacoplador tengo:

0.41 V y quiero que mi rele este abierto
9 V y quiero que mi interruptor este cerrado

¿Qué interruptor uso? es un relé o un transistor? no tengo muy clara la diferencia entre ellos.

Me hechais una mano, Gracias a todos

Daoiz
Si no tienes en claro la diferencia entre un relay y un transistor no tiene mucho caso que te ayudemos, tanto mas cuanto ni siquiera dices que diablos es lo que tienes que "interrumpir". Parece que debieras usar un transistor para accionar un relay, pero lo que has preguntado es una adivinanza...

Saludos!
11/02/2009 #3


Sencillamente lo que quiero es un rele para abrir o cerrar un circuito, la pega es que el optoacoplador solo me da 25 mA y no se si abrá reles que accionen con 25 mA.

lo de la tensión lo tengo resuelto
11/02/2009 #4

Avatar de Dr. Zoidberg

Entonces tienes que conectar un transistor al optoacopplador para que este accione el relay.

Saludos!
11/02/2009 #5


me puedes explicar un poco más esto?' yo he probado con un relé, concretamente el "Relé de láminas DIP PCB SPNO,0.5A 5Vdc" con el siguiente link

http://es.rs-online.com/web/search/s...duct&R=2919675

y no me funciona porque la corriente de conmutación es de 0.5A y con mi optoacoplador solo le puedo dar 25mA.

Cómo puedo hacerlo?

Muchas gracias ezavalla
11/02/2009 #6

Avatar de Dr. Zoidberg

Daoíz dijo:
me puedes explicar un poco más esto?' yo he probado con un relé, concretamente el "Relé de láminas DIP PCB SPNO,0.5A 5Vdc" con el siguiente link

http://es.rs-online.com/web/search/s...duct&R=2919675

y no me funciona porque la corriente de conmutación es de 0.5A y con mi optoacoplador solo le puedo dar 25mA.

Cómo puedo hacerlo?

Muchas gracias ezavalla
500 mA es la corriente que los contactos del relay pueden conmutar, pero la corriente de la bobina, que es la que necesitas entregarle es de 25mA (5volts/200 ohm -> ver las especificaciones). De todas formas, podrías empezar por mostrarnos el circuito que tienes y las tensiones de alimentación que estas usando para saber donde estamos parados.

Sinceramente creo que te vale mas conseguir un libro sobre este tema, por que tienes una confusión gigante. Si seguimos hablando, voy a terminar diseñando el circuito por tí, y aunque es muy simple...si no sabes lo que hace no ganas nada.

Saludos!
11/02/2009 #7


Te adjunto mi circuito te comento brevemente:

- Necesito mediante un optoacoplador, encender o apagar un display de 9 voltios.
- Todo lo que hay a la izquierda del optoacoplador debe de ser independiente de lo de la derecha.
- Todo lo de la derecha debe de funcionar con una pila de 9 Voltios, por ello:
- Existe un regulador para dar Vcc=5V al opto
- La salida puede estar controlada a 5V o a 9V, lo único que hay que hacer es cambiar la resistencia de pull-up de la toma de 5V a la de 9V

- La máxima corriente de salida de opto es de 25 mA
- El display consume 500uA

Solo me falta diseñar el relé para controlar el display. O si existe una solución mejor.

Muchas gracias por atenderme y entiendo que si me das el circuito no aprendo, pero estoy empezando con todo esto lo lleva dando vueltas a la cabeza y voy muy despacio.

Gracias de verdad
Imágenes Adjuntas
Tipo de Archivo: jpg rele_opto_404.jpg (126,7 KB (Kilobytes), 329 visitas)
11/02/2009 #8


Así como tienes el circuito, lo unico que necesitas es alimentar tu optoacoplador con el VIN, con unos 5v. Si le metes por ejemplo un volt no funcionará.
A eso si, el voltaje lo puedes obtener de otra bateria, de modo que si quedarian circuitos separados pero solamente el VIN y todo lo de mas es el mismo circuito...

Para que necesitas un rele o un transistor?

Tal vez lo que intentas es tener un voltaje de 9V del lado izquierdo, con su respectivo regulador 7805, de ahi un pulsador o algo que active el opto y a la derecha del mismo solamente el display con las respectivas resistencias y bateria independiente?

Por si te sirve de algo, aqui te dejo el circuito de prueba de un opto transistor como el que pones en el ejemplo:
Imágenes Adjuntas
Tipo de Archivo: jpg test_circuit_104.jpg (11,1 KB (Kilobytes), 372 visitas)
11/02/2009 #9

Avatar de Dr. Zoidberg

Primero: Quitá la conexión de la base del optoacoplador al positivo de la alimentación. Eso no funciona y tal vez ya quemaste el opto.

Segundo: Quitá el relay del circuito y la resistencia de pull up de 1K. En lugar de esta resistencia conectá el display (el positivo a la alimentación, el negativo al colector del transistor del opto).

Tercero: deberia funcionar como vos quieres. Cuando alimentas el LED del opto, el display enciende. Si no lo alimentas, el display está apagado. Sobre el display va a haber un poquito menos de 9 volts (100 o 200mV), pero igual anda

En este caso, el opto trabaja con los 500 uA del display, así que no hay problema de capacidad de corriente

Saludos!
11/02/2009 #10


Tiene muy buena pinta ezavalla, ahora mismo no puedo probarlo, pero mañana en cuanto pueda te comento.

Muchas gracias
12/02/2009 #11


Perfecto es justo lo que yo necesitaba, la única pega es que cuando meto 0 Voltios, entre la Vcc y el colector tengo 0.04 Voltios, no creo que sea un problema que me descargue mucho la pila, no?

Gracias
12/02/2009 #12

Avatar de Dr. Zoidberg

Daoíz dijo:
Perfecto es justo lo que yo necesitaba, la única pega es que cuando meto 0 Voltios, entre la Vcc y el colector tengo 0.04 Voltios, no creo que sea un problema que me descargue mucho la pila, no?
La tensión que tengas no importa, lo que importa es la corriente que circula en estas condiciones, por que no la medís?. Podés probar por conectar la base del transistor del opto a masa, por medio de una resistencia de 390K (o 470K, por ahí anda el valor ese), pero no creo que mejore mucho.

Los valores que has medido, son de simulación o has implementado el circuito?

Saludos.
12/02/2009 #13


El circuito está implementado físicamente y funciona perfectamente.

No puedo poner la base del transistor a masa porque no tengo pin físico para ello, uso el optoacoplador OPI1268 que solo tiene 5 pies, los 2 del led, la alimentacion, colector y emisor

Gracias
13/07/2009 #14


hola soy nuevo en este foro y yo diria que un poco novato en electronica pero igual que ustedes siempre buscando saciar la sed eterna del conocimiento bueno tengo unas dudas que ojala puedan aclararme.

he realizado un circuito en el cual empleo una compuerta and para obtener un na salida de 1 o 0 como es logico pensar. hasta aqui todo bien pero el caso en que nesecito mover un motro cc que funciona con 5 voltios y el voltaje que me proporciona la salida de la conpuert and en de un voltaje de 2.35V esto es muy poco ya que hace mover mi motor muy lento o en ocasiones ni se mueve bueno lo que he echo es agregar un transistor (KSP2222A) y un rele que funciona con 5V para crear un interructor y poder proporcionar el voltaje suficiente. adjunto una imagen para que puedan ver lo que y comprender lo que he tratado de explicar anterior mente.

bien en si mis dudas son las siguientes:
1)¿estara bien de la forma en que he planteado el esquema?
2)porque si estoy alimentando el transistor con 5 voltios en la palita del colector solo obtengo 2.35V que es lo mismo que tengo en la salida de la conpuerta and cuando las dos variables son unos.
3)si el transistor no es el adecuado cual me recomiendan
4)que tipo de rele recomiendan que use

Por tomarse la molestia de leer mis dudas se los AGRADESCO y SALU2 a TO2
De antemano GRACIAS por la ayuda que puedan aportarme.
Imágenes Adjuntas
Tipo de Archivo: jpg circuito_435.jpg (305,7 KB (Kilobytes), 146 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.