Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

19/11/2010 #1


Resistencia de base para transistor
Saludos! Mi intención es utilizar un BD139 para amplificar la salida de un PIC, es para este proyecto.

La HFE son 120, la he medido con el tester.

La intensidad de lo que quiero conectar son 58,6 mA. El tester me da un valor de 58.6 en la escala de 200mA, lo que equivale a 58.5mA, por favor, corregidme si me equivoco.



Ahora, he calculado la resistencia de base de esta forma:

Ib = Ic / Hfe = 58,6mA / 120Hfe = 0.488mA

R = E / I = 4,3V / 0,0004888A = 8797,05Ω (un valor normalizado es 8k8)

¿Alguien sería tan amable de decirme si los cálculos se realizarían de esta forma? Muchas gracias por vuestra gran ayuda.

EDITO: El pic me da 5V pero he puesto 4,3V por la caída de tensión que provoca supuestamente el transistor.
19/11/2010 #2


¿Alguien sería tan amable de decirme si los cálculos se realizarían de esta forma?
Mmm... con respecto a los cálculos...
creo que seria...


5v.-.7v=4.3v/.0008A=5375Ohms

el .7v es la caida de voltaje del transistor.. por lo demas yo creo que esta bien...

tengo duda de porque si es de 120 el beta tomas 100...
19/11/2010 #3


Tienes razón. Los cálculos no llevan los datos de las mediciones, porque los realizé a posteriori.

Ahora los he calculado correctamente, y teniendo en cuenta tus indicaciones:

Ib = Ic / Hfe = 58,6mA / 120Hfe = 0.488mA

R = E / I = 4,3V / 0,0004888A = 8797,05Ω (un valor normalizado es 8k8)

Creo que ahora, si que estarían correctos los cálculos. Gracias por todo.
19/11/2010 #4


Hola, los cálculos son correctos. Los 0.488 mA serán correctos, pero para asegurarte de que funcione con cualquier bd139, aumenta un poco la Ib. De todos modos, cuando esté funcionando comprueba con el polímetro de que el consumo a través del transistor es el mismo que cuando lo conectas directamente a la fuente.
Gracias y saludos.
19/11/2010 #5


Muchas gracias por vuestras amables respuestas.

Con respecto a lo que dice lubeck sobre la caída de tensión que provoca el transistor, estoy algo confundido, ya que tal caída de tensión, todavía no se ha producido en la resistencia de base. Por tanto en los cálculos de dicha resistencia, ya no sé si debo usar los 5V que nos da el PIC o los 4,3V que sugiere lubeck.

¿Podéis aclararme por favor? Mil gracias.
19/11/2010 #6


¿Podéis aclararme por favor?
mira este link...
http://cromavideo.webcindario.com/DE...ANSISTORES.pdf
creo que ahi lo menciona...
19/11/2010 #7


tienes que hacer lo que dice lubeck, porque la caida base emisor un transistor en saturacion es de 0.7 a 0.8V dependiendo del transistor.
Asi que los calculos y el razonamiento estan bien.
Salu2s
19/11/2010 #8


Hola, tienes que restarle los 0.7 voltios que aproximadamente caerá en la base-emisor. Esos 0.7 voltios se van a producir en la unión base-emisor, sí o sí. Entonces cuando haces el cálculo para saber la resistencia de polarización de base, tendrás que hacerlo con la alimentación menos esos 0.7 voltios y esa será la caída de tensión que se producirá en dicha resistencia. La tensión de alimentación será igual, a la caída de tensión en la resistencia de base más, la caída de tensión que se produce en la unión base-emisor. Vcc=(Rb*Ib)+Vbe. Así que tendrás que calcularlo como te ha dicho lubeck.
Gracias y saludos.
19/11/2010 #9


Muchas gracias por la ayuda! La verdad estoy muy agradecido.

Al finál el resultado me ha quedado así, teniendo en cuenta los consejos de loren y lubeck:

Ib = Ic / Hfe = 58,6mA / 120Hfe = 0.488mA

R = E / I = 4,3V / 0,0005A = 8600Ω (un valor normalizado es 8k6)

Sin embargo, al realizar la prueba con Proteus (y también físicamente en protoboard) el resultado no ha sido bueno.



Como puede verse, el transistor no entra en saturación, ya que debería haber 0V entre emisor y colector. Otro detalle es que a la lámpara deberían llegarle 12V y encenderse, cosa que no ocurre.

¿A qué puede deberse este fallo si la resistencia de base es la correcta? Muchas gracias por todo. Un saludo.
19/11/2010 #10


¿A qué puede deberse este fallo si la resistencia de base es la correcta?
la resistencia de la base puede ser correcta pero la carga en el colector no...

pon una resistencia de 1k en serie con el led... y recalcula la resistencia base...

Corriente ec=0.012

0.012/100=0.0012

4.3/.0012=3k8

con una resistencia de 1k en la base te satura bonito!!!
19/11/2010 #11

Avatar de reyvilla

hola estuve viendo la situacion y hay que tomar en cuenta los parametros de los componentes en el simulador fijate en la resistencia de la lampara yo lo cambie y funciona activa la lampara.
19/11/2010 #12


Jejejej... es una lampara jejej...

perdon por mi comentario anterior.... pense que era un led!!!

nuevamente perdon.... no se entiende bien que es lo que necesitas una tira de leds o una lampara...
no es lo mismo...
20/11/2010 #13

Avatar de Black Tiger1954

Tenés que tener en cuenta para los cálculos algunos detalles. La hfe que mide el tester es en un punto de trabajo, es una prueba estática, y la hfe varía en función de la corriente que circula por el colector.
Te adjunto las curvas para un BD139 de TI.
Además, mirá también la curva de tensión CE en saturación, vas a ver un detalle importante: Ic=10 Ib o Ic=20 Ib.
Si la resistencia de base la calculás para que la máxima corriente que circule es igual al consumo, es probable que obtengas algo así como 2 resistencias en serie con lo cual la tensión CE será de 1/2 de la alimentación.
Para este tipo de aplicaciones (conmutación), es mejor que la corriente que base so sobre y no fa falte
Imágenes Adjuntas
Tipo de Archivo: jpg HFE Ic.jpg (84,3 KB (Kilobytes), 15 visitas)
20/11/2010 #14


Hola, como te han dicho, tienes que tener claro cuáles son los componentes a utilizar, ya según eso, todo variará. En función de lo que quieras tendrás que tener en cuenta alimentaciones y demás. Mi consejo, ve dando detalles de lo que tienes y lo que quieres conseguir. En función de eso, todos estaremos gustosos de ayudarte en lo que podamos.
Gracias y saludos.
20/11/2010 #15

Avatar de Scooter

Asegúrate de que satura; pon un R de 1K5 y listo.
En cualquier caso la Rb se redondea a la baja pra que Ib suba.
20/11/2010 #16


Voy a daros todos los datos posibles:

Pic: 16f628A.
Transistor: BD139 NPN con una HFE de 120
Barra de leds: 12 Leds RGB 5050 SMD Ánodo común 12V. 58,6mA es lo que consumen al encender cada uno de sus colores. Las pruebas las realizo con solo un color.

Gracias a todos, ya he conseguido que el transistor entre en saturación. Ahora lo que pasa, es que no entra en corte, es decir, la tira de LEDS se queda siempre encendida.

Yo lo que quería era que la tira de leds se encendiese o apagase, en función de la salida del PIC, que varía entre 0.03V y 4.99V. Con 0.03V en la R-base, permanecen encendidos los LEDS, solo se apagan, si directamente suelto el cable que va desde el PIC a la R-base, es decir le llegan 0V.

Si quito el transistor, y coloco directamente un solo led a la salida del PIC, si que se atenúa en función de la tensión que le da el PIC.¿Como puedo obtener esa regulación en la barra de LEDs por medio del BD139?
20/11/2010 #17


¿Como puedo obtener esa regulación en la barra de LEDs por medio del BD139?
busca información acerca del de modulacion de ancho de pulsos PWM

pon un push up o pull down al puerto del pic... de 4k7
la resistencia de la base del transistor ponla de 1k

sube el archivo dsn de proteus que estas utilizando si tienes dudas de como...
20/11/2010 #18

Avatar de Black Tiger1954

Creo que el circuito de este hilo: Encender Progresivamente un LED con LDR te puede servir.
Es un regulador de corriente manejado por tensión.
20/11/2010 #19


Mmmm...

Creo que eso no funcionaria o si black Tiger???

entiendo que lo que pretende es que con un microcontrolador controlar la intensidad del led, pero los microcontraloderes tienen salidad digitales... por lo que la manera de variar la intensidad solo es mediante ancho de pulsos o utilizar tu esquema y un potenciometro digital no???
estoy en lo correcto, o como se acoplaria el esquema que propones al micro??'
20/11/2010 #20

Avatar de Black Tiger1954

Efectivamente, esos pequeños micros, tienen un PWM para generar salidas analógicas (luego de un filtro), esa tensión generada, se aplica como tensión de control. Y digo hacerlo así porque ya que la tensión una vez que está conduciendo el LED no varía mucho, con un control de corriente es más simple controlar el brillo proporcionalmente. Si fuera una aplicación de alta potencia, habría que replantearlo, pero aquí no creo que sea necesario. Espero que se entienda lo que digo (y no estar equivocado ), cualquier cosa, aclaro más.

Edito: La tensión de control, entraría en la base de Q2
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.