Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

30/05/2009 #1


Ruido entre servomotores y PIC (solucionado)
Estoy tratando de controlar un servo futaba s3010 con un pic16f877.

Me gustaría saber que puedo hacer para minimizar el ruido del servo hacia el pic.

Con una resistencia el pwm siempre funciona como debería pero al conectar el servo este en ocasiones comienza a oscilar y con el osciloscopio he observado que el duty cicle varía por sí solo sin que el pic reciba ninguna indicación externa.

gracias

Adjunto el código que uso por si las dudas.
30/05/2009 #2

Avatar de alexus

aisla la parte del pic!

lo estas montando en protoiboard?

si es asi cuida que las conexiones sean lo mas cortas posibles para que los cables no trabajen como "antenas",

si podes usa cable coaxil o coaxial, lo hay finitos,

y armalo en impreso, hay cambia bastante la cuestion!
02/06/2009 #3


Si lo estoy montando en el protoboard y ahora estoy usando un optoacoplador para generar el pwm y una alimentacion independiente ya no me da problemas. gracias.
02/06/2009 #4

Avatar de alexus

osea: problema resuelto?
02/06/2009 #5


sí, problema resuelto
02/06/2009 #6

Avatar de alexus

mejor que haya sido asi, estoy a las ordenes adolfo!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.