Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

13/06/2011 #1


Cómo sacar la chispa del contacto del relé
hola, estoy haciendo un proyecto para controlar un motor con un pic. el asunto es que me di cuenta de que el pic se reseteaba cada vez que el rele producia una chispa despues de cerrar sus contactos, para alimentar al motor.

e leido bastantes foros donde mencionan el tema, generalmente se dice que para atenuar la chispa se usa un condensador de 100 nF/400 Volt en serie con una resistencia de 100 ohm/1watt, entre los contactos del rele. pero el problema se soluciona pero parcialmente, ya que las chispas igual salen en algunas ocaciones.

EStoy usando un rele 12 volt dc 16 amp y un motor de 230 volt ac 260 Watt

alguna solucion tienen para sacarle la chispa al contacto del rele?

saludos!
13/06/2011 #2


alguna solucion tienen para sacarle la chispa al contacto del rele?
seguramente alimentas el rele con la misma fuente que al micro.... verdad???

intenta alimentarlo con otra fuente...
13/06/2011 #3

Avatar de ls2k

es casi imposible evitar la chispa si estas trabajando con reles, ni siquiera con contactores se puede hacer, lo de la red rc (snubber) en serie, sirve, pero nunca lograrás eliminar del todo la chispa, lo unico sería que usases relés de estado sólido o triacs en su defecto
13/06/2011 #4

Avatar de pandacba

guitarmen dijo: Ver Mensaje
hola, estoy haciendo un proyecto para controlar un motor con un pic. el asunto es que me di cuenta de que el pic se reseteaba cada vez que el rele producia una chispa despues de cerrar sus contactos, para alimentar al motor.

e leido bastantes foros donde mencionan el tema, generalmente se dice que para atenuar la chispa se usa un condensador de 100 nF/400 Volt en serie con una resistencia de 100 ohm/1watt, entre los contactos del rele. pero el problema se soluciona pero parcialmente, ya que las chispas igual salen en algunas ocaciones.

toy usando un rele 12 volt dc 16 amp y un motor de 230 volt ac 260 Watt

alguna solucion tienen para sacarle la chispa al contacto del rele?

saludos!
manejas el realy directo del puerto o via transistor? le pusiste el diodo en paralelo a la bobina y con el cátodo hacia la fuente?
13/06/2011 #5


voy a intentar lo QUE me dijo lubeck pero como lo hago para aislar fuentes ? alguna idea ?

lei por hay que se le puede poner un varistor, sera cierto que elimina la chispa?

de otra forma, si no puedo sacar la chispa definitivamente, como puedo dejar que el pic quede protegido ante esos chispasos del rele?

saludos

pandacba dijo: Ver Mensaje
manejas el realy directo del puerto o via transistor? le pusiste el diodo en paralelo a la bobina y con el cátodo hacia la fuente?
del pic va a un optocoplador y hay va a un transistor QUE alimenta la bobina del rele QUE tiene en sus extremos un diodo tal como tu me dices
13/06/2011 #6

Avatar de pandacba

podes subir un esquema de todo tu montaje?
13/06/2011 #7

Avatar de betodj

Te preocupa la chispa (circuito de potencia) o el resteo del PIC (circuito de control).

1)Para quitar o disminuir la chispa: disminuir la corriente requerida por la carga/cambiar rele con mayor capacidad de corriente de platinos, / poner redes snnuber/poner en cascada con el rele un contactor o arrancador.

2) Para evitar el reseteo del PIC.: has como dice lubeck (alimenta el rele con otra fuente de mayor amperaje.) (no olvides empalmar el referencial a masa de ambas fuentes). Tambien debes utilizar una buena fuente para el circuito de control (debe contener: redes snuber,varistores,filtro EMI para evitar los transitorios de la linea, ademas de buena regulacion)


Un saludo..
14/06/2011 #8

Avatar de Scooter

¿Que chispa, la de los contactos o la de la bobina?
Para la de la bobina es imprescindible un diodo volante.
Para la de los contactos es poco importante, probablemente el pic se resetea por usar una fuente de mala calidad...
14/06/2011 #9


betodj dijo: Ver Mensaje
Te preocupa la chispa (circuito de potencia) o el resteo del PIC (circuito de control).

1)Para quitar o disminuir la chispa: disminuir la corriente requerida por la carga/cambiar rele con mayor capacidad de corriente de platinos, / poner redes snnuber/poner en cascada con el rele un contactor o arrancador.

2) Para evitar el reseteo del PIC.: has como dice lubeck (alimenta el rele con otra fuente de mayor amperaje.) (no olvides empalmar el referencial a masa de ambas fuentes). Tambien debes utilizar una buena fuente para el circuito de control (debe contener: redes snuber,varistores,filtro EMI para evitar los transitorios de la linea, ademas de buena regulacion)


Un saludo..
las dos cosas me preocupan con respecto al circuito de control y potencia, por que la chispa de los contactos del rele perjudica al pic resetandolo.
efectivamente hoy dia le puse un filtro emi, una red snuber y una buena regulacion, el problema se atenua pero aun sigue.

yo Creo QUE la solucion no va por apagar la chispa (es imposible eliminarla por completo), sino que por estabilizar el pic para que no se resetee.

Scooter dijo: Ver Mensaje
¿Que chispa, la de los contactos o la de la bobina?
Para la de la bobina es imprescindible un diodo volante.
Para la de los contactos es poco importante, probablemente el pic se resetea por usar una fuente de mala calidad...
la chispa de los contactos de la bobina Scooter
14/06/2011 #10


yo Creo que la solucion no va por apagar la chispa (es imposible eliminarla por completo),
EXACTAMENTE.....

que paso con lo de la fuente?.... funciono??

otra que me acorde es que pongas oscilador ttl, en lugar del clasico cristal con los capacitores.. y claro los filtros al micro..., los puertos que no ocupes ponlos como de entrada y aterrizalos con una resistencia de 4k7...

Por favor escribe como un adulto... amenos que no lo seas... y aun asi intentalo...

Mmm y al mclr que resistencia le pones????
15/06/2011 #11

Avatar de Scooter

Me parece que es problema de una fuente de baja calidad, mejórala y el funcionamiento mejorará.
Varisores a la entrada suelen dar una gran diferencia.
15/06/2011 #12


lubeck dijo: Ver Mensaje
EXACTAMENTE.....

que paso con lo de la fuente?.... funciono??

otra que me acorde es que pongas oscilador ttl, en lugar del clasico cristal con los capacitores.. y claro los filtros al micro..., los puertos que no ocupes ponlos como de entrada y aterrizalos con una resistencia de 4k7...

Por favor escribe como un adulto... amenos que no lo seas... y aun asi intentalo...

Mmm y al mclr que resistencia le pones????

cuales son los osciladores ttl??
15/06/2011 #13


estos.............................
http://www.luisdigital.com/tienda/pr...0ira5t4bh8lnp3

he comparado con un frecuenciometro el colocar uno normal y un ttl y el normal varia mucho la frecuencia... el ttl nein...
15/06/2011 #14
Excluido


(imaginen la musiquita de cancion de cancha de futbol )

no se ve .. el circuito no se ve !!!!
porque es que no se ve ?? por que ee no se ve !!!!!

yo hice varios y varios circuistos con cop8 y con pic.... y muchos mas que varios con Cmos y salvo cuando me inicie a los 11 meses de edad nunca mas tuve problemas y no ponia tantas ni grandes cosas.

pero aca en el foro todo es "magia y misterio" .
se resetea el pic pero no ponen el esquema.

ya no es como antes, ahora todo el circuito esta dentro del micro, es un programa, asi que poner el puñetero esquema del pic con su fuente , salidas y demas no es "mostrar " el ciruito.
no hace falta que digas que hace ni que haras, ... una salida a rele o 2 , unos leds, y lo que sea, podes decir que es otra cosa o lo que sea.

lo que no comprendo es por que :

no se ve .. el circuito no se ve !!!!
porque es que no se ve ?? por que ee no se ve !!!!!

si la salida resetea al pic es todo un conjunto :
el rele de salida mete un ruido que activa justo al reset, o al power on ?? o anda a saber que .
lo que no entiendo es comop uno entra a preguntar esto y no pone :

no se ve .. el circuito no se ve !!!!
porque es que no se ve ?? por que ee no se ve !!!!!

quizas sea una tontera, pero asi estan todos adivinando , suponiendo que esa tontera no esta.
cuantos he leido que ponen la salida de el pic o otro ci directo a la carga, o que las entradas sin R-pullup o down .....
tantas "obviedades ...........
como pretende el que pregunta que lso demas adivinen que es lo que hizo .

o solo yo no veo ni un puñetero esquema ???

es facil que deduzcas por donde viene la cosa a veces es mas electricidad que electronica, pero no es un foro de lengua esto, yo .... y disculpa , si no queres no me des bola, pero cuando no ponen ni un miserable esquema ......
15/06/2011 #15


o solo yo no veo ni un puñetero esquema ???


es que ya se sabe fer... todos... los esquemas son lo mismo y seguramente lo copio de algun lado... y a la hora de que vea como rayos se conecta un oscilador TTL va a ver todo lo que esta haciendo mal en uno nuevo.... no es necesario que nosotros o por lo menos yo vea el esquema... ahora que si lo sube algun experto...le puede decir realmente que esta haciendo mal....
15/06/2011 #16
Excluido


es que un experto no tiene este tipo de problemas.

igual te voy a ser sincero, yo use osc RC o cristal comun ......si me decis oscilador TTL pienso en 2 compuertas TTL y no en ese producto que pusiste ahi..... ni sabia que habia .. espero que no me manden al jardin de infantes de nuevo .......o ...no se........anda a saber , en la salita de jardin siempre estan las maestritas jovencitas y tiernitas...... ...

http://www.unicrom.com/Tut_OsciladoresCristal8.asp

asi que no es un cristal.....tramposo ......es un chip con cristal adentro.
16/06/2011 #17


asi que no es un cristal.....tramposo ......es un chip con cristal adentro.
Sip... por eso dije oscilador TTL y no cristal TTL


y podria aventurarme a asegurar que su configuración interna seria algo como esto... o por lo menos su equivalente economico... pero en eso estoy... estudiando esos bichos...

16/06/2011 #18


muy buenas las sugerencias, ademas de ello, ami me paso, tube que colocarle siempre un diodo en polarizacion inversa, entre los extremos de la bobina del rele , asi se extingue la alta tension del transitorio cuado el transistor que exita al rele pasa al estado de corte.

como precausion ademas de las recomendaciones de usar otra fuente de potencia como uds lo indican, hagolo mismo con la red snuber.

tambien si es presiso coloco el diodo en inversa entre el colector y emisor del transistor que exita el rele.

del micro pic al rele se puede colocar tambien un acoplamiento con opto acoplador, para aislacion electrica y sepAracion completa del pic al transistor y rele.
16/06/2011 #19

Avatar de Scooter

La fuente, la fuente, la fuente, la fuente, la fuente, mira la fuente
Pon varistores entre F-N, F-pe, N-pe quita el 7805, y pon un LM323 mira los condensadores, pon los pequeños y los grandes, los de 100k entre + y - de cada IC...
Prueba con una fuente comercial de calidad/ la mejor que encuentres, si con eso va ya sabes de que es.

El diodo volante es absolutamente imprescindible.

¿Es imprescindible un relé?, con un triac disparado en el cruce por cero tendrás muchos menos problemas y en general es mas barato, por supuesto disparado con un moc 3041 o semejante. Si la carga es inductiva, red snubber.
16/06/2011 #20

Avatar de pandacba

En todo lo que se ha mencionado, nadie ha puesto, que en la entrada, si o si debe haber un filtro EMI
Por otro lado los PIC en ambientes ruidosos no se comportan como los motorola por ejemplo
Tampoco nadie se da cuenta que la mejor fomr de ailar de la red un micro es una fuente sms

En una oportunida en ocasión de cambiar la vieje electrónica de una guillotiena, le hicieron un equipo basado en pic, en el laoboratorio funiconaba joya, pero en la máquina nunca funciono, terminaron comprando un equipo, y al traerlo tal como lo preveia habia un micro motorola, con una fuente sencilla, nada del otro mundo, y ese equipo jamás tuvo problemas....

AL ver eso, la misma persona realizo el trabajo sobre un HC11, y para su gran sorpresa, con ese nunca tuvo problemas...
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.