Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/12/2012 #1

Avatar de ESTEBAN555

como saturar un transistor con una corriente exacta?
Estoy haciendo un sensor de temperatura de agua, que al sumergirlo se prende solo y comienza a medir mostrando un led verde.........cuando el agua llega a 80 grados de temperatura suena una alarma y prende un led rojo.....

el problemita que tengo es que para que el sensor al sumergirlo se encienda tiene un transistor que funciona como saturado cuando el agua se interpone entre la base del mismo y una resistencia conectada a positivo....

al usar el circuito en la práctica, cualquier humedad ambiente sin sumergirlo en ningun liquido hace circuilar una pequeña corriente y el circuito funciona incorrectamente ya que el transistor no satura por completo. ademas de no cumplir el cometido de encender el circuito solamente cuando está sumergido en agua....

he probado de aumentar la resistencia pero no sensa el agua.

espero se entienda ! je je...adjunto unas imagenes del inventillo

ahhh todo funciona a 4,5 volt y tengo poco lugar para meter circuitos tipo comparador...
25/12/2012 #2

Avatar de guille990

Hola, y si alejas un poco los electrodos entre si para que no afecte la humedad, o si es que no entendí mal en la foto el sensor es la barra blanca y los dos círculos naranja que tiene en la punta son los electrodos, tendrían que estar mas alejados de la barra y aislados en los costados, ya que la humedad se deposita en la punta y te va a dar continuidad siempre. Saludos
25/12/2012 #3

Avatar de Nuyel

¿Cual es el IC y a que pin esta conectado el transistor?
Intenta colocar una resistencia entre base y emisor del transistor para reducir su sensibilidad y darle una polarización.
25/12/2012 #4


Probá con una resistencia de gran valor, como 1 MOhm, entre base y masa (0V, tierra, etc)...
Y como dijeron, separá un poquito los electrodo del sensor...
25/12/2012 #5


omo saturar un transistor con una corriente exacta?
es mas facil colocar un zener
en la base de modo que cuando la tension supera el valor del diodo zener
se activa el transistor
25/12/2012 #6

Avatar de Gudino Roberto duberlin

Amigo dadas las condiciones en que trabaja el transistor, sera dificultoso lograr una saturacion en todos los casos.
Es por ello que debes añadir un comparador de tension.
26/12/2012 #7

Avatar de ESTEBAN555

buenas ideaasssss !! ahora mismo me pongo a probar

1) resistencia, base - masa
2) zener en la base....(me imagino que ANODO para la base)

veremos los resultados....graciasss
26/12/2012 #8

Avatar de ESTEBAN555

con el zener no me funciona....será que tengo un zener de 3,9volt ? y una vcc de 4.5 volt....
quedarían 0.6 volt para saturar el transistor, eso suponiendo que el agua no tiene resistencia (que no es cierto jeje) !! sera por eso ???

Otra pregunta como calculo la resistencia que va a masa ?
26/12/2012 #9

Avatar de Gudino Roberto duberlin

Amigo, vuelvo a reiterar, utiliza un comparador de tension. Pues las pequeñas variaciones de conductividad del agua, ocasionara mal funcionamiento en la deteccion.
Imágenes Adjuntas
Tipo de Archivo: bmp deteccion liquido.bmp (88,8 KB (Kilobytes), 17 visitas)
26/12/2012 #10


ESTEBAN555 dijo: Ver Mensaje
con el zener no me funciona....será que tengo un zener de 3,9volt ? y una vcc de 4.5 volt....
quedarían 0.6 volt para saturar el transistor, eso suponiendo que el agua no tiene resistencia (que no es cierto jeje) !! sera por eso ???
prueba con un zener de menor valor
el agua si tiene resistencia
por que no mides que voltaje tiene la base en el agua
eso te dara una idea cual es el valor del zener
para probar


y si no tiennes zeners
usa diodos 1n4007 esos necesitan 0,7V para funcionar
ejemplo: 3 en serie son 2,1V

de todos modos el otro circuito del mensaje de arriba parece mas simple de hacer
26/12/2012 #11


Y en vez de un trasistor NPN, ¿por qué no usas un FET?, creo que tiene mas sensibilidad...

Sino, lo que dijeron arriba, con zener, o diodos...
28/12/2012 #12

Avatar de ESTEBAN555

GRACIAS !! ya está solucionado.
El tansistor se volvía "loco" porque le faltaba la resistencia que va de base a masa.
comprobé qie en algunos lugares andaba bien y en otros mal...supongo que donde funcionaba mal se inducían interferencias por la base.
ahora funciona a la perfeción.....ya aprendí---cuando un transistor funciona como switch, la base con una Resistencia (1/10 de la r de entrada)a masa (obiamente npn).-

agradezco tambien a "nilrebud otreboR oniduG" pero como puse en mi primer pregunta...un comparador no entraba fisicamente...solo me entraba un transistor y una o dos resistencias....

Saludos !
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.