Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/02/2013 #1


Señal distorsionada en circuito PWM, ¿Solución?
Hola electrónicos, estoy realizando un controlador PWM para el control de un motor de 24v 12A. He optado por generar el PWM usando un TL084ACN y usar amplificadores operacionales para obtener el PWM. El circuito diseñado es el siguiente:
http://www.forosdeelectronica.com/at...6&d=1361796027
he conseguido que la frecuencia sea de unos 30kHz (es la que necesito) y los valores de resistencia son: R5=20k R4=30k R6=1k el condensador C5=10nF. R7 y R9 son para subir el valor de continua de la señal para usar el potenciómetro. El circuito es el documento adjunto.
El problema es el siguiente, la frecuencia de la señal son 29kHz pero no se distingue que sea un PWM, en este enlace podéis ver un vídeo de la señal http://dl.dropbox.com/u/8941517/pwmvideo.avi en el canal 1 (amarillo) la señal en cuestión y en el 2(azul) el valor de la señal de referencia. La señal triangular varía entre 2.5v y 12.5v.

He pensado en poner a la salida un amplificador Totem-pole y de ahí al MOSFET, ¿Al poner el amplificador, a su salida la señal se vería bien?¿Sabéis alguna forma para mejorar la señal sin bajar la frecuencia?

Muchas gracias por vuestra ayuda y tiempo.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.