Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

15/10/2014 #1


Sólo se ve medio display.
Amigos todos, necesito de su sabiduría y experiencia, resulta que hice un contador digital con el 74192 y 74247 con displays Ánodo común, en mi protoboard funcionó pero que de maravillas, asi que me atreví a diseñar la placa y monté todo y funcionó unos minutos, pero despues el primer dígito de la derecha se dejaron de ver los segmentos C, D y E del display, por un momento pensé que que se había quemado, así que reemplacé el display y siguió sin visualizarse completamente, cambié las resistencias y lo mismo, cambié el 74247 y nada, cambié el 74192 de ese dígito y nada, revisé las pistas de la PCB y no están ni cortadas ni en corto circuito, ni nada, también revisé los cables que conectan la pcb de los IC's con el pcb de los displays y están bien conectados y sin falsos, ya no se que hacer, por fa alguien oriénteme ahora que lo volví a encender veo que a de manera aleatoria el segmento A del 5to display intermita pero no siempre. por fa help me.

una cosa que si noté pero no supe que es, es que medi voltaje entre las resistencias y el display y todos los segmentos encendidos me daban 2.59 v, (promedio) y los que no encienden me daba una lectura de 4v ¿Eso tendrá algo que ver?

Saludos y gracias por su ayuda.
16/10/2014 #2

Avatar de TRILO-BYTE

seguro que no es el display?

ami me paso igual hise un reloj TTL imagina el tamaño de ese mounstruo y revise todo y cres que habia un corto que solo era visible con 2 lupas.

me costo mucho dar con la falla.

yo recomendaria que revisaras todos los pines de 1 en 1 , cambiar el display o revisar que iluminen los segmentos y revisar las soldaduras frias, que den continuidad los cables del pin del chip al pin del display.

pueden ser muchas cosas, y revisa con lupa
16/10/2014 #3


Gracias por comentar Trilo-Byte y si, ya probé creo que todas las posibilidades lógicas, cambié el display, chequé que no haya cortos, ni puentes de basura entre los pines, cambié el cable (es AWG 28) cambié las resistencias, cambié el decodificador, cambié el contador y con todos deja de verse el segmento C y D ahorita ya se vió (porque así le dió la gana) el segmento E, lo que se me hace raro es que me marque 3.79 v, en el segmento D y 4 v, en el segmento C, como si el decodificador diera la orden de apagar esos segmentos, pero ya cambié el decodificador incluso puse un 74ls47 y hace exactamente lo mismo, alguna otra sugerencia aparte de revisar cortos circuitos??? =( me estoy como frustrando un poquito jejejeje porque cuando lo armé puse cada display por separado calando cada dígito precismante para si había alguna falla detectarla antes de que estuviera armado por completo, y funcionó perfecto y de la nada dejó de verse la mitad del display y ahorita ya volvió a encender el segmento E... está muy loco ésto jejejeje xD
16/10/2014 #4

Avatar de TRILO-BYTE

pues no es de sorprender eso pasa por falta de capacitores
solda un capacitor de 100nf el que dice 104
a vcc y a gnd de cada integrado

si te vas a gastar $1 por cada integrado que tengas lo mas cercano que puedas, asi eliminas las posibilidades de ruido de tu fuente, tambien revisa que no haya quedado un puente en los pines de prueba del 74ls47 como los de test lamp y esos.
por que luego generan esa falla.

los capacitores poniendolos cerca de cada chip pues no es invento mio solo es una norma en diseño de circuitos impresos , recuerda que los circuitos impresos actuan como antenas si las esquinas estan a 90°
16/10/2014 #5


pues ya solucioné el problema... xD resultó ser el cable conductor de señal del contador al display... pero era un falso TAN extraño... pero puse uno nuevo y asunto arreglado, sigamos con el proyecto entonces... saludos a todos.

pues ya solucioné el problema... xD resultó ser el cable conductor de señal del contador al display... pero era un falso TAN extraño... pero puse uno nuevo y asunto arreglado, sigamos con el proyecto entonces... saludos a todos.

---------- Actualizado después de 4 minutos ----------

TRILO-BYTE dijo: Ver Mensaje
pues no es de sorprender eso pasa por falta de capacitores
solda un capacitor de 100nf el que dice 104
a vcc y a gnd de cada integrado

si te vas a gastar $1 por cada integrado que tengas lo mas cercano que puedas, asi eliminas las posibilidades de ruido de tu fuente, tambien revisa que no haya quedado un puente en los pines de prueba del 74ls47 como los de test lamp y esos.
por que luego generan esa falla.

los capacitores poniendolos cerca de cada chip pues no es invento mio solo es una norma en diseño de circuitos impresos , recuerda que los circuitos impresos actuan como antenas si las esquinas estan a 90°
Sí! había leído eso de los 90° y en el diseño del pcb eliminé todos los ángulos rectos, eso del cap, lo había visto con los cmos, pero no con los ttl, en fin, lo tengo que poner como filtro entre vcc y gnd de cada integrado? para tenerlo en cuenta en la versión 2.1 de mi diseño jejejeje muchas gracias por el tip. la fuente que uso la saqué de una cpu, me da 5 y 12v en positivo y negativo, la verdad no creo que haya mejor fuente qué éstas de pc, pero igual me equivoco... :P
16/10/2014 #6

Avatar de TRILO-BYTE

asi es las fuentes conmutadas son menos suceptibles al ruido que una de transformador.

ya que estamos en temas de fuentes y contadores dejame decirte que una fuente con transformador es igual de estable cuando le pones su regulador lm7805.

¿como es posible?
dando una leida rapida a la hoja de datos el fabricante requiere un capacitor antes y despues de este regulador del orden de los nano faradios para garantizar el minimo ruido si no se ponen.
en los proyectos con flip- flops y contadores empiezan a hace conteos raros, se brincan numeros ,etc.

tambien recuerda que los TTL son suceptibles al ruido y que las fuentes con transformador se escoje el capacitor al doble de voltaje que el transformador nos da y por cada amper 1500uf.

son tips que te pueden ayudar en la ecuela
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.