Haz una pregunta
  Foros de Electrónica » Temas de Interés » Dudas en general
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

11/08/2011 #1


Por que un transistor se quema
Hola a todos.

Tengo una máquina CNC mas o menos de los años 70´s u 80´s. Durante unos cuatro años funcionó bien, pero un buen día en pleno trabajo empezo a fallar el eje Z, por lo que se me rompió la herramienta y lo que llevaba de trabajo se echo a perder.

Busqué técnicos que me pudieran ayudar. Encontré a dos: uno vio la máquina y dijo que regresaba el sábado pero no me dijo cual sábado. Ya han pasado mas de seis meses y empiezo a sospechar que no va regresar. El otro técnico me dijo que la máquina tenía un transistor quemado que lo iba a comprar, ya pasaron tres meses y sospecho que tampoco va a regresar. No se si no le quieren meter mano a la máquina por lo vieja que está.

Ante esta situación no me quedo otra, mas que empezar a buscar la falla de la máquina y buscando, buscando, encontré que un transistor no cumplía con los parámetros, por lo que compré uno nuevo, lo instalé y probé el funcionamiento de la máquina. ¿Qué paso? Pues corrí un programa para hacer 100 barrenos en vacío y, ¡¡¡¡¡oh por Dios!!!! ¡¡¡¡La máquina estaba funcionando!!!! Me sentía el gran reparador de máquinas CNC de los años 70´s u 80's (como el burro que toco la flauta). Me puse a preparar la máquina y el material para reiniciar con el trabajo que estaba pendiente, inicie el programa con los códigos G y a los 15 minutos de trabajo continuo volvió a fallar. La misma falla. Ya sabía donde buscar y busque y encontré. El transistor estaba quemado. Pensé que el transistor había salido malo, lo cambie, volví a probar y la misma situación.

Concluí que el transistor no era el problema, en alguna parte del circuito había una alta corriente o alto voltaje o alta frecuencia, no se qué, el caso es que no he encontrado el motivo por el cual el transistor se quema, necesito que alguien me diga por que se quema un transistor, si es por la corriente que pasa por la base, el colector o el emisor, esto para poder orientarme y seguir el camino mas probable.

Agradezco de antemano las respuestas.

Saludos.

josemx.
11/08/2011 #2

Avatar de DJ DRACO

El transistor no se quema por alto voltaje (pues se quemaría de una)
Tampoco por picos de corriente (pues se quemaría de una)
Se está quemando por exceso de trabajo...o deficiencia de disipación del calor...

que tipo de disipador tiene? podríamos colocar una mayor
que transistor es? podríamos buscar uno mas robusto

hay mil soluciones...pero hay que saber varias cosas...si podes mete una fotito digital

p/d. yo también sospecho que los técnicos no van a regresar... :(
11/08/2011 #3


Revisá las pistas del pcb!
11/08/2011 #4


- Seria bueno que subas unas fotos del transitor y de la placa para que te podamos ayudar...
12/08/2011 #5

Avatar de pandacba

Podrias pasar la nomenclatura del transitor y medir la tension que llega al terminal del centro del mismo?
Eso servira para ver donde esta el problema.

Posiblementte ha fallado otra cosa y por eso se rompe el transistor mencionado,por eso te pido los datos y la medición

Y si los transistores se rompen por sobre corriente o tensión inversa o directa superior a lo que puede soportar,
12/08/2011 #6

Avatar de DJ DRACO

pandacba: sólo para aclarar...lo que yo dije no fue generalizando a todos los transistores del mundo...sino a éste en particular, por lo que él dice.

Dice que en vacío funciona bárbaro...supongo que si fueran picos de tensión o corriente se quemaría de una...peeeero en cambio se quema cuando trabaja, es decir cuando drena corriente y obviamente calienta.

pero, deberiamos saber más antes de dar nada por sentado...asi que espero más info
12/08/2011 #7

Avatar de pandacba

Suecede que el tiempo que la probo en vacio, no es el mismo, que bajo carga
12/08/2011 #8
Moderador general

Avatar de DOSMETROS

josemx dijo: Ver Mensaje
Ante esta situación no me quedo otra, mas que empezar a buscar la falla de la máquina y buscando, buscando, encontré que un transistor no cumplía con los parámetros, por lo que compré uno nuevo, lo instalé y probé el funcionamiento de la máquina. ¿Qué paso? Pues corrí un programa para hacer 100 barrenos en vacío y, ¡¡¡¡¡oh por Dios!!!! ¡¡¡¡La máquina estaba funcionando!!!! Me sentía el gran reparador de máquinas CNC de los años 70´s u 80's (como el burro que toco la flauta). Me puse a preparar la máquina y el material para reiniciar con el trabajo que estaba pendiente, inicie el programa con los códigos G y a los 15 minutos de trabajo continuo volvió a fallar. La misma falla. Ya sabía donde buscar y busque y encontré. El transistor estaba quemado. Pensé que el transistor había salido malo, lo cambie, volví a probar y la misma situación.


Si bien pienso que algún otro componente se ha degradado y eso produce que el transistor se queme , existe la enooooorme posibilidad de ---> Transistores Falsificados.

Por favor foto del componente.

¿ Lostransistores que tenés son de la misma partida comprados en el mismo lugar ?

Saludos !
12/08/2011 #9

Avatar de zopilote

El transistor solo deberia de actuar como switch, por lo que solo es como un regulador on-off, si existe algun
cortocircuito despues del transistor, por la gran corriente que circula este se destruira, lo que tienes que buscar el la causa por la que se ha destruido el transistor, y como dices que es antiguo, tienes que buscar primeramente en algun diodo de señal o zener y/o transistores. Luego pasa a los condensadores, y si son condesadores de tantalio sospecha mucho más.
12/08/2011 #10

Avatar de Gudino Roberto duberlin

josemx dijo: Ver Mensaje
Hola a todos.

Tengo una máquina CNC mas o menos de los años 70´s u 80´s. Durante unos cuatro años funcionó bien, pero un buen día en pleno trabajo empezo a fallar el eje Z, por lo que se me rompió la herramienta y lo que llevaba de trabajo se echo a perder.

Busqué técnicos que me pudieran ayudar. Encontré a dos: uno vio la máquina y dijo que regresaba el sábado pero no me dijo cual sábado. Ya han pasado mas de seis meses y empiezo a sospechar que no va regresar. El otro técnico me dijo que la máquina tenía un transistor quemado que lo iba a comprar, ya pasaron tres meses y sospecho que tampoco va a regresar. No se si no le quieren meter mano a la máquina por lo vieja que está.

Ante esta situación no me quedo otra, mas que empezar a buscar la falla de la máquina y buscando, buscando, encontré que un transistor no cumplía con los parámetros, por lo que compré uno nuevo, lo instalé y probé el funcionamiento de la máquina. ¿Qué paso? Pues corrí un programa para hacer 100 barrenos en vacío y, ¡¡¡¡¡oh por Dios!!!! ¡¡¡¡La máquina estaba funcionando!!!! Me sentía el gran reparador de máquinas CNC de los años 70´s u 80's (como el burro que toco la flauta). Me puse a preparar la máquina y el material para reiniciar con el trabajo que estaba pendiente, inicie el programa con los códigos G y a los 15 minutos de trabajo continuo volvió a fallar. La misma falla. Ya sabía donde buscar y busque y encontré. El transistor estaba quemado. Pensé que el transistor había salido malo, lo cambie, volví a probar y la misma situación.

Concluí que el transistor no era el problema, en alguna parte del circuito había una alta corriente o alto voltaje o alta frecuencia, no se qué, el caso es que no he encontrado el motivo por el cual el transistor se quema, necesito que alguien me diga por que se quema un transistor, si es por la corriente que pasa por la base, el colector o el emisor, esto para poder orientarme y seguir el camino mas probable.

Agradezco de antemano las respuestas.

Saludos.

josemx.
Hola Amigo, es muy importante conocer varios puntos.
1ro.- Estar seguros de que estamos hablando de un transistor y no de otro componente, no nos dejemos llevar por lo que "aparenta" un encapsulado.-
2do.-Es imprescindible conocer la funcion del componente, es decir si trabaja en forma lineal o conmutado(en el supuesto caso que fuera un transistor) o si simplemente actua como un interruptor de alimentacion.-
3ro.- Si no se dispone de planos, al menos identificar componentes asociados a el.
4to.- Corroborar que la fuente de alimentacion nos esta entregando tensiones dentro del margen aceptable.
12/08/2011 #11


Hola. ¡¡¡Qué rapidez!!! Nunca antes en algún foro me habían respondido tan rápido.

Les agradezco.

En efecto el transistor se está quemando por exceso de calor, pero no tiene que ver con el disipador de calor, ni con una mala elección. El transistor que le puse es igual al que tenía la máquina antes de que fallara 2N6547.

Ahora, si estoy pidiendo ayuda en el foro de principiantes ¿Por qué contradigo a los que si saben? Por que no les explique como está el sistema completo y por que desde que los técnicos me abandonaron empecé a buscar la falla usando la lógica que sustituyo mi ignorancia en el tema.

El sistema cuenta con tres motores de paso: X, Y y Z. Cada motor tiene una tarjeta controladora, idénticas entre si. Estas tarjetas se conectan a cuatro transistores 2N6547 por motor, que actúan como interruptores y me dan los grados de giro. Los transistores de cada motor están montados en disipadores de calor idénticos, esto me hace pensar que el problema no está en el transistor sino en un componente relacionado con el circuito.

Mi teoría es que un diodo o un transistor relacionado con el circuito está en corto circuito lo que lo hace conducir corriente en ambos sentidos, ocasionando sobrecalentamiento en este transistor. Esta teoría se basa en que cuando el motor empieza a fallar, da la impresión de que hay una corriente que lo impulsa a girar hacia un lado y otra corriente de igual magnitud pero de dirección contraria que no se lo permite, por lo que el motor queda oscilando un tiempo hasta que el transistor se quema.

De cualquier manera anexo el diagrama del sistema de alambrado (IMG_4435) y el diagrama del sistema controlador de los ejes (IMG_4463). El transistor que falla es Q3Z. Con el visor de imágenes de Windows se puede ampliar.

Les agradezco su ayuda.

Saludos.
Archivos Adjuntos
Tipo de Archivo: rar diagramas.rar (561,7 KB (Kilobytes), 53 visitas)
12/08/2011 #12
Moderador

Avatar de Dano

josemx dijo: Ver Mensaje
Hola. ¡¡¡Qué rapidez!!! Nunca antes en algún foro me habían respondido tan rápido.

Les agradezco.

En efecto el transistor se está quemando por exceso de calor, pero no tiene que ver con el disipador de calor, ni con una mala elección. El transistor que le puse es igual al que tenía la máquina antes de que fallara 2N6547.

Ahora, si estoy pidiendo ayuda en el foro de principiantes ¿Por qué contradigo a los que si saben? Por que no les explique como está el sistema completo y por que desde que los técnicos me abandonaron empecé a buscar la falla usando la lógica que sustituyo mi ignorancia en el tema.

El sistema cuenta con tres motores de paso: X, Y y Z. Cada motor tiene una tarjeta controladora, idénticas entre si. Estas tarjetas se conectan a cuatro transistores 2N6547 por motor, que actúan como interruptores y me dan los grados de giro. Los transistores de cada motor están montados en disipadores de calor idénticos, esto me hace pensar que el problema no está en el transistor sino en un componente relacionado con el circuito.

Mi teoría es que un diodo o un transistor relacionado con el circuito está en corto circuito lo que lo hace conducir corriente en ambos sentidos, ocasionando sobrecalentamiento en este transistor. Esta teoría se basa en que cuando el motor empieza a fallar, da la impresión de que hay una corriente que lo impulsa a girar hacia un lado y otra corriente de igual magnitud pero de dirección contraria que no se lo permite, por lo que el motor queda oscilando un tiempo hasta que el transistor se quema.

De cualquier manera anexo el diagrama del sistema de alambrado (IMG_4435) y el diagrama del sistema controlador de los ejes (IMG_4463). El transistor que falla es Q3Z. Con el visor de imágenes de Windows se puede ampliar.

Les agradezco su ayuda.

Saludos.
Probaste medir la resistencia de cada bobina del motor ?
Una causa puede ser que el motor se recalentó alguna vez, el barniz de aislación de las bobinas empezó a fallar generando cortocircuitos entre espiras haciendo que el motor haga cosas raras.

Si los tres motores son iguales, mide la resistencia de uno de los bobinados de un motor el cual no esté relacionado con ese transisor, luego mide los 4 bobinados del motor que está relacionado con el transistor.
Si las medidas son muy distintas el motor murió.
12/08/2011 #13
Moderador general

Avatar de DOSMETROS

Yo estaba pensando lo mismo , que cambiara el transistor y lo probara con otro de los dos motores.

Igual vuelvo a la carga con el transistor , que sea de primera línea ya que es bastante groso.

Que no desarme el motor sin ponerlo en corto magneticamente , sinó no le va a servir más

Saludos !
12/08/2011 #14


En este caso la lógica me sirvió para encontrar la falla por que son tres circuitos idénticos, por lo que tenía un punto de referencia, de otra manera la lógica no me hubiera servido para nada, como es el caso de la tarjeta ACC (ver diagramas adjuntos) que es única y sospecho que es en donde esta la falla. El problema radica que no se como o por donde entrarle al problema.

Para determinar que el transistor Q3Z era lo que había fallado seguí la siguiente secuencia.

1º.- Como las tarjetas SMD (Step Motor Drive) son iguales, intercambie la tarjeta del eje Z al eje X y la del eje X al eje Z y probé. El motor del eje X avanza para atrás y para adelante sin problema, el motor del eje Z no avanza, no se mueve, esta muerto. Conclusión: La tarjeta SMD no es problema.

2º.- El transformador asociado al motor del eje X lo cambie al eje Z y el transformador asociado al motor del eje Z lo cambie al eje X y probé. El motor del eje X avanza para atrás y para adelante sin problema, el motor del eje Z no avanza, no se mueve, esta muerto. Conclusión: El transformador del eje Z no es el problema.

3º.- Cambie el motor del eje Z al eje X y el motor del eje X lo cambie al eje Z y probé. El motor en el eje X avanza para atrás y para adelante sin problema, el motor en el eje Z no avanza, no se mueve, esta muerto. Conclusión: El motor de pasos no es el problema.

Hasta aquí se terminan los elementos que se pueden intercambiar. Lo siguiente es buscar entre el cableado los elementos que intervienen.

Localizó los transistores que he estado mencionando entre los cuales se encuentra el que esta dañado midiendo los parámetros con el polímetro y encuentro que once miden lo mismo y uno mide diferente, se encuentra asociado al eje Z por lo que concluyó que ahí esta el mal lo cambio y todo lo demás ya esta dicho.

Si ya vieron los diagramas adjuntos, hasta este momento desmonte de las tarjetas los diodos D30 y D34 y los probé y están bien.

La teoría que tiene zopilote me parece la más cercana ya que en la tarjeta de ACC hay unos diodos Zener asociados, los voy a desmontar para probarlos, el problema es ¿cómo se prueba un diodo Zener?
12/08/2011 #15

Avatar de Eduardo

josemx dijo: Ver Mensaje
...
El sistema cuenta con tres motores de paso: X, Y y Z. Cada motor tiene una tarjeta controladora, idénticas entre si. Estas tarjetas se conectan a cuatro transistores 2N6547 por motor, que actúan como interruptores y me dan los grados de giro. Los transistores de cada motor están montados en disipadores de calor idénticos, esto me hace pensar que el problema no está en el transistor sino en un componente relacionado con el circuito.
Esto tendrías que haberlo escrito en tu primer mensaje, junto con el circuito y lo que escribiste en CNCZone. Es nada mas para que no se genere un ping pong de preguntas y respuestas como "Que tipo de motores son? Continua,paso a paso o brushless?" ,"El famoso transistor, que transistor es?" etc...
Mi teoría es que un diodo o un transistor relacionado con el circuito está en corto circuito lo que lo hace conducir corriente en ambos sentidos, ocasionando sobrecalentamiento en este transistor. Esta teoría se basa en que cuando el motor empieza a fallar, da la impresión de que hay una corriente que lo impulsa a girar hacia un lado y otra corriente de igual magnitud pero de dirección contraria que no se lo permite, por lo que el motor queda oscilando un tiempo hasta que el transistor se quema.
Con esos síntomas, es mucho mas probable que el problema sea un bobinado del motor en corto o un cortocircuito en el tramo de cable que va del drive al motor.
Sobre todo lo último, es muy común que se lastime el cable ya sea por fatiga, aplastamiento o el karma.

Como el corto puede no ser permanente sino un chispeo en determinadas posiciones del cabezal, para verificar te conviene primero conectar el motor con un cable por fuera (arreglate para que no se enrede ). Digo de hacer esto para estar seguro que sea eso, porque en algunas maquinas el recambio es bastante engorroso.
15/08/2011 #16


Veo que hay 10 visitas a los diagramas que adjunte, si los abrieron dando doble clic sobre el icono seguramente se abrio como una fotografía completa en el monitor lo que no permite distinguir la numeración de los elementos.

Si abren un archivo nuevo de Word o Power Point y arrastran el archivo jpg a una hoja de cualquiera de estos dos programas, lo pueden ampliar hasta 500% pudiendo ver la numeración de cada elemento sin deformación de la imagen.

IMG_4435 Es el diagrama de las conexiones externas del motor como son transformador (SX) y los transistores.

IMG_4463 son los diagramas de interconexión entre la tarjeta de ACC (reguladora), la tarjeta SMD (Steep Motor Drive), los transistores, el transformador y el motor.

Si alguien me puede decir por donde empezar se los agradeceré.

Saludos.
15/08/2011 #17

Avatar de DJ DRACO

A ver viejas..si el vago empieza a cambiar los motores, las placas y todo...mejor que se compre una máquina nueva.

la idea aca es cambiar el transistor por uno de similares características pero mayor capacidad en corriente
y colocarle un súper disipador de calor...y/o un cooler tambien.

saludos.
15/08/2011 #18

Avatar de BKAR

josemx dijo: Ver Mensaje
.... uno vio la máquina y dijo que regresaba el sábado pero no me dijo cual sábado. Ya han pasado mas de seis meses y empiezo a sospechar que no va regresar. El otro técnico me dijo que la máquina tenía un transistor quemado que lo iba a comprar, ya pasaron tres meses y sospecho que tampoco va a regresar....
JAJA yo tambien creo que no van a regresar...
...lo mas simple seria poner un Transistor que cumpla con las mismas condiciones que el anterior pero como dijo DJ DRACO
Mayor capacidad de corriente + disipador
pero creo que hay otro problema mas que el transistor quemado..
La pregunta Seria ¿Que causo que se quemara?
15/08/2011 #19
Moderador

Avatar de Chico3001

josemx dijo: Ver Mensaje
Si alguien me puede decir por donde empezar se los agradeceré.
Comienza por revisar los bobinados de los motores... como ya te comentaron son la causa mas probable de que el transistor se siga quemando...
15/08/2011 #20
Moderador general

Avatar de DOSMETROS

Ya te dije que cambies el transistor y pruebes ese eje con el motor de otro eje
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Dudas en general

Aquí se tratan todos los temas relacionados con la electrónica en general.

Cerrar
Foros de Electrónica » Temas de Interés » Dudas en general

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.