Haz una pregunta
  Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/04/2013 #1


Dimmer IGBT controlado por PWM
Buenas he diseñado un circuito con IGBT para controlar la potencia entregada a una lámapra con el fin de variar la luminosidad de esta. No he conseguido que funcione correctamente porque siempre está encendido o apagado.

El circuito es el siguiente, muchas gracias.CircuitoPotencia.JPG
07/04/2013 #2
Moderador general

Avatar de Fogonazo

Sin mirar mucho, estas tomando en el lugar incorrecto GND la señal para GATE del IGBT, se debe aplicar entre GATE Y EMISOR

08/04/2013 #3


Gracias!

Pero entonces como dejaría el circuito definitivo? Yo quiero que conduzca tanto para los semiciclos negativos como para los positivos. En la simulación con el circuito anterior obtenia la señal deseada pero a la hora del montaje no obtenia ese resultado,

Un saludo!
08/04/2013 #4
Moderador general

Avatar de Fogonazo

Lee nuevamente.

Fogonazo dijo: Ver Mensaje
Sin mirar mucho, estas tomando en el lugar incorrecto GND la señal para GATE del IGBT, se debe aplicar entre GATE Y EMISOR
Mirando bien tu esquema, "Está mal".


Mira estas posibilidades:

Imágenes Adjuntas
Tipo de Archivo: jpg Dimmer IGBT.jpg (34,1 KB (Kilobytes), 755 visitas)
08/04/2013 #5


He probado con esas dos configuracioens que me has dicho pero nada. Ahora parpadeaba pero no conseguía que variara modificando el ancho de pulso del pwm. No sé que está pasadon es un circuito sencillo.

La aplicación que quiero hacer es variar la luminosidad de una lámapra de led de 220v con una salidad pwm que viene de un PLC. ¿conoces algo ya hecho y que funciones?

Un saludo, muchas gracias por tu tiempo
10/04/2013 #6
Moderador

Avatar de Luis Eduardo Sánchez

Drj si el pwm no esta sincronizado con la red, es decir que detecte el cruce por cero de la señal seno de la red electrica dificilmente va a funcionar el dimmer. Es mejor diseñar un pwm externo que este sincronizado con la red y a partir de ahi usar la señal de un plc de 0-10V o 4-20mA.

Saludos
10/04/2013 #7


Disculpa mi ignorancia... pero no entiendo como afecta eso al funcionamiento de mi circuito. Según el circuito anterior yo lo que hago es dejar que conduzca el igbt o no dependiendo del estado del pwm, independientemente del estado de la señal de la red (eso tenía entendido yo).

¿Qué tipo de circuito puedo usar para detectar los pasos por cero?

Disculpa de nuevo, soy un poco novato...
11/04/2013 #8

Avatar de Scooter

Eso es una mezcla de ideas me parece a mi.
A) Triac + paso por cero
B) Igbt o similar
11/04/2013 #9
Moderador

Avatar de Luis Eduardo Sánchez

Mira el post destacado en esta seccion sobre control para resistencia calefactora.

Cualquier duda despues de revisar este post nos cuentas.

Saludos
15/04/2013 #10


Primero de todo muchas gracias por el post! me parece un gran aporte.

Yo estaba buscando hacer algo más sencillo. No entiendo por qué con un igbt y la configuración que armé anteriormente no funciona correctamente. En realidad lo que estoy buscando hacer es una especie de relé en estado sólido para variar la potencia entregada a unas lámapras leds de 220V.

Creo que no debe ser tan difícil pero estoy empezando a arrojar la toalla...

¿Se os ocurre algo más? muchas gracias

Un saludo!
15/04/2013 #11
Moderador

Avatar de Luis Eduardo Sánchez

DRJ.

La más facil es, rectificar, usar un condensador para el voltaje de voltaje en DC obtenido que en tu caso si son 220ac al entrada el condensador debe ser de 400VDC como mínimo y dependiendo de la potencia del bombillo mirar el valor de la capacitancia para minimizar la corriente de rizo en DC y en ese punto ya puedes hacer un PWM si cruce por cero el cual lo puedes obtener de un oscilador como un 555, en donde variando el t-on y el t-off puedes obtener el dimmer que deseas.

Saludos
17/04/2013 #12


Muy buenas!

A ver si lo he entendido. Me olvido del pwm que me genera mi PLC no? y me genero uno externo con control por paso de cero de la corriente? o puedo usar el circuito que a continuación muestro añadiendole el condensador? siento ser tan torpe pero es que llevo ya varios intentos y esto no funciona ni a la de tres!

El caso es que con el circuito que aportó el otro compañero (muchas gracias) la simulación es perfecta pero el resultado montado no lo es (puede ser por el igbt usado?) . No entiendo nada.... ¿qué modelo de igbt usais vosotros? ¿cúal es el más común? También ví tu aporte para el control de temperatura con la famosa detección de paso por cero.

La potencia de mis lámapras es de 3W (Led a 220v) pero conectaré unas 5 a este dispositivo

igbt.JPG

Mil gracias por vuestra paciencia
18/04/2013 #13
Moderador

Avatar de Luis Eduardo Sánchez

Hola el esquema que te adjunto Fogonazo es el correcto, el tema que se añade es que usas leds y por eso es que no te puede funcionar bien

agregale un condensador a la salida del puente de 100uF/400V estaría bien (cuidado con la polaridad por que a este voltaje te puedes quedar ciego si explota!!).

Mira este post para que te hagas una idea, olvidate de la parte que dice puente H, antes de la etapa de disparo le agregas el pwm.

Saludos
19/04/2013 #14


Buenos días!

Muchas gracias por el aporte, este finde intentaré armarlo y ya voy comomse tanto como va el asunto.
19/04/2013 #15
Moderador general

Avatar de Fogonazo


Ojo al piojo al agregar capacitores, si se rectifica, así sea en onda completa se continúa teniendo una tensión eficaz de (Aproximadamente) 220V, pero si se agregan filtros, esa tensión cambia al valor pico de los 220Vca originales, así que ahora vamos a tener unos 311Vcc que no le van a hacer nada bien a nuestra pobre e indefensa lámpara.
Si se aplican filtros se deberá establecer por programa un valor máximo de ancho de pulso que NO permita que a la lámpara le lleguen mas de 220Vcc.
19/04/2013 #16

Avatar de Sebastian1989

Hay un tema bastante importante que hasta ahora no se a mencionado, este es que la luces led que se conectan directo a la red eléctrica traen internamente una pequeña fuente switching para entregarle una corriente constante a los leds, a la entrada de esta fuente hay un rectificador con su respectivo filtro, por lo mismo no me parece posible que con este tipo de control puedas variar su luminosidad.
Lo que podrías hacer es desarmar una de esas ampolletas y ver el voltaje y corriente de funcionamiento de los leds (ten cuidado al hacer las mediciones), de esta forma se podría diseñar un circuito con control PWM que los alimente directamente.
04/05/2013 #17


Correcto sebastian y ese es mi caso. Según he estudiado hay dos tipos. Las que tengo yo que son como las que tu mencionas, las cuales, tienen en su interior un transformador, un condensador y creo que un regulador de tensión. Esto hace que cuando paso de un determinado ancho de pulso la lámpara se encienda directamente impidiendome variar su luminosidad. Por otra parte existen otras lámapras con una conexión igual que las halógenas, las cuales, no poseen este circuito interno. Estas si se pueden regular con este circuito añadiendole el famoso condensador del que hablábamos.

Llegados a este punto no me gustaria tener que tirar las lámapras que compré así que seguiré investigando a ver si puedo aprovecharlas.

Si encuentro la solución ya os la comentaré. Sí tenéis algún aporte os lo agradeceré enormemente.

P.d: también cambié el modelo de IGBT que estaba usando, ahora si funciona bien el circuito.
24/05/2013 #18


Buenas. Ya conseguí por fin hacer que todo funcionase con las lámparas leds correctas. El circuito usado fué el aportado fogonazo. El problema que tengo ahora esel siguiente. he realizado dos circuitoss identico pero independientes. En el modelo en Protoboard me funcionaban correctamente, es decir, cada lámapra era independiente para su circuito.

Después de trabajarme una placa de circuito impreso y soldar los componente tengo un problema. al activar una de mis salidas PWM desde el PLC se me encienden las dos lámparas! es decir, yo activo el PWM del del circuito uno y se encienden las lámparas del circuito 1 y 2. HE usado los mismo componentes que en el circuito PROTOBOARD pero no entiendo por qué me pasa. Todo el crcuito es correcto y ya lo testeé con anterioridad.

¿Se os ocurre alguna explicación? ¿por donde puedo empezar a buscar el fallo?

Muchas gracias!!
04/07/2013 #19


Buenas sigo sin encontra el fallo. Para un juego de luces de un color el circuito va perfecto el problema es cuando monto otro circuito igual que el anterior para otro juego de luces independiente al anterior y con otra salida independiente pwm desde plc. Cuando activó una de las dos salidas se me encienden las dos luces.

Como diseñaríais vosotros el circuito final?

Muchas gracias!!!
29/09/2013 #20


Hola, yo optoacoplaria las entradas de los igbt para aislar las señales del PLC.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Automatización, Electrónica industrial y de Potencia

En esta categoría se discuten temas relacionados con la automatización, la electrónica industrial y la instrumentación.

Cerrar
Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.