Haz una pregunta
  Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

18/04/2012 #1


Driver IGBT de motor 48 voltios 3.5 Kw 73A
Buenas tardes amigos.

Tengo el siguiente problema:

Hay un monta cargas electrico de 48 voltios que uiliza 2 motores de 3.5kw 73 Amperios cada uno, uno de ellos para andar y el otro para la hidraulica de las uñas de levantamiento y demas.. Resulta que el IGBT driver de este ultimo motor se daño.. No tengo el numero de parte pero tengo disponible comprar este MG600Q1US59A es marca Mitusbishi de 1200 Voltios 600 Amperios
la datasheet se encuentra en www.alldatasheet.com. cabe destacar que el diodo flywheel del antiguo modulo aun esta en buen estado, de esta manera conecto en paralelo ambos diodos y el transistor IGBT antes mencionado que quiero saber si es posible me funcione adecuadamente, segun la hoja de datos me parece que no habria problema, soy tecnico en electronica y agradeceria mucho si alguien pudiera decirme si ese reemplazo podria funcionar sin problemas.

Casi olvido decir que el motor es de una fase solamente y siempre gira tambien en un mismo sentido, no se necesita un puente H para manejarlo simplemente un driver de corriente en una direccion.

Gracias por au ayuda.

Saludos!
18/04/2012 #2
Moderador

Avatar de Luis Eduardo Sánchez

Randall los motores son de CC? De otro lado ya verificaste la etapa de disparos asociado al Igbt averiado, por que de haber falla en esta etapa se te puede volver a reventar el módulo, Tienes una foto del modulo dañado?, y por último si este módulo controla el sistema hidraulico revisate que la bomba no este atascada! Ayudanos con esta info, y trataremos de darte una mano!

Saludos
18/04/2012 #3


Muchas gracias por su pronta respuesta don Luis Eduardo, valoro mucho ayuda ya que tengo este problema desde hace meses.

Los motores son de CC 48 Voltios.
Ya he revisado la etapa de disparo de este driver, esta perfectamente bien, la compare con la salida de la etapa del motor de andar (que funciona bien y usan el mismo modulo IGBT) , y ambas estan mostrando señales similares al momento de la ignicion que es cuando el montacargas prueba los drivers y motores con un pequeño tren de pulsos.. por otro lado la bomba del hidraulico parece estar bien, el modulo dañado quedo en cortocircuito, de esta manera el motor nunca se detiene y al aplicar los controles de levantamiento todo funciona bien el problema es que el motor no se detiene y usarlo asi implica gastar la bateria muy rapido.

Gracias, lo foto del modulo dañado y el motor tratare de subirla en un rato.

Saludos.
18/04/2012 #4


Adjunte ya las fotos de los modulos gemelos de ambos motores, ademas le tome tambien a los motores.

Es un hecho que mi reemplazo mas accsesible el MG600Q1US59A no tiene la misma forma fisica que el original tambien difieren en su voltaje de excitacion de compuerta, ya que el original trabaja encendido a full con pulsos PWM de 2 voltios mientras que mi reemplazo necesita 15 voltios, este problema lo creo capaz de resolver con un IC especial para manejar modulos IGBT, este toma los 2 voltios (amplificados primeramente a TTL) y los amplifica a 15 voltios con 9A de capacidad de corriente pico para poder encender y apagar el transistor en el tiempo mas rapido posible usando valores muy bajos de R gate.

La idea despues no es retirar completamente el modulo en mal estado, sino simplemente retirar del circuito su colector cortocircuitado y agregar ahi el colector de mi reemplazo y tambien el emisor, aprovechando asi los diodos del antiguo modulo y el cableado tambien.

El reemplazo posee una terminal de sensado de corriente, asi podre tambien elaborar un circuito que no permita que la corriente supere los 150A, quizas menos, este es el valor de los fusibles que tiene el motor y nunca se han quemado, por eso es posible asegurar que ni en condiciones de extrema carga del motor la corriente llega a ese nivel.

Muchas gracias por su atencion, espero sus comentarios y criticas.
Imágenes Adjuntas
Tipo de Archivo: jpg Drivers4.JPG (87,8 KB (Kilobytes), 145 visitas)
Tipo de Archivo: jpg Motores2.JPG (67,3 KB (Kilobytes), 128 visitas)
Tipo de Archivo: jpg Sistema.JPG (94,8 KB (Kilobytes), 122 visitas)
19/04/2012 #5
Moderador

Avatar de Luis Eduardo Sánchez

Randall a la vista esos modulos de potencia son del tipo darlington y por lo que comentas del voltaje de excitacion lo confirmas, entonces de hacer la conversión a IGBT hay que tener sumo cuidado con el voltaje de corte y saturación que en los Igbt es del rango de los -15 y +15 voltios respectivamente, pero en caso de tener una sola fuente, te recomiendo utilizes el driver IR2127, para la Aplicacion que necesitas ellos tienen unas notas tecnicas.

la pagina de los datos técnicos es esta:

http://www.irf.com/product-info/data...ata/ir2127.pdf

Importante observar como el es pulso de activacion del circuito existente por que de ser negado se necesitaria de usar el IR2128.

Saludos
19/04/2012 #6


Buenos dias.

Gracias don Luis, me sorprende saber que los modulos son tipo darlington no lo sabia.

Con respecto al circuito integrado que me recomiendas, ya compre el TC4422, que no tiene tantas protecciones ni es tan seguro como el que me recomiendas pero me gusto por la alta capacidad de corriente y asi encender mas rapido el IGBT. ademas segun estuve viendo tambien parece ser inmune pero no se hasta que punto. Comparando estos dos drivers cual me recomiendas el TC4422 o el IR2127?

Lo que que pienso hacer es tomar los 48 voltios y regularlos a 16 voltios mediante zener y transistor, el negativo de esta fuente va al negativo de los 48 voltios y que es tambien el emisor del IGBT. El motor se conecta de la siguiente manera: una terminal va al + de la bateria, el otro terminal va al colector del modulo y el emisor de este a tierra, es un driver de low side entonces segun entiendo.

Sera correcto si configuro la fuente de esa manera mencionada sabiendo que utilizo el TC4422 o sera necesario el IR2127?

Gracias por su amable ayuda don Luis.
19/04/2012 #7
Moderador

Avatar de Luis Eduardo Sánchez

Randall el tema de usar el TC4422 es que viene diseñado solo para mosfet y para completar requiere de un tranformador de aislamiento galvanico de alta frecuencia para el switcheo de este a lo cual hace que se vuelva más complejo el tema, hace un tiempo atrás subi unos esquemas para el disparo de unos IGBT que usaban el pc923 y el pc929, este esquema explica como debe de ser la fuente dual para el disparo del IGBT, el pc923 y su configuración será la mas sencilla de usar, debido a que si miraste con más atención la ficha tecnica del modulo IGBT que quieres usar se requieren de valores cercanos al Vge de +/- 15 Voltios y el con el IR2127 podría funcionar pero de pronto por la limitante del voltaje máximo aplicable a este IC(24 Voltios más la caida del voltaje del diodo de protección) se nos pueden presentar disparos erraticos en el modulo de potencia haciendo que este se nos reviente nuevamente. este es el link en donde esta el montaje para el PC923:

Conexión IR2110 High and low driver Mosfet

Ahi adjunte dos imagenes revisalos y me comentas.

Saludos
20/04/2012 #8


Gracias nuevamente por la ayuda.

No habia notado que el modulo requiere de ±15 voltios en la gate, pensaba que solo requeria +15. estuve revisando el tema que me recomendaste, pero todavia no comprendo como es que se forma el voltaje negativo, supongo que N1 va conectado al negativo de los 48 voltios y E1 tambien debe ir conectado al mismo ya que es el emisor del IGBT.

No creo que sea asi mas bien debe ser que N1 va conectado a una fuente negativa pero no tengo de donde sacar ese voltaje negativo. Me parece que E1 es el emisor del IGBT y este en mi circuito va puesto a el negativo de los 48 voltios que es ahi mismo donde va N1?

Podrias aclararme la duda don Luis, por todo lo demas me parece muy bien utilizar ese circuito.

Que tengan un buen dia y saludos.
20/04/2012 #9
Moderador

Avatar de Luis Eduardo Sánchez

Randall

Si te fijas en los planos hay un Zenner de 10 Voltios en el esquema de los optoacopadlores en el lado derecho, de ahi se genera el voltaje dual en donde saturan con + 14 voltios el igbt y lo ponen en corte con los -10 Voltios, este tipo de esquema es el que usan la mayoría de fabricantes de variadores en el mundo, para ahorrar costos, ahora bien si quieres tener certeza de que sean +/- 15 la fuente tiene que ser de 30 voltios y el zenner para la division del voltaje de 15 Voltios, asi es como generan la fuente dual, que en el caso tuyo de ser un IGBT low side no habría problema de referenciar con el negativo de la fuente de 48 voltios. De por si el equema tal y como está diseñado funcionaría sin problemas.

Saludos

Saludos
20/04/2012 #10


Buenas tardes.

Gracias por la explicacion, se nota que tiene usted mucha experiencia en esto don Luis.

Comprendo muy bien lo de la fuente dual y lo de los 30 voltios que se dividen por la mitad, pero no termino de salir de la gran duda que si E1 y N1 se conectan juntos al negativo de los 48 voltios, no habra entonces caida de tension en el zener y no tendre el voltaje negativo lamento no poder comprenderlo y agradeceria si pudiera explicarme solo un poco.

Si E1 es el emisor de mi IGBT entonces este por fuerza debe ir al negativo de los 48 voltios pero entonces donde va N1?

Gracias nuevamente don Luis.
20/04/2012 #11
Moderador

Avatar de Luis Eduardo Sánchez

Bueno, tienes razon, lo que pasa es que estos sistemas vienen diseñados para usar fuentes aisladas de la carga! Entoces de ser necesario tendrías que usar una fuente DC-DC ( no nesecitas mas de 500mA/24V)que este aislada galvanicamente para hacer esta operación, de modo que puedas hacer el disparo para poner en corte el Igbt sin que este se ponga en corto con el potencial negativo de la fuente de la montacargas,

Te adjunto un link de una pagina en donde muestran este tipo de fuente que son para montaje en circuito impreso.

http://www.current-logic.com/dcdc/CLD10.pdf

Saludos
23/04/2012 #12


Ok don Luis, ya veo que se trataba de una fuente aislada, voy a ver donde consigo estas fuentes, estuve buscando en ebay pero no encontre..

Mas bien antes de proceder a comprar el modulo y demas partes quiero aclarar mi duda principal, que es si el modulo MG600Q1US59A (suponiendo que fabrico un buen circuito de disparo con la fuente aislada y todo lo demas que me recomendaste) podria este modulo soportar la corriente pulsada con un ciclo de trabajo de 0.5 con maxima duracion del pulso de 2 milisegundos a corrientes de casi 100A? podria este modulo manejar este motor sin fallar?

tambien esta este otro modulo: CM200DY-12H IGBT POWER MODULE 200A 600V es mas bajo en voltaje y corriente que el otro pero aun asi podria tambien este otro llevar bien el motor?

Sinceramente no se como calcular el estress termico en el dispositivo dadas las corrientes, voltajes y perdidas y no se entonces que tan bien estan estos modulos para la aplicacion requerida...

Gracias por su valiosa colaboracion don Luis.

Saludos.
25/04/2012 #13


Buenos dias.

Ya que se complica todo, debido a que el modulo original es darlington, entonces pense que la mejor opcion seria conseguir un modulo darlington y asi me evito conseguir la fuente aislada y tener que construir el circuito de disparo, para esto estuve viendo el 1DI300ZN-120 de Fuji, este es darlington de 300A en 1200 voltios, por cierto muy barato segun estuve viendo este podria funcionar tan solo con conectarlo al disparo del modulo original, la hoja de datos no esta muy clara pero eso es lo que me parece. Don Luis usted cree que el disparo de 2 voltios pueda saturar este modulo? y acaso este no requiere de voltaje negativo en la base?

Gracias y saludos.
25/04/2012 #14
Moderador

Avatar de Luis Eduardo Sánchez

Hola Randall

Segun la ficha tecnica para una corriente de 180 amps estaríamos en ese rango de los 2 voltios, lo único que hay que tener cuidado es con la corriente de base que podría llegar a 4 amps. y acuerdate que con los transistores BJT, DARLINGTON, estos son saturados por corriente, caso contrario de los IGBT y Mosfet que son saturados por voltaje positivo y puestos en corte con voltaje negativo.De otro lado, mira en la etapa de disparos original del montacarga la corriente máxima de los transistores para asi saber si el Beta de este darlington sirve (recuerda la ganancia hfe en donde la corriente de la base se multiplica por este valor y asi obtienes la corriente que puedes obtener en el colector, que para este caso es de 75 con una corriente de Base de 4 amperios (2.5 v). Si puedes coloca una foto de esa etapa . Si esta etapa es robusta puedes colocar este transistor si problemas.

Mira esta otra opcion de darlington

http://www.alldatasheet.com/datashee.../KS624530.html

Saludos
26/04/2012 #15


Gracias don Luis.

voy a tomar tiempo para poner el multimetro en serie con el circuito de disparo del modulo en buen estado y asi ver cuanta corriente consume el modulo original y a ver si esta cerca de la corriente que va requerir el modulo nuevo.

La opcion que me recomendo del KS624530 300A 600V me parece muy buena pero encontre este otro KS621240 400A 1200V, tiene el mismo voltaje de saturacion y un rendimiento muy muy superior pero mas caro eso si aunque creo que voy a comprar ese porque es mas robusto.

Adjunto una foto de lo que creo son las etapas de control de los modulos, aqui se ven varios transistores de encapsulado TO-220, unos con disipador y otro no, voy a revisar cuales son en realidad.

Por otro lado me di cuenta que el modulo original es el Fuji ET439, pero no encuentro la hoja de datos de este por ningun lado, este es bastante caro y no lo pienso comprar en algunos sitios dice que es de 200A 600V y en otros sitios dicen que es 500A 600V, desearia saber de cuanto es en realidad para asi saber si mi reemplazo es mejor o peor... pero en fin parece que el fabricante guarda muy bien el secreto..

Saludos.
Imágenes Adjuntas
Tipo de Archivo: jpg drivers2.jpg (233,5 KB (Kilobytes), 60 visitas)
26/04/2012 #16


Ya pude localizar el transistor encargado de disparar el modulo, se trata de un 2SC2612 que soporta 3 amperios continuos y 6 amperios pulsado, el transistor es uno de los que aparece en la fotografia, esta sin disipador y quizas mejor si le pongo uno. segun veo este transistor soportaria alimentar muy bien al modulo ya que si el pico de corriente del motor no va alcanzar los 150 amperios entonces con una hfe de 75 no se necesita mas de 2 amperios cierto? Creo que el transistor esta bien entonces..

Ahora bien veo que el modulo que me recomendaste KS624530 300A 600V tiene un voltaje de base para saturacion maximo de 2.5 voltios, en cambio el que yo quiero usar KS621240 400A 1200V tiene un volatje de base maximo para saturacion de 3.5 voltios y el circuito del montacargas apenas da 2 voltios, estuve viendo las graficas y parece que necesito al menos 2.8 voltios para la saturacion consiguiendo 2.5A corriente de base.

Que me recomendaria don Luis usar el que menciono usted o usar el que quiero porque es mas robusto? si uso el que quiero debere modificar el circuito para que entregue 2.8 voltios? o con los 2 voltios aun lo saturaria?

Muchas gracias nuevamente por todo el apoyo.
27/04/2012 #17
Moderador

Avatar de Luis Eduardo Sánchez

Hola Randall

Perdon por no responder antes pero es que estuve un poco enfermo :(

Los motores a full carga nos dan algo asi como 80 amperios, el par de arranque de un motor de CC es + / - 1.3 a 1.5 veces la corriente de armadura, que para este motor seria como 110 amperios, pero como este motor es para la bomba hidraulica la corriente instantanea va ser la minima. Entonces usar el transistor que te recomiento es viable.

Si tu miras en la pagina 3 del datasheet del módulo para una corriente de 80 amperios, el voltaje minímo para saturar el transistor y obtener una corriente de base de 200mA es de 1.5 Voltios aprox, Entonces por ese lado no hay problema .

Ahora toca revisar es como adaptamos los cables de disparo del modulo viejo al nuevo modulo ya que se tienen 2 pines solamente(B y Bx)

Por mi lado voy a tratar de consultar con una amiga que vende modulos raros conseguir el pin-out del modulo ET439, además de que posiblemente ella te pueda vender el módulo recomendado.

Saludos
27/04/2012 #18


Gracias don Luis ojala se recupere pronto.

Sobre la corriente del motor, estuve midiendola conectando el motor directamente a la bateria, llega a los 75A sin carga, y en condiciones de maxima carga, levantando algo muy pesado o con la bateria muy descargada alcanza casi los 150A, anteriormente habia dicho que los fusibles son de 150A pero me equivoque, el rating de los fusibles es de 150V 200A, es decir, en las peores condiciones llegaria a 150A como maximo, es aun asi viable el uso del modulo? vi que que el modulo soporta a 48 voltios en un pulso de 1ms los 400A pero si es repetitivo podra soportar los 150A? aunque esos 150A que vi son a DC pura conectandola a la bateria, pulsado con ciclo de trabajo 50% deberia ser un poco menos no se, quizas los 110A que usted dice..

Sobre el pin out del ET439 se puede ver en el propio modulo, identifique tres diodos flywheel que aun funcionan y los quiero dejar, dos de potencia y uno mas pequeño que probablemente proteje la fuente del circuito de disparo, sera buena idea dejarlos? aparte de esto tiene tres treminales mas:

B: base, la desconecto y conecto a el modulo nuevo.
Bo: sin conexion
E: emisor auxiliar que tampoco se conecta.

Me quedaria sin resolver donde va Bx, que probablemente sea el equivalente a Bo que no se conecta..

El modulo que me recomendaste lo encontre en ebay por $60 incluido envio, claro no esta completemante nuevo pero me arriesgaria por lo barato que esta.

Gracias y saludos que se encuentre mejor.
27/04/2012 #19
Moderador

Avatar de Luis Eduardo Sánchez

Randall si en el modulo aparece el pinout por favor postealo para revisar bien su configuración , y con respecto si es viable el uso del módulo, tendriamos que revisar cuantas veces el sistema activa el transistor, debido .a que el pulso de corriente es muy corto (400 A 1ms), si no es muy repetitivo el ciclo lo podriamos usar pero si no tendriamos que revisar otro tipo de módulo.

Pero como tu dices que es la bomba hidraulica no habría problema.

Saludos
30/04/2012 #20


Hola,

Adjunto la foto con el pinout, el PK es catodo, el PA es anodo de los diodos, K y A son del tercer diodo.
C es el colector, E son los emisores, B base y Bo.

Planeo abrir el circuito del colector solamente y poner ahi el Colector del nuevo modulo, tambien cambio el cable de la base para la base del modulo nuevo, de esta manera no hay necesidad de quitar el modulo viejo, usaria cables cortos y del calibre adecuado con terminales de cobre.

Con respecto a la corriente de 400A en un solo pulso de 1ms, es el maximo que puede soportar el transistor a 48V y sin repeticion.. En el montacargas sera repetitivo a 2 ms (max) con maximo de 100A aproximadamente, pero en el peor de lo casos solamente, en condiciones regulares podria ser a solo 75A..
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Automatización, Electrónica industrial y de Potencia

En esta categoría se discuten temas relacionados con la automatización, la electrónica industrial y la instrumentación.

Cerrar
Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.