Haz una pregunta
  Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

20/04/2008 #1


Interferencias en circuitos digitales
Hola a todos los colegas.

Necesito de su valiosa ayuda

Mi problema es con una tarjeta tipo PLC que diseñe para controlar una lavadora industrial
la razón fue porque dicha lavadora ya no la pudieron reparar por que el técnico que distribuye las machinas en el ECUADOR dijo que tenia que cambiar la tarjeta de control que tenia un costo muy alto y que además solo había en ESTADOS UNIDOS y mas aun que dicha tarjeta no se podía conseguir.

La empresa dueña de la lavadora decidió no repararla.
Gracias a la electrónica de control con PIC yo le dije que podía volver a darle vida a la machina sin tanta inversión realizando yo mismo la tarjeta.
Hace 2 meses emprendí dicha tarea utilizando mis conocimientos de programación de PIC
Con buenos resultados ya tengo la tarjeta y el programa de control. La tarjeta trabaja con 12v para los reles mas 5v para el PIC 16F628A. La tarjeta y el programa funciona de maravilla asta con dos motores de 220v decidí montar todo el sistema con la tarjeta fuera de la maquina para probar que tal funciona antes de ensamblar completamente. el programa debe correr durante 45 minutos antes de que se apague automáticamente al principio funciona bien durante un corto tiempo (como 10 minutos) pero el problema es que al hacer todas las conexiones
(Válvulas de agua, desagüe, motores, embragues etc.) La tarjeta se apaga a medio camino o antes de finalizar el programa. Examinado la tarjeta y me di cuenta que faltaban unos diodos que deben ir en paralelo con la bovina de los reles, pero solo corrigió el problema temporalmente, ósea solo trabaja bien con la tarjeta fuera de la maquina, si la ensamblo dentro de la maquina empieza con el mismo problema y ya me a dañado 4 PIC (16f628a) el algo raro porque los PIC trabajan bien pero ya no me dejan programar ni borrar el programa.

Aquí es donde necesito de su ayuda según mi criterio pienso que es por que se filtra interferencia que generan los motores al conmutar o interfasar los contactos de los RELAYs
y esto talvez afecta la alimentación de los PIC e estado examinando y según me e dado cuenta es como un voltaje inverso que afecta al circuito de control .

La fuente que alimenta los PIC es totalmente estabilizada incluso e probado con una fuente de computador.

Al examinar detenidamente me e dado cuenta que la tarjeta deja de funcionar por que el voltaje de alimentación (que debe ser 5v para los PIC) se eleva por encima de lo normal (y no los genera la fuente) es como en una milésima de segundo pero eso hace que los PIC dejen de funcionar y con esto todo el sistema. ¿Cual puede ser el problema y como lo corrijo? Es mi pregunta que la dejo a consideración de ustedes esperando su ayuda.

De antemano muchas gracias.

20/04/2008 #2
Moderador general

Avatar de Fogonazo

Le colocaste la red de Snubber a los contactos de los relees ?
20/04/2008 #3


no se que es explicame
20/04/2008 #4
Moderador general

Avatar de Fogonazo

La red de Snubber disipa la energía (Chispa) que se genera en la apertura de los contactos eléctricos, protege los contactos y reduce las interferencias electromagnéticas.
Es de vital importancia si los contactos de los relees manejan cargas inductivas (Motores, Solenoides, Electrovalvulas)

Como colocar una red de protección snubber
Fabricar circuito antichispas para 220Vca
21/04/2008 #5


muchas gracias boy a probar con eso y luego te cuento

una pregunta mas ¿servira de algo si pongo un varistor?

si alguien mas puede aportar con esto estare muy agradecido.
21/04/2008 #6
Moderador general

Avatar de Fogonazo

El varistor es para proteger lo que viene "Detras", se coloca a la entrada del elemento que quieres proteger y tiende a ponerce en cortocircuito ante reiterados ciclos de sobretension.
Para tu aplicacion me parece mejor la red de Snubber.
21/04/2008 #7


gracias si tienes algun circuito con valores de componentes seria muy valioso

nuevamente digo que el circuito controla motores de 230v mas solenoides o bovinas para el desague las valbulas electricas todo con 230v solo los embragues de los motores funcionan con 12v cc de alto amperaje.
21/04/2008 #8
Moderador general

Avatar de Fogonazo

Un capacitor de poliester de 100nF 630V de aislacion en serie con una resistencia de 47 Ohms 1W y esta serie en paralelo con los contactos es un buen comienzo.
06/05/2008 #9


hola fonogazo sigo teniendo problemas aun despues de aber colocado la red de snubber me refiero al circuito de control que estoy probando. por un corto tiempo se normalizo pero luego siguio con el mismo problema ¿hay otras forma para poder eliminar dicha interferencia o trancitorios que afectan al PIC?
06/05/2008 #10
Moderador general

Avatar de Fogonazo

Habría que hacer investigación sobre "Por donde viene la interferencia"

Los consejos que se me ocurren son
Manejar las bobinas de las electroválvulas y/o motores con triac y optoaisladores que conmuten en punto "0" (MOC3041, MOC3043)
Blindar la placa del micro Incluida la fuente de alimentación de este y este blindaje puesto a tierra efectiva (Jabalina)
Las fuentes de PC son bastante ruidosas "eléctricamente hablando", yo usaría un transformador y un filtro de línea

Esto como para empezar, lo bueno es que por lo menos durante un cierto tiempo te anduvo, analiza si cuando comenzó a fallar nuevamente no coincidió con algún cambio de condición, cambio de alguna válvula, ¿?¿?¿?

Esto seria como para empezar, ve probando a ver que ocurre
07/05/2008 #11


tendra algo que ver con que no estoy utilizando oscilador externo sino el interno que posee el mismo PIC16F628A? he leido que colocando un condensador ceramico en paralelo con la entrada de voltaje de la alimentacion del PIC elimina las frecuencias altas ¿servira de algo?

Gracias por tu valiosa ayuda voy a hacer todo lo que sea para encontrar el problema
espero me acompañes en este recorrido te estaré comentando……

Igualmente a todos los amigos del foro que quieran aportar con su ayuda esta bien venida
Gracias…
07/05/2008 #12
Moderador general

Avatar de Fogonazo

En todo circuito digital es importante colocar un capacitor ceramico de unos 100nF entre el (+) y el (-) de la alimentacion, lo mas cercano al integrado que sea posible, incluso no es extraño ver este capacitor sobre el propio integrado para ahorrar distancias
Tambien es conveniente filtrar las entradas que tengas al PIC, de acuerdo al tipo de señal que resiban
07/05/2008 #13


Hola, ademas de los excelentes consejos de fogonazo tambien tendrias que solucionar el problema con la fuente de alimentacion, si sabes que tenes picos de tension por encima de los 5v o talvez por debajo puede ser que el pic se resetee o se queme. Yo propondria un conversor dc/dc como el LM2575

Saludos
07/05/2008 #14

Avatar de Ardogan

Estás usando un regulador (7805, LM317, o cualquier otro) para los 5V del pic?
10/05/2008 #15


gracias power y ardogan por sus comentarios pero e comprobado que el problema no esta en la fuente que alimenta al PIC, o como se puede explicar que ahora con la red snubber trabaja mucho mas tiempo mientras el circuito de control esta alejado del circuito de potencia pero si coloco el circuito dentro de la maquina junto al circuito de potencia que maneja cargas de alto voltaje empiesa con el problema.
pero boy a probar con todo lo que este al alcanse de mis manos. aunque ya lo e echo con el 7805 Y LM317 y otros mas.


para fonogazo, ayer ise una prueba mas, colocando el condensador 104 en paralelo a la alimentacion del PIC y coloque otra red snubber que abia olvidado colocar en los relays de potencia, y te cuento que como ya lo dije antes funciono casi normal a esepcion de que al finalizar el programa como que se quedo pegado funcionando el ultimo motor aunque el programa ya dio fin, baje el breque para poder parar el motor aunque esta prueba la ise con el circuito fuera de la maquina pero no se si al ensamblarla dentro trajaje igual.
luego te cuento. gracias.
26/05/2008 #16


Interferencias en circuitos digitales
Gracias por tu valiosa ayuda fonogaso ya conseguí eliminar el problema del mal funcionamiento que tenia el circuito de control que diseñe a una lavadora industrial
El único problema que tengo ahora es que la red snubber que coloque a uno de los reles que conmuta al motor grande conduce cuando los contactos se abren, o sea cuando el motor se debe apagar se queda prendido porque la red snubber conduce, (tube que quitar dicha red) y no se porque razón si la del motor pequeño funciona muy bien
Igual me paso con la red snubber que coloque a el relay que maneja la electro válvula
De lo demás todo esta muy bien gracias.
26/05/2008 #17
Moderador general

Avatar de Fogonazo

Primero que nada me alegro que te funcionara la lavadora.

Verifica que el capacitor de la red que te esta fallando no este en corto y tambien el valor de la resistencia.
29/05/2008 #18


pienso que no debe estar en corto porque cuando conduce, deconecto la red y el motor se apaga, vuelbo a conestar la red snubber y si estubiera en corto volveria a encender el motor pero ya no lo ase.
el condensador es de 100nF 600v y la resistencia 47 homios 1/2 w.
29/05/2008 #19
Moderador general

Avatar de Fogonazo

¿ Y no estarás realimentando la bobina del relee con la red de snubber ?
O sea, mal conectada

Si el capacitor y la resistencia están sanos y son del valor correcto, no son capaces de entregar la corriente que necesita el motor para funcionar
30/05/2008 #20


eso mismo pense yo, boy a analizar que pasa
luego te cuento

gracias.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Automatización, Electrónica industrial y de Potencia

En esta categoría se discuten temas relacionados con la automatización, la electrónica industrial y la instrumentación.

Cerrar
Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.