Haz una pregunta
  Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

19/07/2014 #1


Posible ruido magnetico por líneas de fuerza
Mi problema que tengo es que me decidí a mejorar un proyecto de control
Bueno explicare brevemente un amigo se dedica al pintado en agua esa técnica no la explicare por que no es tema
Mi amigo compro una tina para pintar en agua esa tina no tiene nada de maravilloso es simple control.

su funcionamiento es sencillo calienta el agua con resistencias que trabajan a 220v de unos 2500w
su amperaje es elevado y su encendido es con un contactor de potencia
y tiene un bomba de agua que es para la recirculación de agua también accionada por un contactor de potencia este accionado por una perilla selectora
y un tiempo de 2min que cuando termina acciona una alarma o buzzer.

bueno el contactor de las resistencias es accionado con un dispositivo que mide la temperatura con un termopar tipo j
a cierta temperatura se paran las resistencias y si la temperatura baja se acciona nuevamente

El tiempo es controlado con un timer o cronometro que pasado el tiempo establecido suena el buzzer.

el gabinete es una caja metálica de 40 altura x 30 de ancho x 25 de fondo que tiene una puerta que es la tapa principal donde ba montados los controles (timer y el termostato electrónico ) las perillas y las luces testigo esta se abre por si hay que hacer una reparación

el panel queda algo así
makina.jpg

todo esto va metido en un gabinete metálico o llamado panel de control con sus perillas que accionan las resistencias , la bomba de agua , el timer , y el encendido general y cada uno con su luz testigo o luz de encendido

el problema viene que el timer y el termómetro digital son caros y eleva el costo de producir la maquina y el costo de venta

decido hacer un circuito que remplazaría a estos con un arduino y un display lcd 16x2 todo de maravilla ya que el display al inicio mostraría la pagina de mi amigo y su nombre de empresa la temperatura de corte funcionaba muy bien y el timer también

Me decidí a accionar las resistencias con un relay que controla al contactor de potencia
El buzzer también es controlado con un relay que manda accionar un buzzer que ya venden trabaja a 24V CA o CC
y la bomba de agua es accionada atreves de una perrilla selectora de dos posiciones on off y esta asu ves acciona el contactor
el circuito funciona bien y acciona los relay en tiempo y forma

Mi panel de control no lleva el timer y ni el termómetro ya que los e sustituido por el arduino y el display 16x2

makina 5.png

Me decido a montar mi proyecto en el gabinete o panel de control y el display queda situado donde van los aparatos que sustituí y el circuito detrás del display sujetado por el mismo display atornillado a un acrílico y el acrílico al gabinete

mientras es estado del la perilla sea alto (5V ) enciendo las resistencias (rele )siempre y cuando sea menor a x grados
y si es mayor a x grados apago las resistencias (rele )

Para el funcionamiento de timer : mientras la perilla sea alto (5V ) pasa un conteo de x minutos y mando a encender el timer (rele )

el esquema de este es el sig para los dos casos

proyecto.png

cuenta con una fuente de transformador, puente rectificador y reguladores

el circuito funciona bien fuera del gabinete lo probé accionando unos focos 50w incandescentes o bombillas
Tambien accionando los contactores

el verdadero problema es que si meto el circuito al gabinete y acciono un contactor por ejemplo la de la bomba que esta va directo a una perilla el display muestra caracteres raros o cuadritos llenos que me sugieren que sea el problema ...
19/07/2014 #2

Avatar de Scooter

Es lo que tiene el mudo real. En la mesa con dos led y una pila funciona todo, en situación real con corrientes reales etc...no todo funciona.

Se ha tratado muchas veces en el foro, el proceso es complicado:

Mejorar la fuente
Poner filtros de red
Poner varistores
Usar optoacopladores
Apantallar
Bajar la impedancia de las lineas lo que se pueda

Etc

El orden no es necesariamente ese y puede que baste con solo una cosa o no baste con todas ellas....
19/07/2014 #3
Moderador

Avatar de Dano

Agrego a lo de Scooter:

Separar las lineas de potencia de las de control.
Ordenar y ser muy prolijo en el armado.

No hay una solución única, si tenes osciloscopio se facilita en gran medida la búsqueda de las fallas.
19/07/2014 #4

Avatar de torres.electronico

sumo tambien, que seria ideal implementar gnd como señal de activacion y no los 5vcc, osea, en ves de logica postiva, yo implementaria logica negativa...
Otra cosa es que a la salida de tu arduino, si es mas de un relay, podrias usar para desacoplar un ULN28XX o bien, si es tan solo un relay, un foto transitor del tipo 4n25 + ese transistor que estas usando. osea, tendrias una configuracion darlington para extitar la bobina del relay...ahora...note que conectaste el relay a 5v...es de 5vcc ese relay?
Yo en tu caso, dispararia el contactor con un triac y como auxiliar de disparo del triac y desacoplo, implementaria un MOCXXXX con deteccion por cruce por cero. Con eso reducimos un poco el ruido del contactor y el relay...
Otra cosa que quizas te guste aun mas... puedes sustituir las resistencias por un sencillo y economico transductor de sonido.. Con eso no solo vas a bajar el consumo considerablemente para calentar el agua, si no que sera mucho mas rapido el proceso. Te muestro una imagen de como se implementa:


Despues quiero pensar que nos vas a incluir en el presupuesto para pagarnos por la ayuda que le dimos a tu amigo a que lucre con esta maquinita
saludos
Imágenes Adjuntas
Tipo de Archivo: png ultrasonido.png (57,2 KB (Kilobytes), 59 visitas)
19/07/2014 #5

Avatar de ecotronico

hola a todos y a pepex:

tal comentan, el problema puede ser por muchas causas.
pero tal como dice el título del tema , quiero agregar que sí podría ser ruido que llega a la fuente cuando se acciona el contactor.

sugiero agregar una red snubber en paralelo a la bobina del contactor, porque debería quitar el efecto de la conmutación brusca en la bobina.
puede ser resistor de 47ohm (o menos),1/2W en serie con capacitor .47uF,630V
Red SNUBBER para varias cargas Inductivas
20/07/2014 #6


muchas gracias por todas las sugerencias pero fata algo que talves no lo tomaron en cuenta tengo un contactor que es accionado mecanicamente con una palanca selectora y esto a su ves acciona una bomba de agua mi circuito no tiene nada que ver con ese contactor a su salida de dicho contactor presanta la falla mi circuito
20/07/2014 #7

Avatar de Scooter

Ya te hemos dicho que es una cosa totalmente normal.
Para probar mis circuitos los conectaba y al lado suyo me hinchaba a hacer entrar y salir un contactor con un pulsador o con el cable con la mano, cuanto mas falso el contacto y mas chispas, mejor la prueba.
Tienes problemas de fuente de alimentación barata.
Lee mi hilo y ves probando mejorando la fuente y con varistores...
Si el contactor mueve una bomba mas ruido en la red.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Automatización, Electrónica industrial y de Potencia

En esta categoría se discuten temas relacionados con la automatización, la electrónica industrial y la instrumentación.

Cerrar
Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.