Haz una pregunta
  Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

30/05/2014 #21

Avatar de chclau

Por lo poco que vi en absolutamente todos los casos usan componentes adicionales para los buck, tales como transistores en configuracion push-pull entre el IC y el Mosfet. Trata de leer con mas atencion. O colga aqui el diagrama que segun vos funciona conectado directamente al Mosfet, de alguno de esos links.
30/05/2014 #22


Hola a todos , caro Don juanma2468 , lo circuito que te propongo para mi es lo meo mas correcto de polarizar un transistor MosFet de modo el andar como chave y fornir una conponente de +24 Voltios conmutados para sener filtrado por lo filtro passa bajos (L1 Y C2 ) de modo que lo nivel medio desa conmutación sea los +12 Voltios tan deseados .
Devemos recordar que para cerriar lo canal Dreno y Sourse un transistor MosFet tipo canal "N" devemos aplicar un VGS positivo , entonses como hacer eso con un canal "N" en seguidor de Sourse ? si lo Gate tiene que sener "VGS" mas elevado que lo proprio Sourse ?? , Dai mi propuesta en enplear un transistor MosFet tipo canal "P" donde cerriamos su canal Dreno y Sourse aplicando un VGS "negativo" entre Gate y Sourse , o sea lo Sourse es mas positivo en relación a su Gate cerriando lo canal Dreno y Sourse , asi fornindo +24 Voltios conmutado a lo filtro passa bajos. No entiendo como en la simulación si puede obtener +25,36Voltios en la salida con lo circuito alimentado con 24 Voltios si esa configuración es "Step Donw" ?
? Quízaz canbiar lo CI control PWM por un TL494 no sea una buena idea ?
? Que tal armar un prototipo y medir con auxilio de un osciloscopio lo que realmente se passa ?
Att.
Daniel Lopes.
31/05/2014 #23

Avatar de juanma2468

Palurdo:
Por lo q he visto la salida del 3842 no es colector abierto... eso es un problema para el bootstrap porque la puerta no va a poder subir mas de vcc. O haces un doble buffer inversor o interpones un buffer colector abierto no inversor como el de la siguiente imagen:

Podrias explicarme como sería el uso de este circuito, como lo implemento en mi esquema?? Veo cual es el problema, la tensión Vgs no es lo suficientemente elevada como para accionar el MOSFET.
01/06/2014 #24

Avatar de palurdo

En tu esquema, desde la salida del integrado hacia el circuito de bootstrap, cortas el cable, y la parte que va desde el integrado (la patilla out) la conectas al emisor del transistor, y la que va hacia el bootstrap, la conectas al colector. cuando el transistor se encuentra cortado, en el emisor hay 24V, en la base hay 20V, luego entre base y emisor hay -4V, y al mosfet le llega el pulso alto desde la resistencia que conecta el condensador del bootstrap con la puerta. Cuando la salida del integrado está a 0, el emisor del transistor está a 0V y la base pasa de 20V a 0,7V, el transistor conduce y el colector pasa a valer algo cercano a 0, por lo que el mosfet se corta.
01/06/2014 #25

Avatar de juanma2468

Hola de nuevo y gracias por los comentarios, estuve leyendo bastante e investigando, y realice algunos cambios en mis componentes para no tener el problema de la falta de tensión Vgs, además agregue un pequeño zener de 18V en el UC3842 para que la salida PWM no sea mayor a 20V y me queme el Gate del MOSFET. Para poder sensar la tensión de salida tuve que realizar una realimentación a travez de un PC123 en forma óptica.
Lo construí en mi protoboard, la tensión que entrega es cercana a la que yo quiero 13,2V, pero sigo teniendo el problema de que el MOSFET se calienta y la carga que estoy utilizando es una resistencia de 68 ohms, lo cual no es demaciada corriente como para que caliente tanto, ademas mire con el osciloscopio entre las patas Drain y Source y no observo la conmutación del MOSFET, simplemente visualizo una continua, pero los pulsos del PWM si están presentes en el Gate, la verdad es que no se que pueda ser, alguna idea?? Sugerencias del circuito nuevo?? Avisenme si quieren que suba imagenes de las señales que observo con el osciloscopio. Desde ya muchas gracias.
Imágenes Adjuntas
Tipo de Archivo: jpg buck modificado.JPG (35,9 KB (Kilobytes), 41 visitas)
02/06/2014 #26

Avatar de chclau

Pero eso ya ni es una fuente buck, en una fuente buck, cuando el elemento de paso esta cerrado la carga y la bobina reciben energia de la tension de entrada, cuando el elemento de paso se abre la carga recibe energia de la bobina solamente. Lo que hiciste, me parece, no es una fuente buck.
02/06/2014 #27

Avatar de ecotronico

juanma2468 dijo: Ver Mensaje
Podrias explicarme como sería el uso de este circuito, como lo implemento en mi esquema?? Veo cual es el problema, la tensión Vgs no es lo suficientemente elevada como para accionar el MOSFET.
hola a todos!

juanma2468:

veo que ya comprobaste que el problema es tu refererencia para el disparo.
la tensión Vgs está "flotando" y por eso el MOSFET no satura.
da ahí que él se calienta y caen 10V.

en mi opinión, no encuentro sentido usar circuitos auxliares para el disparo, porque el circuito completo queda más caro al introducir más componentes.
mejor usabas un 7812 y resolvías todo el problema de reducir la tensión, pues tu potencia es pequeña.

te repito que no tengo mucha experiencia con este integrado, pero mi sugerencia ahora es que intentes esto:
cambia de lugar y sentido el MOSFET de potencia y tal vez consigas dispararlo tranquilamente con tu integrado (ver adjunto).
digo "tal vez", porque mi única duda es la polaridad que quedaría en el GATE, pues no tengo como simular el UC3842.
solamente hice una simulación simple con tus datos iniciales, cambiando el interruptor (MOSFET) de lugar y funciona.
Imágenes Adjuntas
Tipo de Archivo: png Buck2.png (119,6 KB (Kilobytes), 34 visitas)
02/06/2014 #28

Avatar de J2C

En mi opinión eso ahora es cualquier cosa (por no decir cualquier verdura/fruta), ya que la salida no tiene ninguna referencia con la entrada y tampoco se encuentra aislada de la misma .

Cual seria la masa/tierra de la salida????, ni el "+" ni el "-" de la entrada !!!!.


Saludos, JuanKa.-
02/06/2014 #29

Avatar de ecotronico

hola J2C

tienes razón con respecto a la referencia para realimentar la tensión..
ni lo consideré.

pero créeme que aún posee referencia, que es el positivo de la fuente.
el inductor es prácticamente tensión cero.

y opino que es más fácil crear un circuito auxiliar para la referencia que para el disparo...
tal vez un optoacoplador lo resuelva.
02/06/2014 #30

Avatar de juanma2468

Gracias a todos nuevamente por responder. Primero metalmetropolis, si te fijas bien, el ultimo circuito que postie, es igual al que vos postiaste, solo que mi transistor esta parado y el tuyo acostado. Por otro lado, J2C, es cierto que se pierde la referencia de masa, pero la asislación se encuentra en vez de en +V en la masa. Como ya no es posible realimentar por medio de un divisor resistivo la tensión de salida, es por eso que en mi nuevo circuito propongo un optoacoplador como realimentación, de esa manera me desligo de la referencia de salida. Mi inspiración del cambio, la saque de aqui, chequenlo a ver que opinan.
http://ludens.cl/Electron/latsup/latsup.html
02/06/2014 #31

Avatar de J2C

Juanma246

juanma2468 dijo: Ver Mensaje
.... Mi inspiración del cambio, la saque de aqui, chequenlo a ver que opinan.
http://ludens.cl/Electron/latsup/latsup.html
Si bien dices que has sacado la inspiración del cambio de la página de Manfred Mornhinweg, realmente has creado una mezcla total.

Manfred no ha necesitado OptoAcoplador alguno para tomar la muestra y estabilizar el circuito que por otra parte esta trabajando con tensiones más altas y como si esto fuera poco el podría llegar a utilizar el "+" de su esquema como referencia que ya que no posee ningún componente en serie con el mismo, salvo el tema que rectifica los 220Vca de la línea de distribución eléctrica.




Metalmetropolis
metalmetropolis dijo: Ver Mensaje
.... el inductor es prácticamente tensión cero. ....
El inductor de una fuente switching aunque no tenga caída de tensión en Continua cambia radicalmente el diseño pues cumple cierta función especifica.



Pero bueno, en los diseños es cuestión del gusto de cada diseñador, hacer las cosas más simples o que solo las entienda el mismo y Manfred es una persona muy particular por que da las explicaciones de como ha hecho cada cosa, en otros temas algún forista le ha preguntado por e-Milio y le ha respondido con excelentes aclaraciones.



Saludos, JuanKa.-
02/06/2014 #32

Avatar de juanma2468

Pues bien, no entiendo cual es la diferencia entre el esquema de Manfred (a parte de que trabaja con mayor tensión) en cuanto a lo que es la configuración del MOSFET puesto a masa y no en el +V. Por otro lado, solo quise tomar la idea de él, luego implemente una realimentación optoacoplada porque me resultó más sencillo de verlo por ese lado, o está mal haberlo hecho así?? Pero bueno, igual más allá de la realimentación y de si trabaja con más o menos tensión, no comprendo porque el MOSFET cuando lo miro con el osciloscopio entre DS lo veo una conmutación, solo una continua, de ahí que calienta. Al Gate le llega bien el pulso, lo probe al MOSFET fuera del circuito utilizandolo como llave para accionar un motor y funciona sin problema, la caida de tensión es practicamente 0 y no calienta. Ya no se más que puedo hacer.... agradesco a J2C, chclau, pelurdo, Daniel Lopez y metalmetropolis por sus comentarios, habrá que segir buscando.
02/06/2014 #33

Avatar de chclau

Ahora entiendo mejor de donde viene la idea. A primera vista y despues de leer la explicacion en el link e pusiste pareceria tener su logica... pero no me termina de convencer.... Quiza si movieras la bobina a la rama de abajo podria andar, porque asi como esta cuando el FET conduce tenderia a cortocircuitar el negativo de la salida con el de la entrada.

La unica manera de que esto ande, si es que anda, es que la bobina sea la que separa las dos tierras. Asi como en el diseño convencional, es la bobina la que separa la tension de entrada de la de salida.

Fijate que en el diseño que pusiste tambien es asi, la bobina en la rama de abajo.
02/06/2014 #34

Avatar de J2C

Juanma2468
juanma2468 dijo: Ver Mensaje
.... Pero bueno, igual más allá de la realimentación y de si trabaja con más o menos tensión, no comprendo porque el MOSFET cuando lo miro con el osciloscopio entre DS lo veo una conmutación, solo una continua, de ahí que calienta. Al Gate le llega bien el pulso, lo probe al MOSFET fuera del circuito utilizandolo como llave para accionar un motor y funciona sin problema, ....
Si el MosFet calienta y solo cae continua es por que no llega a conmutar totalmente sus estados, aún esta dentro de la zona lineal del mismo.

O el pulso no tiene la suficiente amplitud o le falta capacidad de corriente para superar el Qg de ese MosFet.




Saludos, JuanKa.-
02/06/2014 #35

Avatar de juanma2468

Pues hoy volvi a medir con el osciloscopio, en el esquema que postie tengo una lijera diferencia con lo que arme en la protoboard, en la proto a la salida del PWM coloque la R de 22K a masa y seguido la R de 39 ohms. Midiendo del lado de la salida de PWM tengo un pulso cuadrado de aproximadamente 15V, del otro lado de la R de 39 ohms tengo una continua de 1,2V (no tengo idea por que). Si las invierto, o sea a la salida del PWM coloco en serie la R de 39 ohms y luego la de 22K a masa, casi no funciona el convertidor, a la salida tengo menos de 2V. Si la R de 39 ohms la bajo a 10 ohms (fue lo que probe) o lo conecto directo al gate la salida del PWM no anda tampoco, como si se muriera todo. Voy a probar lo que me propusieron de cambiar de lugar la bobina, tendria sentido lo que comentan, desde ya gracias, y cuando tenga novedades publico. A por cierto tambien le mande un mail a Manfred a ver que me dice.
---------------------------------Actualizo--------------------------------------------------------------------
Pues les traigo buenas noticias . Ya he podido hacer andar el conversor DC-DC buck y anda de maravillas, procedo a explicar los fallos que encontre. Primero que nada cambié de lugar el inductor como me habían dicho, pero aun seguía haciendo lo mismo que antes, por lo que deduje que el inductor no era, igual lo deje en esa posición. Luego reemplace la R de 39 ohms por una de 10 ohms y ahi la salida de tensión se moria a unos pocos volts (aproximadamente unos 4V), y además se caia la tensión del UC3842, asi que volvi a poner la R de 39 ohms y la tensión de salida volvía a los 13,2V pero el MOSFET calentaba. Luego de probar varias veces entre la R de 39 y la R de 10 ohms, noté con el osciloscopio que cuando medía los pulsos en la pata del gate con la R de 39 no veía nada, solo un pequeño valor de DC, lo cual era raro. Cuando medía con la R de 10 a causa de la caída de tensión en el UC los pulsos que veía eran practicamente imperseptibles, pero algo había y era distinto de una DC . Aplicando un poco de lógica llegué a la conclusión de que la R de 39 ohms debía estar defectuosa, la medí con un tester y para mi sorpresa la resistencia aparentemente nueva, estaba abierta (la puteada que mande llegó a la china) . Bueno un problema menos. Ahora sabiendo que con la R de 10 ohms algo ocurría que me desbarataba todo el circuito, pensé, bueno tal ves, los picos de corriente son elevados (hay una bobina) y hace que las tensiones se caigan . Asi que coloque unos capacitores electrolíticos en la parte de los 24V y en paralelo con el zener de 18V y ...................... GUALA!!!!!!!!!!!!!! todo funcionaba de maravillas. El circuito lo someti a una carga tal que tuviera que entregar 2A constantes durante unos 30 segundos mas o menos, el MOSFET ni se mosquio , no calento para nada, no le seguí dando rosca porque la fuente con la que lo alimento no daba más ya que utiliza un LM317 plástico, pero cuando pueda lo voy a probar con una batería de auto y debería poder sacarle unos 5A por lo menos. Adjunto el esquema final que utilicé, quizas habría que afinar un poco los valores de algunos componentes, pero bueno, la base está.
Desde ya quiero agradecer mucho la ayuda que me han brindado J2C, chclau, pelurdo, Daniel Lopez y metalmetropolis . Gracias a ustedes pude completar este desafio que me había propuesto. Como recompensa les dejo el esquema para aquel que lo quiera tener, desde ya muchas gracias nuevamente, saludos.
Imágenes Adjuntas
Tipo de Archivo: jpg Buck final.JPG (38,1 KB (Kilobytes), 48 visitas)
04/06/2014 #36

Avatar de juanma2468

Hola gente, yo de nuevo, queria consultarles si es que alguno de ustedes tiene algun circuito que con un zener, un transistor y resistencias active un rele cuando la salida supere un determinado valor. Con esto lo que quiero hacer es con una minima cantidad de componentes lograr una protección por sobretensión a la salida, tal que si por algun motivo el MOSFET se pusiera en corto, la protección saltara y me abriera la tensión de salida para no quemar lo que este del otro lado. Propongo con esos componentes porque la idea es minimizar lo más posible el circuito, se que con un simple comparador eso es una pavada, pero no quisiera meter otro IC más, o tal vez tengan otra idea más sencilla y eficiente que la que propongo, nuevamente gracias.

PD: Tensión máxima permitida 14 V. Ah y por cierto alguno sabe cuanto puede consumir en corriente un estereo en promedio y en valor pico?

Moderador: perdon no me di cuenta y cree otro msj sin querer, borrame esto que escribo y lo otro ponemelo en mi anterior msj, mil disculpas, gracias =).
05/06/2014 #37

Avatar de chclau

Una manera de hacer lo que buscas es con una proteccion crowbar, que en esencia consiste en hacer volar un fusible en serie ante la condicion de sobretension
05/06/2014 #38

Avatar de juanma2468

chclau dijo:
Una manera de hacer lo que buscas es con una proteccion crowbar, que en esencia consiste en hacer volar un fusible en serie ante la condicion de sobretension
Gracias por el dato, no sabia como se llamaba, dejo esta página donde en el segundo post se menciona un crowbar activo, aunque en mi caso, para alcanzar la tensión deseada utilizaría 2 diodos 1N4148 en serie para obtener los 14V. Gracias.
http://www.edaboard.com/thread181493.html
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Automatización, Electrónica industrial y de Potencia

En esta categoría se discuten temas relacionados con la automatización, la electrónica industrial y la instrumentación.

Cerrar
Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.