Haz una pregunta
  Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

09/07/2012 #21

Avatar de Gudino Roberto duberlin

jcristhian_1 dijo: Ver Mensaje
cuando usas mosfet de canal p para el lado alto del puente no es necesario tener fuentes flotantes para los mosfet superiores, fijate en el sigiuente circuito:

http://www.forosdeelectronica.com/at...8&d=1304890729

los gates mosfet de ambos lados se atacan con la misma fuente.
Hola Amigo, bueno en ese esquema hay un detalle que no me cierra. Pues ambos gates de la misma rama comparten el divisor resistivo de 1K y 10K, pues cuando el transistor mosfet de canal P sea bloqueado al mismo le costara llegar al corte pues su gate nunca alcanza el valor de 12V.
Ademas no puede aplicarse ese metodo de polarizacion, si la tension de alimentacion es de 52V. como el caso de ntro. amigo, a menos que el transistor soporte una tension Vgs de 52V.

---------- Actualizado después de 3 minutos ----------

caifan dijo: Ver Mensaje
buenas tardes, aun sigo sin conseguir hacer funcionar el pwm con el puente h a mosfets, asi que empece por meterle pwm al mosfet que me causa problemas, el irf9540 que es de los mosfet que utilizo en la rama superior del puente h, no entiendo por que la señal del pwm no es la misma en la salida, hice un circuito para simularlo y paso lo mismo, en el circuito se ve la señal de salida muy parecida a la que obtengo realmente, aqui les adjunto el circuito, espero lo puedan simular y ayudarme con el diseño, no se que estoy haciendo mal

---------- Actualizado después de 7 minutos ----------

perdon, la simulacion es en isis de proteus v6.4
Hola amigo, no tengo esa version de Proteus, pero en tus pruebas tienes carga conectada en el puente?. Si es asi, de que forma funciona?.
10/07/2012 #22


Oh, perdeon, aqui esta la simulacion en isis version 7.

por cierto, el circuito que use no es ese, es parecido, el circuito que yo utilice es este:

http://www.todorobot.com.ar/document...dge-mosfet.pdf

funciona, pero al meterle pwm no responde como deberia
10/07/2012 #23


Gudino Roberto duberlin dijo: Ver Mensaje
en un mosfet canal N, debe conmutar entre 0V. y max. 20V.
En cambio en un mosfet canal P la tension Vgs. debe conmutar entre 32V. y 52V.(en tu caso por utilizar una fuente de 52V.), respecto de GND.
Amigo, he encontrado unos "drives" para las compuertas de los dos tipos de mosfets, simule el circuito y cuando vi los voltajes que estos drives meten a las compuertas recorde esta publicacion que escriviste, y me surgio una gran duda, por que en los mosfet N se debe conmutar la compuerta entre 0 y 20 V ???? y por que en los mosfets P se debe conmutar entre 32 y 50 V ????

para el mosfet N lo entiendo, pero por que el mosfet P tiene que ser conmutado entre estos voltajes y no entre 0 y 20 volts ????

aqui dejo la simulacion que hice, esta en isis de proteus v7

Gracias !!!!!
Archivos Adjuntos
Tipo de Archivo: rar Drives para MOSFETs.rar (15,9 KB (Kilobytes), 90 visitas)
10/07/2012 #24

Avatar de Gudino Roberto duberlin

Hola Amigo caifan, respondiendo a tu pregunta, por empezar los transistores mosfet canal N y P son complementarios, por lo tanto trabajan de manera diferente e inversa podria decirse.
En uno de tipo P la tension Vgs. medida respecto de Vdd sera de 0v. y -20v. en tu caso.
A no confundirse como veras la tension Vgs. en un canal N se toma referencia respecto de Vss, en cambio en un canal P se toma referencia respecto a Vdd.
10/07/2012 #25


OOOO ya veo, entonces cuando puse un IRF9540 ( canal p 52 volts en source ) como interruptor y en la compuerta ponia 0 volts, éste se quemaba por que en realidad el transistor veia un VGS de 52 volts.

Gracias ahora entiendo por que he quemado ya varios mosfets. espero que el circuito de drivers para mosfets le sirva a alguien mas, ya que ami me costaron varios mosfets entener su funcionamiento.

---------- Actualizado después de 26 minutos ----------

Bueno, he logrado una simulacion funcional del puente H a Mosfets con pwm a 20 khz que nesecito, por el momento no tengo todo el material nesesario para hacerlo fisicamente, me faltan algunos transistores para armar los drives para los gate de los mosfets. aqui les dejo mi simulacion esta en isis de proteus V7.0
Archivos Adjuntos
Tipo de Archivo: rar PWM IRF9540.rar (68,7 KB (Kilobytes), 70 visitas)
11/07/2012 #26

Avatar de Gudino Roberto duberlin

Hola Amigo segun comentas "la compuerta ponia 0 volts, éste se quemaba por que en realidad el transistor veia un VGS de 52 volts." asi es, el origen del problema! Exitos.-
16/07/2012 #27


Hola ya mande comprar los transistores que me serviran para switchear los mosfets, pero ahora me surgio una nueva duda, como aun no tengo los transistores no he podido armarlo y me pregunto, en el drive para el mosfet P los 52 volts entran directamente en el colector del 2n2222 y sale por el emisor hacia la compuerta del mosfet CH-P, esto quemaria el transistor ????

---------- Actualizado después de 2 minutos ----------

este es circuito de los drive que menciono
Imágenes Adjuntas
Tipo de Archivo: bmp driver.bmp (88,8 KB (Kilobytes), 79 visitas)
26/07/2012 #28


Bueno, despues de buscar mas opciones hice un nuevo diseño de disparo para los mosfets, lo simule y lo arme fisicamente. Hasta el momento me ha funcionado bien ayer lo termine y lo puse en marcha, se me ocurrio utilizar el drive L293B para conmutar los mosfets de arriva para ello se me ocurrio poner en comun la fuente de alimentacion del L293B (9 volts) en comun con los 52 volts de potencia, de esta manera se manda a los mosfets pulsos de 0 a 9 volts de gate a source (52 vcd) de los mosfets canal P que estan en la parte alta.

la tierra de control esta en comun con la tierra del L293B pero la alimentacion del L293B esta en comun con la alimentacion del Puente H.

Chequenlo y califiquenlo, como les dije me esta funcionando de marabilla, lo revise con osciloscopio y la señal que le meto con un pic a 20 khz es la misma que obtengo en los bornes del motor pero a 50 volts.

diganme si omito algo o estoy haciendo algo mal, si es que todo esta en orden pues espero que le sirva a alguien mas.

gracias !!!!
Archivos Adjuntos
Tipo de Archivo: rar PWM IRF9540.rar (33,0 KB (Kilobytes), 83 visitas)
10/08/2012 #29


mmm, alguno de los que han descargado la simulacion podria darme su opinion ??????????
15/09/2012 #30


He simulado tu archivo, Caifan y me parece bastante bueno. La única cosa que no puedo comparar es debido a que utilizaste un micro del que no puedo opinar. De todas formas, enhorabuena y que tengas suerte.

Respecto de la tensión, no puedo decir nada nuevo ya que no dispongo de fuente de energía que entregue esa tensión, por lo demás parece correcto.

Saludos.
17/09/2012 #31


Gracias !!! el micro solo simula una señal a la que debo acoplar el pwm.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Automatización, Electrónica industrial y de Potencia

En esta categoría se discuten temas relacionados con la automatización, la electrónica industrial y la instrumentación.

Cerrar
Foros de Electrónica » Temas de Interés » Automatización, Electrónica industrial y de Potencia

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.