Haz una pregunta
  Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

15/07/2009 #1


Calculo de THD en LTSpice?
Como puedo realizar el calculo de la distorcion armonica en la simulacion de un amplificador utilizando el LTSpice?

Otra cosa como puedo calcular la eficiencia del amplificador por que en la simulacion, el amperaje que circula desde la fuente( en la rama +) es la mitad que tengo en la salida o mejor dicho en la resistencia que utilizo como parlante y en la rama negativa circula la otra mitad, entonces si la corriente que circula por el amplificador es la misma que se entra al parlante la eficiencia es del 100% y eo esta muy lejos de ser verdad.

por cierto el amplificador que estoy simulando es el Sinclair Z30 que esta publicado en el foro
GRACIAS.
15/07/2009 #2


Te recomiendo suscribirte al grupo LTspice/SwitcherCAD III en Yahoo Groups.
Creo que toda la información "extra" sobre LTSpice disponible esta ahi.

Ahi entre los archivos disponibles tienen una utilidad para calcular el THD. Personalmente no lo he probado nunca, basicamente debido a que requiere instalar Perl. Y como no lo necesitaba imperativamente preferi no instalar mas cosas.

En el grafico adjunto puedes ver lo que hay en ese grupo de yahoo al respecto, y donde.
15/07/2009 #3


gracias amigo encontre la solucion en el grupo de yahoo.

pero todavia como calcular la eficiencia, sigo buscando
15/07/2009 #4

Avatar de Eduardo

La forma mas simple, aunque poco estetica es usando comandos Spice.

Para la THD agregas el comando .FOURIER fo V(Vcarga)

Para la eficiencia necesitas tres lineas del comando .MEASURE
.MEAS Pcarga AVG V(Vcarga)*I(Rcarga)
.MEAS Pfuente AVG - V(Vpositiva)*I(FuentePositiva) - V(Vnegativa)*I(FuenteNegativa)
.MEAS Eficiencia PARAM 100*Pcarga/Pfuente

Los resultados te los da en "Spice Error Log" , no es muy elegante, pero es mas rapido
15/07/2009 #5


Gracias eduardo, subo los resultados para que los observen por que creo que algo no esta bien con la eficiencia
Imágenes Adjuntas
Tipo de Archivo: gif dibujo_212.gif (19,3 KB (Kilobytes), 88 visitas)
15/07/2009 #6

Avatar de narcisolara_21

Puedes subir el archivo?
15/07/2009 #7


el transistor que esta en la rama posivita es un limitador de corriente para que se active cuando se conectan cargas de 2omhs o menores todavia esta n prueba
Archivos Adjuntos
Tipo de Archivo: rar tl494_159.rar (1,5 KB (Kilobytes), 14 visitas)
15/07/2009 #8

Avatar de Eduardo

Te equivocaste de archivo
15/07/2009 #9


ok gracias este si es el correcto
Archivos Adjuntos
Tipo de Archivo: rar sinclair_z30_175.rar (1,4 KB (Kilobytes), 28 visitas)
16/07/2009 #10

Avatar de Eduardo

Tenes que tener cuidado con la etiqueta de los nodos, porque cada vez que agregas o sacas algo te las cambia. Lo que conviene hacer es asignarle un nombre a los que nos interesan (con F4)

Vos tenias dos problemas:

- Uno era que te habia cambiado la etiqueta de los nodos

.MEASURE Pcarga AVG V(n009)*I(R11)
.MEASURE Pfuente AVG -V(n001)*I(V1)-V(n015)*I(V2)
.MEASURE Eficiencia PARAM 100*Pcarga/Pfuente
.fourier 1k V(n009)


Comparalos con los del circuito.


- El otro era un problema de signo en la fuente negativa.
De la manera que estaba conectada, el producto V*I era positivo, mientras que en la de la rama positiva V*I era negativo.
Con dar vuelta V2 y asignarle -30V se soluciona el problema.
Tambien se podia "corregir" el signo en MEASURE --> .MEASURE Pfuente AVG -V(n001)*I(V1) + V(n015)*I(V2)
16/07/2009 #11


Eduardo gracias, estare pendiente para la proxima, veo que tampoco duermes como muchos aqui, saludos
16/07/2009 #12

Avatar de narcisolara_21

Fíjate en estos resultados, te recomiendo que cuando vayas hacer un MEASURE, nombres los nodos con etiquetas, y los componentes le cambies el nombre como por ejemplo R11 lo cambie por LOAD, Así sabras que estas analizando..


AVG
pcarga: AVG(v(out)*i(load))=86.4387 FROM 0 TO 0.01
pfuente: AVG(-v(v+)*i(v1)-v(v-)*i(v2))=126.018 FROM 0 TO 0.01
eficiencia: 100*pcarga/pfuente=68.5922


EDIT: Había puesto algo que no estaba bien..
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Software de Simulación y Diseño Electrónico

Todo lo relacionado con estos programas.

Cerrar
Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.