Haz una pregunta
  Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

12/05/2015 #1


Dudas con Pspice/Schematics, transmisor y receptor ultrasónico
Estoy realizando un proyecto y tengo que usar sensores ultrasónicos. Ahora mismo quiero simular los circuitos de acondicionamiento de la señal. En este caso, para empezar, tenemos el circuito emisor(transmisor). Explico a continuación:

Partiendo de una señal cuadrada (reloj) de 5V, a través del circuito se quiere amplificar tal señal y enviar al sensor ultrasónico emisor. Fácil.

Estoy empezando a usar el programa Pspice/Schematics y no domino mucho el tema. Mi duda es como tengo que poner el circuito para poder realizar la simulación. En particular, como añado, o qué tengo que hacer con el componente que sería el sensor emisor (situado a la derecha del todo).Osea, como "cerrar" el circuito, para no dejar cosas flotantes.
Adjunto el circuito que he podido más o menos realizar en el programa, pero está incompleto.

(El sensor en cuestión es el MA40S4S)

Saludos y gracias por adelantado.
12/05/2015 #2

Avatar de ecotronico

Hola bienvenido!

Utilizo este aplicativo y cuando sucede este error "floating" es porque algún nodo no está referido a tierra (GND ANALOG).
La solución que conozco es agregar un resistor (R) de alto valor (>20Mohm para no interferir en el funcionamiento) entre el nodo y tierra.
12/05/2015 #3


gracias @metalmetropolis por contestar. Podrías decirme el uso o finalidad de esos dos condesadores que hay en el esquema?
13/05/2015 #4


He modificado el circuito como me aconsejó el compañero y ahora si se pueden hacer simulaciones.
Ahora lo que no entiendo es el uso de los condensadores C1 y C2.
En la imagen v1111_v3333 obtengo bien la señal que quiero, que es la señal de reloj original amplificada. Pero si veo la señal pasado el condensador (imagen vpin1_emisor), se pierde....

Alguien puede explicarme ésto?
Imágenes Adjuntas
Tipo de Archivo: png emisor2.png (18,3 KB (Kilobytes), 15 visitas)
Tipo de Archivo: jpg v1111_v3333.jpg (173,1 KB (Kilobytes), 5 visitas)
Tipo de Archivo: jpg v1111.jpg (171,4 KB (Kilobytes), 6 visitas)
Tipo de Archivo: jpg vpin1_emisor.jpg (156,7 KB (Kilobytes), 6 visitas)
14/05/2015 #5
Moderador general

Avatar de DOSMETROS

Los pusiste vos y nos preguntás a nosotros ?

Limitar corriente ? Con uno hubiera bastado .

No se para que los pusieron si el sensor ultrasónico en si mismo es un capacitor y las salidas del 7404 son TotemPole (una especie de pushpull todo npn) , así que eso funciona "en puente" , una salida sube mientras la otra baja , duplicando la tensión y teoricamente cuadruplicando la potencia.

Probá se quitarlos.

Saludos !
14/05/2015 #6


Gracias @dosmetros por comentar.
Esta parte del circuito no la he diseñado yo, sino que la he visto de otro proyecto (pero no explicaban detenidamente esta parte del circuito). De ahí mi desconocimiento de la colocación de los condensadores. Ahora mismo estoy realizando solo simulaciones. Pero el lunes regresaré al laboratorio y probaré físicamente el circuito. Y veremos que sucede.

Quizás al final ni necesite realizar amplificación de la señal porque la distancia entre emisor y receptor es muy pequeña. Ahora estoy diseñando el circuito del receptor. Si surgen dudas lo comentaré en otro post específico.
14/05/2015 #7

Avatar de ecotronico

hola nuevamente!

tal vez esos capacitores sirvan para filtrar alguna componente continua porque la fuente no es doble, es solo 0 y 5V.
y también podría ser lo que dice DOSMETROS:
Limitar corriente ? Con uno hubiera bastado
intenta probar con uno solo de 0,47uF, para concordar con los dos de 1uF en serie..

en el primer dibujo aparece una especie de "parlante" o "altavoz"... es eso mismo?
pues de ser así podrías simularlo como un inductor (L en pspice) en serie con un resistor pequeño (quizas <20ohm), y esto justificaría más aún el uso de un capacitor en serie.
15/05/2015 #8


metalmetropolis dijo: Ver Mensaje
en el primer dibujo aparece una especie de "parlante" o "altavoz"... es eso mismo?
Es un transductor ultrasónico.

Gracias por aportar ideas y conocimientos Semana que viene cuando pase por el laboratorio os comentaré.
16/05/2015 #9


Dudas con Pspice/Schematics
Vale, continúo con mi proyecto, y ahora tengo un problemilla con el circuito de acondicionamiento de la señal del receptor ultrasónico.

La idea es que con el sensor emisor (transductor) envío una señal cuadrada de reloj de 40khz. Luego con el sensor receptor recibo esa señal y tengo que acondicionarla para trabajar. El transductor me capta una señal senoidal de 150mV. Por lo cual mi diseño consta de una primera etapa de potencia con pequeña ganancia (x10), y luego una segunda etapa con más amplificación (además de incluir un filtro paso-banda de 40khz).
Finalmente esa señal se convierte a señal cuadrada con un detector de cruce en la tercera etapa.

Hasta aquí la teoría correcta. Y mi circuito lo podeis observar en la imagen adjunta.

En las gráficas podeis observar la señal recibida y las señales de cada etapa.
Mi problema, como se puede observar, es que no hay "sincronización" entre la señal recibida y la obtenida finalmente (señal cuadrada de la salida del comparador). Mi duda es como podría solucionar el retardo que se produce?

Cosa a tener en cuenta en el diseño. Como fuente de alimentación sólo dispongo de señal +5V (por eso los operacionales no se alimentan simétricamente, +5v,-5v).

P.D: Adjunto el schematic y archivos para abrir y simular con Pspice en el archivo ".rar"
Imágenes Adjuntas
Tipo de Archivo: jpg etapa1_2_3_schematic.jpg (43,8 KB (Kilobytes), 11 visitas)
Tipo de Archivo: jpg Detector de cruce_simulacion.jpg (135,9 KB (Kilobytes), 8 visitas)
Tipo de Archivo: jpg simulacion_todo.jpg (140,8 KB (Kilobytes), 4 visitas)
Archivos Adjuntos
Tipo de Archivo: rar Etapas_1_2_3_TL082.rar (991,1 KB (Kilobytes), 10 visitas)
08/03/2016 #10


Hola,

Estoy haciendo un proyecto de sensores de ultrasonido, parecido al que has comentado. Estoy implementando un sistema con un receptor y un emisor de ultrasonido.

Estoy buscando una etapa de potencia para el señal emisor, me preguntava si realmente funciona el que propones en el post y si pudieses explicarme el funcionamiento.

No acabo de ver su funcionamiento de los inversores para poder implementarlo en el simulador (yo utilizo LTSpice, muy parecido al SPSpice).

Muchas gracias por su tiempo.
09/03/2016 #11


Mfaju dijo: Ver Mensaje
Hola,

Estoy haciendo un proyecto de sensores de ultrasonido, parecido al que has comentado. Estoy implementando un sistema con un receptor y un emisor de ultrasonido.

Estoy buscando una etapa de potencia para el señal emisor, me preguntava si realmente funciona el que propones en el post y si pudieses explicarme el funcionamiento.

No acabo de ver su funcionamiento de los inversores para poder implementarlo en el simulador (yo utilizo LTSpice, muy parecido al SPSpice).

Muchas gracias por su tiempo.
El circuito amplifica la señal, y digamos que lo hace gracias a la suma de dos partes. Con la rama de arriba obtienes una señal de 0 a 3,3V. Y con la rama de abajo obtienes la equivalente pero en negativo (de 0 a -3,3v). Sumando ambas señales obtenemos una amplifacion total mayor. La señal resultante va de -3,3v a 3,3v.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Software de Simulación y Diseño Electrónico

Todo lo relacionado con estos programas.

Cerrar
Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.