Haz una pregunta
  Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

08/06/2014 #1


Problema con el AD633, se satura al elevar al cuadrado
Estoy sensando corriente en un motor trifásico con un ACS712[1], a la salida entrega una señal senoidal con un offset de 2.5V; el rango de operación será de 0 a 10A, en 0A tendría solo el offset de 2.5V en 10A tendría 5Vpp con el mismo offset, así todas las señales en este rango estarían comprendidas entre 0 y +5V y solo haría falta enviarlas al ADC, pero después me percate de un problema, a 10A la señal de Vltaje entregada por el sensor esta comprendida entre 0 y +5V exactamente, a corrientes menores también esta comprendida entre 0 y +5V pero la señal sigue montada sobre un offset de manera que por ej. en 2A hay 1.116Vpp sobre el 2.552Voffset y hay un rango arriba y abajo de la señal donde no hay ningun valor de voltaje, encontre una posible solucion que era quitar el offset y elevar al cuadrado la señal de voltaje[2], asi el rango donde no tengo voltaje solo esta por arriba de la señal y lo puedo calcular +5V -Vpp/2, el problema que tengo es que al tratar de elevar la señal con un AD633 todo funciona bien por un breve periodo de tiempo después solo se satura la salida del AD633 y hasta ahi no he podido arreglar el problema, eh intentado con diferentes configuraciones pero no se que tiene de malo el circuito todo parece correcto.

De izquierda a derecha las miniaturas 1, 2, 3, 4 y 5
1.-Señal 5Vpp cuando hay 10A, la señal se encuentra entre 0 y +5V exactamente
2.-Señal 1.116Vpp cuando hay 2A, la señal se encuentra entre algun rango entre 0 y +5V
3.-Circuito utilizado para elevar al cuadrado (simulado con un circuito que no tiene la señal de x1 invertida, el problema que ocurre es el mismo)
4.-Respuesta deseada(simulado con circuito completo)
5.-Respuesta obtenida después de cierto tiempo(simulado con circuito completo)

Archivos
circuito.rar (Circuito completo)


Solo me faltaría arreglar ese problema con el AD633, estoy pensando en otras opciones para enviar bien la señal al ADC, un convertidor rms-dc no creo que sea una opcion porque graficaré la corriente rms, podría conseguir una configuración con el AD633 para tener offset programable pero me parece muy complicado y necesitaré comparar otro C.I. Lamento si me extendí mucho lo hice esperando que se entendiera mas o menos lo que estoy haciendo, cual es mi problema y esperando que alguien me pueda iluminar.



[1]. sparkfun.com/products/8883
[2]. animations.physics.unsw.edu.au/jw/power.html
08/06/2014 #2

Avatar de chclau

De que rango es la tension de entrada de tu ADC?
Lo que no entiendo tampoco es por que elevar al cuadrado, si tenes una señal unipolar de 0 a 5V y la queres pasar a bipolar en el rango de -5 a 5V, todo lo que necesitas es un amplificador sumador que reste el offset y amplifique por dos.

Pero lo mas importante es el rango del ADC, si ese rango es de 0 a 5V como la mayoria de los conversores no tiene sentido procesar analogicamente la señal.
08/06/2014 #3

Avatar de Daniel Meza

Tampoco entiendo bien, pero creo que el amigo se refiere a quitar sólo el offset y quedarse con la señal unipolar. Para ello un operacional que reste 2.5 a la señal original.
O un rectificador de precisión de onda completa pueda servir
08/06/2014 #4


Estoy usando un AD0804, 0 a 5V, la señal que quiero elevar al cuadrado no es la señal unipolar de 0 a 5V (que es la señal que arroja normalmente el sensor) sino la señal que quiero elevar al cuadrado es una bipolar como la de la miniatura 4(es la señal del sensor pero sin offset).

En pocas palabras deseche la señal unipolar de 0 a 5V porque creí que me causaría conflictos enviarla al ADC pero no estoy seguro, ahora pienso que mi pregunta si pueda llegar a aturdir con tanta información, talvez debería ir por partes, creo que mi principal problema es que no se si afecta enviar la señal ADC como la envié en la miniatura 2, ya que no tengo votlajes por arriba de la señal, ni por abajo de la señal y esto debería según yo afectar en algo cuando adquiera los 8bits que entrega el ADC a la salida.
08/06/2014 #5

Avatar de chclau

No afecta para nada, al contrario, justamente por ser la entrada al ADC unipolar, si lo que queres adquirir es una señal senoidal no te queda otra que agregarle offset.

En tu caso, en que el sensor ya entrega offset, no tenes que hacer nada, solo conectarla directamente al ADC o a lo sumo a traves de un ampli seguidor (ganancia unitaria)
08/06/2014 #6


Muchas gracias Daniel Meza, chclau, solo faltaría hacer las pruebas ya con el seguidor, si tengo algún inconveniente espero que no sea mucha molestia pero voleré.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Software de Simulación y Diseño Electrónico

Todo lo relacionado con estos programas.

Cerrar
Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.