Haz una pregunta
  Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

02/02/2013 #1

Avatar de Limbo

Problema con agujeros del taladrado en Altium 10(Protel)
Buenas,

Llevo dias intentando solucionarlo y no puedo, espero que alguno de vosotros sepa que pasa.

El caso es que cuando creo un footprint desde el altium 10 y utilizo la herramienta "Pad" y lo pego, me sale el agujero, pero con el Pad en la capa "Multilayer", si pongo que el pad este en la "Bottom layer" me desaparece el agujero.

¿Hay idea de porque puede estar pasando esto? San Google no me dice demasiado..

Gracias.
Taluego.
02/02/2013 #2


Hola Limbo,

Lógicamente el pad con agujero solo sale en multilayer (el taladro atraviesa todas las capas). Un pad en una sola capa es para componentes SMD, por eso no deja poner el agujero.

Imagino que quieres que solo dibuje el pad para soldar en la bottom y no en la top o en otras?...
Si es así, pon un Pad multilayer y edita las propiedades: en "Shize and Shape" selecciona "Top-middle-bottom" y pon a 0 las medidas de X e Y de las capas que no quieras que dibuje (por ejemplo: top y middle a 0 y en bottom las medidas que quieras para el pad). Quedará unicamente un pad en bottom con un agujero que atraviesa todas las capas

Full stack es en caso de tener varias capas intermedias, para especificar un valor distinto para cada una.
03/02/2013 #3

Avatar de Limbo

Nada, sigue sin funcionarme. Me sale el agujero con una sola capa pero el color del pad no es el que tengo puesto para la bottom layer, sale como la multilayer, lo que quiero es que sea del mismo color de la capa bottom, sino menudo lio..

Dejo una foto haber si se explica mejor lo que quiero. El pad de fuera de la ventana es uno hecho en dxp2004 y el que sale en las propiedades es del altium 10, lo que quiero, es hacer el pad de fuera en altium 10 ¿Se podrá?
Imágenes Adjuntas
Tipo de Archivo: png protelfoto.png (82,4 KB (Kilobytes), 27 visitas)
03/02/2013 #4


Pues que yo sepa no puede cambiarse el color, ojalá alguien que sepa me corrija.

Puedes usar un truquillo a la hora de rutear. Aunque los pads sean del mismo color, si estas situado en una capa y pulsas " Shift + S", todos los pads y pistas que no pertenezcan a esta capa se oscurecen.

Es lo mismo que trabajar solo en "single layer mode". boton derecho sobre una capa, --> "layer display options" -->"single layer mode"

El pad que se ve en la imagen en R3 tiene huella solo en la bottom, el resto son multilayer. Al situarse en la top, las pistas de la capa bottom y ese pad salen oscurecidos.

Imágenes Adjuntas
Tipo de Archivo: png pads.png (290,5 KB (Kilobytes), 59 visitas)
03/02/2013 #5

Avatar de Limbo

No entiendo una cosa. Que el agujero salga como multilayer, vale porque atraviesa toda la placa, pero el pad puede estar en una capa y en la otra no existir.. No veo la funcion de poner el pad como multilayer..
04/02/2013 #6


La única forma que se me ocurre (solo para pads redondos, como el que has puesto de DXP2004) es al crear el componente, colocar el pad solo con el agujero, con todas las demas medidas a 0 (lo que sale en gris, que desaparezca). Alrededor del agugero, crear en la capa que quieras que aparezca un arco alrededor del agujero. Asi siempre se verá del color de la capa en que dibujes el arco, aunque al colocar el componente en un PCB, el arco no formará parte del pad, sino del componente. Algo parecido, aunque más sencillo, que lo que hacen en este video (casi al final)

http://altium.com/VideoPlayer/simple...hapes&w=100%25
Imágenes Adjuntas
Tipo de Archivo: png pads3.png (60,0 KB (Kilobytes), 9 visitas)
04/02/2013 #7

Avatar de Limbo

Por lo que estoy viendo, en altium 10 se trabaja con pads en multilayer, pero ¿como puedes diferenciar la capa en la que esta el pad? A la hora de imprimir, si solo quieres imprimir la bottom ¿como sabe el programa en que caoa esta el pad? He ahi mi duda..
05/02/2013 #8


Para diferenciarlos mientras trabajas, como son todos grises, yo solo sé con Shift + S, pero a la hora de imprimir no hay ningún problema. Si un pad multilayer solo tiene huella en la bottom, en esa capa la dibuja, en las demás no, como si no existiera.

Si en las propiedades del pad, las medidas de top y middle estan a 0, en esas capas ( Top Layer, Middle Layer 1,2... ) al imprimir no dibuja el pad. Imprime lo que ves en "single Layer mode", lo que esté oscurecido no lo dibuja.

También lo diferencia en todas las demás capas, como top solder y bottom solder, solo lo dibuja según las propiedades de "size and shape" del pad. En este caso, al imprimir, la capa top solder no tendría pad, pero la bottom solder sí.
12/02/2013 #9

Avatar de joryds

Limbo dijo: Ver Mensaje
Por lo que estoy viendo, en altium 10 se trabaja con pads en multilayer, pero ¿como puedes diferenciar la capa en la que esta el pad? A la hora de imprimir, si solo quieres imprimir la bottom ¿como sabe el programa en que caoa esta el pad? He ahi mi duda..
Hola Limbo, en las vistas 3D de Altium 10 hay una con el nombre de Altium 3D Color By layer, creo que esta opción te puede ayudar a identificar mejor las capas que estas usando.
Si con esto no lo resuelves, sube el archivo del PCB para analizar donde podría está el inconveniente.

Adjunto una imagen de como se observa Altium 3D Color By layer

Saludos…
Imágenes Adjuntas
Tipo de Archivo: jpg Altium 10.JPG (133,5 KB (Kilobytes), 12 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Software de Simulación y Diseño Electrónico

Todo lo relacionado con estos programas.

Cerrar
Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.