Haz una pregunta
  Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

07/11/2009 #1

Avatar de Salvador609

Problema al simular
hola antes que nada

weno aqui planteo mi problema al querer simular una fuente asimetrica en el circuit maker de 25v a 3amp

1.-me marca un error al simular siempre con el transformador al no saver ingles pos no se a que se refirere ya lo traduci pero no le veo coerencia

2.-no se si algun elemento no es el correcto ya que dudo del buen funcionamiento del diagrama (por eso lo simulo)y dudo con respecto alas caracteristicas del transformador ya que no lo indica

3.-pido amablemente que si me pueden ayudar a incontrar la faya ya que yebo mas de una semana tratando de aser que funciene y no lo logro, alser una practica tengo que terminarla TT_TT, si no quien sabe que pasara conmigo

aqui les adjunto el circuito esta en circuit maker

bueno y graxias por su tiempo se los agradesco

saludos
07/11/2009 #2


Respuesta: Problema al simular
No uso el circuit maker, de modo que no puedo ni siquiera ver que diagrama estas intentando simular. Si copias ( literalmente ) el mensaje de error tal vez podriamos hacernos una idea.

Otra cosa que podria ayudar a ver que cosa estas haciendo es incluir el diagrama en un formato grafico estandard ( gif o jpg ).
07/11/2009 #3

Avatar de Salvador609

Respuesta: Problema al simular
ok
te subo una imagen y el error que dise

grax por tu tiempo

Warning: singular matrix: check nodes vs1_1 and lpkt1#branch

Note: starting Gmin stepping
Note: One successful Gmin step
Note: One successful Gmin step
Note: One successful Gmin step
Warning: Gmin step failed
Warning: singular matrix: check nodes lpkt1#branch and vs1_1

Warning: Gmin stepping failed
Note: starting source stepping
Warning: source stepping failed
Note: starting Gmin stepping
Note: One successful Gmin step
Note: One successful Gmin step
Note: One successful Gmin step
Warning: Gmin step failed
Warning: Gmin stepping failed
Note: starting source stepping
Warning: source stepping failed
doAnalyses: Matrix is singular

run simulation(s) aborted
Imágenes Adjuntas
Tipo de Archivo: jpg fuente.jpg (60,2 KB (Kilobytes), 122 visitas)
07/11/2009 #4


Respuesta: Problema al simular
Por lo poco que he visto ese tipo de error puede significar que hay algo en el circuito que el simulador no logra resolver del todo bien.

Te recomiendo simular por partes. Eso puede ayudar a encontrar el problema.
Por ejemplo... simular el circuito usando una fuente de tension AC en lugar del transformador. Simular solo hasta el puente diodos y condensador...

Eliminar ( temporalmente ) partes del circuito tambien puede ayudar, como por ejemplo U3, U4 y componentes asociados.

No he analizado en detalle el circuito, pero me da la impresion de que tiene cosas un poco extrañas. En que consiste la practica? en simular ese circuito especificamente? O simular cualquier circuito de fuente de alimentacion con caracteristicas similares?
07/11/2009 #5

Avatar de luisgrillo

Respuesta: Problema al simular
Sabes que Circuit Maker no tiene los modelos de muchos zener y transistores que si aparecen hay?

Ese puede ser tu problema, te recomiendo que cambies de simulador.
07/11/2009 #6

Avatar de Salvador609

Respuesta: Problema al simular
bueno la practica consiste en simularlo y luego yebarlo ala realidad construyendo dicha fuente antes del 5 de diciembre

are lo que dises de simular por partes,am y yo tambien creo que as cosas raras en la fuente pero ya lo discuti con el profe pero es terco y no me ase caso solo me dise "la quiero terminada" -.-

y cual es el simulardor mas completo que me recomiendas ya uso este y el livewire pero tambien carese de componentes

bueno grax por su tiempo

saludos
08/11/2009 #7


Respuesta: Problema al simular
Personalmente te recomiendo el LTSpice.

Las ventajas que le veo son:

- Es un SPICE. Por lo que he visto SPICE en general funciona mejor que otros simuladores ( por ejemplo Micro Cap )
- Es gratuito. ( No pirataware o crackedware )
- Funciona bien.
- Es abierto. Si bien las librerias incluidas contienen basicamente componentes del fabricante de LTSpice ( Linear Technology ), es posible agregar componentes sin mucho problema si se logra encontra el modelo spice de cada componente.
Muchos componentes adicionales se pueden encontrar en el grupo yahoo de LTSpice.

Con respecto al diagrama .... lo unico que se me ocurre es verificarlo y luego corregir lo que sea necesario , documentando o demostrando el analisis que justifica los cambios. ( Analisis, no simulacion ! )

Logicamente todos los op. amps deberian usar la misma alimentacion. LM324 son 4 op.amps juntos en un solo IC. No es logico tener uno trabajando a +Vcc y otros -12,+12.

Por otro lado el circuito de U3 y comonentes asociados, en teoria es una proteccion para corriente maxima, pero tal como esta no creo que funcione correctamente. Para que funcione correctamente D7 deberia estar polarizado al reves, y la alimentacion de ese op.amp. deberia ser la misma que U2.

U4 seria un indicador de que se ha alcanzado la corriente maxima, pero en este caso R18 y SPK1 no tienen sentido.

La fuente de alimentacion de referencia ( U1 ) funciona si se alimenta a +30V, en lugar de +12. -12. Con respecto a los datos del transformador.... tienes que calcular la tension maxima y minima que necesitas en el condensador C1. La maxima ( que no se deberia sobrepasar nunca ) son 32V , pues si tienes mas de eso el LM324 se podria dañar.

Por otro lado puedes calcular la tension que deberias tener a la salida de U2 para tener 25V a la salida de la fuente. Luego tomar en cuenta de que la salida del LM324 no llega hasta su Vcc de alimentacion ( verificar datasheet ).

Y con respecto al profesor.... 2 posibilidades:
  • Sabe que el circuito esta mal, pero no dice nada para que Uds lo averiguen, ( eso explicaria la frase "Lo quiero funcionando" ).
  • No sabe nada de nada, pero cree que sabe algo.
Mas me inclino por la posibilidad 1.

Bueno..... ya te ayudamos bastante.... ahora te toca trabajar a ti que si no me tendran que poner la nota a mi.....
09/11/2009 #8

Avatar de Salvador609

Respuesta: Problema al simular
oye enserio muchas grasias me as ayudado mas que mi profe que ba cada 20 años -.-"

bueno comentare lo que me dises alos de mi grupo lo exprondre en clase y lo berifecaremos bien como lo as mensionado, ya que son muchos los que no saben nada osea nada (digamos de 40 solo 3 sabemos algo referente ala lectronica) y les trato de ayudar en lo que puedo, por que las ideas ya se me abian terminado :P por eso biene aqui por ayuda

y con repescto al profe yo me boy la obcion 2 u_u que nosabe nada ya que como mensione solo ba al salon a desir que esta vivo y luego se ba ¬¬

como nota te comento que esa fuente ya la an tratado de aser en semestres anteriores y nadie la ha logrado aser funcionar como debe por que, ni idea, pero bueno pondre todo mi esfuerso para lograr aserla funciar

y denuevo grax 43 personas te lo agradeseremos ^_^

que tengas buen dia dentro de unos dias te comento para que veas como vamos
grax de nuevo
17/08/2010 #9


Respuesta: Problema al simular
¿alguien me podría decir como realizar un analisis AC con una fuente dependiente en el circuito? por mas que he buscado en manuales no lo encuentro...
17/08/2010 #10

Avatar de Eduardo

Respuesta: Problema al simular
JM88 dijo: Ver Mensaje
¿alguien me podría decir como realizar un analisis AC con una fuente dependiente en el circuito? por mas que he buscado en manuales no lo encuentro...
Tenés que poner una fuente en la entrada de señal y declararle un valor de alterna.

Si no encontrás como, adjuntá el archivo y te muestro.
21/08/2010 #11


Respuesta: Problema al simular
No se muy bien como hacerlo... adjunto el esquema de mi circuito
Imágenes Adjuntas
Tipo de Archivo: jpg modelo.jpg (38,8 KB (Kilobytes), 47 visitas)
21/08/2010 #12

Avatar de Eduardo

Respuesta: Problema al simular
JM88 dijo: Ver Mensaje
No se muy bien como hacerlo... adjunto el esquema de mi circuito
1- Cuando se piden mostrar los archivos, no solo es para ver el esquema usado sino tambien para simular sin tener que hacerlo de vuelta.

2- En esa imagen estás cortocircuitando base con colector. Que ganancia esperás? :enfadado:

3- Para la simulación en AC hay que declarar primero cual es la entrada. El LTSpice asume como excitación aquella fuente que tenga declarado en sus "Propiedades" un valor de "AC amplitude" en "Small signal AC analysis".
--> Agregás entonces una fuente conectada a Vbe y la declarás de 1V.
(imagenes 1 y 2)
El LTSpice usa los valores declarados de las fuentes solo para calcular el punto de trabajo, después pasiva todo menos la excitación. Puede haber solamente una con el valor de AC activo.

4- Seleccionás los límites de frecuencia y la cantidad de puntos por octava y le das gas.
(imágenes 3 y 4)
Imágenes Adjuntas
Tipo de Archivo: jpg 1.jpg (47,8 KB (Kilobytes), 40 visitas)
Tipo de Archivo: jpg 2.jpg (63,4 KB (Kilobytes), 25 visitas)
Tipo de Archivo: jpg 3.jpg (57,6 KB (Kilobytes), 22 visitas)
Tipo de Archivo: jpg 4.jpg (69,2 KB (Kilobytes), 19 visitas)
06/09/2010 #13


Respuesta: Problema al simular
muchas gracias! no encontraba la solucion por ningun sitio...
22/03/2012 #14


estimado lo que tenias que hacer era definir una fuente AC.
Este lo ingresas desde la pestaña SEARCH, colocando SIGNAL GEN.
LUEGO LO EDITAS, BASICAMENTE COLOCAS LA TENSION PICO Y LA FRECUENCIA.
SALUDOS.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Software de Simulación y Diseño Electrónico

Todo lo relacionado con estos programas.

Cerrar
Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.