Haz una pregunta
  Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

09/08/2006 #21


Te paso los dos files, NO quiero que me lo hagas!!! Y no grito. Lo que quiero es aprender, lo que quiero es que me digas donde está mi fallo.

Como ves, es a partir de 220V conseguir 5V estabilizados.

El mensaje de error es:

ERC control (9/8/2006-14:22:21)

***** Hoja 1 (Raíz)
ERC: Warning Pin input not driven (Net 1) (X= 4,000 pulgadas, Y= 2,700 pulgadas

>> Errores ERC: 1

Gracias y a ver si entre todos me ayudais.

Gracias
09/08/2006 #22


Hola Serch,

He visto el problema que comentas y es muy curioso. No lo deberías tener.

Sea como sea te paso una manera de resolverlo. Al parecer utilizas el fusible de la libreria device que se llama FUSE. Los dos pines del diagrama están definidos como entrada.

Si cambias el pin de la derecha del símbolo FUSE a salida, y lo cargas en memoria puedes hacer que el error desaparezca. Curiosamente el error ocurre aunque en la matriz de revisión de pines de entrada contra entrada no debe tener problema. Asi que ésto es lo curioso.

Para corregir el error has los siguientes pasos:

1. Abrir el editor de bibliotecas o componentes con el cuarto ícono de izquierda a derecha.
2. Dentro del Editor de bibliotecas o componentes. Hacer click en el ícono de seleccionar componente a editar.
3. Selecciona la biblioteca device
4. Selecciona el componente FUSE
5. Has doble click en el pin 2 del símbolo esquemático. Te debe aparecer un menú de propiedades de pines.
6. En el área de TIPO ELËCTRICO cambia la propiedad a "Salida". En vez de "Entrada".
7. Aprieta ACEPTAR para cerrar el editor de propiedades.
8. Aprieta el ícono de "Guardar el elemento actual en la bliblioteca cargada actual (Memoria)", es el sexto ícono de izquierda a derecha.
9. Te aparecerá un mensaje que dice "El componente FUSE ya exisite, Cambiarlo?" y debes escoger "YES".
Al hacer ésto se modifica la propiedad en el componente en tu diagrama esquemático con la propiedad de Salida en vez de entrada.
10. Cierra el editor de librerías. Te aparecerá un mensaje que la biblioteca DEVICE fue modificada, Continuar?, escoge "YES".
11. Has click sobre el pin 2 del símbolo FUSE sobre tu diagrama esquemático y debe aparecer la propiedad de TIPO DE PIN cambiadad de "Input" a "Output".

Y con ésto puedes correr el ERC Check y no deben aparecer errores.

Espero ésto te sirva para que puedas continuar tu aprendizaje.

Suerte,
10/08/2006 #23


Lo he corregido de una manera muy tonta. Resulta que me faltaba poner el transformador y ahora no me indica ningun fallo.

Pero lo que me sucede ahora es que el conector de salida (donde tengo los 5V) no me deja unirlos con el ultimo condensador; sim embargo el primero si. Alguna idea?? Te paso el esquema y el pcb generado.

Hay alguna manera de que me cargue SIEMPRE el modulo Gajda (lo llamo así porque se llama así, es donde estan los transformadores y rectificadores) Me refiero a que lo cargue junto con los otros!! Es un coñazo cargarlo en el esquematico y luego en el pcb siempre... no se si me explico.

Gracias
Archivos Adjuntos
Tipo de Archivo: sch fuente_5v_v2_204.sch (3,0 KB (Kilobytes), 35 visitas)
10/08/2006 #24


Hola Serch,

Baje el archivo que enviastes pero es igual al que tenías antes, y no logro ver ningún condensador que no esté conectado. El PCB no lo encontré en el archivo que enviastes.

Podrías intentar enviarlo nuevamente para ver si puedo ver el problema que tienes?

Saludos,

P@n@
11/08/2006 #25


Lo siento, intentaré pasartelo mañana, ya que estoy de vacaciones y me conecto por un cyber.

Gracias
14/08/2006 #26


Bueno, os paso 3 files, el esquematico, el pcb y la libreria.
Archivos Adjuntos
Tipo de Archivo: sch fuente_5v_956.sch (3,0 KB (Kilobytes), 21 visitas)
14/08/2006 #27


El pcb...
Archivos Adjuntos
Tipo de Archivo: brd fuente_5v_202.brd (10,8 KB (Kilobytes), 22 visitas)
14/08/2006 #28


Y la libreria...

No me permite añadir la libreria, me pone q la extension lib NO estrá permitida :(

Me he dado cuenta que gran parte de mis fracasos eran opr la libreria, sobretodo con el puente de diodos. No especifica cuales son los pines de AC y cuales son los de DC, por eso he modificado ese cmponente, pero no me deja subirlo para que lo veais.

Gracias
14/08/2006 #29


Hola Serch,

Veo que ya has creado buena parte de tu diseño, has avanzado bien. Te hago unos comentarios.

1. No pude ver la asociacion de símbolos con módulos en el diseño, seguramente estaban definidos en el archivo .net del proyecto que no estaba incluído. En el futuro al pasar proyecto sería bueno que incluyamos el archivo .net.

2. Veo que en tu tablilla tienes varios componentes que no has conectado. Por ejemplo el D1, C2, C3, C4. Veo que el trazo de cobre pasa por ensima de las patas, pero no esta conectado. Mi recomendación es que cuando hagas el ruteo de cobre, conectes también cada pin del componente antes de seguir al siguiente, puedes perder conexiones de cobre si no haces ésto.

3. Veo que no tienes definido el contorno del PCB. De preferencias deberías crear el contorno del PCB dibujando lineas en la capa de contorno de PCB. Ésto te puede servir mucho para crear las zonas de cobre de tierra y hacer el relleno de la zona. Además de referencia cuando hagas la tablilla.

Bueno en general creo que vas muy bien, y no se que más dudas puedas tener?

Avísanos para ayudarte a lograr el éxito en tus proyectos....

Saludos,

El P@n@
15/08/2006 #30


Bueno, te paso el archivo .net

En cuanto a tus comentarios, muchas gracias.

1.- Por lo que me comentas de que los componentes NO están conectados, sino que es una pista de cobre que pasa por ellas... pues no se como se hace de otra forma....

2.- Lo del contorno... es para tener gran parte de la placa conectada a masa (x ejemplo no??) Lo modificaré cuando me digas como puedo "conectar" los componentes

Gracias, sigue sacando fallos, es la única manera de aprender.

Gracias

PD1. He metido el modules.lib para que podais ver que he cambiado la asigancion de pines del puente de diodos
PD2. Para Li-ion, NO me deja adjuntar los .net
PD3. No se como adjuntar mas de 1 file en el mismo post
Archivos Adjuntos
Tipo de Archivo: lib device_990.lib (40,3 KB (Kilobytes), 23 visitas)
15/08/2006 #31


Hola Serch,

Para adjuntar un file en un post puedes utilizar un compresor de archivos como el WinZIP, WinARC o cualquier otro compresor de archivos.

Asi puedes adjuntar todos los archivos .pro .pcb .net .lib en un solo archivo .zip

1.
La ventaja de conectar los pines es para que el software detecte las conexiones y no te aparezcan errores en el control de reglas de diseño (DRC).

Generalmente cuando acabas el ruteo utilizas el boton DRC que es el 4 de derecha a izquierda para hacer la revisión de distancias entre trazos y de que has conectado todo lo dice el NETLIST. Cuando le das en el menu "Lista no conectados" te aparecen todos los componentes que deberían estar conectados en trazos, pero que no están conectados. En tu caso aparecen varios componentes.


Para conectarlos solo tienes que llevar el trazo de un pin a otro pin y dar doble click dentro del comando de añadir pista o via. Te puedes ayudar de visualmente con el botón de mostrar líneas aereas que es el sexto ícono en el menú de la izquierda.


2.
Sí por lo general es muy bueno en cualquier diseño tener un contorno de tierra, GND, o común en toda la tablilla que vas a utilizar. Esto es muy bueno principalmente para hacer tu diseño robusto e inmune a los ruidos eléctricos y electromagnéticos. También te ayuda en la manufactura de tablillas caseras porque es menos cobre que debe comerse el ácido. Asi que te recomiendo lo hagas.

Puedes ver un ejemplo de un proyecto que hice utilizando los planos de tierra en todo el diseño, y lo he creado con KICAD, te puede servir de referencia para que veas lo que puedes hacer con tu diseño. De la siguiente liga bajas el archivo ZIP
http://www.kedo.com.mx/modules/wfdow...wcat.php?cid=3

dentro del ZIP existe un archivo

kedo_blackfin_audio_codec_GBR_0.3.zip

Contiene los datos de fabricación de la tablilla y puedes verlos con archivo GERBVIEW de kicad o puedes utilizar los PDFs en Adobe Acrobat Viewer.


Me alegro mucho que le heches ganas a tu diseño. Y pronto vas a tener una fuente bastante buena. Sigue así...

Te incluyo ejemplo de un pin mal conectado que está en tu diseño, para que veas a que me refiero.
Imágenes Adjuntas
Tipo de Archivo: gif fuente_5v_c4_ok_110.gif (6,0 KB (Kilobytes), 464 visitas)
Tipo de Archivo: gif fuente_5v_c4_163.gif (8,5 KB (Kilobytes), 464 visitas)
16/08/2006 #32


Ops, pues tienes toda la razon.

Pero ... ahora n o puedo borrar las lineas ya que hago zoom y el cursor sube o baja, pero no me cae en la linea. Los enanos me crecen.... y yo que creía que ya lo habia terminado... arggg
16/08/2006 #33


Bueno, pues he hecho lo mas facil. Repetir la placa jejeje

Aqui os adjunto un zip con todos los ficheros (creo)

Tambien he añadido el device.lib para que vieseis el cambio de los pines en el puente de diodos. A ver si alguien me confirma que está bien...

Gracias

PD. Sacarme mas fallos!!! Me interesa, no quiero hacer mal la placa... así que sacarme fallos!!
Archivos Adjuntos
Tipo de Archivo: rar fuente5v_166.rar (16,8 KB (Kilobytes), 28 visitas)
17/08/2006 #34


Hola Serch,

Muy buen trabajo... Solo unos comentarios.

1. Para borrar trazos o pistas tienes que irte sobre el trazo y con el botón derecho te aparece un menú de opciones. Allí está la opción de borrar segmentos/pistas/net. Asi podrías modificar el trazo que desees. Pero veo que ya tienes 0 errores en conexión.

2. Vi la modificación de la librería de símbolos en el puente y me parece buena idea. Solo que recomiendo que la dejes en una librería personal para que no se te olvide que has creado una mejora al símbolo en el futuro. Buen trabajo.

3. No veo valores en tu diagrama esquemático para los capacitores electrolíticos. Te recomiendo los introduzcas para que puedas tener referencias de la corriente máxima que va a generar tu fuente. Asi podrías hacer más exacto tu diseño. (opcional)

4. El plano de tierra está localizado en la capa de cobre y no de componentes. Creo que si fabricas la tablilla la vas a hacer en una sola cara, asi que te recomiendo que hagas el relleno de cobre en la capa "Componentes". Recuerda de seleccionar la red de GND justo antes de hacer el relleno.

5. Te recomiendo que definas el contorno de PCB con línease en la capa de Contorno de PCB. Así podrías dimensionar la tablilla y darle una vista más profesional. (opcional)

6. Creo que puedes reducir el tamaño de tu tablilla en un 50%. Asi con la mísma cantidad de tarjeta de PCB, podrías hacer 2 fuentes. Pero claro que es una sugerencia. (opcional)

7. Los trazos de alimentación te recomiendo que los hagas más grandes. Mínimo de 1mm. Pero mientras más grandes mejor para las corrientes altas. (opcional)

8. En el esquemático te falta el símbolo de GND en el nodo GND del LM7805, siempre es una buena referencia visual. (opcional).

Creo que esos son todos mis comentarios. Pero está muy bien todo lo que has hecho. Creo que si quieres ya podrías fabricar la tablilla!!!

Te recomiendo intentar generar los Gerbers, para que aprendas el proceso.

Saludos,

El P@n@
17/08/2006 #35


1.- Se borrar pistas, lo que pasa es que a veces, el puntero o se pasaba o no llegaba, y tenía que mover la linea hasta que me coincidiera.
2.- Gracias
3.- vaya despiste!!! Ya lo tengo los valores puestos. He grabado el esquemático, tengo que hacer algo (en este punto) en el Netlist o en el pcb??
4.- La creé en la cara de las pistas ya que es allí donde tiene que estar no?? En la cara de componentes no. Uso una placa de 1 sola cara... Si estoy equivocado, dimelo e intento corregirlo.
5.- Como se hace??
6.- Para reducirlo todo, hay algun método?? O tengo que mover uno a uno??
7.- Tienes toda la razón. Pero el problema lo veo como salvo el puente rectificador... para que no tenga que poner ningun puente (para salvar las pistas). Dime como puedo solventar este problema.
8.- No te entiendo. En el esquemático, el pin central pone GND (dentro de LM7805)

Bueno, espero que me ayudes a mejorar esta plaquita.

Gracias!!
17/08/2006 #36


Hola Serch,

1. cuando no llegas a las pistas, puedes cambiar el tamaño de la rejilla con el botón derecho, puedes utilizar rejillas muy finas y alli no tendrías problemas con que el puntero no llegue.

3. No es necesario cambiar ni el netlist ni el PCB, ya que la vía de comunicación es por el atributo de "footprint", si no afectas éste atributo no tendrás que volver a generar nada.


4. Si te das cuenta todos los trazos los tienes sobre la capa de componentes y el plano lo tienes sobre la capa de cobre, para que salgan en la misma cara. Sino van a salir en caras separadas. Puedes visualizarlo mejor si modificas los colores en el menú de preferencias.

5. Para definir el contorno de PCB escoges la capa de contorno de PCB en el menú superior de íconos. Luego, escoges "añadir línea polígono o gráfico" de la lísta de íconos de la izquierda. Trazas el borde de la tablilla, va a aparecer en amarillo con los colores originales. Luego para hacer las dimensiones puedes utilizar el ícono de Cota.

6. Lastimosamente se tendría que reducirlo moviendo uno por uno...

7. Si definitivamente veo el problema que me comentas. Aunque podrías todavía aumentar el tamaño del trazo a 1 mm y todavía podría caber entre los pines del puente.

8. Me refería más bien al símbolo de GND que aparece cuando agregas el ícono de añadir alimentación en el lado izquierdo, es el triangulito que indica la tierra de tu diagrama esquemático. Es solo de ayuda visual, no afecta nada tu PCB ni otros detalles.

Ojala y te haya ayudado con los comentarios. Ya casi estás allí... Suerte!!!

El P@n@
21/08/2006 #37


yo quisiera hacerte una pregunta eduardo ya que tu fuiste el que me dejo la liga del kicad y veo qeu entiendes. el problema es el siguiente, en eeschema sirve para hacer diagramas electronicos pues bien yo me puse ayer noxe hacer un esquema para ser exactos comprobador de cuarzos con dos transistores el cual lo hice en el programa y la duda que tengo es que no se poner los valores de las resistencias, condensadores, diodos (poner cual es)y transistores a y por supuesto el valor del cuarzo, otro problemilla que me dio es cuando le doy hacer el control de reglas electricas (ERC) me da dos fallos señalados con las flexitas aquellas verdes y me señala dos puntos el del tierra y el de corriente y la verdad cuando le doy a escribir informe de ERC me da un error no se cual es si quieres lo puedo poner a ver si te suena, de todas formas donde se puede leer un informe de ERC en el block de notas?? por ejemplo?

saludos y gracias de ante mano
21/08/2006 #38


Hola usher,

**Valores visibles**
Todos los valores que quieres que aparezcan en el diagrama esquemático los puedes configurar como atributos visibles del símbolo que estás utilizando, por lo general las librerías que vienen con el programa traen varios atributos visibles, la referencia y el valor solo los modificas y ya puedes incluir valores a los componentes.

Si das doble click en el componente aparecen las propiedades del componente y en la pestaña de campos puedes agregar más atributos y hacerlos visibles.

**ERC**
Cuando quieres hacer la revisión de ERC, las fallas las puedes revisar si generas el archivo de reporte, activando la pestaña de escribir informe de ERC. El archivo lo puedes ver en cualquier editor de textos, como el notepad.

También puedes ver punto por punto los errores dando un click sobre la flecha verde y aparece en la línea de estatus en la parte baja de la pantalla, el detalle del error.

Si sigues teniendo errores avísanos, puedes enviar los archivos del proyecto como referencia para ayudarte mejor.

Saludos y suerte en tu aprendizaje.
21/08/2006 #39


bueno pues hay va mi esquema para la realizacion del circuito lo miras, bueno ya esta arreglado ya no tengo problemas y me da 0 errores de todas formas te subo el circuito y me dices que tal a ver como va ok??

saludos y gracias
Archivos Adjuntos
Tipo de Archivo: sch cuarzos_173.sch (5,3 KB (Kilobytes), 24 visitas)
21/08/2006 #40


Recomendaciones para mejorar el esquemático
Hola usher,

Creo que vas muy bien en tu diseño del diagrama. Me alegro que te sirva para tus diseños.

Tengo unos comentarios para que lo mejores:

1. En donde tienes localizados los LEDs, tienes dos LEDs en vez de uno solo, debes eliminar uno y solo dejar un LED. Te envío la foto del área de error, puedes ver que hay 2 LEDs en vez de uno

2. No es necesario que agregues nodos de conexión en los pines de los símbolos, solo con la conexión a pines es suficiente. Puedes eliminar la conexiión, es la que hace que el cuadro se vea relleno de verde, solo con una conexión directa a la pata es suficiente. Puedes ver por ejemplo en el capacitor C1 tienes una pata conectada directa y otra con un nodo de conexión extra. Puedes eliminar el nodo de conexión extra

3. El cristal XTAL 1 tiene un nodo cerca que no está conectado, por ésto se ve un cuadrito en la pata del pin, debes eliminar ésta conexión, haciendo nuevamente la conexión del pin superior, o moviendo un poco el componente, te incluyo la foto del error.

4. Elimina todas las conexiones extras de nodos que tengas sin conectar, te incluyo un ejemplo, pero he contado hasta 22 nodos de conexión que no ocupas. Solo te muestro 1. Ésto creo que es solo visual.

Bueno espero te sirvan los comentarios y ya casi estás listo para darle a la transferencia de partes al PCB.
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Software de Simulación y Diseño Electrónico

Todo lo relacionado con estos programas.

Cerrar
Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.