Haz una pregunta
  Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

08/06/2017 #1


Servomotores "tiemblan" o se mueven al energizarlos.
Hola de nuevo, he abierto este hilo pues no he encontrado información muy concreta y la verdad no se como solucionar, si alguien me pudiera brindar una pequeña guía para resolver mi problema. Les agradezco de antemano.

Problema: Les comento que cuento con dos servomorores: uno trucado(giro continuo) y otro normal, ambos son de marca towerpro-mg996r. El inconveniente se presenta cuando energizo todo mi circuito (varios componentes, un nodemcu, ldr, leds, buzzer, RTC, etc.) que por cierto lo hago primero con una fuente grande regulable de 2500mA. De ahi trabajo a 12V para alimentar dos fuentes conmutadas step-down MP1584.

La una la utilizo para alimentar todo el circuito y la otra para alimentación de los servos.
Lo que sucede es que al momento de energizar todo los servos se vuelven locos, el servo trucado "tiembla" y va girando unos cuantos grados (aprox 15 segundos) hasta que se estabiliza y al fin se queda quieto. El otro se mueve unos cuantos grados y regresa a la posición inicial.

Todo funciona perfecto, pero a ratos inesperados el servo trucado "tiembla" y de nuevo se mueve sin razón alguna y luego se queda quieto.

Como podría evitar que suceda esto??? Leyendo un poco, me parece que se introduce "ruido" y es por eso la causa de este problema no estoy del todo seguro, si es así, como podría mitigarlo para que no afecte el comportamiento de los servos??
Porque para mi proyecto necesito que mis servos sean lo mas precisos posibles y no se muevan para nada. :/

- Cabe aclarar que ambos los tengo estabilizados a una posición cero al momento de comenzar el programa por ejemplo

Código:
void setup() {
servonormal.attach(D5);     
servotrucado.attach(D6);         
 
servonormal.write(0)    
servotrucado.write(90)
}

- El circuito por lo pronto lo tengo implementado en protoboard.
- Las masas de las fuentes las tengo todas conectadas.
- He colocado capacitores de desacople a la alimentación de cada servomotor de 0.1uF.
09/06/2017 #2

Avatar de Nuyel

Si querías precisión yo hubiera elegido un motor a pasos en lugar de modificar un servo. ¿Qué fue lo que le hiciste?
10/06/2017 #3


Bueno, es que si usaba un motor a pasos, necesitaría mas pines, los cuales solo me sobran 2, uno para controlar cada servomotor. Pero buena recomendación.

Y bueno ya encontré el inconveniente parcialmente. Lo que sucede es que tuve que encontrar varias veces su centro, y pues a veces era 88 u otras 89 y 90 hasta 91 en el que el servo finalmente se queda quieto, no se extrañamente luego de cierto tiempo cuando de nuevo conecto todo el servo pierde el centro y tengo que volver a hallarlo,

No se como podría hacer en la programación para que saber si el hardware(el servomotor empiece a temblar) pues se coloco en un centro específico para que no se mueva o algo así no se si me hago entender. :/
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Software de Simulación y Diseño Electrónico

Todo lo relacionado con estos programas.

Cerrar
Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.