Haz una pregunta
  Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

09/10/2011 #1


Simulación Proteus excesivamente lenta
Hola compañeros, escribo porque tengo un problema con una simulación en proteus. Estoy intentando simular un circuito compuesto por 4 microcontroladores y el tiempo avanza muy lento y es imposible hacer nada. He leido que puede ser un problema de oscilaciones muy grandes pero la verdad nose como lo puedo arreglar. El circuito simplemente se basa en 3 pequeños circuitos (que ya he simulado con exito individualmente) los cuales son controlados por una array de polsadores y un microcontrolador haciendo funcion de master. Adjunto el esquema.

Estaria muy agradecido si alguien pudiera aconsejarme para poder llevar correctas simulaciones a cabo, ya que me tiene muy desconcertado y nose muy bien que hacer.

Muchas gracias de antemano!
09/10/2011 #2

Avatar de cansi22

Si subes el archivo lo pruebo en mi pc ke tiene bastante potencia
09/10/2011 #3


Hola, muchas gracias por tu respuesta. No creo que sea un tema de potencia del PC ya que he simulado anteriormente cosas bastante parecidas. Creo que va mas porque estaré generando unas oscilaciones que el Proteus no aguanta y nose muy bien porque. De todas formas pruebalo en tu PC, adjunto la carpeta zip. El orden de cada codigo con cada micro es: A-->micro de abajo a la izquierda, B-->micro de abajo a la derecha, C-->micro de arriba a la derecha y D-->micro de arriba a la izquierda. Fijate en como avance el tiempo de la simulación, a mi me tarda muchísimo en avanzar un segundo... me avanza de us en us prácticamente!

Muchas gracias!
Archivos Adjuntos
Tipo de Archivo: zip Esquema.zip (125,1 KB (Kilobytes), 64 visitas)
10/10/2011 #4

Avatar de Eduardo

El problema es el código del 16F877. Vas a tener que optimizarlo un poco.
10/10/2011 #5

Avatar de cansi22

Eduardo dijo: Ver Mensaje
El problema es el código del 16F877. Vas a tener que optimizarlo un poco.
Eso ya no se. Pero tanto codigo el ordenador no lo procesa bien. Por eso por separado van bien.
10/10/2011 #6


Ciertamente si quito la parte del 877 funciona ok. Me resigno a pensar que el programa no ese es el máximo de capacidad de Proteus porque he simulado correctamente una situación muy similar con cuatro microcontroladores y circuitos parecidos.

Mirando y remirando el código del 877 creo que posiblemente a Proteus le molestaba que tuviera que hacer el rastreo del teclado en cada iteración y en la gran mayoría de ocasiones sin necesidad. Puse un pequeño delay de 200ms en la primera linea de código dentro del while(true) y la simulación va perfecta y sin ninguna deficiencia a nivel práctico del programa. Muchas gracias por la ayuda a los dos, vuestros aportes han hecho que pudiera resolver mi problema porque sinceramente me quede cuando vi una simulación tan lenta! Estoy muy agradecido, muy amables por su parte
10/12/2014 #7


Saluditos. Independientemente de los problemas de nuestros codigos y circuitos, el Proteus simula muy bien los circuitos pero es EXTREMADAMENTE LENTO!!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Software de Simulación y Diseño Electrónico

Todo lo relacionado con estos programas.

Cerrar
Foros de Electrónica » Temas de Interés » Software de Simulación y Diseño Electrónico

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.