Haz una pregunta
  Foros de Electrónica » Temas de Interés » PC Hardware
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

15/09/2011 #1


Problema con adaptador USB-RS232
Buen día foro!

Hacia bastante que no me pasaba por acá..

Les cuento que estoy haciendo un trabajito con un PIC.. y lo conecto por el cable serial a traves de un MAX232.

Así que para usarlo con la netbook, me compre un adaptador USB-RS232 que funciona con profilic 2303.

La cosa es que en la PC de escritorio me funciona todo perfecto. La PC envia a través del adaptador y el pic recibe, el pic envia y la pc recibe.

Ahora el tema es cuando lo conecto a la netbook, la netbook envia.. el pic recibe. Pero cuando el pic envia la pc no recibe nada.. y no logro hacerlo funcionar.. no se que sera lo que pasa.


Este es el adaptador que estoy usando: http://www.dealextreme.com/p/usb-to-...nt-green-24512

La netbook es una HP mini 110 1020la.


Saludos, espero alguno pueda ayudarme!!
Desde ya, gracias.
15/09/2011 #2

Avatar de Haslick

Yo me compre exactamente el mismo adaptador por DealExtreme con ese fin! ... Pero aun no me e puesto a hacer nada con el... :( No me digas que no fuca con la Notebook... :( era para usarla ahi mas que nada que lo compre..

Apenas me ponga a hacer algo te aviso que onda si tengop el mismo problema!
15/09/2011 #3


Buenisimo!! avisame cuando tengas alguna info.
15/09/2011 #4

Avatar de mdchaparror

yo he probado esos adaptadores y funciona muy bien en mi computador de escritorio y en el portátil
yo los he usado con Realterm en Windows y en Linux con el kterminal.

seguro que el microcontrolador si recibe?
16/09/2011 #5


Ya esta, lo solucione... El problema estaba que la Netbook creía que no tenía un puerto serial.

Para solucionarlo fui a Panel de control -> Sistema -> Hardware -> Administrador de dispositivos
(También se puede llegar haciendo click derecho en Mi Pc -> Hardware -> Administrador de dispositivos)

Ahí en el administrador te vas a el menu -> Ver -> Mostrar dispositivos ocultos

Y después en la lista te van a aparecer los "dispositivos que no son plug and play". Ahí mismo deshabilitas el que se llama Serial y listo, el USB-RS232 empieza a funcionar...

Yo creo que debe haber algún conflicto con eso, la netbook al no tener puerto serial se empacaba con el usb jajajaja

Ahora, el unico drama.. es que la conexión es media chota.. no se la verdad porque, en la pc de escritorio me funciona perfecto. Pero en la netbook es como si no pudiera enviar y recibir al mismo tiempo :S

Saludos y espero que si a alguien le pasa esto le sirva!!
11/12/2011 #6


Yo estoy pensando en comprarme una netbook (porque es más económica y portátil) para poder hacer las materias que me faltan de Ingeniería, y buscando en Google las ventajas y desventajas, encontré este post.

¿Has probado conectar la fuente de la netbook? Creo que con la batería sola, los puertos se debilitan un poco.

Esos adaptadores, ya sea con pc de escritorio, notebooks o netbooks, no siempre son plug and play, a veces hay que buscar y descargar drivers. Yo tengo un adaptador Manhattan, y al principio no andaba, pero después busqué y descargué los drivers, y ahora lo reconoce perfectamente.
26/01/2012 #7

Avatar de solaris8

escribo aqui porque veo que tienen un problema sejante al mio, tengo una Texas Instrument Extensa 600cds Pentium 120 (sin risas por favor)... y quiero hacer un adaptador serial usb ya que no cuenta con usb


el adaptador tendria que ser usb hembra a serial, vi esto pero no me convence....les dejo el adjunto. tendra solucion
Imágenes Adjuntas
Tipo de Archivo: gif usb_serial_stabilizer.gif (4,3 KB (Kilobytes), 48 visitas)
19/11/2014 #8


Problema con adaptador usb a rs232
Un compañero y yo tenemos el mismo problema al querer usar un convertidor de nuestros puertos usb hembra a serial macho nos aparece un triangulito amarillo en el com viendolo desde la interfaz del admin. de dispositivos el cual dice

"Este dispositivo no puede iniciar. (Código 10)

Se ha especificado un dispositivo inexistente."

, otros compañeros que compraron el mismo cable no tienen este problema en sus portátiles, al principio creía que era problema de que tanto mi portátil como la de mi compañero con el mismo problema son ultrabooks a pesar de ser de diferentes marcas tenían el mismo problema, pero ahora con ayuda del enlace que les copio a continuación, me he puesto a pensar que las ultrabooks son portátiles con menos hardware y que el problema esta lejos del hardware, entonces me di cuenta que el problema pudiese ser que ambos utilizamos Windows 8.1, en el enlace que les pego de la comunidad de microsoft es donde he encontrado como han resuelto otras personas el mismo problema:

http://answers.microsoft.com/es-es/w...d-c18c5ec73f7d
19/11/2014 #9


etp94 dijo: Ver Mensaje
Un compañero y yo tenemos el mismo problema al querer usar un convertidor de nuestros puertos usb hembra a serial macho nos aparece un triangulito amarillo en el com viendolo desde la interfaz del admin. de dispositivos el cual dice

"Este dispositivo no puede iniciar. (Código 10)

Se ha especificado un dispositivo inexistente."
entra a las propiedades y cambia el numero de com, otros dispositivos pueden estar usando el mismo numero
19/11/2014 #10


analogico dijo: Ver Mensaje
entra a las propiedades y cambia el numero de com, otros dispositivos pueden estar usando el mismo numero
Ya encontré la solución! , para los que tienen Windows 8.1 es simple, el nuevo OS de windows no te reconoce el convertidor usb-rs232 utilizando drivers del convertidor que esten citados con fecha después del año 2011, aquí les adjunto la versión del driver que utilizé, el problema esta en que Windows 7 y 8 al conectarle un periférico te busca la versión del driver más actualizada ya sea por medio de la red o de forma local, para esto hay que ir a:

1.- Admin. de dispositivos
2.-Click izq. en Puertos (COM y LPT) --> Aquí si tienes el mismo problema que yo debe de aparecerte un triangulito en el Prolific USB-to-Serial Comm Port (Tu cable debe de estar conectado para que te salga esta categoría).
3.- Click derecho En el Prolific USB-to-Serial Comm Port
4.- Click izq. en Actualizar software del controlador...

nota: sile das click izq en propiedades, si tienes el problema te dirá en el estado del dispositivo que tiene el error 10 y que el dispositivo no se encuentra

5.-Click izq. en Buscar software del controlador en el equipo
6.- (Una vez instalado la versión que les adjunto o anterior al 2011) Click en elegir en una lista de controladores de dispositivos en el equipo
7.- Eligen la versión que les pase no recuerdo si es la 2007 o 2008 pero cualquiera sirve
Archivos Adjuntos
Tipo de Archivo: zip PL2303_USBSerial_Win78_3264.zip (2,16 MB (Megabytes), 419 visitas)
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa PC Hardware

Sección destinada a sistemas electrónicos utilizados en la informática.

Cerrar
Foros de Electrónica » Temas de Interés » PC Hardware

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.