Haz una pregunta
  Foros de Electrónica » Temas de Interés » PC Hardware
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

18/07/2011 #1


Problema con conexión PIC-MATLAB por USB, concretamente con controladores de Windows
Buenas noches a todos, os cuento que estoy haciendo y cual es mi problema:

estoy con el proyecto final de carrera, construyendo un generador de números aleatorios. Los números se generan por hardware y se envían al PC por comunicación USB mediante un pic, concretamente el PIC18F2455. Estos datos que envío los trataré con el MATLAB posteriormente. Es decir, los datos se van enviando del PIC al MATLAB.

El código que he cargado al PIC y las instrucciones para que el PC te reconozca la placa del PIC como un dispositivo USB los he encontrado en esta página:

http://www.mathworks.com/matlabcentr...ndo-puerto-usb

Bueno, una vez he expuesto lo que trato de hacer, os comento el problema que tengo: tengo que instalar los drivers proporcionados por microchip necesarios para que cuando conecte la placa por USB me la reconozca.

Problema: cuando conecto la placa por USB, automaticamente la trata como un dispositivo PLUG and PLAY, es decir, me instala los controladores que a Windows le sale de los huev** y no me deja instalarle los controladores que me he descargado.

En mi opinión, el problema puede estar en 3 posibles lugares:
- El primer sitio que se me ocurre que me esté provocando el fallo es el conexionado de la placa. Si os descargais el "proyecto" del link que he puesto arriba, en la página 16 de las instrucciones aparece el conexionado. Esta hecho integramente como sale, a excepción del puerto A, en el que no he puesto las resistencias ni los pulsadores porque solo voy a utilizar una entrada para la adquisición de los datos. La otra cosa que no he puesto es el condensador que va desde la pata 20 hasta el GND.

-En segundo lugar, los pines del USB. Me he guiado por esta imagen para asignarlos:
http://www.yoreparo.com/foros/files/...raci_n_usb.jpg
Lo que pasa es que si mirais de nuevo la imagen de la página 16 de las conexiones, la pata de tensión del USB la deja sin conexión, y ahí también dudo.

-En último lugar, el software, pero de aquí no sabría decir bien bien cual puede ser el problema.

¿Alguien me puede ayudar?

Gracias de antemano!
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa PC Hardware

Sección destinada a sistemas electrónicos utilizados en la informática.

Cerrar
Foros de Electrónica » Temas de Interés » PC Hardware

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.