Haz una pregunta
  Foros de Electrónica » Temas de Interés » PC Hardware
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

27/03/2013 #1


Señales en pines de puerto serie
Hola a todos

Tengo un PC el cual necesito usar el puerto serie -que nunca lo he utilizado- al que quiero conectar un programador del tipo JDM, pero las señales que hay en sus pines no coinciden con las que tienen que ir a dicho programador.
El programador es este:
http://perso.wanadoo.es/pictob/jdmd....ma_electronico

Las señales presentes en el conector DB9 del PC son:

PIN 1 ........ 0.O7 v
PIN 2 ........ -11.15 v
PIN 3 ........ 0.00 v
PIN 4 ........ -11.15 v
PIN 5 ........ 0.05 v
PIN 6 ........ 0.07 v
PIN 7 ........ -11.15 v
PIN 8 ........ 0.06 v
PIN 9 ........ 0.06 v

Que difieren bastante de las que se comentan el esta pagina.
y hay esta la duda ----- ¿falla la pagina del programador o falla el puerto serie?

Alguna buena orientación. Gracias
27/03/2013 #2


Hola, el esquema esta bien, el programador JDM ya esta mas que probado, conectalo sin preocupamientos
27/03/2013 #3


Gracias por tu pronta respuesta

Es lo que suponía yo. Que el esquema necesariamente tenia que estar bien. Por lo que se resume que al tener estas señales de voltaje en el DB9 no me funcionaria el programador, digo yo.
Porque las señales no entran al programador por los pines correspondientes, lo que viene a decir que este puerto serie no me sirve.
27/03/2013 #4


Ehh!.. Che Luis, no es tan así como decís, miré la página que has enviado, y es un simple JDM, nada raro...
Lo de las tensiones no lo tomes al pie de la letra, el puerto serie RS232, eran algo de lo más "tolerante" conocido, tienen un rango de funcionamiento bastante amplio, en lo que se refiere a sus tensiones, busca info y lo verás.
Además está el asunto que marcan los "0" y "1" con tensiones positivas y negativas, lo que parece extraño al neófito acostumbrado por ejemplo a un CMOS.
Por conectar ese programador del enlace, no tengas miedo, está bien, a lo sumo lo que puede suceder, es que el puerto de la PC no llegue a los valores de tensión requeridos y no pueda "dialogar" con el PIC.
En tal caso deberías ver un circuto como el del enlace, tambien es un JDM, pero asistido con una fuente externa.
http://www.lancos.com/siprogsch.html
http://www.lancos.com/ponykit.html

http://www.unicrom.com/Tut_ProgPICyMem1.asp
28/03/2013 #5


Hola alesergi, agradecido por los sitios que has colocado son buenos, y me han servido.

Estaba creido que en este tipo de programador serie no se podía añadir alimentación externa.

Intentare con uno de estos que hay con alimentación externa, haber si asi consigo grabar el dichoso 16F84a que es para sustitución de otro quemado.

De todas formas, no ves extrañas las tensiones que tengo en el DB9, y sobre todo en los pines 2 y 3 . Por lo que he medido en otros PCs (3 en realidad) siempre encontré en el pin2 mV y en el pin 3 rondando los 11 Voltios.
28/03/2013 #6

Avatar de Scooter

A ver, haber medido señales digitales con un polímetro simple y pretender sacar conclusiones es bastante absurdo. Solo puedes tener una remota idea de lo que está pasando. Si las señales cambian el valor de la tensión media a saber cual es.
En principio un puerto serie no se pensó para alimentar nada, todos los inventos que se alimentan de él en ocasiones funcionarán y en otras no.
Prueba a ver con alimentación externa y si no prueba con otro programador porque de haber hay miles.
Yo no me compliqué la vida y compré uno hecho; lo que gasté en dinero lo ahorré en dolores de cabeza esperando a ver si funciona.
28/03/2013 #7


Estimados amigos: el puerto serial no es tan complicado como puede parecer al principio. Es importante saber las señales y su nivel de tension, asi como el sentido de las mismas. El puerto del PC corresponde a la categoria DTE, con conector macho (de pines) mientras que los dispositivos que se conecten a este corresponden a DCE (con agujeros). hay señales de control y señales que llevan la informacion propiamente dicha. Las de control, poseen un voltaje negativo cuando estan inactivas; al activarse, l voltaje pasa a un valor positivo; segun el standard, los valores de tension andan entre +/- [3 y 15 voltios]. En este caso, cuando se carga el software del programador (o cualquiera que maneje el puerto serial) las señales de los pines 4 y 7 pasan a positivo, alimentando la placa del programador. El pin 8 lleva una señal que requiere el PC como respuesta a la señal del pin 4. Una vez que estan presentes estas señales ya se puede proceder a enviar la informacion para programar el Chip.
En tu caso Luis, mediste los voltajes en vacio, sin nada conectado al puerto del PC? Si es asi, no deberia haber voltaje en el pin 2, podria ser que te equivocaste en el numero de pin lo cual ocurre en ocasiones cuando uno toma la referencia de la numeracion en el conector hembra y no en el macho, ya que estan invertidos. En mi caso personal en solo una ocasion, en 30 años he visto un puerto de Pc con falla. Deberias armar tu quemador y probar, ya que pienso que no tendras inconvenientes con la alimentacion. Si te animas a hacerlo nos comentas.
Imágenes Adjuntas
Tipo de Archivo: jpg Puerto serie.JPG (42,2 KB (Kilobytes), 53 visitas)
29/03/2013 #8


Muy detallada tu respuesta Lamas, de hay viene la confusión que tengo, que al no funcionarme el primer programador que me fabriqué, me dediqué a hacer comprobaciones a diestro y siniestro, y una de las que realicé ya un poco mosca fue las de tensiones.

Tal como me pones en tu dibujo, es como tienen que ir las señales, y en el orden que tienen que ir los pines.

Pero estas señales aún en vacio, tienen un nivel de tensión que es el que en un principio he comprobado yo; y comparando en otros PCs, en el mio no lleva este orden establecido.

Por último, y esto es lo último que colocando una tarjeta PCI (puerto serie) sí que he obtenido las señales en este orden y con el nivel se tensión aún en vacio com odices tu.

O sea que descartado el puente que une el DB9 a placa base, me inclino con que es en esta última donde está el fallo.
29/03/2013 #9

Avatar de Scooter

La cuestión está ahí porque depende del hadware que hay dentro de tu PC. Aunque la norma rs232 lleva las tensiones a +-12 V dependiendo de como esté implementada dentro la circuitería puede que esté en +-5V o +-7V que aunque se sale de la norma funciona el 99% de las veces. Luego está la corriente que entregue; dependiendo del driver será una u otra.
29/03/2013 #10


No, la norma dice que se permite un valor de tension de entre 3 y 15 voltios, la polaridad es funcion de si esta activa la señal o no. Los valores de entre +/- 3 voltios son estado indefinido. Las corrientes que circulan en los pines del puerto serie son bastante bajas, pero la potencia que se obtiene a partir de los pines en cuestion es suficiente para activar dispositivos de bajo consumo, tales como el programador.
Luis, el puerto en el que mediste las tensiones tiene conector macho? (el de los pines)
30/03/2013 #11

Avatar de miguelus

Buenos días LUIS CANDELAS.

En las medidas del Post #1 hay algún error...

Las señales presentes en el conector DB9 del PC son:

PIN 1 ........ 0.O7 v
PIN 2 ........ -11.15 v - El valor real tiene que ser 0V
PIN 3 ........ 0.00 v - El valor real tiene que ser -11V
PIN 4 ........ -11.15 v
PIN 6 ........ 0.07 v
PIN 7 ........ -11.15 v
PIN 8 ........ 0.06 v
PIN 9 ........ 0.06 v

Los valores son aproximados ya que dependen del PC

Otra cuestión...
Las tensiones Negativas son un "1"
Las tensiones Positivas son un "0"

El Circuito que has Posteado funciona perfectamente, miles y miles de ellos lo atestiguan desde hace muchos años.

En PC´s portátiles es posible que el circuito no funcione ya que no dan la tensión suficiente para obtener los 12VCC para la tensión de programación.

Esto también pasa con los adaptadores USB > RS232.

El Software Icprog dispone de una utilidad para comprobar el Harware.

Sal U2
30/03/2013 #12


Hola miguelus, tal como dices tu las señales no son las que corresponden a los pines, porque aunque sean señales tomadas con un tester y salientes de placa base, esas señales existen y si en realidad aunque sean señales bien analógicas, bien digitales, tienen que seguir un estandar y no lo cumplen.

En resumen, que después de comprobar hasta la placa base.

Después de comprobar hasta con una tarjeta PCI donde si que salen las señales en el orden que tienen que ir, pero que tambien me da error a la hora conectar un programador jdm que me acabo de fabricar. Casi he llegado a la conclusión que el fallo está en placa base.
Y conclusión, que como último intento, voy a fabricarme un programador con alimentación externa, y si acierto tal vez pueda terminar mi clone pickit2.
Un saludo a todos compañeros.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa PC Hardware

Sección destinada a sistemas electrónicos utilizados en la informática.

Cerrar
Foros de Electrónica » Temas de Interés » PC Hardware

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.