Haz una pregunta
  Foros de Electrónica » Temas de Interés » Telemática y Comunicaciones
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

25/10/2005 #1


Como eliminar la interferencia?


Hola k tal no se si puedan ayudarme en este foro.

Estoy usando unos módulos de RF un TX y un RX los modelos son los siguientes el TX : TWS-BS3-C y RX: RWS-371-6-C modulan mediante ASK su rango de frecuencia es de 433.92MHZ y la verdad es que funciona perfectamente los estoy utilizando junto con 2 microcontroladores (PIC's).

Funcionan hasta cerca de 70m de distancia y lo hacen bien o al menos a mi me parece que funcionan genial.

E aqui el problema: el dispositivo receptor cuenta con un buzzer el cual tiene un tono constante de 95dB y una frecuencia de 3.7Khz; a una distancia de 8mts con el transmisor apago y enciendo ese buzzer (como si fuera una alarma), ademas de unos leds y una pantalla LCD; pero con el buzzer encendido al finalizar la rutina ya no llega la señal del transmisor y eso hace que el dispositivo se trabe. Si retiro del dispositivo el buzzer todo funciona perfecto la señal del transmisor es recibida de manera muy limpia.

Es por eso que yo creo k es interferencia del mismo buzzer que destruye la señal del transmisor, trate de alejar el buzzer a mas de un metro y tampoco.

Quisiera saber como podría eliminar esa interferencia del buzzer o si en realidad es interferencia alguna idea.
25/10/2005 #2
Moderador general

Avatar de Andres Cuenca

Pienso que en ves de interferencia, el buzzer consume mas corriente de la que le puede entregar la fuente de alimentación, lo que hace que el voltaje se caiga y el microcontrolador pierda la secuencia.

Ya verificaste que no sea por falta de corriente?
25/10/2005 #3




si ya lo cheque mi fuente da 5V a 500mA y funciona perfecto, yo creo k es el buzzer pork al kitarselo funciona genial o de manera muy correcta
25/10/2005 #4
Moderador general

Avatar de Andres Cuenca

Creo que con seguridad el problema es por falta de corriente, prueba con una fuente de mayor capacidad.

La frecuencia con que manejas el buzzer no creo que pueda interferir, ya que es el micro quien la genera.
26/10/2005 #5


si creo k tienes razon voy a crear una etapa de potencia para el buzzer y ya te digo como me funciona gracias estamos en contacto
26/10/2005 #6
Moderador general

Avatar de Andres Cuenca

Pero así crees una etapa de potencia debes tener la corriente para soportarla. No te olvides de aumentar la capacidad de corriente de la fuente de alimentación.
20/07/2007 #7


Hola.

Para mi es el tema de que debes ponerle un transistor al buzzer.

Si tu miras la salida del PIC con un Osciloscopio y el buzzer esta conectado directamente a esta
en varios tipos de buzzer veras que el 1 que entrega el micro se deforma y parece un tren de pulsos, eso puede estar molestandote.

Atte:welsu
29/08/2010 #8


Respuesta: Como eliminar la interferencia?
Pudieron solucionarlo? Me sucede lo mismo, conectando el buzzer y/o un piezo con un 555 al colector un transistor. Controlo el transistor conmutandolo con la salida del PIC (tensión a su base).
13/12/2010 #9


ya intentaron poner un buffer? podria eliminar la falla, un 74LS245 es bueno.
13/12/2010 #10


No sé los muchachos, yo lo solucioné con un diodo en directo a la salida del PIC.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Telemática y Comunicaciones

Todo lo relacionado con los Sistemas de Telecomunicación, la Transmisión de Datos y las Redes de Computadores.

Cerrar
Foros de Electrónica » Temas de Interés » Telemática y Comunicaciones

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.