Haz una pregunta
  Foros de Electrónica » Temas de Interés » Telemática y Comunicaciones
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

13/06/2016 #1


Xbee serie 2 inconvenientes
Hola tengo un inconveniente y espero me puedan ayudar.<br />
Tengo instalado una red con 20 Xbee serie 2 en donde 19 están configurados como dispositivos finales y 1 como coordinador, el inconveniente que tengo es que en muchas ocasiones algunos de los 19 Xbee Serie 2 dejan de recibir y transmitir datos, es como si se activará el sleep lo más raro es que aveces después de transcurrir una hora vuelven a funcionar con normalidad.<br />
<br />
De antemano agradezco su ayuda.<br />
<br />
Enviado desde mi SM-N910C mediante Tapatalk

Enviado desde mi SM-N910C mediante Tapatalk
13/06/2016 #2

Avatar de Daniel Meza

Hola, ¿qué distancia hay entre ellos?, ¿los que fallan son siempre los mismos?. Da más detalles amigo
13/06/2016 #3


Gracias Daniel por responder, la distancia es 15 metros, no siempre son los mismos,

Enviado desde mi SM-N910C mediante Tapatalk

Lo último que estaba pensando es que se estan saturando... help pliace

Enviado desde mi SM-N910C mediante Tapatalk
13/06/2016 #4

Avatar de Daniel Meza

Saturación, mm ¿son largas a las cadenas de datos?. ¿Las transmisiones se dan de manera simultánea?


Enviado desde mi iPad utilizando Tapatalk
13/06/2016 #5


No son largas pero el coordinador cada 200 ms le pregunta a cada terminal si tiene datos, cada vez que el coordinador pregunta todos las terminales reciben la petición pero la que se identifique con el ID responde.

Enviado desde mi SM-N910C mediante Tapatalk
13/06/2016 #6

Avatar de Daniel Meza

bien, lo que se me ocurre para ir aislando el problema es habilitar la función del pin RSSI de cada Xbee para monitorear visualmente la recepción del comando enviado por el coordinador, así descartaremos la posibilidad de que el Xbee esclavo esté teniendo problemas en la recepción.

Otra sugerencia es hacer más robusto el algoritmo de comunicación, digamos, por cada esclavo intentar establecer la comunicación unas 4 veces, si esas 4 veces falla se dará por hecho que el XBee direccionado no se encuentra y se proceda a hacer X cosa.
14/06/2016 #7

Avatar de Ardogan

Otra cuestión es el ambiente: esta red xbee esta dentro de un galpon, fabrica, oficina, al aire libre?. Hay paredes de por medio?. Todos tienen linea de vista?. Quizás hay nodos que fallan esporádicamente por ruido del ambiente.
Con que potencia transmiten los nodos? (relacionado con ver que pasa con lo que dice Daniel Meza: RSSI). Un esquema de distribución y obstáculos?.
Dedicanos unos minutos en detallar la situación en forma precisa y nos ahorramos tiempo en preguntar una cosa, luego otra, y otra...
14/06/2016 #8


Ok en el transcurso del día les comparto un bosquejo de la red gracias por su ayuda

Enviado desde mi SM-N910C mediante Tapatalk
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Telemática y Comunicaciones

Todo lo relacionado con los Sistemas de Telecomunicación, la Transmisión de Datos y las Redes de Computadores.

Cerrar
Foros de Electrónica » Temas de Interés » Telemática y Comunicaciones

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.