Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?
31/08/2014 #1


Como alimentar todos los dispositivos de mi robot
Hola a todos,

estoy construyendo un robot como muchos ya sabéis, y gracias a vosotros tengo cada día más avanzado y terminado el proyecto. Por esto, primero daros las gracias a todos y recordaros que sois los mejores...

he solucionado el problema de las baterías (Falta de potencia), el de las bombas a de agua, y el del cargador de pilas... gracias a vosotros.

ahora siento que el proyecto está llegando a su fin, y solo me queda un pequeño problema que no me deja dormir tranquilo...

tengo varios dispositivos en mi robot que necesitan corriente eléctrica, éstos son:

1. uC arduino (Pro Mini, Leonardo, Robotale ó Mega 2560).
2. 2 Servo motores: uno para la dirección de giro, y otro para un tema que quiero hacer con el robot.
3. 2 "focos" de luz blanca con LEDs que he construído, de 5 diodos en serie cada uno de los dos, que en un foco son de alta luminiscencia y en otro son de aún más alta luminiscencia...
4. 6 bombas de agua barwig a 12Vdc y 1.5A en el agua...

así que, por motivos de prueba y cabezonería, compré muchas pilas recargables ni-mh de 2.5Ah, y al final resulta que me sirven, pero el robot va un poco pesado... porque son más de 350gr de batería... por lo que he decidido comprar en hobbyking una de LiPo de 14.8V y 1300mAh... y quisiera alimentarlo todo con esta batería, consuma lo que consuma, puesto que es de 95gr y tiene potencia suficiente (10 ó 25C - no recuerdo - en cualquier caso, suficiente).

entonces, planteado el enunciado, dispongo a mi pregunta:

cómo podría alimentar los diferentes dispositivos, sin provocar una caída de tensión demasiado grave como para alimentar las bombas de agua, teniendo en cuenta que las quiero hacer funcionar a los 14.8Vdc que trae la batería de LiPo, ya que estos motores soportan mucha más tensión de la que dice el vendedor y además darle la tensión requerida a cada dispositivo?

por ejemplo, los LEDs pueden ir conectados en paralelo con la batería (después del conexionado en serie) ya que 5/14.8 son casi 3V y se iluminarán bien, estoy seguro.
El arduino necesita de 5 a 12Vdc en caso del Pro Mini, y en caso de cualquier otro, el rango recomendado es máx. 12Vdc, (y realmente fuera del rango recomendado no funciona correctamente con dispositivos como un GSM shield que tiene picos de hasta 2A).
Las bombas como ya he dicho, las quiero alimentar a 14.8Vdc.
Y por último, los servo motores, funcionan entre 4.5 y 6V (Algunos...).

Espero vuestras respuestas, porque podría usar reguladores de tensión, pero realmente, habría caída de tensión muy grave? no sé, así que os pregunto.

Gracias,

un saludo. ...
31/08/2014 #2

Avatar de solaris8

como lo veo me parese que el unico inconveniente seria el arduino y los servos, creo que deberias montar una fuente que te regulara de los 14.8 a unos 5.5 V y unos 3 o 4 amperes por ejemplo, los led (no se cuantos son) pero con resistencia limitadora, y las bombas directo a las pilas...
31/08/2014 #3


muchas gracias por tu respuesta solaris8,

ciertamente el problema es el que tú has nombrado. correctamente debería regular esos 14.8V a 5.5V, está muy bien pensado. Ahora el único inconveniente si es que se puede llamar así, es si la batería tendría una caída de tensión a causa de este regulador. Y otro posible, es si se puede alimentar un servo y un arduino con la misma batería, ya que según he leído es aconsejable usar una aparte... sabes de que te hablo? esto se podría solucionar con 2 reguladores...? :(
31/08/2014 #4

Avatar de Scooter

No, la batería no tiene caída de tensión, la tiene el regulador.
Para evitar quemar el 60%de la energía de la batería necesitas un regulador conmutado
31/08/2014 #5


Una observación; 06 bombas de 12V /1.5A eso es como 12V/9A, lo moveras con una LiPo de 1.6Ah???, falta sumarle todo lo demás , considera el arranque de las bombas.
31/08/2014 #6

Avatar de Scooter

Releyendo el último post ¿Ahora la potencia se mide en C?, toda la vida he pensado que era en W
Como dice opamp no tengo idea de la corriente máxima de salida de la batería pero me parece que te falta así a bulto como tres veces mas de la que tienes. En el caso de que te de la corriente que demandas la batería va a durar quince minutos.
Los leds no se pueden usar sin algo que regule su corriente, resistencia, transistor en zona lineal...
31/08/2014 #7


Las LiPo cargadas te dan más de 16V y tus bombas de 12V/1.5A pasaran a mover más carga, la I facil se incrementa a más de 2.5A, cuidado con el sobrecalentamiento.
31/08/2014 #8


Gracias a todos por las respuestas,

aquí van mis respuestas:

1. Ok, si la batería no tiene caída, y sí la tiene el regulador, entonces perfecto. Pero, qué es un regulador conmutado? Voy a buscar, pero debe ser un regulador más eficiente, verdad?

2. La batería es de 1300mAh (http://www.hobbyking.com/hobbyking/s...idProduct=9494), y da 20C de descarga, según esta tabla: http://aeromodelismo.epiel.com/c_baterias.html y lo que entiendo (si es que no entendí mal), da entre 20 y 30A... pero como dices que podría no ser suficiente, quizás esté malinterpretando los datos... explícame por favor.

3. Sí, la batería va a durar a penas 10 minutos, que es lo que suelen durar los robots según un amigo de bricogeek, cuando pregunté por un quadcopter, lo máximo que suelen durar son 15 minutos y es porque tienen baterías muy grandes que hacen muy pesados los robots... no sé si esto ha cambiado hasta hoy, desde hace 3 años a hoy. Respecto a la medición de las baterías, yo no sé a qué se refieren exáctamente cuando dícen 20C, por ejemplo. Pero me guié por esa tabla...

4. Ok, si la lipo da 16V, los LEDs se iluminarán mejor, es un dato importante, y por supuesto, tendré que regularla porque 2.5A a 16V son más del doble de Watts que dice el vendedor que es la bomba... y no quisiera fundirlas...

Entonces, si la batería es incorrecta y la tensión demasiado alta, deberé regular la salida con 2 o 3 reguladores? 1 para el arduino, otro para el servo (por eso de que hay que usar diferentes baterías para un servo) y otra para las bombas. Y entonces, qué batería me recomendáis y que reguladores?

os agradezco mucho vuestro esfuerzo y tiempo, de verdad.

gracias,

un saludo.
01/09/2014 #9


bueno, gracias a todos, creo que ya me ha quedado claro. solo tengo que regular la salida de la bateria a 5.5V para el arduino y para el servo. los leds los conecto directamente, y probaré con un regulador conmutado variable si es que existen para los motores y así elegir bien la potencia que necesito

gracias a todos, como siempre un placer.

un saludo.
01/09/2014 #10
Moderador general

Avatar de Fogonazo

romeroperez dijo: Ver Mensaje
bueno, gracias a todos, creo que ya me ha quedado claro. solo tengo que regular la salida de la bateria a 5.5V para el arduino y para el servo. los leds los conecto directamente, y probaré con un regulador conmutado variable si es que existen para los motores y así elegir bien la potencia que necesito

gracias a todos, como siempre un placer.

un saludo.
Busca información sobre:

L4960
LM2576
01/09/2014 #11


Fogonazo dijo: Ver Mensaje
Busca información sobre:

L4960
LM2576
hola fogonazo, gracias por la respuesta. te cuento... lm2576 me vendría muy bien la versión de 5V ó 12V para el arduino y/o el servo. Pero para los motores... me recomiendas usar 6 reguladores? el L4960 tiene una eficiencia del 90%, lo que es un 60% de pérdida. Es que los motores necesitarían 1.5A a 12V cada uno.. claro que ya he buscado y no encuentro ninguno de 9A :( como lo ves?

un saludo.

---------- Actualizado después de 4 minutos ----------

bueno, conectaré los motores directamente, y que sea lo que dios quiera... gracias.
01/09/2014 #12
Moderador general

Avatar de Fogonazo

romeroperez dijo: Ver Mensaje
hola fogonazo, gracias por la respuesta. te cuento... lm2576 me vendría muy bien la versión de 5V ó 12V para el arduino y/o el servo. Pero para los motores... me recomiendas usar 6 reguladores? el L4960 tiene una eficiencia del 90%, lo que es un 60% de pérdida. Es que los motores necesitarían 1.5A a 12V cada uno.. claro que ya he buscado y no encuentro ninguno de 9A :( como lo ves?

un saludo.

---------- Actualizado después de 4 minutos ----------

bueno, conectaré los motores directamente, y que sea lo que dios quiera... gracias.
Si tienen una eficiencia del 90% las pérdidas son del 10%, ¿ Que cuenta estás haciendo ?
01/09/2014 #13

Avatar de papirrin

bueno, gracias a todos, creo que ya me ha quedado claro. solo tengo que regular la salida de la bateria a 5.5V para el arduino y para el servo.
ya consideraste y descartaste el poner una bateria de menor voltaje e independiente para el control del arduino y los servos, asi evitas posibles interferencias que producen los motores.
01/09/2014 #14


Fogonazo dijo: Ver Mensaje
Si tienen una eficiencia del 90% las pérdidas son del 10%, ¿ Que cuenta estás haciendo ?
de poner 6 reguladores...

papirrin dijo: Ver Mensaje
ya consideraste y descartaste el poner una bateria de menor voltaje e independiente para el control del arduino y los servos, asi evitas posibles interferencias que producen los motores.
yo es que leí que las de lipo tienen muy poca caída, y pensé que la de 14.8 serían esos 14.8V... pero poner una de 11.1V, sería una opción. lo he pensado, y va a ser que es una solución.
cuando esté cargada la de 11.1V cuanta tensión subirá? y cuando esté descargada (11.1 ~ 12V) cuanta intensidad dará?
01/09/2014 #15

Avatar de Scooter

Sigue siendo el 90% si pones uno o si pones un millón.
01/09/2014 #16


Scooter dijo: Ver Mensaje
Sigue siendo el 90% si pones uno o si pones un millón.
Ok, perfecto. Entonces usar una batería 14.8 con 6 reguladores de 2.5A a 13 ~ 14V sería mejor que poner una batería de 11.1V y conectar directamente?
porque a mí lo que me gustaría es sacarles un poco más de potencia, nada más...
01/09/2014 #17

Avatar de Scooter

No, una batería conectada directamente es el 100% (mas o menos, algo perderán los cables)
A mi me gustaría ser un poco mas alto pero con 46 años no creo que crezca. Osea que lo que no va en llantos va en suspiros, si le sacas mas potencia la batería dura menos. Si usas conversores del tipo que sea pierdes si o si, claro que dentro de esas pérdidas pueden ser mas o menos asumibles.
01/09/2014 #18

Avatar de papirrin

yo es que leí que las de lipo tienen muy poca caída, y pensé que la de 14.8 serían esos 14.8V... pero poner una de 11.1V, sería una opción. lo he pensado, y va a ser que es una solución.
cuando esté cargada la de 11.1V cuanta tensión subirá? y cuando esté descargada (11.1 ~ 12V) cuanta intensidad dará?
no, yo decia que usaras la de los 14.8V para los motores que es lo que mas consume (Casi 9A), y aparte una bateria de lo mas proximo a 5V, para alimentar el arduino y los servos.

me parece que regular el voltaje a los motores de las bombas es algo inecesario. XD
01/09/2014 #19


papirrin dijo: Ver Mensaje
no, yo decia que usaras la de los 14.8V para los motores que es lo que mas consume (Casi 9A), y aparte una bateria de lo mas proximo a 5V, para alimentar el arduino y los servos.

me parece que regular el voltaje a los motores de las bombas es algo inecesario. XD
jejeje perfecto, es una buena solución haré eso pues. usaré 2 baterías, una para el arduino y el servo, otra para los motores! sin regular nada. es la mejor solución, sin duda.

gracias a todos, espero que todo bien.

un saludo.
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.