Haz una pregunta
  Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica
Foros Registrarse ¿Olvidaste tu contraseña?

Temas similares

15/06/2016 #21


Muy buena noche amigos del foro, continúe haciendo el robot el cual ya he comprendido mejor el lenguaje ARDUINO, y lo estoy controlando mediante voz en Android, ahora bien, tengo esa plataforma de robot que les mencioné anteriormente, y mi programación funciona correctamente con los motores sueltos, pero al ponerlo todo junto siento como que si le falta fuerza o potencia.

Me pueden ayudar a decir cómo puedo aumentar la fuerza o potencia de un motor DC de 5v o 9v mediante ARDUINO?

Estoy además utilizando el adaptador de puentes H compatible con ARDUINO.... Espero sus respuestas y ayuda... Muchas gracias
16/06/2016 #22

Avatar de Nuyel

Solo son motores conectados directamente o son motorreductores?

También tengo curiosidad por lo de la programación si aun planeas usar iOS, La ultima ves que intente programas para eso fue como hace 3 años, el programa iba en el simulador pero para pasarlo al teléfono de necesitaba licencia de desarrollador para desbloquearlo, creo que eran 20 o 25USD mensuales la cuota.
16/06/2016 #23


Gracias por tu respuesta @Nuyel, te comento lo estoy realizando con Android y los motores están conectados al Shield de L293 de ARDUINO y la programación utilizó la librería para este módulo L293 y luego le indicó que salidas deseo utilizar, el problema es que mueve los motores si están fuera, pero al momento de colocarlos en la base del carrito solo hacen el intento de moverse pero no mueven el carrito. Espero me comprendas, le tomare foto a la progra y a el carro para que te tomes una idea, Gracias por tu tiempo
16/06/2016 #24


Aquí la programacion

---------- Actualizado después de 5 minutos ----------

Me he percatado que es de 12 v que debo hacer?

Gracias por la ayuda brindada
Imágenes Adjuntas
Tipo de Archivo: jpg image.jpg (97,7 KB (Kilobytes), 10 visitas)
Tipo de Archivo: jpg image.jpg (96,0 KB (Kilobytes), 9 visitas)
Tipo de Archivo: jpg image.jpg (140,6 KB (Kilobytes), 4 visitas)
22/06/2016 #25


Necesitarás un elevador de voltaje (step-up) de 5V a 12V. Mide también la intensidad que necesite para comprarlo con suficiente potencia. Otra opción es tener una batería de 12V y controlar la alimentación de los motores con transistores (pero si te da miedillo usa el elevador)
¿Para iOS no necesitas Bluetooth tipo BLE (Low Energy)?
No te sirven los modulillos HC-05/06 tan famosos para arduino...
Me interesa la programación del Bluetooth para iOS por lo que estaré al loro
22/06/2016 #26

Avatar de gustavo

Hola, yo estoy aprendiendo a utilizar Atmega8 + modulo bluetooth HC-06. Realice una APP sencilla y de prueba en APP INVENTOR del MIT junto con ARDUINO UNO para verificar el funcionamiento.
Te adjunto los documentos para que realices las pruebas, estan testeados fisicamente y funcionan, tambien te adjunto la programacion en bloque hecha en APP INVENTOR y el codigo fuente de ARDUINO UNO.



Codigo fuente, Arduino UNO:

Código PHP:
/*

  Archivo: Comunicacion Bluetooth
  Autor:   Gustavo

*/ 
 
 // Declaracion de variables
 
int led13 13;
 
int estado 0;
 
 
void setup()
 {
   
// Comunicacion serial a 9600 baudios
   
Serial.begin(9600);
   
// PIN 13 de Arduino como salida
   
pinMode(led13,OUTPUT);
   
// Inicia PIN 13 apagado
   
digitalWrite(led13,LOW);
   
// Retardo 200ms, para que el modulo bluetooth inicie correctamente
   
delay(200);
 }
 
 
void loop(){
   
// Almaceno dato recibido por puerto serial en la variable "estado"
   
estado Serial.read();
   
   
// Comparo "estado"
   
if(estado == 'a')
   {
     
// Y si es igual al caracter "a", enciendo led 
     
digitalWrite(led13,HIGH);
   }
   
   
// Comparo "estado"
   
if(estado == 'b')
   {
     
// Y si es igual al caracter "b", apago led
     
digitalWrite(led13,LOW);
   }
 } 

Programacion en bloque APP INVENTOR:




Interfaz APP:



Espero ayude de algo, Saludos!
22/06/2016 #27


Much as gracias por sus respuestas y por su apoyo, les comento el problema que tengo es que tengo una plataforma deSainSmart comprada en Amazon y poseen motores de 12v de 266RPM y si conecto los motores directo a 5v o una batería de 9v, el motor se mueve junto con su cinta, pero al utilizar mi programación solo hace el intento.

No obstante si desarmo la estructura y dejó solo el motor funciona de manera adecuada, no sé qué pueda estar sucediendo, porque si el Shield De Arduino puede mover hasta motores de 24v creo , no es capaz de mover uno de 12v hay algo que no estaré haciendo?


En el Shield estoy alimentándolo con 9v y al ARDUINO con 5v, puesto que lo estaba alimentando solo con el ARDUINO y pasaba lo mismo, y pensé que eso lo solucionaría.....Ayuda porfavor!!!

������
23/06/2016 #28


Hola, deberías subir el diagrama esquemático incluyendo las fotos/datos de tu fuente de alimentación, ya que aunque todo pinta para una insuficiencia de energía, con esta información que nos proporcionaras podríamos ayudarte mas certeramente con respecto a la fuente de alimentación.

Saludos
Respuesta
¿Tienes una mejor respuesta a este tema? ¿Quieres hacerle una pregunta a nuestra comunidad y sus expertos? Registrate

Buscar más temas sobre:
Lupa Robótica, Domótica y Mecatrónica

La electrónica Aplicada a la Robótica y sus técnicas de interface.

Cerrar
Foros de Electrónica » Temas de Interés » Robótica, Domótica y Mecatrónica

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO ©2011, Crawlability, Inc.